Jump to content

[HOW TO] Getting IDT Audio Working


  • Please log in to reply
288 replies to this topic

#61
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL

idt 9273E

0x111D7676

80865002

revision id 1002

applehda hex data plz.. help me. T,.T



Your Apple Hex Data for your card would be 76761d11 you should do a find for b0761d11 and replace it with yours.....

#62
astearon

astearon

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I did everything step by step but it didn't work, it doesn't even show up in system/sound.

Can anyone help me ?

HDAUDIO\FUNC_01&VEN_8384&DEV_7682&SUBSYS_10192633&REV_1036

This is my IDT soundboard.

(also if anyone got the time or just want to help me could they modify the kexts to suit my device? just in case i did something wrong)

Thank you in advance :mellow:

#63
bartont

bartont

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

I did everything step by step but it didn't work, it doesn't even show up in system/sound.

Can anyone help me ?

HDAUDIO\FUNC_01&VEN_8384&DEV_7682&SUBSYS_10192633&REV_1036

This is my IDT soundboard.

(also if anyone got the time or just want to help me could they modify the kexts to suit my device? just in case i did something wrong)

Thank you in advance :unsure:


Your font is huge! Why size three font?

#64
abcbello

abcbello

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
hey bkpatel7!! could you get your sound working? Im using the same computer.

I have a noob question, I have already installed the kexts correctly, and I get device ID of 0x103C1505.
How do I transform this to decimal mode? and What program do I have to use to put this in the kexts??

thanks!

#65
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL

I did everything step by step but it didn't work, it doesn't even show up in system/sound.

Can anyone help me ?

HDAUDIO\FUNC_01&VEN_8384&DEV_7682&SUBSYS_10192633&REV_1036

This is my IDT soundboard.

(also if anyone got the time or just want to help me could they modify the kexts to suit my device? just in case i did something wrong)

Thank you in advance :)

Post your codec dump and I will try and get you started....

hey bkpatel7!! could you get your sound working? Im using the same computer.

I have a noob question, I have already installed the kexts correctly, and I get device ID of 0x103C1505.
How do I transform this to decimal mode? and What program do I have to use to put this in the kexts??

thanks!



Go to Applications and use the calculator and switch to programmer view.
The Decimal form of your codec is 272372997

#66
abcbello

abcbello

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks for the info ridgeline! I was able to get through every step except one:

Edit IOPCIPrimaryMatch with your HD audio controller.
Mine is Intel Audio Controller 0x293e8086

ex. IOPCIPrimaryMatch = 0x293e8086

Where do I find my iopciprimarymatch hex?? thanks!

#67
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
You would need to look for it under the HDAcontroller.plist
but, I know from experience that yours is already included.... so no need to mess with it....

#68
jaysonz

jaysonz

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
hey you guys..

hrmm i have IDT AUDIO and my device id = 0x111D76B2
i managed to get int mic to work . nd shutdown working to.
but i need help with line- in .

thanks here the kext if you want to see

Attached Files



#69
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
Does your master volume control work? or are you having to adjust it via iTunes or other software?

Does your master volume control work? or are you having to adjust it via iTunes or other software?

#70
RaidenII

RaidenII

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts

hey you guys..

hrmm i have IDT AUDIO and my device id = 0x111D76B2
i managed to get int mic to work . nd shutdown working to.
but i need help with line- in .

thanks here the kext if you want to see


good job thx shutdown issues solved.
but my int mic doesn't work.

#71
mehdymehdy

mehdymehdy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Hey guys.

Ive got a Dell Studio 1535 with 92HD73c1 audio.

My deviceID is 0x10280254 (decimal-271057492)

In step 2 I edited the apple hda binary, replacing B0761D11 with 45028201 in both places

In Step 3 I edited AppleHDA.kext/contents/info.plist, changing CodecID to 271057492.

Step 4 is where I got stuck

I changed the CodecID in AppleHDA.kext/contents/plugins/AppleHDAController.kext/contents/info.plist

The how-to did not tell how to find the HD audio controller,so i didn't mess with it.

This is what it looks like.

<string>AppleHDAController</string>
<key>IOPCIPrimaryMatch</key>
<string>0x793a1002 0x437a1002 0x43831002 0x269a8086 0x26688086 0x27d88086 0x284b8086 0x293e8086 0x026c10de 0x037110de 0x75021039 0x546110b9 0x32881106 0x026c10de 0x03e410de 0x03f010de 0x044a10de 0x044b10de</string>

Do i need to add anything to this list,what am I doing wrong?


Help will be appreciated, thanks.

#72
jaysonz

jaysonz

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

good job thx shutdown issues solved.
but my int mic doesn't work.



r u sure.? because mine works finely . now im trying to fix line in

#73
bartont

bartont

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

<string>AppleHDAController</string>
<key>IOPCIPrimaryMatch</key>
<string>0x793a1002 0x437a1002 0x43831002 0x269a8086 0x26688086 0x27d88086 0x284b8086 0x293e8086 0x026c10de 0x037110de 0x75021039 0x546110b9 0x32881106 0x026c10de 0x03e410de 0x03f010de 0x044a10de 0x044b10de</string>

Do i need to add anything to this list,what am I doing wrong?


I have a studio 1735 and mine is 0x284b8086, which you have already. We need the pinConfig guide. Wish i had time to dig into it myself.

#74
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL

Hey guys.

Ive got a Dell Studio 1535 with 92HD73c1 audio.

My deviceID is 0x10280254 (decimal-271057492)

In step 2 I edited the apple hda binary, replacing B0761D11 with 45028201 in both places

In Step 3 I edited AppleHDA.kext/contents/info.plist, changing CodecID to 271057492.

Step 4 is where I got stuck

I changed the CodecID in AppleHDA.kext/contents/plugins/AppleHDAController.kext/contents/info.plist

The how-to did not tell how to find the HD audio controller,so i didn't mess with it.

This is what it looks like.



<string>AppleHDAController</string>
<key>IOPCIPrimaryMatch</key>
<string>0x793a1002 0x437a1002 0x43831002 0x269a8086 0x26688086 0x27d88086 0x284b8086 0x293e8086 0x026c10de 0x037110de 0x75021039 0x546110b9 0x32881106 0x026c10de 0x03e410de 0x03f010de 0x044a10de 0x044b10de</string>

Do i need to add anything to this list,what am I doing wrong?
Help will be appreciated, thanks.

First of all you are not using the correct info for your card..... You should only attempt to do this if you have gotten a codec dump from linux..... But I would like to say try applehda and hdaenabler and let me know if it works for you,
They are not perfect yet however they do work for me... I am still working on them though so there will be updates.

#75
RaidenII

RaidenII

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts

r u sure.? because mine works finely . now im trying to fix line in


well in the system profiler it could detect the int mic and line in
but in system preferences it shows "the selected device has no inputs controls"
and i found a recorder and tried. no response.
what did you use to test?
btw, sound won't work after waking from sleep :-(

#76
bartont

bartont

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

Hey guys.

Ive got a Dell Studio 1535 with 92HD73c1 audio.

My deviceID is 0x10280254 (decimal-271057492)

In step 2 I edited the apple hda binary, replacing B0761D11 with 45028201 in both places

In Step 3 I edited AppleHDA.kext/contents/info.plist, changing CodecID to 271057492.

Step 4 is where I got stuck

I changed the CodecID in AppleHDA.kext/contents/plugins/AppleHDAController.kext/contents/info.plist

The how-to did not tell how to find the HD audio controller,so i didn't mess with it.

This is what it looks like.

<string>AppleHDAController</string>
<key>IOPCIPrimaryMatch</key>
<string>0x793a1002 0x437a1002 0x43831002 0x269a8086 0x26688086 0x27d88086 0x284b8086 0x293e8086 0x026c10de 0x037110de 0x75021039 0x546110b9 0x32881106 0x026c10de 0x03e410de 0x03f010de 0x044a10de 0x044b10de</string>

Do i need to add anything to this list,what am I doing wrong?
Help will be appreciated, thanks.


Here is the header of my Dell Studio 1735 codec dump, same as yours:
Codec: IDT 92HD73C1X5
Address: 0
Vendor Id: 0x111d7675
Subsystem Id: 0x10280256
Revision Id: 0x100202

Here is the link to the entire file in another thread:
http://forum.insanel...t...st&id=31468

Here is my modified AppleHDA.kext file that doesn't work and according to the OP needs the pinConfig mod:

Attached Files



#77
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
  • Gender:Male
  • Location:Mexico City

Hey guys.

Ive got a Dell Studio 1535 with 92HD73c1 audio.

My deviceID is 0x10280254 (decimal-271057492)

In step 2 I edited the apple hda binary, replacing B0761D11 with 45028201 in both places

In Step 3 I edited AppleHDA.kext/contents/info.plist, changing CodecID to 271057492.

Step 4 is where I got stuck

I changed the CodecID in AppleHDA.kext/contents/plugins/AppleHDAController.kext/contents/info.plist

The how-to did not tell how to find the HD audio controller,so i didn't mess with it.

This is what it looks like.

<string>AppleHDAController</string>
<key>IOPCIPrimaryMatch</key>
<string>0x793a1002 0x437a1002 0x43831002 0x269a8086 0x26688086 0x27d88086 0x284b8086 0x293e8086 0x026c10de 0x037110de 0x75021039 0x546110b9 0x32881106 0x026c10de 0x03e410de 0x03f010de 0x044a10de 0x044b10de</string>

Do i need to add anything to this list,what am I doing wrong?
Help will be appreciated, thanks.



1.- You need to edit AppleHDA binary with your hex id in this way I will put mine for example.

111d76b0 this is my codec id

111d for vendor ID IDT
76b0 for dev ID

so inside AppleHDA binary this hex will be b0761d11 if you look is 2 digits back ordered b0 was the last now is the first and so 76 and then 1d and at last 11. thats why 111d76b0 is b0761d11 and you tried 10280254 and this will be 54 02 28 10 not 45 20 82 01

you tried with 0x10280254 this isnt your codec id is your subsystem id your codec id looks something like "111d1234" (is just an example) because is and IDT with ven id 111d and 1234 for dev id. Using this as an example your codec id will be 34121d11. and translate this to dec will be

111d1234 = 287117876 for using it inside plist in codec id.

if you post your codec dump I will help you to find youd right pin config.

Sorry for bad english.

:) hope it helps


Here is the header of my Dell Studio 1735 codec dump, same as yours:
Codec: IDT 92HD73C1X5
Address: 0
Vendor Id: 0x111d7675
Subsystem Id: 0x10280256
Revision Id: 0x100202

Here is the link to the entire file in another thread:
http://forum.insanel...t...st&id=31468

Here is my modified AppleHDA.kext file that doesn't work and according to the OP needs the pinConfig mod:



OK

1.- You need to pach AppleHDA binary with 75761d11
2.- your codec id in dec will be 287143541 for patch inside plist
3.- follow your codec dump try this pin config

speaker

pin complex 0x0d
audio output 0x15

Headphone

pin complex 0x0a
audio output 0x16

Mic at ext

audio input 0x1b
audio selector 0x21
audio mixer 0x1d
audio selector 0x29
pin complex 0x0e

int mic

audioinput 0x1a
audio selector 0x20
pin complex 0x13

Reply with results. find if you have Output with volume control and mute so with input.

Hope it helps ;)

well in the system profiler it could detect the int mic and line in
but in system preferences it shows "the selected device has no inputs controls"
and i found a recorder and tried. no response.
what did you use to test?



Post your codec dump, for help but I try to explain

for output volume control works you need to have inside your plist

For example

mine

pin complex for int speaker 0xd in dec 13
and output 0x10 in dec 16 for make output obtain volume control inside plist this NODEID 16 must have an AMP this must be in coordination with your codec description inside your codec dump

Node 0x10 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
Amp-Out caps: N/A
Amp-Out vals: [0x71 0x71]
Power: 0x0

for input to obtain amp this must concordate with an AMP-IN the pin config for mic int or mic ext

the mine for example

mic ext

audio input 0x13
audio selector 0x1d
audio mixer 0x17
audio selector 0x1b
pin complex 0x0b

in all this path the only one with an AMP-IN was the audio mixer so the amp must be at NODE ID 23 (in hex 0x17)

Hope it helps ;)

Attached Files



#78
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
I would just like to point out that Areos you are the man.... I had been putting too much info into my path and that is why I lost audio control...... I had the pins correct but, I was trying to hard. I was tracing all through the codec and inputing everything.... such as mixers and selectors..... I can now use my folume control for everything I see my mic but I have no options with it and it appears 7o be non-working at the moment of course this is my Internal Mic I am talking about.....

Thanks Again, I will be working further and post my updates.

#79
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
  • Gender:Male
  • Location:Mexico City

I would just like to point out that Areos you are the man.... I had been putting too much info into my path and that is why I lost audio control...... I had the pins correct but, I was trying to hard. I was tracing all through the codec and inputing everything.... such as mixers and selectors..... I can now use my folume control for everything I see my mic but I have no options with it and it appears 7o be non-working at the moment of course this is my Internal Mic I am talking about.....

Thanks Again, I will be working further and post my updates.


I have your codec dump, and I think your Int Mic will be

audio input 0x1a dec 26 this one alone in plist
audio selector 0x20 dec 32 this with a boost value in plist
Pin complex 0x13 dec 19 this inside plist need an amp value

see the attach image.
Inside this amp mod there are other values if you are using plist edit pro just copy and paste it.

Good luck :(

Attached Files



#80
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
I will try that now and hopefully have it work soon.... I get a detect on my headphone insertion however I get no sound any ideas?

P.S. can you give me a view of what your amp layout is like for that mic?

Okay I tried the method mentioned and I see it as a built in input but, I still can not get it to do anything I even entered the config data under the controller......

I am also still having issues with headphones, but that is what I am working on now....
I have attached what I have done so far so any Dell Studio guys it mwill save you some time and I will update as I get more done.

Thanks, Mark





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy