Jump to content

Install Mac OS X to Acer Aspire One A150 from version 10.5.2 – 10.5.5

- - - - -

  • Please log in to reply
749 replies to this topic

#721
Fabrice en Picardie

Fabrice en Picardie

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Monneville, France
Hello,

My ACER ASpire One 150 was running fine with 10.5.6, but I had the silly idea (!!!) to upgrade to 10.5.7 and now the computer loops try to boot again and again...

I guess the problem is around the video driver (GMA950), but can someone help me getting my computer running again without loosing any document (photos, and so on) ?

I tried to boot "-v", got a screen full of lines for 1 second and then... reboot !

Same with "-x"...

Thanks a lot for any help.

Fabrice.

#722
bryanb124

bryanb124

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Hello,

My ACER ASpire One 150 was running fine with 10.5.6, but I had the silly idea (!!!) to upgrade to 10.5.7 and now the computer loops try to boot again and again...

I guess the problem is around the video driver (GMA950), but can someone help me getting my computer running again without loosing any document (photos, and so on) ?

I tried to boot "-v", got a screen full of lines for 1 second and then... reboot !

Same with "-x"...

Thanks a lot for any help.

Fabrice.



same thing happened to me. I ended up reinstalling....I hope someone else can figure it out. Only thing I've caught is that you have to have terminal and os86x tools open before you update and then redo the kernal and the gma950 kext; that might not be 100%, check on a couple more boards and see what they say.

The only 10.5.7 install I've seen is for ideneb....not xxx or ipc


late
r
bb

#723
bryanb124

bryanb124

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
alright, figured out the problem if you are having a boot loop after 10.5.7 update. type cpus=1 at the boot loader screen, you should get past the boot loop. At this point reinstall the mach_kernal, system kext, and seatbelt kext.

This worked for me. Once you do this, your boot file that had cpus=2 should work again (ie no change needed). Only issue I have right now is with video. Loads all the way up to the login screen then the graphics {censored} out and I cant discern anything on a scrambled grey login screen. I am able to boot all the way though in safe mode and am currently retrying different video kexts to resolve the issue.

Best of luck.

Bb

#724
bryanb124

bryanb124

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
ok deleted GMA 950 kext and video works...sigh, I just noticed USB is broken though, not sure if it is somehow tied to the GMA950 kext or it was broken from update. Tried to reinstall the USB fix kext but that didnt do it either....looking for some help now...

thanks

Bb

ok reinstalled the old IOUSBFamily and Massstorage kexts...back in business.

I think everything works now...camera and microphone, usb, etc.

havent checked hibernate, but thats neverworked for me, oh well.

Bb

#725
el_vecio

el_vecio

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

ok reinstalled the old IOUSBFamily and Massstorage kexts...back in business.

I think everything works now...camera and microphone, usb, etc.


I have got your same problem, my usb is no longer working but i can't find those kexts you talk about. could you please post them or email me them?
Thanks a lot!

#726
jumapili

jumapili

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have read though most of this thread it seems to go on and on so if I have missed this I am sorry. I actually have a new version of the acer one I have the AO531. I have been able to get it to update to version 5. I am not worried about the G3 modem but I would really like to get sound to work. When I follow the steps infact it does show up as HD audio but I get no sound. Has anyone tried this and been successful.

EDIT: I am thrilled. if you follow this link http://code.google.com/p/voodoohda/ you can download the voodoohda.kext and install it and everything works. Okay I am not sure about the mic... I will try that and give and update

#727
smeeshum

smeeshum

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

ok deleted GMA 950 kext and video works...sigh, I just noticed USB is broken though, not sure if it is somehow tied to the GMA950 kext or it was broken from update. Tried to reinstall the USB fix kext but that didnt do it either....looking for some help now...

thanks

Bb

ok reinstalled the old IOUSBFamily and Massstorage kexts...back in business.

I think everything works now...camera and microphone, usb, etc.

havent checked hibernate, but thats neverworked for me, oh well.

Bb


Thanks, helped out there loads! You got QE on you graphics though?


Through reading this entire post I have made a Magic 8 GIG USB Pen Drive,
I now have 10.5.7 working on my Acer Aspire One,

I went 10.5.4 iAtkos via USB Stick
Then Chameleon 2.0 RC1
Then the Terminal Sleep Code and upgrade to 10.5.5
Then the Terminal Sleep Code and upgrade to 10.5.6
Then reinstall mouse and keyboard kexts as they stopped working
Then the Terminal Sleep Code and upgrade to 10.5.7

Then install All Video Kexts except GMA950 kext
Install Ethernet
Install Sound

Fully booting and running with Vanilla Kernel!! No need for Seatbelt.kext either and am very happy all except theres no QE on the graphics card as the GMA950 kext wont work. Anyone know a fix for it?

#728
tori007

tori007

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hey everyone really new to os x actually first time trying it out. i v installed this over 10 times am sure i v done more and when i install the 5.4 update my keyboard and mouse stop working. read the guides over and over again please would like a step by step help. i really dont know much so please try to explain clearly.

#729
paulieweb

paulieweb

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Okay. AAO GZ5 running XXX 10.5.6.

Can't get wireless to work at all with the default card.

Can't get it to even see the hardware. The Airport fan
won't show up at all.

Any suggestions?

#730
paulieweb

paulieweb

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Okay, update from the above post.

AAO GZ5 with default Atheros card.

Now I'm running iPC 10.5.6
Voodoo kernell 9.5.0
and the wireless card shows up (the airport fan icon is there)
but it doesn't find anything.

I run kismac r19 and it scans but doesn't find any networks.

I tried installing the io80211.kext thingy but it changed it to say
that no airport card was installed.

So I reinstalled the iPC 10.5.6 and the card exists, the airport fan icon is there,
but it still won't find any networks.

Any ideas?

#731
Bhashkar

Bhashkar

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

EDITED : As per BLUE-K you can now use the new xXx 10.5.5-Disc to install your AA1 without editing some kext, the distr will work most of the hardware drivers except WIFI.

You may search for the xXx Mac Distribution using any torrent site.
Download the xXx-Disc, and apply the PPF1 + PPF2 on it and ins



This tutorial will help you Install Mac OS X to Acer Aspire One A150 from version 10.5.2 – 10.5.5
WARNING !!! not for the faint hearted ( children don't try this at home )
I have been doing a lot of trial and error on this just to get my AA1 work in Mac OS, but i guest my sacrifice has paid off, I thinks its safe to follow this tutorial
:twisted:

Need fixing are the following :
Touchpad Tap ( I'll try to recover the old 10.4.7 kext i have before since touchpad tap was working for my ECS laptop, I'll just update you once testing was OK )
Wifi Atheros AR500EG ( Still trying to find ways to solve the issue )
Sleep mode ( hmm not sure still looking for solution )

:!: Things you needed for this tutorial :
- A DVD containing Kalyway 10.5.2 install (you can find this on the usual 'torrent sites')
- The Kalyway 10.5.3 ComboUpdate (you can find this on the usual 'torrent sites')
- The Official 10.5.4 DELTA update from here
- The Official 10.5.5 update from here
- Paul's Wind driver and utility pack here
:!: place the above list on a USB stick or CD / DVD
- An external DVD drive
- Acer Aspire BIOS update here


How to update Acer Aspire One A150 BIOS
Thanks to : machani for this link here I modified and posted the procedures below.
1. You need a USB flash drive (SanDisk or any Generic brand)
2. Make it bootable to DOS by following these instructions: http://macles.blogsp...shing-bios.html
Follow this screenshoot when creating the bootable USB here
(NOTE: The screenshot shows the Drive is /dev/sb1. This screenshot seems to be done from a Linux machine. From XP, the Drive shows up as D:\ or E:\. Verify that that is the correct drive letter for your USB flash drive).
3. After you click OK, unzip the new BIOS files and copy the three files: 3304.bat, fla{censored}.exe and ZG_3304.fd to the flash drive
4. Leave the flash drive in the USB port, reboot, hit F12 at the initial boot prompt.
5. Choose USB drive to boot
6. It should bring you to a DOS screen choose number 5
7. Change to the C: drive by typing: C: followed by ENTER
8. Type: 3304
(You need to have your laptop connected to external power supply or it won't work).
9. When you reboot, hit F2 at the boot prompt and verify that your BIOS version is 3304

:!: After updating your BIOS, enter BIOS setup and press F9 to 'restore best performance defaults'. This step is VITAL!

Step by Step - installing OSX on your AA1 A150
1. Insert the Kalyway 10.5.2 disk into your external DVD drive, and plug it into your AA1
2. Start your AA1, and press F12 when prompted to choose a boot device, select your DVD drive
3. When prompted to hit a key to boot from CD/DVD, hit a key.... you'll see a ton of text scroll up the screen - just sit tight
4. You'll next be presented with your language select screen. I imagine you want English, so just hit enter! It'll then sit doing 'Preparing Installation' for a while.
5. When you get the 'Welcome' screen, don't hit continue straight away! Move your point to the 'Utilities' menu, and select 'Disk Utility'.
6. When the Disk Utility application has loaded, click your main drive in the left hand pane (probably the very top entryis your HDD manufacturer's name')
7. Click 'Partition' on the right hand pane.
8. Under 'Volume Scheme', click '1 partition'. ( this varies on your desire on how many partition you want )

9. Give your disk a nice name.
10. Click 'Apply'
11. Wait for it to do it's thing, then select 'Quit Disk Utility' from the 'Disk Utility' menu.
12. You'll now be taken back to the installer welcome page. Click 'Continue'.
13. Click 'Agree' when the legalese blurb pops up.
14. Choose a destination drive - obviously the one you just partitioned! Click 'Continue'.
15. Click 'Customize'.
16. Completely uncheck 'Language Translations'.
17. Expand 'Kernels' and select ONLY 'kernel_9.2speedstep'
18. Expand 'Graphics_Drivers', expand 'Intel_GMA' and select ONLY 'GMA950'
19. Completely uncheck 'Audio_Drivers'.
20. Expand 'Networks_Drivers'. and select ONLY 'RTL1000'.
21. Completely uncheck 'Mobo_Chipsets'.
22. Completely uncheck 'Thirds_Applications'. ( I choose some applications which I have used before but if you are a 1st time Mac user need you need uncheck this area )
23. completely uncheck 'Patches'.
24. Click 'Done'
25. Click 'Install' and go and make yourself a cup of tea! ( nice one Paul :lol!: )
26. :!: The install will now take place, if you want to speed it up, you can 'Skip' the installation DVD check.
28. When the 'Install Succeeded' screen appears, eject the install DVD and hit 'Restart'.
29. OS will now start up for the first time, and take you through the setup wizard.
30. When you have booted into OSX for the first time, goto drive name > applications > Utililities > Terminal


31. Insert the disk containing the Kalyway 10.5.3 update in a USB or CD
32. Run '1_Kalyway_UpdCombo10.5.3.pkg' this wil upgrade the system from 10.5.2 to 10.5.3 and step through the installation process. Do NOT hit restart when prompted!
33. After the above install has completed, run '2_kalyway_10.5.3_kernel.pkg' and step through the installation process. Select the 'vallina_kernel_9.3' kernel.
34. Restart your AA1.
35. When prompted to do so, press F8 to interrupt the Darwin startup.
36. Type 'update -v' (without the quotes obviously), and press enter. Your AA1 may reboot a couple of times during this update process. Don't panic!

37. When you have booted back into OSX, insert the disk containing the 10.5.4 update.

38. Double click the 'MacOSXUpd10.5.4.dmg' to mount the image.
39. After the image has mounted, run 'MacOSXUpd10.5.4.pkg' and step through the installation process.

40. When prompted press F8 and use "-v" to boot without quotes ( a lot of text msg comming out dont worry system will boot it self soon )
41. When you have booted back into OSX, insert the disk containing the 10.5.5 update.

42. Double click the 'MacOSXUpd10.5.5.dmg' to mount the image.
43. After the image has mounted, run 'MacOSXUpd10.5.5.pkg' and step through the installation process.

Installing Sound Drivers
1. Insert the disk containing the Wind driver and utility pack.
2. Select the 'Sound' directory
3. Double click on AzaliaAudio.pkg and go through the installation wizard and restart.
4. Download ALC268FIX from here http://rapidshare.co...8/ALC268FIX.zip
5. Run ALC268Installer 1 but Do not restart !
6. BEFORE restarting delete /System/Library/Extensions/ALCInject.kext

7. Use Paul's Kext Helper b7 to install HDAEnabler.kext

4. Fix Permissions with Disk Utility (launch Disk Utility, select your partition and then click on "Repair Disk Permissions" in the "First Aid" tab). and Restart.
5. Goto System Preferences > Sound > make sure that Internal Speakers is selected in Play alerts and Sound effects through
6. Now sound should work
Fixing the About this MAC

1. Goto Paul's Wind Driver Utility Pack
2. under Utilities
3. Double click on About this Mac.pkg and follow the instructions
4. no need to restart, you can check is changes are made by following the quote above
It should say : Processor Intel Atom CPU N270@1.6Ghz

Installing Video Card Intel GMA 945 with 1024x600 resolution my Fab.
1. run Kext Helper B7 from your Application Folder
2. open Paul's Wind Driver Utility Pack
3. select ONLY AppleIntelGMA950.kext, AppleIntelIntegratedFramebuffer.kext, AppleSMBIOS.kext, ClamshellDisplay.kext and Natit.kext
4. drag to Kext Helper B7
5. enter your password and click EASY INSTALL
6. Fix Permissions with Disk Utility (launch Disk Utility, select your partition and then click on "Repair Disk Permissions" in the "First Aid" tab). and Restart.
7. after restart you can now change your LCD resolution from 600x800 to 1024x600

Fixing Internal Microphone ( Thanks to StickMAC™ ) for the kext compilation from iDeneb_v1.3_10.5.5_ISO.

1. Download StickMAC kext compilation file at this link >> http://www.mediafire.com/?vmwyyzdmh3y
2. unzip the file
3. open kext helper and drag and drop AppleHDA.kext and HDAEnabler.kext
4. type in password and click EASY Install
5. to be safe Open Terminal
6. type "sudo diskutil repairpermissions /" without ""
7. reboot AAO
Fixed :
- Auto Switching from Internal Speaker to headphone
- Internal Microphone receiving excellently

With regards to touchpad tap Thanks to BurnZcodE

Just go to System Preferences...Keyboard & Mouse...Trackpad...at trackpad gestures, Check clicking...
touchpad tap /double tap and dragging should work by now.

I also found solution on the Mirror Issue you may download the pkg file from this link
http://forum.insanel...mp;#entry913715 Thanks to kamikaze for sharing the file
I have tested the pkg works great.

Some useful Tools for your new AA1 Mac OS X 10.5.5
X86 Tools utilities by : ~pcwiz click this link
Google the ff :
VLC for Mac - Video Player
Adium - Chat/Messenger for MAC works with MSN, Yahoo and many more accounts
MAC the Ripper - rip Video DVD
Onyx - maintenance tools
Pacifist - Extract dmg files
SimplyBurns - Mac CD/DVD burner
StuffIt - its like winzip
MacFuse & NTFS-3g - enables you to read & write on a NTFS file format partition

For Desktop Eyecandy Google for
- desktop manager for MAC



#732
nazimjamil

nazimjamil

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi guys and girls, I've found this thread quite helpful and have wrote up my specific walkthrough to get this bangin' operating system working on your aa1!

http://nazimjamil.co...r_Acer_Aspire_1

Thanks and comments welcome!

#733
acm1108

acm1108

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
When I try to open photobooth it tells me that my Video Card is not supported. I used XxX 10.5.6 and installed the 950 drivers and such am I missing anything? Or should I use Kalyway and try it that-a-way lol.

#734
Jack87

Jack87

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Has anyone come up with a solution to turn this install into snow? 10.6.x

#735
exuptoy

exuptoy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hi all,
Finally finished intalling XxX 10.5.6 last night, wicked distro you guys. Amazing think of beauty.

I am still struggling with getting my wireless atheros working, I had a message after installing IO80211Family Kext that there was a new device found. Now I have a yellow dot and AIRPORT ON but even with Kismac it still doesn't find my WPA2 network.
I have tried allowing airport to assist me and is says other airport network but when I try to input my password it says incorrect password, I have checked my router and can find no mac equivalent of the password.

Can anyone point me in the right direction? I realise it may be in the thread but there is so much info in there for a total MAC newbie I am lost.
I may have to upgrade to a 1390 card.

#736
exuptoy

exuptoy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Reinstalled everything to make my acer dual boot and when I finished with OS X it finally connected to the net but after rebooting Kismac no longer finds my network.
Why? What should I do?

#737
exuptoy

exuptoy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Finally sorted it by swapping out the wireless card for the 1390 but it was a PITA trying to find a windows xp driver. Got there in the end though.
Thanks for all the advice and input everyone. :D

#738
exuptoy

exuptoy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Just noticed the resolution is only 800x600 and there is no option for anything else. When checked the extensions file, I noticed there are quite a few drivers in there, ie gma950ga plugin, gma950gldriver bundle, gma950vadriver bundle, gmax3100fb, ga, va and gl drivers, surely this will conflict and I should remove some of these.

I made the mistake of adding gma950 driver from pauls wind drivers thinking that it would give me extra resolution settings and just succeeded in hanging on the startup screen and had to do a safe start then delete the file which is when I found all these others.

Anyone have any advice for me?

#739
exuptoy

exuptoy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Would Netbookinstaller 8.2 cure my resolution maladies as I am lost.
Can anyone help?

#740
exuptoy

exuptoy

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Resolution sorted. Deleted 4 of the kexts which are included in the paulswind pack and noticed clamshell missing. Anyway reinstalled all 5 drivers and voila.
Just need to sort out the tap click on the mouse and I'm there!
Anyone?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy