Jump to content

ATI Radeon HD pkg installers 10.5.x & 10.6


  • Please log in to reply
2377 replies to this topic

#1581
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
for all 3650 Pcie users report back kthx

DOWNLOAD

#1582
Ritz Carltn

Ritz Carltn

    Ritz Carltn

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Interests:HP EliteBook 8540p,i7-820QM, 68CVD Ver F.0F, nVidia NVS5100M, ML with Clover

for all 3650 Pcie users report back kthx

DOWNLOAD


LastExile,

I failed. Same Symptoms.
Can not boot as normal with deep blue color with small blinking square, just Safe Booting.

Attached File  screen_capture_3.jpg   49.4KB   130 downloads

#1583
Meowolf

Meowolf

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Nope nt working for me either. I get black / white squares like sumone in previous posts

#1584
jaguarg

jaguarg

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Hi guys,

I have installed the package for ATI HD Mobility 3650 available from the first post.
Also, I activated QE/CI using osx86 tool.

Still,I can't change the resolution to anything but 1024x768.

What am I missing to get full QE/CI working on my mobility 3650?

thanks
jaguarg

____________________________
OSX86 10.5.6 on:
dell studio 1735
HD radeon mobility 3650
dual boot Vista Ultimate / OSX86

#1585
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

Hi guys,

I have installed the package for ATI HD Mobility 3650 available from the first post.
Also, I activated QE/CI using osx86 tool.

Still,I can't change the resolution to anything but 1024x768.

What am I missing to get full QE/CI working on my mobility 3650?

thanks
jaguarg

____________________________
OSX86 10.5.6 on:
dell studio 1735
HD radeon mobility 3650
dual boot Vista Ultimate / OSX86


what laptop ? and internal screen works but only at 1024x768 post a screenshot of the system profiler

#1586
chishty

chishty

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

ATI Radeon HD 3450 & 3470 pcie
Device ID:

Coming soon

I have been waiting for at least 3 months for the drivers for 3450.
Still no progress?

#1587
coltrane

coltrane

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Cologne/ Stettin

I have been waiting for at least 3 months for the drivers for 3450.
Still no progress?


Please read the whole thread, were all waiting;)
To be more exact: Waiting for new framebuffer that Apple has to realase or someone can write one...

#1588
completemacnewbie

completemacnewbie

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
To Methanoid in particular, but for anyone else still having problems getting the 3850 working. I got it to work (almost) 100%.

I'm running a PowerColor HD 3850 512MB GDDR3. I don't remember what the memory speeds are, but message me if you really need to compare. I tried for two weeks to get this card working. I tried everything including every different installer from 10.5.2 to 10.5.6. I tried more different driver packages than I can count. Finally I found a driver that worked. Here is what I did:

1. Installed iPC 10.5.6 from scratch without any video drivers
2. Installed the downloaded package from this page (file = ATI Radeon HD.pkg dated June 1st 2008 / 43.3MB)

That's it!
After all the messing with framebuffers and drivers etc, this one worked right away.

I now have all resolutions on both displays (LG 22" LCD + Sharp Aquos TV), even rotation works!

I have yet to get sleep working, but I'll report back if I do.

Thanks so much to everyone here.


Cheers!

#1589
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany

To Methanoid in particular, but for anyone else still having problems getting the 3850 working. I got it to work (almost) 100%.

I'm running a PowerColor HD 3850 512MB GDDR3. I don't remember what the memory speeds are, but message me if you really need to compare. I tried for two weeks to get this card working. I tried everything including every different installer from 10.5.2 to 10.5.6. I tried more different driver packages than I can count. Finally I found a driver that worked. Here is what I did:

1. Installed iPC 10.5.6 from scratch without any video drivers
2. Installed the downloaded package from this page (file = ATI Radeon HD.pkg dated June 1st 2008 / 43.3MB)
That's it!

Cheers!


Ok, much better than no QE/CI, but your driver set will be really old and will have bugs which can make trouble in games / CI Apps.
I dont know why a lot of people (really tried all) have such big problems to get their 3850 running.
I am sure it also depends on the ATOMBIOS of that card.
So i am lucky that my 3850 PCie MSI 512 MB also wasnt easy, but runs with newest
drivers and the efi string made with EFISTUDIO_EXTENDED (MegadolonFB selected).
So i would not recommend buying ATI 3850 anymore (also Snow Leo will be an nightmare!).

#1590
camtech

camtech

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:CA
  • Interests:Web Design, Photoshop, OSX86!

I dont know why a lot of people (really tried all) have such big problems to get their 3850 running.

I agree, my 3850 pcie 256MB actually works perfectly... just every other restart (I know, wtf).
Basically for me every day, I go on>blue screen>off>on>work perfectly. QE/CI, Dual screen (1680x1050 x2), everything works fine...every other restart.

So its livable, just kinda sucky.

#1591
WinstonAce

WinstonAce

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 334 posts
Hi
from my experience, you only need two kext's (attached) for megadolon support on 10.5.6 with HD 2600 PRO
(Device id 9589)

May also work with other cards:
Radeon 2900 (0x94001002 0x94011002 0x94021002 0x94031002)
Radeon 2600 (0x95811002 0x95831002 0x95881002)
Radeon 2400 (0x94c81002 0x94c91002)
Radeon 3800 (0x95001002 0x95011002 0x95051002 0x95071002 0x95041002 0x95061002
Radeon 3600 (0x95981002 )

Attached Files



#1592
Murton

Murton

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ATI Radeon Mobility HD3650

tried driver from front page and as many other reported, blue screen and fades to white with a graphic artifact on the right hand side, vertical line.

Dell Studio 17, havent tried external monitor or HDMI. 10.5.5. Will do a clean install and update to 10.5.6 and try again with external montiors etc and report back soon.

#1593
aurelien9

aurelien9

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
i've a toshiba a300, i tried the package for mobility 3650 but i have a strange screen (white, black, yellow, green)

#1594
klofisch

klofisch

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
mmh I have an HD2600Xt PCIe. Nothing changed after installing the driver. Core image is still software accelerated and no quartz extreme support.
How to fix?

#1595
amihot

amihot

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Dear lastExile:
My card is Onda 2600 Pro work on iPc 10.5.6(AMD cpu).
I use the 2600pro pci.pkg,installed and reboot.
In System Profiler.Display ATI Radeon HD 2600XT(no right).
I get good Resolutions 1440x900 in LG 19w inch monitor,but no CI/QE.
Google it,and find someone solved the problem.
He update 2600pro graphics card bios with 2600XT then can get CI/QE.
I follow what he do,but not successful.
My English not very good, please forgive me.
Can you give me some help? Thank you.

amihot

Attached Files



#1596
applehacker

applehacker

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 386 posts
I have been digging around, and apparently the framebuffer (megaloden) WORKS with mobility 34xx and 36xx, HOWEVER, only mobility 36xx is compatible iwth ati2000.kext (injection method). Mobility 34xx does not work this way, something with the way the lcd is wired, preventing it to work.

#1597
MrGreen

MrGreen

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
I am currently on 10.5.5 with dead Nvidia card (AGP) and no success with AGPgart.
I an very interested in Sapphire ATI Radeon HD 3850, 512MB, AGP - good performance, good price.

1. Will you recommend it ?
2. Is there installer available ?
3. Can I get full acceleration through AGPgart ?

BR

Edit : Apple released their Graphic Update 1.0 Yesterday.

#1598
bastop

bastop

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
So does the update, apple released, include the framebuffer update for the 3450?
Does apple actually announce the topics of their updates?
So is there already hope, that the mobillity 3450 will be working? My problem is: I'm running macosx since November last year on my only laptop. I wasn't sure about, how much work it is for the developers of the drivers here? So I supposed, the drivers would be coming out soon...
So is there any news, which not posted yet? Sorry for that post :(
But thanks

Basti

#1599
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France

Edit : Apple released their Graphic Update 1.0 Yesterday.


What Graphic Update 1.0 ????? You talk about the 11/02/2008 one ?

http://www.apple.com...csupdate10.html

#1600
Gazza_DJ

Gazza_DJ

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Suscribing to this - I have a Dell Studio 15, spec:

C2D P8400

4GB DDR2 800MHz RAM

ATI HD 3450 256MB

32GB HDD

1440x900 LED screen



As soon as any sort of driver package is available for the 3450, i'll gladly test it on my machine :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy