Jump to content

Creative SB [Live!, Audigy, Audigy2, EMU10kX eDSPs] OSX Driver info here!


  • Please log in to reply
849 replies to this topic

#841
yassinex

yassinex

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts

I had the same problem and this kext fixed it. I'm using Yosemite.

 

Confirmed working with Sierra 10.12 with my PCIe Audigy RX

 
Can any one help me to understand : 
1- How to use the Mixer ( As I can see only one output in Sound System Preferences). Is there a working version of kX Mixer ?
2- I've connected my PC Front panel. Now, I can plug the headphone/mic, but I still have sound coming out from the main output. Why the sound is not switching off automatically when I plug the HP ? is it a normal behaviour ?
 
Thanks a lot guys for your help !


#842
mrkapqa

mrkapqa

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Hello i just found out about this here - freshly installed Soundblaster Audigy FX in a Powermac G5 Quad with running Leopard 10.5.8 PPC - can i use this

 

kXAudiodriver.kext 

 

to get this card recognized?



#843
kaws

kaws

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hello guys

I want to buy a new audio card for my rig and Audigy 2 looks fine (24/192 and all that stuff).

But only thing I can't figure out is inputs

Do they work? I really need my microphone to work

So can someone help me with that?

I'm on Sierra right now 



#844
jaymack

jaymack

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts

Hello guys

I want to buy a new audio card for my rig and Audigy 2 looks fine (24/192 and all that stuff).

But only thing I can't figure out is inputs

Do they work? I really need my microphone to work

So can someone help me with that?

I'm on Sierra right now 

I have not been able to get my Audigy card to work since Yosemite. I found that a very cheap USB sound device works perfectly well.



#845
ITzTravelInTime

ITzTravelInTime

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 266 posts
  • Gender:Male
  • Location:Italy
  • Interests:computer science, programming, hardware, software developing

for the audigy rx and for better compatibility with newer versions of os x i am working on my own branch of this driver, you can find more info and a beta download at this thread:

 

http://www.insanelym...124rx-emu-edsp/


Hello i just found out about this here - freshly installed Soundblaster Audigy FX in a Powermac G5 Quad with running Leopard 10.5.8 PPC - can i use this

 

kXAudiodriver.kext 

 

to get this card recognized?

 

the driver is compatible only with some emu 10kx chips, not with the chip used on the audigy fx, so the card will not work with this driver, if you want, you can try voodoo hda that maybe can get it working, but i am not sure about it



#846
jaymack

jaymack

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts

The card has not worked for me since Yosemite. Now using Sierra.



#847
ITzTravelInTime

ITzTravelInTime

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 266 posts
  • Gender:Male
  • Location:Italy
  • Interests:computer science, programming, hardware, software developing

to get the kx driver and mine driver mod to work under Mac OS X Yosemite and newer you have to use the kext-dev-mode=1 boot arg  and you have to make sure that your audio card is properly installed in your computer



#848
jaymack

jaymack

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts

kext-dev-mode=1 s being used. The card works perfectly under windows, so I know it is correctly installed.



#849
ITzTravelInTime

ITzTravelInTime

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 266 posts
  • Gender:Male
  • Location:Italy
  • Interests:computer science, programming, hardware, software developing

ok, may be a conflict with other drivers, I suggest to you to try without other audio drivers installed, the kext has been tested and works apple alc and voodoo hda installed on the same machine, may be something conflicts with the card, so do some tests



#850
jaymack

jaymack

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts

I removed voodoohda as I do not use the onboard audio. I have been using a USB sound device that worked right away. I do not know if Sierra has installed any drivers for this. When trying to get my Audigy to work, the USB device is removed. I have two separate installs of Sierra and the card fails with either.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy