Jump to content

OS X 10.10.4 Update Available - Build 14E46 - Updated


Allan
 Share

Apple release today the new update for OS X Yosemite.

 

The new OS X version is available through the Mac App Store. Developers and public beta testers running preview releases of OS X 10.10.4 can find the update through the Updates tab as well.

 

This update:

• Improves networking reliability

• Improves Migration Assistant reliability

• Addresses an issue that prevented some external displays from functioning properly

• Improves the reliability of upgrading iPhoto and Aperture libraries to Photos

• Improves reliability when syncing photos and videos to iCloud Photo Library

• Addresses an issue that could cause Photos to unexpectedly quit after importing some Lecia DNG files

• Resolves an issue that could delay outgoing email messages in Mail

• Fixes an issue where a website could prevent the user from navigating away by presenting repeated JavaScript alerts in Safari

 

Enterprise content

 

For enterprise customers, this update:

• Addresses an issue where OS X systems bound to directory services could stop responding under certain conditions

• Adds the ability to create mobile accounts with the createmobileaccount tool

• Fixes an issue in Profile Manager that could allow a user to install pre-release software even when the setting is disabled

 

Normal Update: OS X Yosemite 10.10.4 Update

Combo Update: OS X Yosemite 10.10.4 Combo Update

 Share


User Feedback

Recommended Comments



Installed the update and all went fine, I had to do 2 minor fixes:

 

boot with nv_disable=1 and install nvidia beta drivers WebDriver-346.01.03b01 for my 970GTX

 

and

 

patch Realtek HDA1150 again

 

All fine now, 10.10.4 up and running.

Link to comment
Share on other sites

And just for report, this command - Is for resolve the garbled boot in Yosemite

sudo perl -i.bak -pe 's|\x41\x88\xC4\xEB\x11|\x41\x88\xC4\xEB\x31|sg' /System/Library/Extensions/IOGraphicsFamily.kext/IOGraphicsFamily

Don't work in 10.10.4  :(

Link to comment
Share on other sites

artifact graphics on hd7770 .... i can boot in to safe is fine... iirc on 10.10.3 i had to edit a boolean  in the AMDhd4000 kext   i cant remember which kext it was ... 

Link to comment
Share on other sites

artifact graphics on hd7770 .... i can boot in to safe is fine... iirc on 10.10.3 i had to edit a boolean  in the AMDhd4000 kext   i cant remember which kext it was ... 

Change the red number

 

<key>AMDVerdeGraphicsAccelerator</key>

<dict>

<key>ATIEnableWideBlitSupport</key>

<true/>

<key>ATIUseTearingWideBlit</key>

<false/>

<key>CFBundleIdentifier</key>

<string>com.apple.AMDRadeonX4000</string>

<key>GpuDebugPolicy</key>

<integer>0</integer>

<key>IOClass</key>

<string>AMDVerdeGraphicsAccelerator</string>

<key>IODVDBundleName</key>

<string>AMDRadeonVADriver</string>

<key>IOKitDebug</key>

<integer>0</integer>

<key>IOMatchCategory</key>

<string>IOAccelerator</string>

<key>IOPCIMatch</key>

<string>0x68201002 0x68211002 0x68231002 0x68251002 0x68271002 0x682B1002 0x682D1002 0x682F1002 0x68351002 0x68391002 0x683B1002 0x683D1002 0x683F1002</string>

<key>IOProbeScore</key>

<integer>200</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>IOSourceVersion</key>

<string>0.0.0.0.0</string>

<key>IOVARendererID</key>

<integer>16908288</integer>

<key>cail_properties</key>

<dict>

<key>CAIL_DisableDrmdmaPowerGating</key>

<integer>0</integer>

<key>CAIL_DisableDynamicGfxMGPowerGating</key>

<integer>1</integer>

<key>CAIL_DisableGfxCGPowerGating</key>

<integer>1</integer>

<key>CAIL_DisableGmcPowerGating</key>

<integer>1</integer>

<key>CAIL_DisableStaticGfxMGPowerGating</key>

<integer>1</integer>

<key>CAIL_DisableUVDPowerGating</key>

<integer>0</integer>

<key>CAIL_DisableVCEPowerGating</key>

<integer>0</integer>

</dict>

 

</dict>

Link to comment
Share on other sites

boot with nv_disable=1 and install nvidia beta drivers WebDriver-346.01.03b01 for my 970GTX

 

 

Btw, official web drivers are already available

  • Like 1
Link to comment
Share on other sites

Update from osxupd10.10.4.dmg and restart without any issues till now.

 

Model Name: iMac

Model Identifier: iMac13,2

Processor Name: Intel Core i5

Processor Speed: 3,40 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 6 MB

Memory: 16 GB

Bus Speed: 400 MHz

Boot ROM Version: IM131.010A.B05

  • Like 1
Link to comment
Share on other sites

And just for report, this command - Is for resolve the garbled boot in Yosemite

sudo perl -i.bak -pe 's|\x41\x88\xC4\xEB\x11|\x41\x88\xC4\xEB\x31|sg' /System/Library/Extensions/IOGraphicsFamily.kext/IOGraphicsFamily

Don't work in 10.10.4  :(

 

Forgot what i say about this code, now i can boot without any glitches in OS X 10.10.4

sudo perl -i.bak -pe 's|\x41\x88\xC4\xEB\x11|\x41\x88\xC4\xEB\x31|sg' /System/Library/Extensions/IOGraphicsFamily.kext/IOGraphicsFamily
sudo touch /System/Library/Extensions
  • Like 2
Link to comment
Share on other sites

Hi and Welcome to InsanelyMac.

 

I use Clover in UEFI, and after this update everything works fine here.

 

Are you sure that you have installed the Clover in UEFI mode?

Link to comment
Share on other sites

Anyone with EFI clover setup that made the update? I can't boot now and i can't find the amd kext in the EFI partition

What is your specs ? Please put this info in signature

because People need this Info for helping you

  • Like 1
Link to comment
Share on other sites



×
×
  • Create New...