Jump to content

How to solve Kalyway 10.5.1 blinking cursor problem


15 posts in this topic

Recommended Posts

This problem has annoyed me for a long time.

Fortunately, I finally found the solution.


It's already been mentioned in the following topic:




But you may miss it.


Therefore, I start a new topic so that people can easily read it.


My situation:


If I leave the DVD installer in the drive, it can boot correctly.

Otherwise, I got a blinking cursor.



Erase your Kalyway partition.

Name it only with 1 word such as "Kalyway", "Leopard", etc.

Install Kalyway, it would boot correctly.


Hope it help

Link to comment
Share on other sites

  • 2 weeks later...

Yes, I discovered about having spaces in the Volume name. However, I was still not able to boot after installing the DVD.

So, I developed a boot loader installation that works on Kalyway, iATKOS, ToH, or BrazilMac. If anybody wants to try it, send me and e-mail to macgenius6@gmail.com and I will send it to you.



Link to comment
Share on other sites

  • 3 weeks later...
  • 4 weeks later...
  • 2 months later...
hi... my partition is called 'leopard'.... one word.. and i still get the blinking cursor...



I thought after previous successful iATKOS installation and many months of tweaking, I know how to install but I guess I am wrong. Don't know what I am missing. I too have a single word Leopard name in it and I get blinking cursor. Its Kalyway 10.5.2 and I am trying on Western digital (640 GB one) with 7 partitions; first diskXs1 is EFI non mountable one; disk Xs2 is a small 2 GB partition and I am trying to install on the third partition disk Xs3, named a Leopardcopy.

With a working iATKOS, I had partitioned this WD640 with GUID partitioning scheme. Installed PCEFI_v8, MANUALLY, from a USB drive (could be done from iATKOS HD installation also, but just in case).


Unmounted first all the partitions


./startupfiletool /dev/rdisk0s3 ./boot_v8


dd if=./guid/boot1h of=/dev/rdisk0s3 bs=512 count=1


Unmounted all the partitions again


dd if=./guid/boot0 of=/dev/disk0 bs=400 count=1


Interesting, I dont see any error during this efi install, no resource busy or anything. But I dont get that com.apple.boot.plist not found thing, just a blinking cursor. But I went ahead to install Kalyway DVD 10.5.2 anyway. I can boot through the DVD but blinking cursor without.


I have used Gparted Live CD to put a boot flag on the third partition, but what I find is that the disk remained unmounted or greyed out in disk utility. So I have to remove the boot flag.


Anyone can tell me what is going on?


PS: I used fdisk to activate the partition as well but does not help.

Link to comment
Share on other sites

if you dont have too much to worry on your hdd, just use kalyway 10.5.2 dvd and use disk utility to make new partitioning...


if you care, what i would suggest you is, create 4 partition scheme...


1-main-osx journaled-80gb

2-test or backup-osx journaled-80gb


4-name this anything you want-dos/fat32-rest of the hdd space (later from windows to add your other stuffs... 4th partition will be extended so you can create more partitions as you like later :( )


options: MBR scheme!!! dont use GUID, it will give u more trouble than good... MBR is more than enough already

if you dont understand or need more advice pm me...

Link to comment
Share on other sites


  • Create New...