Jump to content

[GUIDE] Leopard on HP Compaq 6710b with EFI_v80 (Wireless, Graphics, Sound)


119 posts in this topic

Recommended Posts

Hi @all


I bought a HP Compaq 6710b a week ago and I was trying to get Leopard working on it. With everything it needs... Actually, that is quite difficult, but I got some results, I'd like to share with you.


What you need:

- OS X ToH RC 2 - Disc

- USB Stick

- 6710b Installation Files: Download ZIP here

- Linksys Compact Wireless-G USB Adapter (WUSB54GC) --> costs about 20-30 Euros. And it's worth the money... AND the only way to get networking yet



- Format your USB-Stick and Name ist to "123".

- Unpack the 6710b ZIP and copy the files on the stick

First part: Installing Leopard

To Install Leopard on your 6710b, you just need to follow the guide here: http://forum.insanelymac.com/index.php?showtopic=75928

Only change: you don't have to do the copy-part with your USB stick. The files in the 6710 zip-file contains also all files needed for the guide (pc_efi_v80)


IMPORTANT: Boot with the -x option from the ToH DVD (press F8 before boot, and then -x)

Be aware: After Installation of OS X ToH, you'll get a Kernel Panic. This is okay, just do the next step


Second Part: Install the right Kernel and get Framebuffer Support

Now boot once again to the ToH Disc (-x again).

Go to the Terminal again.


IMPORTANT: You'll need the name of the Volume where leo is installed and also the stickname (which should be 123, if you followed the guide until now). For my leo-Volume I'll use "Macintosh"


What are we gonna do now:

First, we will replace the ToH Kernel withe the newest 9.1 Speedstep Kernel which works perfectly for the 6710b. Then we delete all X3100 Files and install the Original Leo Framebuffer File, so that you can boot without -x mode into leopard. To work in the Terminal in Leo is much easier than in the ToH installer ;-)


So type this in the Terminal:


rm -R /Volumes/Macintosh/mach_kernel
 cd /Volumes/123/kernel/
 cp mach_toh /Volumes/Macintosh/mach_kernel
 chown root:wheel mach_kernel
 chmod 644 mach_kernel

 cd /Volumes/Macintosh/System/Library/Extensions
 rm -R AppleIntelGMAX3100*
 cd /Volumes/123/framebuffer/
 cp -R AppleIntelIntegratedFramebuffer.kext /Volumes/Macintosh/System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext
 chown -R root:wheel AppleIntelIntegratedFramebuffer.kext
 cmod -R 755 AppleIntelIntegratedFramebuffer.kext


Now, reboot (don't remove USB stick atm) and first enjoy the Leopard GUI... You did the first step to a good working leo System on your HP Compaq 6710b :blowup:


Third Part: Get REAL graphic support - with QE and CI

Now, we should try to get some better graphics now. If you didn't get any Kernel Panics or other errors, then this should be easy ;-)

Open the Terminal in Leopard

cd /Volumes/123/graphics
 sudo cp -R AppleIntelGMAX3100.kext /System/Library/Extensions/AppleIntelGMAX3100.kext
 sudo cp -R AppleIntelGMAX3100FB.kext /System/Library/Extensions/AppleIntelGMAX3100FB.kext
 sudo cp -R AppleIntelGMAX3100GA.plugin /System/Library/Extensions/AppleIntelGMAX3100GA.plugin
 sudo cp -R AppleIntelGMAX3100GLDriver.bundle /System/Library/Extensions/AppleIntelGMAX3100GLDriver.bundle
 sudo cp -R AppleIntelGMAX3100VADriver.bundle /System/Library/Extensions/AppleIntelGMAX3100VADriver.bundle
 sudo cp -R Natit.kext /System/Library/Extensions/Natit.kext

 sudo chown -R root:wheel *
 sudo chmod -R 755 *


Reboot again... If everything went well your leo boots up with QE and CI supported. Just go to the Display Section in you System preferences. Change the resolutions to 1680x1000 (not 1680x1050!! This will perform a nice bluescreen :-P).

Have fun with full QE/CI support :P

Fourth Part: Get WLAN connection

That part is the hardest part... It costs acout 20-30 Euros, because to get networking with the 6710b you'll need to use an external source. At the moment, the integrated wireless and also the intergrated ethernet connection won't work. I hope they'll do later. Drivers are in development, but it's quite hard for the developper, because he has not the right hardware to test.

The best WiFi support you'll get with the Linksys Compact Wireless-G USB Adapter (WUSB54GC), which is fully supported and has good drivers.

- To install the drivers for the adapter, go to the USB stick, into the "wireless" folder. Unpack the Ralink Wireless Drivers Installation Wizard.mpkg.zip and install the package.

- Reboot and press F8 before booting. Enter -f as boot argument to load the driver.

- Now undpack and install the ralinkv015.zip package


- Go to /Library/Preferences/SystemConfiguration and change the com.apple.Boot.plist

- Add/change the following:

<key>Kernel Flags</key>


- Reboot again, enter nothing, just boot

- Go to the network properties and configure the new adapter which you'll find there (manually will do it best)

- If the Ralink Utlity didn't start yet, just go to programs folder and open the Wireless utilty.

- Your adapter and the nearest network should show up here (so you nearly got ist ;-)).

- Create a profile with your network informations (SSID, Security, etc.) and connect

You should have now full internet access :D


Fifth part: We want sound :D

That part is quite easy :D

The azalia sound driver will help your sound card to get some music :D

Just navigate to the "audio" directory on your USB Stick and install the azalia.audio.pkg


Enjoy sound :D



So that's it for the moment...

IMPORTANT: Don't update the Kernel with the 10.5.1 Kernel from apple. It will end into a Kernel Panic... Don't know why. The speedstep 9.1 kernel seems to be the best for the 6710b at the moment.


Sixth Part (added 16.12.): Add energy options

Maybe you'll found out, that you have no battery icons and no infos about the battery. Either, the battery is going down quite fast.

I found a first workaround, which gets you at least the icon.

- Download http://forum.insanelymac.com/index.php?act...ost&id=2295

- Do the following steps:

1. Un-archive the files. This will leave you with a PowerManagement.bundle

2. Navigate to: /System/Library/SystemConfiguration

3. (Optional) Backup your old PowerManagement.bundle

4. Copy (drag-n-drop) the new bundle into the SystemConfiguration folder

5. When the dialog box pops up, select authenticate and type your admin password

6. Reboot

For me I can't change the energy environnment yet. But I'm gonna do some tests with Paulicats ACPI kexts soon. So hope, I'll do some progress,


Special Thanks to:

JamesD (for the pretty cool installation guide (see above))

mitro (for his extensions I used to get QE/CI working)

keithpk (for the energy options workaround)

Things I'll need to find out:

- How to reduce brightness (for longer battery lifetime)


If you have suggestions, questions, ideas...

I'm glad to read responses :D

Link to comment
Share on other sites

HI Klyx,


I've lost my Leo :D, can you send me in private my Ext link..




...in my last installation i' ve got working vanilla kernel with efi 5.1, i think the kernel panic problem is EFI v8..


..I know for strange thinks with ralink on reboot, but you know .. 20 Euro and you got it.. (i think is the driver implementation).. :P)

Link to comment
Share on other sites

Hi mitro


got PM ;-)

I saved my leo partition to an external USB device. So if something would go wrong, I can restore it. Only thing I have to do is reinstall efi which is done in some minutes :D



The problem I had with the USB Wireless driver was, that after every reboot it didn't work again. But I found out, that it will work, if you reinitiate all drivers on boot with the -f option. So that's why I added the -f flag in the com.apple.Boot.plist. Don't want to enter this all the time :D


Does the guide helps someone else? Anyone with HP 6710b? Might also work with other HP business notebook with this chipset (GMA 950).



Link to comment
Share on other sites

Just found out: The azalia driver brings some problems: System mutes itself every minute or so... That's not nice.

As soon as there is a solution, I'll post it here.



Link to comment
Share on other sites

  • 2 weeks later...

Gruezi KlyX :)


I have a 6710b and will try to install Leo just tomorrow. In the meantime, can somebody tell me how the 1680x1000 works? Does it look stretched on the vertical edges? Or do you get black stripes?


It would be nice to get native resolution..


By the way, I've downloaded Kalyway 10.5.1 and will install it tomorrow. Any known drawback or should it be just fine?





Link to comment
Share on other sites

Thank you KlyX!!!!


I spent long time trying to install real graphics in my Leo and finally I did it thanks to you... :)


...but today when it tried to install the wireless driver my Leo just gone :P .


I already reinstall everything but I cant get real graphics again...

Link to comment
Share on other sites

Hi KlyX,


Good guide =D


I'm just curious about the AppleIntelIntegratedFramebuffer.kext you got inside the zip file.


Where did you get that? I noticed that the version is 1.5.2?


Did you happen to get this version from 10.5.2 beta? usually its 1.4.20 and 1.5.18 (from 10.5.1)


THank you =D

Link to comment
Share on other sites

Installed yesterday Kalyway 10.5.1 on my 6710b with vanilla kernel and EFI 8.0. Kernel version is


I've been able initially to boot the system with the -x switch and got graphics immediately although in safe mode (1024x768). Then I've replaced all of the X3100 kexts with the ones provided by Klyx. I *deleted* the framebuffer one as that's used by the GMA950 and has nothing to do with the X3100.


I've skipped the kernel replacement step suggested by Klyx as the one provided within Kalyway worked out of the box.


If I boot in safe mode I can select 1680x1050 because QE and CI are disabled but the mouse cursor will be corrupted. Booting normally only 1680x1000 works and QE+CI will be enabled, but screen will look a bit blurred due to the resolution stretch. I don't find it very usable having 50px stretched from the top to the bottom, but I admit to have picky eyes.


ACPI doesn't work at all. Fan never gets turned on and this is quite dangerous for a laptop, as heating tends to grow and doesn't get cooled. Brightness is a no no as well, this is strange because in the 6710b this is controlled by the bios. In Linux I had problems with the ACPI video control and after having it disabled I could control the brightness through the keyboard. We should do the same under Leopard, exclude ACPI for the brightness control and let do this to the BIOS, but I don't know how.


Sound. Azalia default kext in Kalyway 10.5.1 works but it presents the same mute issue described in a few posts above. Also, I've noticed that if I plug the earphones into the integrated output, sound still goes out the integrated speaker. I supposed this was done by hardware through an exclusion mechanism, you never stop to learn.. :-)


At the moment I'd say the most critical issues to solve are ACPI (for proper cooling and energy saving - included brightness control) and native resolution (1680x1050). Sound and wlan can wait (for the latter I've managed to get a CNET usb dongle working with the ralink drivers found on the realtek website, although they seem to have some tcp overflow issue).


So far this is my experience with the 6710b. It's the first time I put my hands on Mac OSX on x86 hardware so I don't really know how the whole thing works, but I have experience under Unix/Linux so if I can be of any help let me know and I will do it without reserve.


In the meantime thanks Klyx for your miniguide :)






Link to comment
Share on other sites

Try this for bcm5787 ethernet card.. seems to work!! In my compaq 6710b loaded in Leo, but now i can't try.


please give me a feedback




Now it detects the network card as en0 but it shows a null mac address (I just get a bunch of 00:00:00ecc). Connecting a cable on a DHCP-enabled switch doesn't work.


This is how the device shows under Linux lspci output:


+-1c.2-[0000:18]----00.0 Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express


Did you test at least the connection? Can you see the mac address under your en0 interface using ifconfig?





Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hi folks


I was absent quite a long time from this site... I stopped trying to get the most critical issues away, as motorfinger told above... It seems, that nothing changed since then.

@jabonga: sorry, can't answer youre question, because I don't know it either ;) I got it from another user to integrate it into my package...


If anyone got news about acpi, wifi or ethernet and sound... tell me PM or here. Then I can test things again on my 6710b...

At the moment I have a lot of troubles with my normal computer ;) no boot... no installation... nothing (win xp).



Link to comment
Share on other sites

Glad to know about you KlyX... well I’m still in 10.5.0 ToH and trying to update 10.5.2


I had problems with original update package but right now I have Kalyway update package....I think that is a problem with kernel and graphics kext that you gave us, I really don’t know.


I want update cause it could be a solution to apply spoof MAC command.


I really need this or a patch that fix internal wifi card.


Maybe in a few days we can do more with your help :wub:

Link to comment
Share on other sites

I did it! I updated directly from 10.5.0 Toh to 10.5.2... :)


Thanks Kalyway!!!!


I didnt install nothing, just ran the update file.


I dont have any delay boot issue...the only lost that I had was power icon, but I think how Ill solve this.


Thank everybody.

Link to comment
Share on other sites

I have a Compaq 6710b.


I've followed the above instructions and have ended up with a copy of Mac OSX that doesn't recognise my onboard keyboard and trackpad. It works fine when I plug in a USB mouse and keyboard - but I don't really want to do that - since it really defeats the purpose of a laptop... :P


Any suggestions?



Link to comment
Share on other sites

HI Im newbie on this... so Ihave too 6710b but I tried to instlall kalaway Leopard, but I doesnt work on my laptop, so I tried too iATKOS,, the same result,,,


so Iwill try the KlyX tutorial with TOH... so any news about Intel 3945abg driver???



best regards

Link to comment
Share on other sites

  • 2 weeks later...

Hey, since I am going to try to have a look at getting OS X working on it for a second time, I just wanted to know if anyone was succesful in making the original resolution (1680*1050) to work. I find it quite unattractive to have a stretched image, even if only 50 pixels are missing.

A second thing is that I have a WLAN card with Atheros chipset in spare that I can not use due to HPs hardware restrictions. My question is now if anyone has tried to overwrite the BIOS whitelist. I know that it should theoretically be possible to do so, but since I don't have an USB floppy drive I am not going to try.

Thanks for your answers in advance.

Link to comment
Share on other sites


  • Create New...