Jump to content

Run AppleTV on your intel mac - uses local media or acts as a standalone appleTV, can QUIT


223 posts in this topic

Recommended Posts

yea thats the first one i tried and nothing worked, the i used triggers and it worked when it apple tv wasnt open but when apple tv was open the the trigger never worked and didnt close the program down

hey does anyone know what will happen if i choose to reset apple tv to factor settings? will it erase m hard drive

I'm not sure if it would erase the hard drive, but I have noticed that the appleTV settings affect your system settings. I tried to change the language to Danish just for fun and it failed, but after that my OS X was in Danish :) (easy to change back though in system preferences)

Im stuck here :-(

 

Followed the steps in the sticky to get the local Front Row app replaced by the one from aTV. (inluding the patch for hw chk)

 

Followed all the steps listed, but getting error when it trys to launch...

 

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: No matching IR micro server found.

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: VERS: failed to get ImageVersion for display

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: VERS: failed to get BootImageVersion for display

Mar 29 18:05:43 Pauls-Computer-Home /System/Library/PrivateFrameworks/BackRow.framework/Resources/SettingsHelper: Failed to setuid

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: Settings helper failed: status 100

Mar 29 18:05:43 Pauls-Computer-Home /System/Library/PrivateFrameworks/BackRow.framework/Resources/SettingsHelper: Failed to setuid

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: Settings helper failed: status 100

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: VERS: failed to get ImageValid for display

Mar 29 18:05:44 Pauls-Computer-Home FrontRow[4232]: Could not locate media location! Using /dev/disk0s4

 

 

Any ideas?

Im stuck here :-(

 

Followed the steps in the sticky to get the local Front Row app replaced by the one from aTV. (inluding the patch for hw chk)

 

Followed all the steps listed, but getting error when it trys to launch...

 

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: No matching IR micro server found.

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: VERS: failed to get ImageVersion for display

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: VERS: failed to get BootImageVersion for display

Mar 29 18:05:43 Pauls-Computer-Home /System/Library/PrivateFrameworks/BackRow.framework/Resources/SettingsHelper: Failed to setuid

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: Settings helper failed: status 100

Mar 29 18:05:43 Pauls-Computer-Home /System/Library/PrivateFrameworks/BackRow.framework/Resources/SettingsHelper: Failed to setuid

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: Settings helper failed: status 100

Mar 29 18:05:43 Pauls-Computer-Home FrontRow[4232]: VERS: failed to get ImageValid for display

Mar 29 18:05:44 Pauls-Computer-Home FrontRow[4232]: Could not locate media location! Using /dev/disk0s4

Any ideas?

 

I get the same exact error any help would be appreciated ty

Are you running a hackintosh? The first error in the log is "No matching IR micro server found". I'm pretty sure you need an apple remote to make it work. As far as I know, there's a USB IR receiver that can add support for apple remotes...

Nope iMac 17" Intel with OSX 10.4.9

 

Are you running a hackintosh? The first error in the log is "No matching IR micro server found". I'm pretty sure you need an apple remote to make it work. As far as I know, there's a USB IR receiver that can add support for apple remotes...
Are you running a hackintosh? The first error in the log is "No matching IR micro server found". I'm pretty sure you need an apple remote to make it work. As far as I know, there's a USB IR receiver that can add support for apple remotes...

 

if you check my sig you'll see i'm running an Apple Macbook Pro Core Duo 2.0 ghz, also it has OS X 10.4.9 installed on it dunno if that makes a difference. All the frameworks have been copied and the Finder file patched. It'll switch the resolution but nothing else happens. Any help is welcome.

I don't know, but theoretically it should work the same on hackintosh since the only requirement is an OS X install.. Unless the patched finder was only hacked to ignore macs in the hardware-checks, but I doubt it because I think this patch comes from semthex, master hackintosher :blink: Also make sure that you follow the steps exactly as shown and if some of them are unclear (as you may understand them differently than I intended) don't be afraid to ask in the thread here. I've found that logging in and out after changing crucial system files is important, or else it doesn't get updated / loaded into memory and it screws up.

has anyone else run into this bug? after i exit out of the new Front Row app (quit ATV) using all steps in the tutorial, i am unable to: log out the user, restart, shutdown, pressing "command+option+esc" does nothing (tried to relaunch finder). although pressing "command+option+shift+esc" makes the menu bar disappear until i click on an app in the dock and then it reappears...

 

other than that everything is working as it should

 

does anyone know why the finder is being disabled so to speak?

 

help? :)

any success stories from a hackintosh user? mine fails to work crashes after intro movie, n intro isnt suppose to come on :/.

 

Well I can get past the intro movie on my hackintosh, so it is possible.

okay, i followed these instruction to a T........got the keyboard shortcut to work once, but now it doesnt

 

i opened the app, played around for a second, then used the shortcut

 

waited a minute, re-ran the app, and now i'm stuck locked out of the system.........any help??

 

and also, am i the only one who can't adjust the volume (i'm on a macbook btw)

 

EDIT: Somehow it just started working now

and also, am i the only one who can't adjust the volume (i'm on a macbook btw)

 

 

i too cannot adjust the volume while in ATV. Could be the fact that it thinks the volume should only be adjusted with the regular TV remote only??? i would think the apple remote would work the volume too though.

Having strange issues.. First time I tried installing, I did the separate user account thing... That worked, except I can never get iTunes on another machine to see an Apple TV on the network.. Other than that, the remote worked, I could even watch movie trailers...

 

Thinking perhaps there was some mistake with my installation, I tried the auto-installer yesterday on my main user account. With that installation, I got to the initial screen that tries to get me to connect to iTunes on another box... Still no go there.. Nothing in iTunes seems to see the AppleTV... What's even stranger is that my remote won't work with this install. After a few minutes, it starts scrolling pictures of flowers across the screen.. So, I dumped that install last night... (Deleted the Apple TV.app file along with the PrivateFrameworks)

 

Today, I tried to follow the edited instructions in the main post to have it replace Front Row. All the steps seemed to go just fine, but when I run it, it gets to the screen where it wants me to get a copy of iTunes to see it... But, just like last night's install, the remote doesn't function, and iTunes on other machines still don't see it...

 

Any ideas?

 

This is with a 1st generation Intel iMac 20".

Problem solved!

 

First, I uninstalled Timbuktu... I'm not 100% sure if that was a problem or not, but I'm pretty sure about the 2nd thing I did... Months ago I installed Mira, which can alter your remote control functions. I had pretty much forgotten about it... I disabled it tonight and suddenly my Apple TV began responding to the remote.. Great! So, I went to my wife's Mac, and iTunes now sees my Apple TV.. Woohoo!

 

Of course, all of my video content from the iTunes store is actually stored on my iMac... Not sure how to sync Apple TV with it, though, since the Apple TV interface is running on that machine...

 

Anyhow, this is mainly for me to play with Apple TV to see how useful it is.. If I really like it, I'll probably end up buying a real Apple TV... I almost went to the Apple store tonight to buy one, but I'm still on the fence regarding functionality... I'm currently running SageTV as my PVR solution of choice... If someone could get Apple TV to be a PVR (or even a good client for another machine with Tuners), I might very well buy a couple...

has anybody tried this with leopard??? beacuse i have and it didnt work proparly! :thumbsup_anim: when i hit the menu button, the screen goes black and then returns to the desktop....what do i do??? (without switching back to tiger...)

×
×
  • Create New...