Jump to content

No Wake From Sleep - Discussion / Fixes thread


219 posts in this topic

Recommended Posts

Since I built my (second!) hackintosh in January of 2006, I have solved all the problems bar two: one is sound input, which I can live without, and the other is wake from sleep.

 

The machine will sleep normally, and upon hitting a key, mouse button or power button, it seems to be waking correctly, but the screen never comes back, and the monitor remains in standby. Using older kernel versions, the machine was nonresponsive on wake, but using 8.8.1 (semthex, mifki or paulicat) and Natit, the machine is now operational at this point - I can ping it, access its drives, even ssh into it and issue terminal commands. However, it seems that the video is not reinitialised. I can VNC into the machine, which appears to connect: the VNC window opens on the client, but remains black.

 

I notice that a few others have had this problem, so I thought i'd start this thread as a single point for us all to collect our thoughts and focus our efforts at fixing this thing.

 

To document what i've tried to date:

 

VNC - connects, but window is black

 

SSH in and start screensaver - screensaver crashes (dont have exact error message to hand, but will post later)

 

SwitchResX - set up two different resolutions mapped to two hotkeys. Woke the machine from sleep and hit the hotkeys - no result.

 

 

I'm running Paulicat's new SpeedStep / Sleep fix kernel, on an Intel D945GTPLR board, with Pentium D920 and a GeCube Radeon X1800XL PCI-E 256Mb.

 

 

Other thoughts i've had: maybe some kind of terminal command I could issue which will reinit the gfx hardware? What about a SwitchResX applescript run using osascript?

 

Please post your thoughts / findings here!

 

Also note: if your machine seems to hang on wake, check to see if you can ping it or access its shares. If not, try updating to a newer kernel (I recommend Paulicat's SpeedStep / Sleep Fix kernel found here: http://forum.insanelymac.com/index.php?sho...=42865&st=0, or Semthex's latest).

The sleep problem seems to be related to SATA, try installing your OSX on a IDE and at least to me the sleep thing worked but on SATA it doesn't work.

nah, im booting from an IDE drive, so i doubt its that.

 

tho i do have two other drives connected via SATA tho. hmmm.... i might try disconnecting them... :(

 

@cyclone - im using the first one posted on prasys thread about the paulicat kernel.

nah, im booting from an IDE drive, so i doubt its that.

 

tho i do have two other drives connected via SATA tho. hmmm.... i might try disconnecting them... :)

 

@cyclone - im using the first one posted on prasys thread about the paulicat kernel.

 

I am booting from sata drive, however, I have osx installed on a USB disk also, I tried that..

same problem.. btw I am using the modified package.

 

also I have perfectly fine sleep and wake functions with the old kernel.

I am not sure how the sleep function actually works differently in the 8.8.1 kernel.

it might be related to the framebuffer

Edited by Eskurza

just want to give my feedback

 

i had sleep function working until 8.8.1 kernel. with all the semthex kernel i have that what munky discriebs a fully working system with black screen .. only using mifki kernel

 

"Darwin localhost 8.8.1 Darwin Kernel Version 8.8.1: Sun Oct 29 01:33:16 MSD 2006; vit:xnu-792.13.8/BUILD/obj/RELEASE_I386 i386 i386"

 

i get screen back and sometimes a fully working system using sleep. i said sometimes because system restart perfectly but sometimes it imediately freeze.. i didn't find out why it sometimes work .. what i know for sure is when u use automatic sleep by powermanagmant it never works only if u manually but the system into sleep.

 

Edit.. With both paulicat modified kernels i get screen back but frozen system.

 

cheers

Edited by OsXsO

cyclone: no, paulicat gives me wake but no video, as before.

 

iirc, the 10.4.4 kernel and the earliest 10.4.8 kernels hung the machine on wake. so its progress, at least :D

going to try paulicat's new 'working speedstep' kernel tonight ;)

 

has anyone with this problem tried it? does it help?

Using an Asus P5B Deluxe/Wifi and Asus X1600XT Silent I used to be able to wake my system from sleep but here is the catch:

I my system had been running for too long it never woke up. The longer I had had it running the slimer the chance of waking it and also the longer it had been running the longer it took to wake it (sometimes I had to stare at the spinning wheel of death for 20 minutes before the system came back and sometimes it just frooze on the wheel).

 

This was, I believe, all with semthex beta 5 kernel. I do not have the P5B any more and I haven't gotten my AB9 to wake at all anytime. Haven't tried the paulicat kernel or later semthex kernels though (if there are any).

going to try paulicat's new 'working speedstep' kernel tonight :P

 

has anyone with this problem tried it? does it help?

 

With paulicat's kernel, sleep works as long as I let energy saver put it down automatically -not by selecting from apple menu. Then, there's about 10~15 minutes to do wake; any longer and I get a frozen screen back & HD spins for 5s before everything locks up. Wether I can get video back depends on the combination of kernel and natit version I use.

 

I have an idea but unfortunately haven't had much luck putting it into practice -I noticed that on my GFs macbook, if it's been alseep for a long time or battery runs down while it's asleep, when you wake it up you get a little white progress bar (similar to the volume indicator) at the bottom of the screen and HD works hard. Most of the time it flashes too quick to notice, but occasionally you can catch it after video comes back.

 

My theory is that there is a deep sleep hibernation mode as well as a "snooze" mode that doesn't write a state file to disk. The first one doesn't work for me the second does. So I've been searching for a plist that controls how deep a sleep the OsX uses; unfortunately I've had little luck.

 

Can anyone point me in the right direction (or tell me that I'm on the wrong track at least) ?

I just installed 10.4.8 Jas on my Centrino Notebook ... everything worked fine (except WLAN, LAN, Sound)

I wanted to test "Sleep" --> worked --> wake up --> DEAD (black screen)

 

so i killed my system.

since then i cannot reboot ... i only see the blue background .. nothing happens ..

 

HELP -- how can i restore my system and get it to work

 

NOTE: it was my first reboot i think

vienna: i think that was a known issue with the first JaS 10.4.8 release - you maybe need a ppf or a later release.

 

consolation: what you're talking about is Safe Sleep, which is (afaik) enabled on the last powerpc macs and all intel macs. it writes the memory contents to disk (ACPI S4 Hibernate) before entering 'normal' sleep (which is really ACPI S3 Standby - all power is off except a trickle to the RAM to keep the contents live). the theory is that if the battery runs totally out of power (and cant maintain S3 sleep), it will fail, but on next power-on it will use the hibernate image (ie will recover from S4 Hibernate) instead.

 

i'm not sure if we can do S4 on our hackintoshes, but I guess there's a possibility it might work. it would give us a reasonable compromise solution i spose.

 

 

i'm in agreement that its a combination of natit and kernel which seems to make or break things with S3. some kernels and natits make my machine hang on wake, but others give me the awake-but-black-screen syndrome. wish i could find a combo that works! ;)

ok just a small update, DiaboliK has suggested following the JCCool method for my X1800, as outlined here:

 

http://forum.insanelymac.com/index.php?sho...l=jccool+method

http://forum.insanelymac.com/index.php?act...ost&id=9062

 

which i will try tonight and post results :whistle:

 

(thx for ur continued efforts DiaboliK!)

 

EDIT: The JCCool method, as stated, is only for X1900 and X1950 cards, and he has now adopted Natit instead. I will have a play with some {censored} hybrid of borisbadenov and jccool methods, along with paulicat kernel and see what happens...

random mindspill:

 

Natit enables X1600, X1800, X1900 etc cards...

 

without the need for plist edits to put in device ids...

 

could it be possible that the plist edits are needed AS WELL...?

 

and those folks who have working sleep/wake and other features (dual screen?) just happen to have cards with the correct device ids to match the unmodified apple kexts?

 

and therefore, if i edit my kexts to match my actual hardware, it might work?

 

:(

I tried out the theory I outlined above (under 'random mindspill'), and it did nothing. No effect, good or bad. Oh well.

 

 

In other news...

 

 

Looking thru AGDenton's ioreg dumps (Mac Pro with apple-supplied X1900), some interesting keys jump out, which might help if injected with Natit:

 

"acpi-path" = "IOACPIPlane:/_SB/PCI0@0/NRP4@40000/PXS1@ffff"

 

"Power Management protected data" (appears twice)

 

 

The second Power Management key contains:

 

"{ this object = 05c89500, interested driver = 05c89500"

 

Interested Driver? Could that possibly be a driver which must be notified when the powerstate changes? could that prompt it to re-init on wake?

ok, so AGDenton also posted IOReg dumps of a PC X1900 card which he put in his Mac Pro in the secondary PCI-E slot.

 

I took both dumps and ran them thru a visual diff tool, and then removed all lines which were identical. finally, i added/removed blank lines as necessary so everything will line up in a side-by-side comparison.

 

i'm hoping this will provide clues as to what values may be missing from our Natit injections which might help the wake-from-sleep situation.

mac_card.txt

pc_card.txt

My PC if I put it to sleep and wake it up, no matter how long though, it resumes. HDD Spins up, GFX card fan starts and everything, but the OS is frozen and my cursor keeps spinning. I can move my mouse, but I cant do anything, the OS doesnot respond. As if its hung.

 

I have tried Paulicat's/Semthex and DaemonES kernels.

 

I am using NVidiaEFI on GF4 Ti, with an Intel SSE3 capable CPU.

Ok, another theory, from grepping thru my IOReg -l output....

 

The onboard GMA950 I have is in there, matching as 'display'. I tried removing all GMA-related kexts but its still in the ioreg.

 

Could the problem be that the onboard video is getting the wakeup call instead of the PCI-E card?

 

Does anyone else with the problem NOT have onboard video?

×
×
  • Create New...