Jump to content
MaLd0n

Install MacOS Catalina / Big Sur on Mobos Serie 400 with Intel 10th Desktop Processors using OpenCore or Clover bootloader

15 posts in this topic

Recommended Posts

-OpenCore Vanilla TUTORIAL-

 

 

-USB Port Mapping TUTORIAL-

 

 

1 -Create a USB bootable

 

Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers

 

Catalina

installScript_allfullapp.zip

 

Big Sur

installScript_1016fullapp.zip

 

Credits: crazybirdy

 

Copy Catalina / Big Sur installer to Applications folder, open terminal and run

 

Catalina
 

Quote

sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/UsbName

 

Big Sur
 

Quote

sudo /Applications/Install\ macOS\ Big\ Sur\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/UsbName

 

If you want check one step by step, check here

 

-Opencore Vanilla Tutorial

https://tinyurl.com/ycvcnp8h

 

2- EFI folder USB installation

 

-EFI OpenCore Folder Desktop 10th Intel Processors

Paste this EFI folder in EFI partition in your USB STICK

https://tinyurl.com/ybwr9kq3

 

-EFI Clover Folder Desktop 10th Intel Processors

Paste this EFI folder in EFI partition in your USB STICK

https://tinyurl.com/yxsw7d3t

 

3- EFI folder SSD

 

-EFI OpenCore Folder Desktop 10th Intel Processors

Paste this EFI folder in EFI partition SSD 

https://tinyurl.com/ybwr9kq3

 

-EFI Clover Folder Desktop 10th Intel Processors

Paste this EFI folder in EFI partition SSD

https://tinyurl.com/yxsw7d3t

 

4- Start Fine Tune

 

Run this app and post full dump here for full ACPI solution

 

RunMe.app

https://tinyurl.com/y9562hz7

 

 

If you like a SSDT way, here we go

SSDT-OLARILA.aml.zip

 

5- USB Solution

 

Use these kexts, enable XHCI port limit patch

 

USB INTEL SERIE 400.zip

 

and follow this tutorial for remap USB ports

 

 

--DSDT PATCHES--

 

-FIX ERRORS AND WARNINGS
-FIX ACPI ERRORS
-REMOVE UNUSED SCOPES / DEVICES
-HIGH PRECISION EVENT TIMER
-SATA SERIE ID
-DMAC
-REMOVE LINES, PROBLEMATIC and UNUSED
-FIX K.P in REBOOT
-NVRAM
-REAL TIME CLOCK
-SLPB
-DARWIN / WINDOWS
-XHCI
-PLUGIN TYPE
-HDEF
-ARTC
-IPIC
-TIMR
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-UAR1
-LAN
-FWHD
-USBX
-PMCR
-PPMC
-XSPI
-kUSBCompanionIndex
-io-device-location
-IMEI
-EC
-PNLF
-ARPT
-GFX0
-NVME
-ACPI-WAKE-GPE
-DTGP
-HDMI / HDAU

 

--SCREENSHOTS--

2MRZbCC.png

7H3bhTD.png

OH1QQZN.png

HAO1mpK.png

VGq2fSR.png

6uaY1Bh.png

EXkcWfI.png

A0SZQYh.png

iLEjszW.png

bQw0vGz.png

KltktNo.png

QinwZrc.png

7WKKgcf.png

IKKuA1V.png

o0dtnxJ.png

ezlIIoy.png

Fi2lykR.png

0uBvKFV.png

c7USqbd.png

73cjKaf.png

kZjrvhd.png

LSpj6lv.png

QxFXr0B.png

OoqTQKY.png

oOTB4bb.png

dLmg3kt.png

zu4ddVI.png

YlZNNPc.png

2pZg8Jr.png

qPt9Nx7.png

6vXFdZd.png

-If you want to buy me a beer - Donations with PayPal
https://tinyurl.com/r2bvzm7

 

Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,

Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.

 

 

-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!

Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!


We're all here to have fun and learn from each other!

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

I Have bought a Gigabyte Elite motherboard.(waiting for it to be delivered) im thinking of getting a 10600k cpu and will use a vaga 56 gpu. i have tryed to make a Opencore Efi folder in advance. of my parts arriving. it is my first attempt at building a open core EFI folder. i would be grateful if someone would have a look at it please

                                                    Best Regards

                                                                         Baldyman

 

 

 

 

 

 

 

 

 

Gigabyte.Z490 Elite EFI.folder.zip

Info.plist

config.plist

Edited by BALDY_MAN

Share this post


Link to post
Share on other sites

@MaLd0n. thank you very much. as soon a my stuff arrives. and its built. i will keep you informed . thanks once again for you help

 

Share this post


Link to post
Share on other sites
4 hours ago, BALDY_MAN said:

@MaLd0n. thank you very much. as soon a my stuff arrives. and its built. i will keep you informed . thanks once again for you help

 

Enjoy!

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks  you:thumbsup_anim:lMald0n

 

I install through the virtual machine, which has some of your EFI configuration, Thank you very much!

 

according to 

 

 

Motherboard: Gigabyte z490 aorus ultra motherboard supports CPU 10900k / 10700k (Intel z490 / LGA 1200)
CPU:I7 10700K
Graphics card: public version of AMD radon RX 5700 XT  8g gddr6 game graphics card
Memory: g.skill 16gbx2 DDR4 3200 frequency desktop memory module sniper x (camouflage black)
Hard disk: m.2 x2 250gwd_ Black sn750, western data 1TB SSD m.2 interface (nvme protocol) WD_ BLACK SN750
Network card: bcm4360cs two antenna version, Intel i225v 2.5gbe perfect, Intel ax201 has no driver at present
Sound card: alc1220-vb

 

 

截屏2020-07-02 上午2.51.58.png

config.plist.zip

Edited by cfmwan

Share this post


Link to post
Share on other sites
On 7/1/2020 at 11:42 AM, Tightlovin said:

I thought that USBSerie400.kext something special. But it seems like some kind of USBInjectAll clone? =)

generate one injector with hackintool

On 7/1/2020 at 3:49 PM, cfmwan said:

Thanks  you:thumbsup_anim:lMald0n

Enjoy!

Share this post


Link to post
Share on other sites
Posted (edited)

MaLd0n. thanks you very much for sharing you efi folder. and getting my new Z490 hackintosh up and running. 

IMG_20200705_040956230.jpg

IMG_20200705_190102002.jpg

Screenshot 2020-07-10 at 08.43.06.png

Screenshot 2020-07-21 at 06.58.26.png

Screenshot 2020-07-21 at 07.00.22.png

Edited by BALDY_MAN
added screenshots

Share this post


Link to post
Share on other sites
21 hours ago, BALDY_MAN said:

MaLd0n. thanks you very much for sharing you efi folder. and getting my new Z490 hackintosh up and running. 

hey

Nice!

Share this post


Link to post
Share on other sites

--UPDATE FIRST POST--

 

OPENCORE FOLDER

CLOVER FOLDER

CREATE USB BOOTABLE

DSDT

SSDT

Share this post


Link to post
Share on other sites

Why does OpenCore EFI destroy BIOS every time?
I do not understand why it is embedded in the BIOS.

Share this post


Link to post
Share on other sites
1 hour ago, naiclub said:

Why does OpenCore EFI destroy BIOS every time?

check OpenCore github

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By slurpi
      Hi everyone:
       
      This is to report a success (!) in installing macOS Big Sur Beta 6 (version 20A5364e) on my system MSI X299 SLI Plus with Intel i9 9940X using OpenCore 0.6.1. I followed the main OpenCore guide here:
      https://dortania.github.io/OpenCore-Install-Guide/
      Make sure you look for the Skylake-X or HEDT sections.
      The SMBIOS is for the iMacPro1,1.
       
      There were two main issues that had to be taken care of:
       
      * I needed the kernel argument 
      npci=0x2000 otherwise USB would not work.
       
      * I had to replace the precompiled SSDT-AWAC with my own RTC SSDT, as explained here:
      https://dortania.github.io/Getting-Started-With-ACPI/Universal/awac-methods/manual.html#rtc0-method
      The problem is that my SSDT does not have any AWAC to be patched. A sign that I needed this was that booting into the installer hanged around loading Lilu or some of the SMC extras.
       
      The path to replace in the provided SSDT-RTC0 is:
      ** PCI0 -> PC00
      ** LPCB -> LPC0
      This is probably specific to my motherboard. Instead of using the SSDT-AWAC, I use my own RTC0 like this:
      DefinitionBlock ("", "SSDT", 2, "ACDT", "RTC0", 0x00000000) { External (_SB_.PC00.LPC0, DeviceObj) // (from opcode) Scope (_SB.PC00.LPC0) { Device (RTC0) { Name (_HID, EisaId ("PNP0B00")) // _HID: Hardware ID Name (_CRS, ResourceTemplate () // _CRS: Current Resource Settings { IO (Decode16, 0x0070, // Range Minimum 0x0070, // Range Maximum 0x01, // Alignment 0x08, // Length ) IRQNoFlags () {8} }) Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (0x0F) } Else { Return (Zero) } } } } } Only the lines:
      External (_SB_.PC00.LPC0, DeviceObj) // (from opcode) Scope (_SB.PC00.LPC0) are different from the original SSDT-RTC0 here:
      https://github.com/acidanthera/OpenCorePkg/blob/master/Docs/AcpiSamples/SSDT-RTC0.dsl
       
      By following the guide above and implementing these two differences, I was able to install macOS Big Sur beta 6.
       
      Big thanks to the amazing OpenCore team for allowing this. Not only the complete tools, files, binaries, are fantastic, but the manual is amazing!
       
    • By chris1111
      Here my theme of OC 

      How to create are own Theme with Icnspack-Builder
       

       
      You can Download the themes with ➤ Themes Downloader
       
      You can also have the themes on ➤ Github
       
      You can also have the themes on ➤ HTML Page
       
    • By rvilbert
      Good evening,
       
      I apologies for the broadcast message but i have decided to reinstall my Hackintosh machine using Catalina 10.15.6 and .... I'm stuck at "PCI configuration begin".. 
       
      My configuration is:
      Asus X99 Deluxe Core i7 5960x 32 Gb memory GTX 980  
      Knowing that my graphic card would not be fully recognised in Catalina i have also tried to install High Sierra but I managed to get exactly to the same point  and i have therefore decided to give another try to Catalina and .... I'm still stuck.
       
      (FYI I had managed to install 10.8 on my machine a while ago but a few things have changed since then and I may be missing a trick).
       
      In a nutshell I believe my issue is linked to this message that i'm getting:
       
      Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourcesMatch</key><string ID="2">boot-uuid-media</string></dict> 
       
      I tried all options (with/without flags and with/without kext) but i think that my issue is between my DSDT, SSDT and config.plist files.
       
      Any help would be much appreciated!
       
      I have attached my EFI folder and the print screen with the error message.
       
      Let me know if you need any further information.
       
      Thanks a lot
       
       
       
       

      EFI.zip
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.7 WhateverGreen.kext 1.4.2 AppleALC.kext 1.5.2 IntelMausi.kext 1.0.3 (acidanthera version, not IntelMausiEthernet) NVMeFix.kext 1.0.3 EFIChecikDisabler.kext 0.5  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk800 G4 Mini - Rev 1.2.zip
×