Jump to content
aikidoka25

OpenCore Legacy for GA-EX58-UD5

18 posts in this topic

Recommended Posts

It seems there are no topic for GA-EX58-UD5 board, so I started one here.

 

I had followed the guide to install OpenCore on legacy system, a GA-EX58-UD5 motherboard with macOS Catalina in this case.

However it cannot load the OS and shows some texts in red colour that starts with X64 Exception Type.

If there is another partition with Clover, it falls back to that partition and load the OS.

 

I attached the config.plist I use, based on OpenCore-0.5.3-RELEASE.

 

Any ideas what is missing?

 

config.plist

Screen Shot 2019-12-15 at 2.28.03 PM.png

Edited by aikidoka25
added more information

Share this post


Link to post
Share on other sites
Advertisement

wish you good luck maybe i can learn something from you

the only info about  legacy bios  

 

Legacy Install

OpenCore supports DuetPkg which emulates a UEFI environment for legacy systems.

To start, you need the following:

  • BootInstall.command
  • Install source

Within your OpenCore build folder, navigate to Utilities/BootInstall. Here you’ll find a file called BootInstall.command. What this does is install DuetPkg to your desired drive.

Now you’ll want to run BootInstall.command, do note that you may need sudo for this to work correctly on newer versions of macOS

sudo Utilities/BootInstall/BootInstall.command

Share this post


Link to post
Share on other sites

Rockey12, Thanks for sharing your research.

 

I did execute BootInstall.command.

 

At this moment, I think OC BOOTx64.efi is not compatible with my rig or GA-EX58-UD5 in general.

 

Following dgsga idea to install Clover first, I did the following:

1. installed Clover 5094 on the partition and choose Clover for BIOS (legacy) booting

2. Deleted /EFI/BOOT and /EFI/CLOVER

3. Copied OpenCore's BOOT and OC folder into /EFI

4. After rebooting, I was able to see the blue white menu thingy, then I navigated and selected to /EFI/BOOT/BOOTx64.efi

5. The texts in red colour that starts with "X64 Exception Type" is displayed

6. Tried selecting /EFI/OC/OpenCore.efi and got the same error 

 

Photo 2019-12-15, 5 34 19 PM.jpg

Edited by aikidoka25
Adding information

Share this post


Link to post
Share on other sites

Is there a way to generate a log? or verbose mode with OpenCore 0.5.3?

I think I followed the guide that says the log will be created in EFI partition.

During one of many reboots I saw 2 of them but they were not text file hence cannot be read using a text editor, I used Visual Studio Code app in this case. So I deleted them.

But now I don't see new logs created.

Share this post


Link to post
Share on other sites

I have a small progress, it still doesn't work for this board, but at least I can consistently generate the log.

The HDD must be on the first port (SATA0), even if there is only one HDD, otherwise it wasn't loaded at all.

OC ignores the boot order in BIOS.

It still generate the red error texts.

 

It seems there is something wrong when it tried to load HfsPlus.efi, as we can see from the attached log file.

The rest of the log is not readable.

 

00:000 00:000 OC: OpenCore is now loading (Vault: 0/0, Sign 0/0)...
00:003 00:003 OC: Boot timestamp - 2019.12.16 23:40:18
00:006 00:003 OCCPU: Hypervisor: 0
00:009 00:003 OCCPU: Found Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
00:012 00:003 OCCPU: Signature 106A5 Stepping 5 Model 1A Family 6 Type 0 ExtModel 1 ExtFamily 0
00:015 00:003 OCCPU: Detected Apple Processor Type: 07 -> 0702
00:018 00:003 OCCPU: Ratio Min 12 Max 20 Current 0 Turbo 22 21 21 21
00:021 00:003 OCCPU: Timer address is 408 from LPC
00:125 00:103 OCCPU: CPUFrequencyFromTSC  2698759881Hz  2698MHz
00:128 00:003 OCCPU: CPUFrequency  2698759881Hz  2698MHz
00:131 00:003 OCCPU: FSBFrequency   134937994Hz   134MHz
00:134 00:003 OCCPU: Pkg 1 Cores 4 Threads 8
00:137 00:003 OC: OcLoadUefiSupport...
00:140 00:003 OCC: Install console control 0 - Not Found
00:143 00:003 AIFTimerBoostInit Current timer is 100000
00:146 00:003 AIFTimerBoostInit changed period 100000 to 50000
00:149 00:003 AmiEfiKeycodeProtocol is unavailable on gST->ConsoleHandle - Unsupported
00:152 00:003 gST->ConIn DF66C390 vs found DF66C390
00:161 00:008 OCABC: Firmware has 12569745 free pages (904337 in lower 4 GB)
00:164 00:003 OCC: Configuring console ignore 0 san clear 0 clear switch 0 replace tab 0s
00:168 00:004 OCC: Configuring behaviour 1
00:171 00:003 OCC: Setting cc mode 0 -> 0
00:174 00:003 OC: Got 5 drivers
00:178 00:004 OC: Driver EmuVariable.efi at 0 is being loaded...
00:182 00:003 OC: Driver EmuVariable.efi at 0 is successfully loaded!
00:185 00:003 OC: Driver HfsPlus.efi at 1 is being loaded...

 

 

opencore-2019-12-16-234018.txt

Edited by aikidoka25
more information

Share this post


Link to post
Share on other sites

I modified the config to load VBoxHfs.efi instead of HfsPlus.efi, and now I have the boot picker.

The partition cannot be booted with a message saying the platform is not supported for the OS.

 

With the log available, I am confident we can slowly grind the config to completely boot Catalina.

opencore-2019-12-17-000224.txt

Edited by aikidoka25

Share this post


Link to post
Share on other sites

Hi aikidoka25 congratulation i feel so happy for you this is a great success

 

i am waiting for the end results

 

 

the thing what i am requesting for when  you have done this can you please write a how to GUIDE it can be short but step by step

Edited by Rockey12

Share this post


Link to post
Share on other sites

Hello, I own a ga-x58a-ud3r v2.0 and having tried OpenCore for two days. In short I can boot Mojave with edited DSDT, but reboot doesn't work, shutdown looks fine. Instead of spending more time on try and error I dicided going back to Clover. X58 is a bit old now I would happy already if it can carry Catalina with Clover. 

 

 

Share this post


Link to post
Share on other sites

I didn't have the chance to continue the work on OpenCore, hence not much progress.

In my setup, I think the DSDT need to be modified. The one I currently have was from Chameleon era.

 

@Rocky12 did you manage to see the OpenCore picker/selection list at all?

I will compare your config.plist with the one I have and will let you know if I have any suggestion.

Share this post


Link to post
Share on other sites
Posted (edited)

I rebuilt the config.plist and I am able to boot the unit.

However there are some other issues, using version 0.5.8:

1. no verbose mode

I have the -v in NVRAM section but still no verbose from macOS, should I set AppleDebug to YES?

I doubt it because the unit is still on 10.15.0 

<key>Add</key>
		<dict>
			<key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
			<dict>
				<key>boot-args</key>
				<string>-v debug=0x100 alcid=1 slide=0</string>
				<key>SystemAudioVolume</key>
				<data>Rg==</data>
				<key>prev-lang:kbd</key>
				<data>cnUtUlU6MjUy</data>
			</dict>
			<key>4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14</key>
			<dict>
				<key>UIScale</key>
				<data>AQ==</data>
				<key>DefaultBackgroundColor</key>
				<data>AAAAAA==</data>
			</dict>
		</dict>


2. no audio [SOLVED by defining layout-d 1 in DSDT]

The kexts are loaded as verified using kextstat | grep -E "AppleHDA|AppleALC|Lilu"

On another partition with Clover, I have layout-id 1 works.

I have checked the device properties using

gfxutil -f HDEF

00:1b.0 8086:3a3e /PCI0@0/HDEF@1B = PciRoot(0x1)/Pci(0x1B,0x0)

and add it in the config

<key>DeviceProperties</key>
	<dict>
		<key>Add</key>
		<dict>
			<key>PciRoot(0x1)/Pci(0x1B,0x0)</key>
			<dict>
				<key>layout-id</key>
				<data>AQAAAA==</data>
			</dict>
		</dict>
		<key>Block</key>
		<dict/>
	</dict>


3. when restarting, the unit freeze with black screen

no clue
4. wakeup from sleep freeze black screen [SOLVED]
5. apple icloud error message

has the least importance at this moment

Edited by aikidoka25

Share this post


Link to post
Share on other sites
Posted (edited)

I think there is something wrong with the NVRAM mechanism.

Besides the variables reported by hackintool or the command nvram -p , the rest that specified in config.plist never appeared.

Which I think, impacted the verbose mode, because it relies on the using of NVRAM.

I tried the emulated method, I know the scripts works because upon shutdown it erased the manual entries I created from nvram.plist

But I still don't see the others NVRAM variables. Should they be visible too?

 

950555239_ScreenShot2020-05-22at6_29_47PM.png.1fd80ea325e84160a9ad0baa0d683e2b.png

Edited by aikidoka25

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×