Jump to content

HELP TOPIC - [RYZEN] macOS 10.12.x (Sierra)


410 posts in this topic

Recommended Posts

@antrace, no iCloud/iMessage here either, but the eLicense installer ran fine on my system using the kernel dated June 17th (from ryzenpatcher) and Clover 4077 from the Ryzen tutorial thread.

 

Issues i ran into:

I'm having trouble running DaVinci Resolve 14 which spams my console with "HALC_ShellObject.cpp" related messages during (choppy) playback and beachballs most of the time using any newer kernels. I also got the USB webcam/bluetooth problems mentioned in this thread (with and without Shane's fix). 

Other than that - great work Bronya & Gigamaxx

i guess there is nothing we can do if certain things just dont run and iam pretty sure its kernel related.

 

please bronya help us :)

 

http://download.steinberg.net/downloads/eLicenserControl.dmg

 

this is "my" problem and the installer refuses to run :(

Can you just make a copy disk of Sierra (clone, fresh install, etc..) and use RyzenPatcher? If you make a USB intstaller with Sierra 12.4 or 12.5 it works, but Sierra 12.6 has issues. The easiest way is to make a copy of Sierra on a disk and then use Ryzen Patcher and add clover bootloader.

Hi ! What problem for "install"?

I tried open installer eLicenserControl.dmg - working . 

My system sierra 10.12.6 on FX 8350. 

iam using 10.12.6 and ryzen 1600 and installer does not even run. have tried all kernels. guess its 12.6 making the problem.

 

Can you just make a copy disk of Sierra (clone, fresh install, etc..) and use RyzenPatcher? If you make a USB intstaller with Sierra 12.4 or 12.5 it works, but Sierra 12.6 has issues. The easiest way is to make a copy of Sierra on a disk and then use Ryzen Patcher and add clover bootloader.

 

i will try this. so with 12.6 it doesnt work at all then i guess?

 

thx to both of you for the reply... and special thx to bronya for the kernel. i didnt have much hope running osx again when i went with ryzen and sold my skylake system and my old mac pro :) THX!!!

so the only chance for me to get 12.5 was to get an dmg from amd-osx. i only installed sierra and didnt use the postinstall script from shanee (does it to everything ryzenpatcher does and is the dmg somehow prepatched already?)

 

so i booted up a working osx sierra and connected the drive with the fresh installed osx. ryzenpatcher does its job but seems not to copy everything. atleast i could never boot from it after patching.

 

so ryzenpatcher is working for you guys without doing anything manual afterwards?

 

isnt shanees post install script easier to use and does it do the same?

so the only chance for me to get 12.5 was to get an dmg from amd-osx. i only installed sierra and didnt use the postinstall script from shanee (does it to everything ryzenpatcher does and is the dmg somehow prepatched already?)

 

so i booted up a working osx sierra and connected the drive with the fresh installed osx. ryzenpatcher does its job but seems not to copy everything. atleast i could never boot from it after patching.

 

so ryzenpatcher is working for you guys without doing anything manual afterwards?

 

isnt shanees post install script easier to use and does it do the same?

Ryzen patcher requires you to select a path for the kernel, when I used it I just added the kernel and prelinked kernel ran kext wizzard and it worked. Like you I didn't specify a path for the kernel and got an error indicating the kernel didn't have correct pathway.

You could try replacing the kernel and prelinked on the 12.5, or start over and use Shanees, I've heard it works well.

 

Did you say you have Sierra 12.6 working? Is this for RX 480 support?

Ryzen patcher requires you to select a path for the kernel, when I used it I just added the kernel and prelinked kernel ran kext wizzard and it worked. Like you I didn't specify a path for the kernel and got an error indicating the kernel didn't have correct pathway.

You could try replacing the kernel and prelinked on the 12.5, or start over and use Shanees, I've heard it works well.

 

Did you say you have Sierra 12.6 working? Is this for RX 480 support?

ok, i will try it once again and give it the path to the kernel and lets see if it works then.

shanees script works on 12.5 (amd_osx4) but uses an older kernel which seems to be a bit slower compared to the one in (amdosx5/12.6). sadly this one doesnt run my mentioned elicenser app. not sure about the rx480, but i got my hd5450 to work without a problem making some small config.plist adjustments.

 

oh i tried to replace the kernel manually, and system didnt boot afterwards. yes, i ran kext wizard after it.

ok, so i got my system working and the elicenser app is running now aswell.

 

the only thing i have to complain now about is that when i overclock my ryzen and set busratio in clover i have dropouts with my usb audio interface. the usb audio interface will only work if i dont overlock the cpu. also overclocking for me also only worked when i set cpu frequency with clover configurator. busratio flag didnt work at all...

 

any clue what this could be? usb drivers maybe? are there newer ones?

×
×
  • Create New...