Jump to content

VMware Fusion Thread

177 posts in this topic

Recommended Posts

OK, here is some followup information.


The "VMware Fusion" kext packages in question are these:

rainbow:~ lrh$ ls -al /Library/Application\ Support/VMware\ Fusion/kexts
total 0
drwxr-xr-x	5 root  wheel  170 Oct 17 05:28 .
drwxr-xr-x   11 root  wheel  374 Nov 29 02:21 ..
drwxr-xr-x	3 root  wheel  102 Oct 17 05:28 vmioplug.kext
drwxr-xr-x	3 root  wheel  102 Oct 17 05:28 vmmon.kext
drwxr-xr-x	3 root  wheel  102 Oct 17 05:28 vmnet.kext


I tried to load each in turn using:

sudo kextload -vt  /Library/Application\ Support/VMware\ Fusion/kexts/vmioplug.kext


What I found was that kextload reported vmioplug.kext & vmnet.kext each loaded correctly while vmmon.kext caused a kernel panic. If I modified the kextload parameters to include -n in addition to -vt then all three would complete without a kernel panic.


I need to study some more - I don't yet have another test in mind. More later if I can figure out another test.


Edit update:

OK! next set of results. I tried a direct load of the vmnet & vmioplug kext packages and they loaded for real. so, I went back to the boot.sh command and activated everything except vmmon. The end of the script now shows:

# kextload "$LIBDIR/kexts/vmmon.kext"
kextload "$LIBDIR/kexts/vmioplug.kext"
kextload "$LIBDIR/kexts/vmnet.kext"

# TODO: We should use launchd to start up both vmnat and vmnet-dhcpd.
"$LIBDIR/vmnat" -c "$LIBDIR/nat.conf" vmnet8 > "$VMNAT_LOGFILE" 2>&1 &

# vmnet-dhcpd puts itself in the background (daemon mode)
"$LIBDIR/vmnet-dhcpd" -cf "$LIBDIR/dhcpd.conf" -lf "$LEASEFILE" \
-pf /var/run/vmnet-dhcpd-vmnet8.pid vmnet8


When I restarted the system it booted to the GUI correctly. However, vmware still just opens a blank white screen which is non-functional. Obviously, vmmom.kext is required.


If I now try to load vmmon for real I get instant kernel panic. Back to thinking :(

Link to comment
Share on other sites

Try using Semthex's latest kernel avaliable on the irc. It suports vmware and works fine for me.


Mmm, yes, need to update my signature specs. I have been using the semthex beta8 kernel for the past few days. That doesn't fix the problem.




I also tried with the Hyper Thread disabled - just in case - and it had no effect - still got kernel panic as soon as vmmon.kext was loaded.

Link to comment
Share on other sites

Nah, I have a x1600 and it doesn't work... Same kernel panic.


I noticed you have a Prescott processor, and so do I.


So it seems the bug is indeed related to the Prescott, though I'm not sure.


Anyone else with a Prescott tried it ?

Link to comment
Share on other sites

On a side note - I had also tried Parallels. During the time I was using the integrated Intel graphics and the Diamond Stelth Radeon 9250, neither of which could I make provide CI/QE, Parallels woulld not start. The icon would appear on the dock and then vanish with no reason given for the failure.


As soon as I installed the nVIDIA GeForce FX5500 and activated CI/QE Parallels started running just fine. I am now installing some Linux & WinXX systems under Parallels. If that all works I plan to try a version of OS X. Getting a test OS X running in a virtual environment was what got me in this swamp in the first place.


Since I have two workable native OS X partitions on my drive (repair & production) I plan to continue with Parallels on one and Fusion on the other. Although, I think I will wait for a later release of Fusion since I have exhausted all my ideas on this one.


Edit-Update: I tried to install OS X under Parallels - it crashed Parallels every time I attempted to boot the instal DVD. I was using a JaS-10.4.7 install DVD. Guess I will need to keep working on Fusion :(

Link to comment
Share on other sites

  • 4 weeks later...
  • 5 weeks later...

FYI 3D support is coming possibly as soon as the next beta for Fusion. Parallels has talked smack about VMware not having any 3D support when they have had it since workstation 5. This pissed off the devs at VMware since it is a flat out lie. Fusion is working on stability first then adding in 3D support. It is there but not enabled. The feature is experimental but better some 3D that works than none at all. So far Parallels has no demo even to show they have it working. I know that by Final release of Fusion 3D will already be enabled. But I think it will make it in well before that.


Just a heads up and keep your eyes peeled. There will be videos and such on the net. I was shown one by a Vmware employee and it will be posted by VMware soon. They are putting it out there as a teaser of sorts soon.

Link to comment
Share on other sites

Mac will run windows and windows will run mac. And they both have the same intel core dual 2 processor on board. Same components same resource using.....


So i guess in the future there will be no apple Mackbook nor the pro. Because people just will not need it....


FUN :hysterical:

Link to comment
Share on other sites

Its surprising some user can install it perfectly while others get kernel panic. I've tried using an older version (ie 33141) it installs perfect but when i try to make a vm it just displays a white blank screen. the lastest version is a no go since it gives kernel panic. Anybody knows any solution to the kernel panic issue in the installation?

Link to comment
Share on other sites

  • 2 weeks later...

Can anyone report on the stability of VMware-Fusion-e.x.p-36932 beta.. This is the latest one they are allowing for download.. My only interest is to setup a linux LAMP VM for php/mysql coding purposes.. I could care less about windoze..



Link to comment
Share on other sites

Really, I don't think that VMWare Fusion is all that "cool" just because it has some 3D acceleration.

Fusion is extremely limited in the 3D acceleration area since all of the important stuff isn't accelerated anyways

(taken from: http://www.vmware.com/support/ws55/doc/ws_...d_audience.html Yes, I know that says VMWare Workstation 5.5, but they're probably using the same technology in both).

It's a step, yes, but it's definitely not anything that'll be extremely useful for any serious gamer.

Link to comment
Share on other sites


  • Create New...