Jump to content
60 posts in this topic

Recommended Posts

Do you have Maciasl? If not then please download it. Then Open it and it will load/open your present DSDT. Now press cmd-F (for Finding text) Search for HDEF you probably will not find it. Next look for HDAS in the same way. You will have a few entries. So what you will need to do is "patch on the fly" using Clovers ACPI patching feature and on the first page that is ACPI add entry to the DSDT patches box. Press + sign and add any name under Comment column. I called it REN AUDIO you may call it AWAZ KARO! ;-) Then go here http://string-functions.com/string-hex.aspxor any other online Text to Hex converter. Enter HDAS in box called" Enter the text to encode to hex, and then click "Convert!":" and  press convert you will get 48444153. Back in clover enter this under Find Hex Column and find value for HDEF similarly to enter under replace hex.

I hope you followed? This changes all HDAS to HDEF in DSDT that is booted.

Reboot system, run maciasl and confirm by searching for HDEF as I showed earlier. Now all HDAS should be HDEF.

This is necessary otherwise the ALC script to patch AppleHDA will not work.

Also you must under devices tab page under Audio part Inject "1" and check reset HDA

Now Find the script from the GitHub repo here https://github.com/toleda/audio_CloverALCand be online when you run it.

Reboot you will have sound. Now you may play Kishore Kumar's Mere Sapno Ki Rani.. ;-)

Appreciate it   :D  :D  :D

 

 

Do you have Maciasl? If not then please download it. Then Open it and it will load/open your present DSDT. Now press cmd-F (for Finding text) Search for HDEF you probably will not find it. Next look for HDAS in the same way. You will have a few entries. So what you will need to do is "patch on the fly" using Clovers ACPI patching feature and on the first page that is ACPI add entry to the DSDT patches box. Press + sign and add any name under Comment column. I called it REN AUDIO you may call it AWAZ KARO! ;-) Then go here http://string-functions.com/string-hex.aspxor any other online Text to Hex converter. Enter HDAS in box called" Enter the text to encode to hex, and then click "Convert!":" and  press convert you will get 48444153. Back in clover enter this under Find Hex Column and find value for HDEF similarly to enter under replace hex.

I hope you followed? This changes all HDAS to HDEF in DSDT that is booted.

Reboot system, run maciasl and confirm by searching for HDEF as I showed earlier. Now all HDAS should be HDEF.

This is necessary otherwise the ALC script to patch AppleHDA will not work.

Also you must under devices tab page under Audio part Inject "1" and check reset HDA

Now Find the script from the GitHub repo here https://github.com/toleda/audio_CloverALCand be online when you run it.

Reboot you will have sound. Now you may play Kishore Kumar's Mere Sapno Ki Rani.. ;-)

Good to learn that. Now you need to pop the bonnet once more. Go into the BIOS and check where you selected the boot disks. The list I expect is now huge I mean really upto the floor! Every time you boot an entry is added to the UEFI Boot list. Is this so? If it it just 2 or 3 devices then okay or one day the system will not boot anymore. Please check and confirm.

Is your Audio working fully? I have audio from the Green out port on the rear and also on the header to the case. I won't be able to tell you more because I never check for 5.1 & anything fancier. Just simple L-R out and in.

As for the recurring UEFI boot entries you will need to boot into the Clover GUI and select the first item below your disk icons. It is the UEFI Shell much like the command prompt on PCs. To get to Clover GUI you will need to add -v to the config.plist and add a timeout value that will allow you to interrupt the boot process.

Once in the UEFI Shell type "bcfg boot dump" without quotes and you will find entries scroll past and halt at the highest number something similar to the image below. Note the numbers in blue 00 01 02 03 etc.,. You will need to remove these extra entries and add a new entry for booting.

To remove entries type "bcfg boot rm nn" where nn is the highest number you got to see when to typed the first command. In the image below it is 03. Keep at it until you have removed all. Be careful when you do this. Now when you type "bcfg boot dump" you will have no bootable entries. Now you add the one entry to boot as "bcfg boot add 00 FS0:\EFI\Clover\Cloverx64.efi CloverBoot" (That is FS Zero not letter O") Now this is assuming you have one disk bootable in the system & not multi-booting" For that you have to make note of the FS# number you want to make bootable. But for one disk & OSX only do as I did.

Now type again "bcfg boot dump" and see that the 00 entry is added. If it is you are good to go, so type exit and you will be back into clover GUI. Now boot OSX and immediately open Clover Configurator & mount your EFI partition where you have installed Clover. In there rename the BOOT folder to BOOT.bak or anything else. Again reboot into BIOS and see only 2 entries Keep the one called CloverBoot and disable the other. Now go into UEFI shell and check there will be 2 entries 00 and 01. Safely remove 01 only and now your BIOS will show only one UEFI drive. Phew! Lot of elbow grease but much cleaner now.

Suggest you also read up elsewhere to get a firmer grasp of the concept.

post-144165-0-20710700-1462642266_thumb.jpg

If you have windows double boot use "easyuefi" to delete all the duplicate entries. Be careful not to delete the original entry then you wont be able to boot into the windows. I realized that this happens if you installed osx after installing the windows. in essence there are 2 efi paritions now (one for windows and one for osx). so the entries keep duplicating. I reinstalled my windows after formatting the windows ssd and now all is fine. 

@hashish.k - Nope - haven't got windows double boot. 

 

@William Parker - "Is your Audio working fully? I have audio from the Green out port on the rear and also on the header to the case. I won't be able to tell you more because I never check for 5.1 & anything fancier. Just simple L-R out and in."

 

I use it as you do - nothing fancy - headphones from the port on the cabinet or Altec Lansing MX5021 2.1 audio from the Green out port. I have no use for anything fancier either.

 

Thx much for the heads up and the solution for the UEFI multiple entries glitch. 

 

 

Update: Followed your detailed instructions - I had fourteen entries - All removed and now the BIOS shows only one UEFI drive. Thank you  :D :D 

  • 1 month later...
Bros !!! 

 

Calling all Z170M-D3H owners !!!!

 

I am new to hackintosh.

 

Just finish building my rig

 

Spec as follow:

 

i3 6100

Intel 530

Z170M-D3H

Kinston Hyper X Fury 2666Mhz

PNY Sata SSD 240GB

 

I need your guide so that I could get mine to work... 

 

Hopefully we all can walk together till the next MacOS Sierra

 

Really appreciate all input & help !

Hi.Welcome to the world of computing with a difference. Since you are new to the scene I suggest you follow any z170 install here in the forum. Make a bootable 10.11.5 usb and see that you can reach the install screen. You will only need fakesmc and intel ethernet kexts to do so. Once you get to the install screen you will have few questions. Try this and update progress

Hi.Welcome to the world of computing with a difference. Since you are new to the scene I suggest you follow any z170 install here in the forum. Make a bootable 10.11.5 usb and see that you can reach the install screen. You will only need fakesmc and intel ethernet kexts to do so. Once you get to the install screen you will have few questions. Try this and update progress

 

Hi Successfully booted using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + el capitan 10.11.5

 

Installed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

 

Now i have the following issues

 

1. Display keep going 800x600 during startup. Cannot adjust to max resolution.... I selected Intel 530 in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] already

2. RAM displaying 4GB 3000mhz instead of 8GB 2666mhz

3. Sound works, but lots of hissing sound !!! (I chose the 892 + 100 series in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]) after that installed VoodooHDA kext

 

Please help !!!

Thank You Allan.

@cscheat while the tools you used may or may not get your system working, I was hoping you would read around and pick up how to boot using a proper bootloader of choice e.g. Clover & its options so you will be able to quickly achieve a working close to vanilla install. Approach it methodically step by step and it will work perfectly. Try it.

These tools are not supported here.

 

Read our Rules.

 

very sorry... so I I should use clover????

Thank You Allan.

@cscheat while the tools you used may or may not get your system working, I was hoping you would read around and pick up how to boot using a proper bootloader of choice e.g. Clover & its options so you will be able to quickly achieve a working close to vanilla install. Approach it methodically step by step and it will work perfectly. Try it.

 

Dear William Parker,

 

Your build is same with mine (GA Z170M-D3H)... I need help to get a vanilla install...

Look I could have given you a step by step but I do not know when I will have the time. So I was asking you to read on the forums about It. Even the tools you used rely on Clover for boot. Chameleon or its variant is also used. But Clover is preferred for a number of reasons. Make a clover bootable USB with 10.11.5 & install from there.

Look I could have given you a step by step but I do not know when I will have the time. So I was asking you to read on the forums about It. Even the tools you used rely on Clover for boot. Chameleon or its variant is also used. But Clover is preferred for a number of reasons. Make a clover bootable USB with 10.11.5 & install from there.

 

Appreciate it William, I just need some tips of what to choose in Clover.... 

 

Here's what I did:

  1. Format USB Drive
  2. Copy 10.11.5 installer to USB Drive using terminal 
  3. Install Clover to USB Drive

Here I need advice ! Already chosen Install for UEFI Booting only, Install Clover in the ESP, and for Drivers64UEFI which one should I choose? 

 

Screen%20Shot%202016-06-16%20at%202.36.4

Use OsxAptioFix2 and always boot verbose i.e. -v in Clover better if you use clover configurator. This all assumes you have an alternative computer already running OS-X. If then in verbose mode you see the boot getting stuck at lines displaying +++++++++++++++++++++ then it is aptiofix problem needing you to use the other one

Edit : Also try my plist

config.plist.zip

Use OsxAptioFix2 and always boot verbose i.e. -v in Clover better if you use clover configurator. This all assumes you have an alternative computer already running OS-X. If then in verbose mode you see the boot getting stuck at lines displaying +++++++++++++++++++++ then it is aptiofix problem needing you to use the other one

Edit : Also try my plist

 

Hi, how to use your config.plist.zip?????

This is why you need to read up on Clover bootloader. Config.plist is how you control lot of boot parameters, edit dsdt on the fly, patch kexts, manage smbios etc. Clover configurator is a utility that helps editing this plist easily. This is too vast a topic for me to get into here. So please dig.

William Parker, on 16 Jun 2016 - 6:31 PM, said:

This is why you need to read up on Clover bootloader. Config.plist is how you control lot of boot parameters, edit dsdt on the fly, patch kexts, manage smbios etc. Clover configurator is a utility that helps editing this plist easily. This is too vast a topic for me to get into here. So please dig.

 

William, i copy and paste your config into the thumbdrive's EFI clover folder... during boot it fails...

 

You choose.  ;)

 

But FYI, here's the explanation why InsanelyMac doesn't give support for Tonymac tools:

 

 

Only now I know this... very sorry for talking too much on Tonymac...

 

I bought my Z170M-D3H following their buyer's guide !!!

during boot it fails...

Can you please describe exactly what happens. The plist is for the hdd after you install, for use with usb I will send you one later. Meantime I hope you are aware that Clover boot can be interrupted and most plist parameters be switched in before osx boots. Read Read Read my good fellow, that is the shortest route.

during boot it fails...

Can you please describe exactly what happens. The plist is for the hdd after you install, for use with usb I will send you one later. Meantime I hope you are aware that Clover boot can be interrupted and most plist parameters be switched in before osx boots. Read Read Read my good fellow, that is the shortest route.

 

Good news here !

 

i am able to boot into the installation screen !

 

my steps:

 

1. Make bootable usb of el capitan 10.11.5 (downloaded from app store)

2. use clover v2.3K r3556 as EFI bootloader (choose UEFI Booting only, Install Clover in the ESP, and for OsxAptioFix2Drv- 64)

3. use EFI mounter and find the EFI partition of the usb installer.

4. Then copy the config.plist provided by William Parker into the Clover folder to replace it.

5. Copy theAppleIntelE1000e 3.3.1USBInjectAll.kextFakeSMC.kextto the following directory: /EFI/CLOVER/KEXTS/10.11

5. Bios setting as usual (make sure disable fastboot, set other OS, disable Intel Virtualiztion, enable XHCI handoff)

6. Boot it and install OSX ! (1st installation went 100% and reboot automatically, during reboot, it will continue to reinstall the OS... after 10 minutes, it also reboot automatically but this time I can see the OSX HDD installation partition! I go in and it works !!! Now I success install !!! I wonder what happen )

7. Tested the following:

  • Wifi = OK
  • Intel HD530 Graphic = OK
  • Ram = OK (reported 8GB 2666Mhz correctly)
  • Sleep = can sleep but won't wake up (CPU seems waking up, but monitor still black)
  • Sound = no sound

 

Anybody can help me???

 

 

 

Fantastic!

Sound can be made to work by using the clover ALC script from Toleda available on Github.

Sleep with proper wake does not work yet with HD530 graphics. Need to wait some more or splurge on a NVidia card. I do not think USBInjectall is needed if you're using my plist. I do not use it.

Also please note that your BIOS UEFI entries are getting filled up every time you boot. I have talked about it earlier. You need to take care of this also.

Great going. Wish you luck.

Have a nice weekend.

×
×
  • Create New...