Jump to content
Sign in to follow this  
Followers 0
Kaya80

[SOLVED]El Capitan on AMD 990XA-UD3

57 posts in this topic

Recommended Posts

Hi guys, i start this new topic under the tips of Spakk....

I had a working machine, my first in signature, working well with Yosemite, but i wanted to test this new build, so i decided to try Shanee tutorial on how to proceed to the installation.

From here my problems started... with the help of Spakk we tried several times to install, with no luck, almost 3 weeks, but no chance for me to reach the installation screen not a single time.

As boot loader i use Enoch, that Spakk configured for me from teamviewer, i have all the Extra folder and USB  Fix we used for the installer.

I had two different problem, the common one is AppleEhci Stop/Restart error, that comes after few lines after booting, that causes the installation stop....the other one, that brings me almost to the installation screen, but not, gives me another USB error, but different from the first one, that put the usb HDD used as installer disconnected from usb, not blinking anymore, like the HDD usb was physically removed from usb ports....

In any case i never reach the installation screen and really would like an help to install El Capitan, but better to know what me and Spakk were not able to solve....

i post Extra folder that Spakk gave to me and all the things that help you to know were is my problem.

Another important thing to say is that, in both cases, the installation stuck with USB errors and i've to force shut down holding the button, and this causes RTC resets every time, even if i have RTC Apple patch on S/L/E....

Can someone help me please? Because my old Yosemite build does not work any more

post my extra folder, if u need something else i will pot as soon as possible, but please, help me :D

 

Here are my bios settings

 

3. BIOS Settings:

MB Intelligent Tweaker (M.I.T): ===> Make no changes before installing OS X !!! CPU overclocking perform after installation if required.

==> leave everything unchanged!

 

Standard CMOS Features:

leave everything unchanged!

 

Advanced BIOS Features:

AMD C1E Support ==> Disabled

Virtualization ==> Enabled

AMD K8 Cool&Quiet control ==> Enabled

Hard Disk boot Preiority: 

first USB Flash Disk

second HDD for OS X

 

IOMMU Support ==> Enabled

==> leave the rest unchanged!

 

 

Intergrated Peripherals:

OnChip SATA Controller ==> Enabled

OnChip SATA Type ==> AHCI

OnChip SATA3.0 Support ==> Enabled

OnChip SATA Port as ESP ==> Set all required SATA ports where a HDD is connected to Enabled.

F_USB30 Controller ==> Enabled

eSATA3 Controller ==> Enabled

eSATA3 Ctrl Mode ==> AHCI

Onboard 1394 Funktion ==> Disabled ==> set to Enabled after successful installation.

 

Pictures of DCPI and System info

https://www.dropbox.....16.44.png?dl=0

https://www.dropbox.....17.29.png?dl=0

 

My usb Errors

https://www.dropbox.com/s/5f6dls54pkl6rob/IMG-20160323-WA0000.jpg?dl=0

 

And here another problem

http://www.insanelymac.com/forum/topic/311245-help-topic-amd-os-x-el-capitan-1011/?p=2222805

 

P.S. Spakk tried to create an installer from my mac by teamviewer, but neither him was able to solve the problem

Share this post


Link to post
Share on other sites
Advertisement

kaya, when you get back home then try to boot without DSDT.aml: DSDT=NO and the other boot flags and reports.

upload your Extra folder so that everyone can check the contents .

Share this post


Link to post
Share on other sites

The error you had here, http://www.insanelymac.com/forum/topic/311245-help-topic-amd-os-x-el-capitan-1011/?p=2222805

 

I faced the same and ended up using the 10.11.0 installer which booted fine.

 

Then you think i'm using a different version from 10.11.0?Have to try with that build?this one is good OS X El Capitan 10.11.0 (15A284)?

 

Edit Duran: Links to torrents are not only illegal, but they are also not allowed in the public forum.

 

Sorry, my mistake, i forget to delete the link to the site, i know the rules, really sorry...i wanted to ask only if the build was correct

Share this post


Link to post
Share on other sites

I am of the opinion that the problem is not at the El Capitan build. Probably the dsdt, I've created is not 100 % okay, or is missing an important driver for your hardware or a driver was not modified correctly. As a basis you use a clean install version. and no USB installer. The clean install version was created by El-Capitan HD tool by chris1111 ,, then we have been installed Enoch bootloader with the drivers in to the Extra folder.

The BIOS settings are correct for the motherboard and the BIOS, a problem with the settings, as long as kaya are described above, are okay.

Share this post


Link to post
Share on other sites

it seemed to be the right one, but no, it isn't....now the lines proceed very slow intead of previous installation, booted with DSDT=NO, all other flags are the same

 

But Spakk, i'm not so confident on this post, i think noone will consider this little problem that only i have....

post-839034-0-51830300-1459446439_thumb.jpg

Share this post


Link to post
Share on other sites
1) if you have to used the USB-Fix_V3 for El Capitan, then you must first remove the following original apple drivers from System/Library/Extensions/ ==> IOUSBFamily.kext, IOUSBMAssStorageDriver.kext,IOUSBMassStorageClass.kext, pmtelemetry.kext, AppleIntelCPUPowerManagement.kext, AppleTyMCEDriver.kext 

 


2) the symbol error „in interface com.apple.iokit of __kernel__. couldn’t find symbol ….“: 

in each kernel package that I upload, is located in to the Extensions folder a system.kext, share this system.kext against the orig apple system.kext in S/L/E (that fix the error messages)


then repair the permissions and renew the cache with kext wizard 

 

then start the system.


 

Share this post


Link to post
Share on other sites

Ok

Share this post


Link to post
Share on other sites

ok, i tried yesterday but i forgot to change bios settings, then i started from hdd, but i had the same error of USB, but now the RTC does not resets anymore.Now i think that the hdd we prepared is damaged, because i had to shut down the PC for the usb error, and i think the disk is damaged....i try to correct error with disk warrior, but stuck at boot with GPT boot0 error_....

 

Solved the boot0 error reinstalling boot loader, but still no luck unfortunately....i made a video, seems all goes good, but here it comes again, the AppleUSBEhci loop again and again. I load bios configuration as you told me, disconnected every other hard disk and external usb, but nothing change

Share this post


Link to post
Share on other sites

put the hdd not in the first two Sata slot. use the third or fourth slot and reboot.

Gigabyte motherboard can sometimes be a bit...ch. my motherboard I can not boot OS X from the first two slots. No idea why?

but otherwise a very reliable mainboard.

Share this post


Link to post
Share on other sites

First try by USB

https://www.dropbox.com/s/wksismfn1u76k45/20160402_111529.mp4?dl=0

 

Second Try on sata

https://www.dropbox.com/s/2otkpnguuqi2lxb/20160402_113435.jpg?dl=0

 

Ooooooooooh my Zoooooooooood, i'm at installation screen now, i left the pc with "still waiting for root device", and when i return....baaaaaaaahm, installation screeeeen :Dnow i try to install, thank you Spakk, i hope it will install correctly

 

Sorry, it's not the installation screen, the system is starting directly :D

 

 

OOooooooook , i'm on desktop now, now i've to install all correct kext, right?

Share this post


Link to post
Share on other sites

I have completely forgotten with all the other problems due Sata ports Problems on gigabyte mainboard. That was the cause throughout.I'm getting old and forgetful.

A little self-mockery can not hurt ;-))

Share this post


Link to post
Share on other sites

:D it's not a problem for me, i appreciate so much what you did for me, really thanks, but i'm 36, you? From where can i start installing kexts?

I need ethernet, graphic and i think nothing more...

Share this post


Link to post
Share on other sites

It is a complete installation. You have to adjust only your system access data that's it.

Share this post


Link to post
Share on other sites

It is a complete installation. You have to adjust only your system access data that's it.

But i've only 5mb video and no network, can't you help me with this too? Have to install nvidia web driver?

Share this post


Link to post
Share on other sites

use the Realtek diverse of Mieze, the driver can be found here on insaneleymac under download. This works 100%. Sound previously only possible with VoodooHDA current version. otherwise, use an external USB sound card. This will work the same.

Share this post


Link to post
Share on other sites

Graphics card I fit you later. When I'm at home, ... i write only with my smartphone.

Incorrect video ram, it may be that I have created your dsdt without the right vram-total size. or you boot without dsdt.

But this is a minor problem and can be solved.

Share this post


Link to post
Share on other sites

Ok, now i'm trying to install ethernet and audio....the system can be upgraded to 10.11.4 or not? last question :D

Share this post


Link to post
Share on other sites

No!! wait with the update!

I'll describe you later what exact you have to do, so that the update works without problems.

Share this post


Link to post
Share on other sites

after you have installed the drivers, then make a backup*** on an external hdd.

*** create a image with Disk Utility, as I did yesterday via teamviewer.

kaya, can you remember, I gave you an org.chameleon.boot.plist with a efi-string for your Video card . Search this modified org.chameleon.boot.plist and cange them against with your exist boot.plist in to Extra folder, then run the system and reports.

Share this post


Link to post
Share on other sites

Oh no, installed VoodooHDA and the system stuck, i've to force shutdown, now Opcode kernel error at startup, no chance to load the system anymore....incredible, i can't believe this, never ending story

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×