Jump to content

OS X El Capitan 10.11 est disponible !


22 posts in this topic

Recommended Posts

616976Capturedcran20150930201726.png

 

 

Apple sort aujourd’hui son nouveau système d’exploitation aussi connu sous son rocheux nom d' "El Capitan".

 

Avec cette nouvelle mouture, Apple reprend les mêmes fonctionnalités et le design de Yosemite, tout en optimisant l’interface graphique et les performances.

 

Comme pour ses prédécesseurs, El Capitan sort en mode « free » et est téléchargeable depuis Apple Store.

 

 

 

***Nouveautés d'OS X El Capitan***

  • Like 2

je suis en Public Beta, et pas de mise à jour vers la version officielle proposée.
je ne sais pas comment passer dessus sans avoir à faire une réinstallation.

je n'ai pas testé encore cela:

sudo /usr/sbin/softwareupdate --set-catalog "https://swscan.apple.com/content/catalogs/others/index-10.11seed-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz"

++

Bonjour,

 

Voilà mon soucis... En bon noob que je suis j'ai installé El Capitan. Ayant une MSI GTX970 j'ai installé le driver Nvidia suivant :

 

WebDriver-346.03.01b06 (Normalement indiqué pour la build 15A)

 

Malheureusement j'ai un problème car ça ne marche pas... Ecran noir... J'ai replacé ma ATI : Nickel, je réinstalle mon driver, switcher sur redémarrer sur Nvidia driver et... Ça ne marche toujours pas... Aidez moi Obi Wan Kenobi, vous etes mon seul espoir... :D

 

Merci d'avance !

Salut !

 

Enfin le week-end, je vais avoir le temps d'installer El Capitan sur mon PC fixe. Je m'étais lancé tout seul comme un grand du temps de Yosemite mais ça avait donné un thread de 160 messages:) Cette fois je préfère me rencarder avant !

 

Je cherche la solution la plus simple. Je vois que certains d'entre vous ont simplement mis à jour comme ils l'auraient fait sur un vrai Mac, en lançant depuis Yosemite l'app qu'ils ont téléchargée sur le Mac App Store. Sous quelles conditions est-ce qu'on peut faire ça ? Ce que je sais moi c'est que j'ai pu faire les mises à jour intermédiaires de Yosemite directement depuis le MAS.

 

Autrement s'il vaut mieux faire une clean install, est-ce que la dernière version officielle de Clover prend en charge El Capitan ? Et si oui, est-ce que ça fonctionnera avec les mêmes fichiers/configurations que sur Yosemite ?

 

En tout cas je vois qu'il y a toujours les mêmes pointures dans cette rubrique du forum, merci encore pour votre implication pour la communauté. :)

  • Like 1

Bon je crois qu'il ne me manque pas grand chose !

 

J'ai cloné mon SSD système de 256 Go sur un SSD de test de 128 Go avec Carbon Copy Cloner (CCC). Il n'était pas bootable, alors j'ai ressorti ma clé USB d'installation Yosemite pour démarrer dessus. Puis j'ai téléchargé la dernière version de Clover depuis http://sourceforge.net/projects/cloverefiboot/sur une autre clé USB, et je l'ai installé sur le SSD de 128 Go. J'avais alors retrouvé une copie fonctionnelle de mon Yosemite sur mon SSD de 128 Go.

 

De là, j'ai lancé l'installation de El Capitan avec la méthode officielle. Il a juste fallu que je choisisse "OS X Install" au redémarrage avec Clover, et l'installation s'est déroulée sans encombre.

 

L'ordinateur ne démarre pas complètement, mais je n'ai pas de kernel panic pour autant, on m'incite seulement à RebuildPrelinkedKernel (voir photo). Que me conseillez-vous de faire et comment le faire à ce stade ? Sachant que je peux brancher mes deux SSD en parallèle au besoin. À quel moment dois-je désactiver SIP ?

 

Merci d'avance pour vos réponses ! :)

  • Like 1

justement, c’est parce que FakeSMC.kext n’est pas présent dans le cache et SIP ne veut pas le laisser se charger

 

tu vas devoir le désactiver et ton kext devrait se charger sans soucis.

 

Une fois sur le bureau, tu reconstruits ton cache avec ce petit utilitaire et avant de redémarrer, tu réactives ton SIP et ensuite tu redémarres.

Salut les francophones ! :-)

 

justement, c’est parce que FakeSMC.kext n’est pas présent dans le cache et SIP ne veut pas le laisser se charger

 

tu vas devoir le désactiver et ton kext devrait se charger sans soucis.

 

Une fois sur le bureau, tu reconstruits ton cache avec ce petit utilitaire et avant de redémarrer, tu réactives ton SIP et ensuite tu redémarres.

C'était bien FakeSMC. Je vous ai fait une infidélité cette nuit, j'ai été demander du côté du forum général anglophone, et quelqu'un a remarqué qu'il n'y avait aucune référence à FakeSMC sur ma photo. Je me suis aussitôt souvenu que je n'avais pas copié les kexts de /EFI/CLOVER/kexts/10.10 dans le nouveau sous-dossier 10.11 !

 

Précédemment j'avais ajouté les RtVariables au config.plist de Clover, et régénéré le cache de ces manières :

 

Désactiver SIP avec Clover

<key>RtVariables</key>
<dict>
	<key>CsrActiveConfig</key>
	<string>0x03</string>
</dict>

 

1. Boot into Yosemite with kext-dev-mode=1

2. Open terminal and type the following lines, followed by <Enter>. My El Capitan volume is named "El_Cap", so change if yours is named something else...

sudo -s
rm -f /Volumes/El_Cap/System/Library/PrelinkedKernels/prelinkedkernel
touch /Volumes/El_Cap/System/Library/Extensions
kextcache -u /Volumes/El_Cap
exit
3. Reboot into El Capitan.

 

Et effectivement au redémarrage, j'ai retrouvé l'interface d'installation d'El Capitan, installation qui s'est finalisée en quelques minutes avant qu'on ne me présente l'écran d'identification. Je vous réponds depuis El Capitan et pour le moment tout semble fonctionner.

 

Avec ce que j'ai fait précédemment, ai-je quand même besoin de suivre ta procédure fantomas ? Je pensais que les kexts injectés par Clover étaient chargé indépendamment du cache ?

  • Like 1

hello,

Pour passer de la beta public, j'ai été obligé de créer un installateur USB.

C'est généralement le cas pour chaque passage de version.

 

Le seul hic, même une fois en release officielle, on me propose encore les beta dans le MAS.

quelqu'un pourrait me donner le bon catalogue ?

cf #4

 

merki !

mais c'est le bon catalogue   :yes:

 

si tu ne veux plus recevoir des mises à jour bêta, tu peux  régler ça dans Préférences Système -> App Store

 

ça doit être écrit quelque chose comme : "Votre ordinateur est prêt à recevoir des version bêta de mises à jour de logiciels", clique sur le bouton "Modifier"

 

ou bien simplement nettoyer ton catalogue via Terminale

sudo /usr/sbin/softwareupdate --clear-catalog

;)

  • Like 1

Je me tate toujours.... pas de soucis avec le contrôleur ethernet Realtek RTL8111/8168B PCI-E Gigabit, je pense qu'avec le kext pour Yosemite (RealtekRTL81xx.kext) ça passe mais pas sur à 100%. Des retours ?
Un lien pour fakesmc compatible El Capitan ou celui de Yosemite suffit ?

  • 2 weeks later...

Bonsoir Got!3r,

 

ayant  la meme carte mere que toi, l'install d'EC c'est pas bien passé avec clover.

 

peux tu m'indiquer quels kexts as tu utilis et as tu changer le DSDT.

 

pour ma part j'ai reussi a installer  yosemite avec  clover suivant cette config :

dans SLE :

 

appleHDAenabler

NVenabler64

realtekRTL81xx

VoodooHDA

Dans clover 10.10 :

FakeSMC

Nullcpupowermanagment

et le DSDT dans acpi

 

qu'en est il pour toi

 

Merci pour ton aide

 

Yegor

  • 2 weeks later...

:)

 

bon aillé , la MAJ du hackintosh Mavericks du collègue est faite , assez simple à faire , clef usb à la mano comme d'habitude , tout les pilotes de Mavericks sont fonctionnel sur El Capitan 10.11 , le seul hic j'utilise Clover au lieu de Chameleon pas terrible sur CM non UEFI (P67) 

 

tout ses dossiers et Appli sont fonctionnels :)

 

Merci la communauté de codeurs , développeurs et autres participants essentiel à la bonne marche de nos hackintoshs 

  • Like 2

:)

 

je n'ai pas trop cherché en fait , j'ai juste tenté Enock mais kp ACPI , j'ai préparé la clef USB comme Yo et le reste comme pour AMD en fait :D , tout s'est installé sans histoire , les pilotes réseaux audio était déjà là (Mavericks) comme une simple MAJ mineur :)

 

Et puis j'ai installé Clover , c'est plus long mais ça marche bien , par contre , j'ai vu qu'on ne pouvait plus réparer les auto via utilitaire disque  ?? c'est un peu nul , je le garde un peu en observation , ensuite le collègue le récupérera et il pourra gérer les MAJ mineur .

 

Moi je suis revenu sur mon Mhac AMD YO :) 

  • Like 1

Ton KP, c'est sans doute parce qu'il te manque un kernel.plist ;).

 

Sinon, pour les perms dans EC :

 

Vérifier :

 

 

sudo /usr/libexec/repair_packages --verify --standard-pkgs /

 

Réparer :

 

 

sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume /
  • Like 1

j'ai vu qu'on ne pouvait plus réparer les auto via utilitaire disque  ?? c'est un peu nul , je le garde un peu en observation , ensuite le collègue le récupérera

 

ben aux dernières nouvelles, on allait dans un garage pour réparer son auto...   :frantics:

 

boulet%20(2).png

  • Like 2
×
×
  • Create New...