Jump to content

ALienWare M17x R4 - DSDT


163 posts in this topic

Recommended Posts

Coloquei o VoodooHDA e o som está funcionando, porém o controle de volume não funciona, mesmo ativando a opção info.plist dentro da kext

 

quando a bateria, coloquei as duas kexts dentro da pasta SLE (fiz uma cópia antes da original) não adiantou.

li algumas pessoas dizendo que somente via DSDT. 

Poderá usar a kext ACPIBatteryManager, e deletar a VoodooBattery.

 

Se mesmo assim não funcionar, terá de usar DSDT+ACPIBatteryManager.

olá

 

o dsdt que te enviei já tinha como anteriormente escrito os patch aplicados para teres usb nativo .. possivelmente os problemas que tinhas eram da generic kext que usavas ..

 

está também  aplicado o patch para a bateria .. tens de usar a kext do rehabman .. não mexas se não souberes o que estás a fazer..

 

porque ai fica dificil de detetar possiveis problemas..

 

tenho o mesmo chipset que tu .. por isso sei o que apliquei .. meu note tem sleep nativo .. hibernar ..

 

bom hack

Sim artur, não alterei nada.

Vou tentar a Kext, obrigado pela ajuda.


Pessoal, se o arthur não tivesse aplicado o patch para a bateria, como eu faria por exemplo para saber qual patch aplicar.

De onde eu retiro a informação para saber como construir esse patch ou saber se ja existe pronto.

 

me mandem algum link para eu ler ou me digam como procurar no google. Obrigado.

Beleza, depois eu vou ler,

Coloquei a kext ACPIBatteryManager, e funcionou.

 

Fiz um teste e aconteceu uma coisa um tanto estranha

 

coloquei ele em repouso somente na bateria, ele entrou em repouso, quando apertei o power para ele voltar, ele acendeu e desligou, e não ligou mais.

 

coloquei o cabo de força apertei para ligar, ligou e iniciou como se estivesse ligando.

O clover identificou o Sistema como em hibernação, dei enter para acordar, mas ele reiniciou, quando voltou veio em modo normal, como se estive desligado.

 

Como faço para saber o que houve?

 

 

Atualizado

 

 

Fiz mais dois testes,

1º cabo de força ligado. hibernei, entrou normal em hibernação, abaixei a tampa, ao levantar a tampa ele acendeu (ligou os leds) e depois desligou.

 

2º Hibernei, apertei o botão, acendeu e apagou. 

 

nesses dois últimos tive que ligar o note e ele entra no chover normal (sem dizer que está hibernado)

Sem essa kext o indicador de bateria não funciona.

 

Tenta adicionar a flag slide=0/ou outro valor, e faz o teste.

Cara tem algo a mais. Ainda não acabei os teste, mas no slide=2 funcionou, ai alterei o config.plist para deixar fixo, reiniciei e testei, não funciona mais. vou continuar testando.

Os valores do Slide podem ir de 0 a 100, aqui eu uso o 100.

Mas pra chegar a isso foi vários e vários valores.

  • Like 1

Acho que ficou estável no slide=3 (atualizado. Voltou a desligar ao tentar acordar)

 

nem o percentual nem o tempo restante da bateria desce, vou ver como resolve isso

não sei se tem alguma ligação, mas percebi, que se eu der o comando de desligar, e depois de ligar tentar o repouso rola de boa.

 

Acabei de fazer esse teste, não estava mais entrando em repouso. 

após desligar voltou a funcionar.

Olha o log quando coloca a kext com mode debug

 

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::pollingTimeOut called

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::pollBatteryState: path = 1

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBatteryManager::getBatterySTA called

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatterySTA: battery_status = 0x1f

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBatteryManager::getBatteryBIF called

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBatteryManager::getBatteryBIF: validateObject return 0x0

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: acpibat_bif size = 13

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fPowerUnit       = 0x0

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fDesignCapacity  = 90000

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fMaxCapacity     = 77560

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fBatteryTech     = 0x1

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fDesignVoltage   = 11100

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fCapacityWarning = 7750

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fLowWarning      = 2325

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fDeviceName      = 'PABAS0241231'

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fSerialNumber    = '41167'

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fType            = 'Li-Ion'

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBIF: fManufacturer    = 'SDI'

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBatteryManager::getBatteryBST called

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: acpibat_bst size = 4

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fPowerUnit       = 0x0

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: currentStatus    = 0x2

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fCurrentRate     = 631210

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fCurrentCapacity = -1

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fCurrentVoltage  = 12816

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: Calculating for WATTS

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fCurrentRate = 56865

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fCurrentCapacity = 386933

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: adjusted fCurrentRate to 8670

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::setBatteryBST: fAverageRate = 8719

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery: Battery is charging.

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::constructAppleSerialNumber called

May 19 16:04:31 MacBook-Pro-de-Wesley kernel[0] <Notice>: AppleSmartBattery::rebuildLegacyIOBatteryInfo called


Essa é a bateria

 

post-628074-0-21066000-1432063188_thumb.jpg

olá

 

como está errado ?

 

n mostra ?  n desce usando ? n mostra carregando ?

 

o que está errado é teu sleep e hibernar .. acho que te deves debruçar sobre isso ..

 

deixa o sistema trabalhar sem sleep e hibernar .. isso é a ultima parte .. de certeza que tens problemas + graves .. bt .. n está funcionando .. até mais vale n usares a kext .. que so deve estar a trazer + 1 problema ao sistema .. net ? o que estás a usar ? sleep e hibernação so funciona bem num hack perfeito ..

 

bom hack

  • Like 1

Quanto a bateria, mostra o indicado de carga quando o carregador está ligado

Quando o carregador não está ligado ele não diminui o percentual de carga, e o tempo de uso fica em 20:00

 

O hibernar funciona, as veze não sei porque ele não volta.

Quando isso acontece eu posso tentar quantas vezes quiser não funciona. Só volta a funcionar se desligar o notebook.

 

A rede estou usando uma kext atherose2200ethernet-v1.0.0

 

Bluetooth e o Wi-Fi Vou trocar a placa.

 

O som funciona, mas o controle de volume não.

 

Eu estou tentando resolver essas coisas, mas eu não consigo.

olá

 

tens de procurar seguir os tópicos das kext que usas ..

 

http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/

 

     Solution for Qualcomm Atheros AR816x, AR817x and Killer E220x    

 

essa versão é antiga .. outro roubo do tmac.. que nem atualizou a kext no " beast "

 

onde está instalada ?

 

se for em 10.10

 

deve estar junto com ionetworkfamilly do sistema

 

dentro de plugins

 

essa kext tem dependências

 

quanto ao hibernate eu uso 

MacBook-Pro:~ artur_pt$ pmset -g | grep hibernatemode

 hibernatemode        57

vou dar outra olhada na bateria

 

que usas para o som ?

 

bom hack

  • Like 1

Artur, amanhã e confirmo a kext correta de rede e aonde ela está.

Para som segui seu conselho. VoodooHDA. Já tentei editar o info.plist é colocar true na opção volumefix, mas não resolveu.

A lan, está funcionando. Não sei se está causando algum problema. Hibernate eu estou usando 0. Já tentei 29 mas não foi. Vou ler sobre os diferentes tipo de modo de hibernação.

 

Minha dúvida é porque às vezes para de funcionar e só volta a funcionar se eu der shutdown.

 

Eu posso colocar em repouso 10 vezes que ele volta

Mas se der erro uma vez. Somente desligando e ligando novamente, ai volta ao normal.

×
×
  • Create New...