Jump to content

[Guide] Yosemite 10.10.X - Dell Optiplex 780 (760)


pepto
 Share

468 posts in this topic

Recommended Posts

Are you using a DSDT ? If so, remove it.

Post a screenshot of your KP also.

I deleted DSDT.aml from /EFI/EFI/CLOVER/ACPI/Patched and I can't boot... I will put it back, backup is on the Desktop

Here is the picture

post-1344968-0-37034000-1420725454_thumb.jpg


Well, obviously you have a conflict with VoodooHDA and AppleHDA ;)

 

It's not related to GFX. Remember that when you're using VoodooHDA, you always have to remove AppleHDA.kext from S/L/E or leave it in place AND use AppleHDADisabler.kext to avoid a Kernel Panic.

 

I think using AppleHDADisabler.kext is a better choice because next OS X updates will likely reinstall AppleHDA.kext but they won't overwrite or remove AppleHDADisabler.kext.


After that I reinstalled yossemite…

 

Make sure that AppleHDA is not in S/L/E ! There's 100% chances that it's still there because you've just re-installed Yosemite.

 

Maybe the problem occurs because HDMI audio isn't managed the same way with 5450 and R9 280 and a conflict may appear where there's none with 5450. But according to your KP screenshot, the problem is definitely related to VoodooHDA as you can read by yourself ;)


Well actually 5450 has HDMI output and hence digital audio. But maybe VoodooHDA hasn't detect or enable it.

 

That said, I still think that mixing VoodooHDA and AppleHDA is the problem ;)


You can revert your VoodooHDA.kext to the working one as long as you leave AppleHDADisabler.kext in S/L/E.

 

I assume that you installed the VoodooHDA 2.8.8 pkg. This package also install AppleHDADisabler.kext so you'll be fine and you should find the previous VoodooHDA.kext in the Backup Extensions at the root of your HDD.


I had success with CMI8738 chip on some cheap pci card :)

Youtube is a little slow, latest flash player, same thing with Chrome... but never mind, everything else works... Next "mission" is iMessage & FaceTime


  • 2 weeks later...

Hello all!

 

First of all thanks for the tutorial, it took me a while but I pretty much succeded.

 

I have managed to get the the first installation process and have created a partition on my hard drive.  When I come to close the disk utility however, I am not then prompted to install Yosemite, my only option is to restart from the partition which does nothing apart from give me a black screen!  I have done a bit of googling and can't seem to find an answer to my problem.  Just wondered if anyone could help.

 

Thanks

 

PS  This is my first Hackintosh project so i apologies in advance if I ask any pretty obvious questions.


Welcome aboard ;)

 

First, check that your partition is formated with Mac OS (Journalised) option.

 

Second, please confirm that this is a partition on an existing partionned drive with others partitions and how they're organized (i.e NTFS + HFS+ + ExFat).

 

Your problem seems that you're trying to install OS X on an MBR scheme partitionned drive instead of an GUID partition scheme drive. If so, you have two options :

 

• If your drive is empty and you can re-format it without any important data-loss, you can do it by selecting GUID in the Options when you're creating a new partition scheme. Create as many partition as you whish in any format (NFTS, HFS+ and so) but make sure to reserve one in Mac OS (Journalised) for the OS. That way, you should be able to choose it at the installation screen.

 

• You'll need an MBR patch that you can easily find here at IM or by googling "MBR Patch Yosemite". You'll have to modify files on your Yosemite install USB pen. Then, back to the installation screen, you should see your Mac OS (Journalised) partition as a destination for the OS installation.


Looking at a  refurbished 760  with an Intel Core 2 Duo Processor 3.0GH

  • Microsoft Windows 7 Professional 64-bit
  • 2GB RAM
  • 160GB Hard Drive
  • DVD-ROM Drive

Could you recommend a $50 video card that would allow both 10.6 SL and 10.8 ML? I was looking at this http://www.microcenter.com/product/357061/Radeon_HD_5450_Low_Profile_1GB_DDR3_PCIe_20_x16_Video_Card

 

 

transparent.gifSapphire Technology Radeon HD 5450 Low Profile 1GB DDR3 PCIe 2.0 x16 Video Card

listed as DirectX11 and OpenGL 3.2. Other than the specs saying it requires a 400watt power supply and I don't know what the computer will come with, does it seem like this card would run both 10.6 and 10.8?.


No problem with 5450 series. Works fine with latests OS X versions so far as long as you use patched AMD5000Controller.kext and AMDRadeonX3000.kext for 10.8/10.9/10.10. You may need AMDRadeonAccelerator.kext for ML 10.8 (but this not for sure). Don't know for 10.6 SL as the OS lacks these kexts. It seems that 10.6.6 brings support for 5000 series so you should be able to patch them the same way as for newer OS X versions. To confirm. Do some research but I'm pretty sure it is possible.

 

Or

 

You can use DSDT patch with untouched kexts to avoid kexts patching at every updates.

 

This both works with Chameleon and Clover bootloaders without bloot-flags.

 

All infos and hows-to are in this thread so take time to read and you'll be fine.


Well I have the 760 too with an XFX Radeon HD 5450 1Gb low-profile inside and a standard and genuine Dell power supply built-in. There's no issue with it so I assume that Dell's power supplies can handle any GFX Cards in this format. Only difference is that I have a Pentium Dual Core e222O CPU @ 2,2 GHz but I'm pretty confident that a Core 2 Duo @ 3 GHz will not drain all the power from the PSU.

 

But if the 760 is a refurbished model, it is reasonable to check that point before making any decision.


Hi.

 

I sad times it is still not working, i cannot for the life of me figure out what is wrong.

 

My USB drive seems to be all setup properly.

 

When i boot into the Dell computer I come straight into the OS X Utilities screen, i am not given a prompt to install Yosemite.

I then create a partition on the HDD of the dell computer.

I then attempt to close the disk utility and begin the install but the dell computer will only let me choose a startup disk which does nothing but give a black screen.

 

As you may be able to tell i am pulling my hair out with this a little now, just wondered if you have any further suggestions.

 

THanks


Your USB install disk seems to be badly prepared. What method did you use to create it ?

 

All steps are described in the guide so check them one by one because you probably missed something important. You should see the installer when you boot from it.


Im wondering if it is something in steps 14-17, as these do not work for me at all.  Terminal does not find the file in the code listed.  I have googled other ways of doing it which appear to work but maybe this is the issue.

 

Can you suggest a way I may rectify these steps, or simplify them for a complete Mac Novice.  I am fairly Windows savy but my wife must have a Mac and this was the most cost efficient way of achieving it! (but not time efficient  :) 12 hrs later)

 

On a side note, how are getting on with your AMD Athlon build.  I have an old dell Machine that is basically the same sat in the loft, I was going to make it into a server but may repurpose it.

 

Thanks

 

EDIT: I have just been doing some research, should i be setting up the USB as an MBR rather than GUID, as it does not appear to be a UEFI bios, but a legacy one?


Ok, you're right and this is indeed due to mistakes in the part 5 of the guide and some others chapters too.

 

This has been addressed in the 2 next posts just after the 1# of the guide here :

http://www.insanelymac.com/forum/topic/302877-guide-mavericks-1010x-dell-optiplex-780-760/?p=2088990

 

Following the new steps will fix all your problems. It's absolutely normal that your USB Pen fails to reach installation screen if you follow the original guide :)

 

 

On a side note, how are getting on with your AMD Athlon build.  I have an old dell Machine that is basically the same sat in the loft, I was going to make it into a server but may repurpose it.

 

Well, AMD Yosemite is quite another story :P It's possible but success largely depends on what kind of AMD CPU you use. I suggest to have a look at here for further informations : http://www.insanelymac.com/forum/forum/491-os-x-1010-yosemite/ & here : http://www.insanelymac.com/forum/forum/489-amd/

 

You may be stick to Mavericks with Athlon CPU's.


polyzargone my dear helper! :D

Do you know why APP Store is slow, sometimes "Cannot Connect to the App Store"

I've deleted network adapter several times, but no success :(

Sometimes works... Can't figure out... It would be easier if never woks

Also, YT play some videos normaly, sometimes to slow to load, and default is 144p video

Everything else works perfectly! :)


I was searching a little... here is what I found in logs while appstore was trying to check for updates:

"storeuid deny mach-lookup com.apple.dock.server"

 

I tried with DNS's... I put google's 8.8.8.8 and secondary 8.8.4.4, I think it works now!

 

Edit: Solved only AppStore, not youtube :(


Hello Again.

 

So i feel like I have made some progress but have come across a slightly different issue.  On boot into OSX installation I select my language and i am them faced with "Failed to open OS X installer",  The path /System/installation/pacakages/OSinstall.mpkg appears to be missing or damaged."

 

I have looked in the USB folder and it is correct it is infact missing, but I am unsure why it is missing, or where to get it from.  Any suggestions?

 

Thanks once more.


 Share

×
×
  • Create New...