Jump to content

Success - HP XW6600 Workstation

30 posts in this topic

Recommended Posts

EDIT: See reply below for a more elegant, and simple solution, requires one character KEXT EDIT, to get all built-in motherboard SATA ports working perfectly (should work with Mavericks USB install as well, just substitute method for USB instead of Boot HDD)




I had to cut a lot of corners here, and I may have to switch to an IDE DVD-RW drive, as the Mac boot (2xHDD installed) I have is running from a 2-port ASM1061 SATA3 PCI-e card.


I used my existing Hackintosh Time Machine backup, and made sure the SMBIOS.plist was identical on the MyHack Mavericks installer USB. I could then restore from my Time Machine backup to this machine (both HDD plugged into ASM1061).


I have a GeForce 8500GT 512MB, and the only way I can use it was to use GraphicsEnabler=Yes. I also use npci=0x2000 and PCIRootUID=1 in my Boot.plist.


I am using Voodoo 0.21 for audio.


I am using Kext Utility to manually update the Kext Cache -- machine boots to desktop in ~10 seconds with UseKernelCache=Yes.


I am using BCM5722D.kext for ethernet. Does not work after sleep, but can be manually reloaded. I am looking into a RELIABLE script to do this automatically with SleepWatcher.


I have a SiliconImage 3114 PCI SATA card, and two VIA VT6421 PCI SATA/IDE cards, but with PCIIDE.kext or AppleVIAATA.kext, there is still no DVD-RW visible. This is a HP BIOS DVD-RW, but I have no other SATA models to test with, I do have one working IDE model, which I might test in the motherboard's IDE port.


List of things working:


2 x Quad-Core Xeon 2.33GHz -- 2 power states, 2.0GHz and 2.33GHz. C2 State a possibility - mentioned in BIOS.


4GB 667MHz DDR2 RAM - Strange, it shows 9 slots (only 4 in machine) and slot 9 is a 1MB ROM???


GeForce 8500GT 512MB PCIE - Perfect, QE/CI OpenGL and CUDA all perfect.


Sleep/Wake working perfectly (darkwake-0) -- USB2.0 and graphics working across sleep.


BCM7555 working with BCM7522D kext. Does not work across sleep.


USB2.0 - all ports, even working across sleep.


Audio - ALC262 working via VoodooHDA 0.21


Rolled back AppleACPIPlatform, and it seems to have gotten rid of the beachball of death


Used M*ltiB*ast for all installs/rollbacks, and KextUtility for kext installs/kextcache creation.


Working Firewire400 card, just noticed firewire port on front of workstation, there may be Firewire built-in as well?!?


App Store/iCloud both working fine.


All software (except DVD Player, which complains of no Optical Drive) working sweetly, and quickly.


List of things not working:


Ethernet not working after sleep -- can be unloaded and reloaded manually.


DVD-RW -- I need another working SATA port, and a non-HP drive to get this working. I just remembered I have a working Firewire400 optical drive enclosure (IDE) so I will certainly give that a try.!!!


I would like more power states, but I am unsure if these processors go below 2GHz ??? I do not understand C2/C3/C4 states at all, so will not try that out for the time being.


Posting this from this very machine. LOVELY!


Need a new heatsink/fan for my exposed/jerry-rigged fan on the 8500GT.

  • Like 1
Link to comment
Share on other sites

In S/L/E/AppleAHCIPort.kext, find Intel ESB2 AHCI and change the number from 2681 to 2682. Reinstall kext with Kext Utility, and away you go! I have removed my ASM1061 SATA3 PCIe card, as no longer required (no drives faster than 3Gb/sec installed).


I have the two hard drives installed under SATA4 and SATA5 (Red ports), thinking that the others may not be full 3Gb slots (4 & 5 set to 3Gb in BIOS - Internal Only). Also, I discovered my Firewire400 works perfectly as well, but no hot-swap (is this a Firewire feature?) Once I unplug, I need to restart to see the device connected (or the Firewire at ALL).


Anyways, using entirely stock system now (except for graphics card update). I ordered a $35 NVIDIA GeForce 9800GTX 512MB online, so that should give the system a little BOOST :)


I am not using DSDT, update to latest BIOS available, and it appears that I have perfect sleep/wake (tried it with multiple disks attached, and they were all there and working on wake, with no complaints). All I really need now is a perfect shell script for sleep/wake that will unload and reload the BCM5722D.kext, then it will be a 100% working system, very close to stock.


More news as it comes to hand.

EDIT: DVD-RW working perfectly now from mobo SATA ports. Would like to write a new firmware so it doesn't read "hp" before the drive name. Anyone know of a good firmware patch to rename it to SuperDrive?

  • Like 1
Link to comment
Share on other sites

I created a DSDT.aml from Linux, thinking I may need to change some IRQ values (as recommended for the XW8600 etc., but I have disabled the floppy drive in BIOS, and this IRQ thing does not seem to bother me. Admittedly, I am using the SATA hardware ID, and not the AHCI hardware ID (2681). With the DSDT loaded and ForceHPET (there was NO HPET inside the DSDT), the computer would not wake up, so I have reverted to NO DSDT, and no ForceHPET (not even sure what HPET does??).


Sleep/Wake working now, Ethernet has reloaded correctly twice, will retest again tonight, and if it still works, I am calling it 100% working.


Also, I am a bit sick of Voodoo 0.21, as the volume control is changeable and "iffy". I'll give the USB sound card a trial maybe as well. 

  • Like 1
Link to comment
Share on other sites

I tested the same edit on my Mavericks MyHack install USB, and it works beautifully. I think I will create an install guide, as there is a lot of interest in these dual-Xeon workstations as Hackintoshes (they are plentiful, and incredibly cheap for their performance - 64bit GeekBench=9350).


Wake still working, but ethernet not always reloading, it works again after manually running the sleep/wake scripts.

  • Like 1
Link to comment
Share on other sites

I am working on a xw6600 too! I have the one with dual E5450s @ 3GHz and 16GB RAM, and It has a 6850 in it. I am running 10.9.2. Sleep works perfectly. I am also having to use voodoo for audio. I have not been able to get the ethernet working (using the kext you referenced I now have ethernet working).


I have noticed in Hardware monitor that only 2 cores on one processor change multipliers from 6x to 9x, the rest all stay at 6. Needless to say my geegbench suffers (only 7400)


I would love to know how you installed OSX.

Link to comment
Share on other sites

hmmm, the E5450's were used by Apple (I had the same real MacPro3,1). It also excepts the cheaper Wxxxx modules too (but the heatsink bolts need some micro washers on them, as the W's have a heat spreader, and the E's don't.


Are your E5450's dual core, or Quad-core? If they are Dual Core, your GeekBench sounds correct (for 4 cores) - double that for 8 cores :-0


14,000+ is a RIDICULOUS GeekBench 64bit score. latest Core-i7 machines (overclocked) are only getting 15,000 and a bit more.


I would first update to the latest FakeSMC + plugins + hwmonitor, the one that comes with MB is very out of date.


I would then rollback your ACPIPlatform with MB, and (re)patch your AppleIntelCPUPowerManagement.


Rolling back your ACPIPlatform seems to be a big step in getting older/stranger motherboards working nicely. You could try setting GenerateCStates/PStates in Boot.plist, and even CS-usingIO. You may get lots of errors at startup that you cannot generate P States etc., but it might give you the edge with power states being switched correctly. As I said, I only have two, but I am sure there are more available. I will test with Win7 on the same machine, and see if I can figure this out.



  • Like 1
Link to comment
Share on other sites

Its best to simply count the turns to unmount the heatsink and add 2 with a lidless processor. The washers aren't too reliable I have found. 


I think the E5450 is only a quad core. Anything that says 54xx is going to be 4 cores. I think the dual core variant is the 5240. 


I rolled back the acpiplatform and repatched aicpm.kext All cores are stepping between the 2 states, with a geek bench of almost 13,000. 


CPU-Z in windows 8 confirms the existence of only 2 states at present, but there may be a bios setting or something. 


This machine is impressive for $150 

Link to comment
Share on other sites

Yeah, I paid AUS$200, best $200 I ever spent :thumbsup_anim:


I am working on a new Hackintosh (starting today) - A Core2Duo 3.16GHz 6GB RAM - MSI P7N SLI Platinum mobo (nForce 750i) with GeForce 6600/8500GT/9800GTX. I think I will save the 9800GTX for the HP workstation tho  :)


New box has a CARD READER, something that I would have loved in the HP XW6600 !!!


I think you will discover that there are only TWO power states with this setup. There is a BIOS setting for setting C2 State, but I have no clue what this means?!


I wonder if you can mix ECC and non-ECC RAM in the HP? Would love 8GB  :D

Link to comment
Share on other sites

I have HP XW6000, with no SATA port...IDE is the default HDD...just wonder how can I feed the OSX into this machine,  since the OSX always UNABLE to Unmounting the HDD during installation...

Probably someone can help

Thanks in advanced

Link to comment
Share on other sites

  • 2 weeks later...

Follow my instructions and change that value for Intel ESB2 AHCI in AppleAHCIPort.kext (2682 instead of 2681). Install onto USB boot stick using Kext Utility, also check installed version after installing 10.9.x.


Remember to roll-back AppleACPI *AND* patched AppleIntelCPUPowerManagement (10.9), otherwise you will be stuck at one speed after updating to 10.9.3.


Even with the AICPM patch, I could not get multiple frequencies out of this machine without the rolled back ACPI. My CPU supposedly locked at full speed got a GeekBench score which was 1000+ less than before... :(


All good now tho.

Link to comment
Share on other sites

  • 1 month later...

I'v got Dell Precision t5400 which has similar chipset (intel 5400), cpu (E5420) on LGA 771 and Nvidia Quadro NVS 290. But I'm unable to turn on cpu speed step - always have only single speed (2493MHz). Can you point me to some doc how can I force Mavericks to use 2 states (2.0GHz and 2.5)?


My current version of Mac os is 10.9.1. I was trying to update to 10.9.2, 10.9.3, 10.9.4 and always had spinning wheel problem. After upgrade to any of those versions I'm unable to login. Starting of mac os stops just before login screen and a spinning ball appears. I'm only able to login via safe mode (-v -x). Did you encounter such a problem?

Link to comment
Share on other sites

  • 3 weeks later...

Sorry I am so late in my reply. I never had this problem, due to recovering from a Time Machine backup. I did do the last update to 10.9.4 tho. You need to remember to use the Combo updates, and always have a backup of your Extra folder, and S/L/Extensions folder. You can then boot from USB startup to fix any problematic kexts (or reinstall some needed ones).


Apart from only having two power states, this was a 100% compatible Hackintosh. I was sad to see it go. My next one is an Acer Aspire laptop, which is hopefully having the correct wifi card installed :)

Link to comment
Share on other sites

  • 1 month later...

Hi tiny323, I have sold my WX6600, but I know I was using Chameleon bootloader (latest).


I cannot give you my Extra folder as I no longer have it, but my info in the first post should give you a very good starting point. Also, do not forget the Intel ESB2 edit in second post, otherwise you will see NO SATA HARD DRIVES!!!


Hope this gets you going...

Link to comment
Share on other sites

Ok, hope this helps as this is my first post on this forum!  :)


First of all, sorry for my English as I´m not from an English-speaking country.


This weekend I decided to go hackintoshing an xw6600 I bought this week, and it has been a complete success!


Before starting, What do I need to install Mac OS X on my xw6600?

              1. An xw6600, obviously.

              2. A USB pendrive with 8 or more GB.

              3. ########## for Mavericks, BCM5722D.kext by @adlan  and KextWizard

              4. And very important, a COMPATIBLE graphics card, this is because it is, by my personal experience, the number 1 troublemaker. A good and cheap graphics card could be an Nvidia gt210 or an ATI HD 4850 reference PCB (this is the one I have and works flawlessly, with only some tweaks, with a dual screen configuration)


So, no more waiting, this are the steps I followed:


1. Download Mavericks (the actual version is the latest 10.9.5 and works like a charm) from the Apple Store in a previous existing hackintosh machine/Mac computer.


2. Plug your USB stick in the xw6600 (any port will do, but I connected it in one of the rear ports, as I´m a little superstitious about it) 


3. Download ##### and run it, selecting Mavericks as the OS that is going to be installed. Wait until the process finishes, and be patient, as it may look it has frozen.


4. Make all hidden files visible in your hackintosh/Mac.


5. Navigate to your USB (remember, once ##### has ended) System/Library/Extensions and there locate AppleAHCIPort.kext. Copy it to your desktop, right click on it and select "Show Package Contents". Once in there, double click on     Contents and select Info.plist. Copy it to your desktop and don´t close the package windows you opened in Finder.

                 OPTION B: If you can´t see anything once you have clicked on Show Package contents, open your terminal and navigate to the file (cd User/Desktop/AppleAHCIPort.kext/Contents, and then type sudo nano Info.plist to follow the next step of the guide in the Terminal. Once you finish editing, press Ctrl+O to save and Ctrl+X to exit the editor)


6. Here is where you have to make the change @themacmeister said. Open the Info.plist file from your desktop with TextEdit and Press Command+F. Search for ESB2. Once there, a few lines below you will see     <string>0x26818086</string>. Change it for <string>0x26828086</string>. Save file and close TextEdit.


7. Copy the new Info.plist to the AppleAHCIPort.kext of your desktop Contents folder.


8. Open KextWizard and go to the Install Tab. In there, select your USB as the installation destination and drag the AppleAHCIPort.kext to the KextWizard window. Make sure you have selected the S/L/E folder of the USB as destination. Wait for the process to finish. You´re ready to install ;)


9. Turn off your xw6600 and then ON again. Enter bios and make sure you have Raid+AHCI selected and the Boot Order is USB or external drives first (sorry, I don´t remember the routes to the options right now)


10. xw6600 should boot up to the Chimera screen. Once you see your USB in this screen, select it with your keyboard keys and, before pressing enter, type -x -v -f. 


11. Yay! You´re almost there! If everything gone well, you´ll see the Mac OS X installation screen. Select your language and, in the menu bar above select Applications or Utilities (I don´t remember the name) and Disk Utility. Now you can see your drives!!! Select the destination disk, go to Partitions tab, give it any name you want and make sure you select Mac Os (Journaled) and GUID table as options. once finished, close the Disk Utility and begin to install!!!


12. When the installation finishes, don´t extract the USB. Reboot your system andlet it boot to the Chimera on the USB again. You´ll see now your installation on your HD. Select it and here we go!. No bootflags needed here, if any, it would be GraphicsEnabler=No (respect the capital letters), but I think this version of Chimera has GraphicsEnabler set to No by default, so... 


13. Configure your Hackintosh for the first time ( :lol:  :lol:  :lol: ) and get to the Desktop. Once in there, move ##### from your previous Hackintosh/Mac to your "brand new" xw6600 Hackintosh. 


14. Run ##### and select Voodoo 2.7.3, Voodoo PS/2 (if needed, I had to select it since I have a PS/2 keyboard that works really fine), roll-back AppleACPI, patched AppleIntelCPUPowerManagement (10.9), last version of Chimera           and any personalization for the Bootloader that you want. Build it!.


15. Use KextWizard to install BCM5722D.kext by @adlan to your S/L/E folder in your HARD DRIVE.


16. Reboot your system without the USB inserted and there you go, Congrats!


Now depending on your GFX card, you´ll need to do some tweaks to get it working, but that is a completely different story that would get us another post. BTW, if you need info on a reference HD 4850, only ask as I have battled it during almost an entire weekend and it is, in the end, very simple to get it working!


Happy Hackintoshing!


EDIT: Seems that InsanelyMac doesn´t support TonyMac things, I didn´t know about that, if it is wrong to post this on this site, I will delete this. By the way, this is the method that worked for me and the easier one I tried. Thanks!

Link to comment
Share on other sites

  • 3 months later...
  • 5 months later...

I used another tutorial the get the installation running. 

When I open the DiskUtility in the installation proces I don't see my harddrive when the option is set to RAID-AHCI in the bios.

Now I changed that setting to Combined IDE and the harddrive is showing. 

Do need to adjust AppleAHCIPort.kext at post installation? I'm a little bit confused.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 months later...

Could someone please post the bios settings for XW8600 Workstation?  I've been trying for the past week and can't seem to get the usb to boot.

My specs are Intel® Xeon® CPU X5470 @ 3.33GHz × 8 (dual CPU)

Nvidia GeForce 560ti GPU

32GB DDR2 Ram

500GB WD Hard drive.

Link to comment
Share on other sites

  • 2 weeks later...

...Dual X5470... These are mighty processors. Your xw6600, though nearly vintage, will keep up with most contemporary Xeon E3, i5 and i7 based systems.

It's the equivalent of a mac pro 3.2 "build-to-order" 8-core (Dual x5472). 

In case you haven't yet installed one or more ssd's, I recommend the HP approved Intel ssd's for optimal and hassle-free performance (no slow boot due to controller mismatch etc.).

So much for the hardware...


Have you tried to boot while pressing esc followed by F9? This should enable the boot order menu.


Besides, you should also try to boot with 'factory default settings' , which you can select in the first tab of the bios.



- Use a quality brand usb flash drive (Sandisk, Kingston, Dane-Elec etc.). No name/white label usb flash drives often won't boot.

- Put the usb drive in one of the rear usb ports. 


You may as well give cvad's BootDiskUtility.exe a shot:



Hope this helps.

Link to comment
Share on other sites

  • 5 months later...

I'm having issues getting SAS HDD's working.  I can see my SATA drives (with AHCI) inside the DiskUtility but none of my SAS drives.  I have three 15,000 RPM SAS drives that I wanted to use for my Macintosh HDD instead of my 1TB SATA drive running at 7,200 RPM.  This is really starting to annoy me, I've seen others say they are able to get SAS to work, so I'm wondering what I am doing wrong.  


Has anyone been able to get the SAS ports to function properly in their Hackintosh XW8600?  I'm currently using Yosemite, but I have no issues downgrading to Mavericks if it's necessary to get SAS drives to function properly.

Link to comment
Share on other sites

  • 2 months later...

wow. i reckon thats the easiest hackintosh i have EVER got to have work thanks to the awesome info here guys - really appreciate it. i have mavericks humming on the machine, the NIC doesnt wake from sleep but theres a link on another unnamed site which might help

Link to comment
Share on other sites


  • Create New...