Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
ios9

[ NooBs Guide ] How to install OS X Mavericks from scratch in progress

32 posts in this topic

Recommended Posts

Hi guys,

 

Note: This guide is out dated now and will no longer provide support. So please follow the updated guides from other members on this forum.
 
:welcomeani:  to NooBs GuiDe :)
This guide is presented to you all by me and iFire. :) post-333439-0-80636100-1393954282.gif 
We will be putting some time and effort in contributing this new guide to all our community members and will be updated daily by us. 
 

Basic Requirements to Lion /Mountain Lion/ Mavericks

 

 A Core 2 Duo or Core i3/i5/i7 Processors 
✓ Minimum of 2GB RAM (But most recommended will be 4GB for performance boost)
 Minimum of 10GB hard disk space is required. 
 Check your hardware compatibility list View Reference Link

 Last but not least and very important is to have lot of Patience  :yes: 
 

Part - I How to get access to a real Mac/OSX desktop/laptop using Windows PC

 

This part of the guide is must and only for all who don't have access to real Mac desktop/laptop. For others who can access real Mac desktop/laptop either by borrowing from friends or by any other means can skip this Part-I and move on to Part - II. Follow the steps taken in the below video to create a virtual mac system using Windows PC.The Virtual Machine should be either Lion/Mountain Lion/Mavericks OS X versions in order to proceed with next steps. So finally once you have a working Virtual Mac Machine then proceed to Part -II to create a OSX USB Boot Disk/Installer.

[View Reference Link]

                                                                   

http://youtu.be/6KXv6d0HHlI

 

Part - II How to create OSX USB Boot disk/installer

 

Requirements

 A working install of OS X :  Virtual Machine or a native Install  to make your USBInstaller.
 A flash drive of minimum size 8GB formatted in GUID/GPT partition map scheme and HFS+ format type (see pic below).
 A copy of Lion / Mountain Lion / Mavericks.app.

✓DiskMaker X 
application [File Download Link]  to automate the process of creating USB Installer/boot disk.

   
Formatting USB flash drive   
1. In Windows, format your flash drive in FAT32
2. In your VM/Mavericks open Disk Utility and format the flash drive GUID/GPT and HFS+        
 

How to use DiskMaker X app

This video shows a good and easy tutorial on how to use the DiskMaker X app under Mac Virtual Machine in windows PC.

 

 

http://youtu.be/NT_XTW3wVjM

 

 

Part - III How to choose and install correct Boot Loader

                  

How to install Clover  boot loader on to USB Flash drive in Legacy BIOS mode

 

1. Download clover [File Download Link] and follow the video below.

                    

http://youtu.be/-_pXEfiLTvc

 

How to Install CLOVER to UEFI Mode : Install Clover to USB/HDD - Clover UEFI Guide

 

Part - IV Preparing system for OSX Install

 

Here first make sure the following checklist is double checked in the case of Laptop/Desktop before proceeding to installation part.

A Intel Laptop/Desktop with the OSX supported motherboard and processor.

Remove all the external connected devices of the Laptop/Desktop.

Only use On-Board Graphics and make sure you disable discrete graphics card either from BIOS or by removing it from Motherboard.

Make sure you only have working motherboard, CPU with on-board graphics and USB 2.0 ports (Do not use USB 3.0 port,because they need special drivers and can be fixed in post install). 

For laptops use external Keyboard and Mouse for installation,this is because the trackpad/touchpad will not work until they are fixed with correct drivers, which can be done in post-install.

Finally the above prepared OSX USB bootdisk/installer.

 

Part - V BIOS Settings/Configuration

 

Legacy BIOS - Laptops/Desktops

 

Essential Settings:

Config > Serial ATA (SATA) > SATA Controller Mode Option [AHCI] 

Security > Memory Protection > Execution Prevention [Enabled] 

 

Other Settings:

Security > Security Chip > Security Chip [Disabled] 

Startup > UEFI/Legacy Boot [both] 

Startup > UEFI/Legacy Boot Priority [Legacy First] 

 

 

Part - VI Fix OSX Boot using Boot Flags and Other Fixes

 

Below are the list of combination of boot-flags which may be required for those who are having trouble to boot USB boot-disk/Installer.Please be aware the list of combinations has been tested, so don't mix unless you know what you're doing. And most importantly try the combinations one after other,  BUT NEVER TRY MORE THAN ONE COMBINATION AT THE SAME TIME.

 

-v
-v -f GraphicsEnabler=Yes UseKernelCache=No dart=0
-v -f -x GraphicsEnabler=No UseKernelCache=No dart=0
-v -f -x GraphicsEnabler=No npci=0x2000 dart=0
-v -f -x GraphicsEnabler=No npci=0x3000 dart=0
-v -f -x GraphicsEnabler=No npci=0x2000 PciRootUID=0
-v -f -x GraphicsEnabler=No npci=0x3000 PciRootUID=1
-v -f cpus=1 UseKernelCache=No dart=0
-f -v cpus=1 USBBusFix=Yes npci=0x2000 dart=0
-f -x -v busratio=21 GraphicsEnabler=No cpus=1 npci=0x3000 PCIRootUID=0

 

 

How to use boot flags in clover bootloader [View Reference Link]

 

1. First press any key at clover GUI to stop auto loading the Operating System, the Clover GUI screen is shown below.

post-1089822-0-91690600-1394183848_thumb.gif

 

2. From the above screen shown in step 1, make sure the OSX operating system is highlighted and press space bar key on the keyboard.

post-1089822-0-66520100-1394183846_thumb.jpg

 

3. Once after pressing the space bar key the below shown screen will appear.

post-1089822-0-93872200-1394183847_thumb.gif

 

4. From the above screen shown in step 3 there is a option named Boot Args, which is a short form for Boot Arguments (a.k.a Boot Flags). At this point highlight the Boot Args option and press Enter once and type the required boot flags and then press Enter again to lock editing. Remember only press Enter twice before and after typing to lock and unlock.Once done from there move on to return option and come back to operating systems menu and choose the right one and proceed.See pic below.

post-1089822-0-77291300-1394183845_thumb.gif

 

Other Boot Troubleshooting Fixes 

 

If for some reasons the above boot flags didn't work and stuck somewhere with below messages then try these fixes. Please read reference link carefully before you proceed.


1. Still waiting for root device     Still Waiting for root device.zip  [View Reference Link]

2. Pci configuration begin            PCI Configuration begin v.1.3.6 ACPIPlatform.zip
3. Instant reboot Haswell cpu    mach_kernel.zip    [View Reference Link]
4. Usb problems                              GenericUSB30.zip  or Use this flag: USBBusFix=Yes 
5. System :no:
  boot ?       -              mv Graphics kext script.zip - Remove all Graphics kexts from S/L/E 

6. SATA IDE Enhanced/Compatible Mode - The Installer d0n't see the HD to Format and Install-  ICHx-based SATA chipsets/southbridges.  SATA_IDE.zip

7. How to Install the kexts to the USBInstaller/EFI/CloverEFI/Kext 10.9 - https://www.dropbox.com/s/ozyf92uaykd5to3/EFI%20Kexts%2010%209.png

 

Installation Process

 

 Finally once Installation is done successfully without any errors then do first boot from your Hard Disk. For some reasons the first boot may not go as smooth as it should and will need to try below steps as required.

 

1. Try booting with the same boot flags that have been used before for installing the OSX  or try one from the above given list.

2. If you have problems with graphics kexts, try remove with this script -[File Download Link]

3. Problems with the first boot ? Kernel Panic, crash system, stop,  Please, Screenshots of the error are always helpful  :yes:

post-333439-0-99383300-1393710349.jpeg

Edited by ios9

Share this post


Link to post
Share on other sites

PART VI - Post Installation

 

Post-Installation is all about making hardware devices to get recognized by OSX  by finding appropriate drivers and patches. This section will be tricky unless you have a hardware that is supported by native OSX kexts(a.k.a Drivers). So please be aware that you might need some more patience which you used so far  :yes: 

 

Installing the boot loader on to your OSX installed Hard Disk

 

http://youtu.be/-_pXEfiLTvc

 
Hardware Devices 
 
How to find any hardware device ID under Windows 7
 

 [media=640x480]http://youtu.be/6axUssYb5fk[/media]

 
 

Find device id of your Wifi card and Ethernet car

 post-333439-0-75979100-1393969300_thumb.png

 
post-1089822-0-00215800-1394043296.gif Airport - PCIe Half Mini
 
Airport - PCIe Half Mini - LAN and Wireless
The Perfect Mini PCIe WiFi and Bluetooth Combo card for Notebooks    
List of cards with Native Support  
List of current half and full size WLAN cards working native in OSX    

 
post-1089822-0-47626300-1394044893.gif Ethernet
 
Realtek RTL8111

 

New Driver for Realtek RTL8111 - LAN and Wireless

 

Supported IDs 

Realtek RTL8111/8168 B/C/D/E/F/G found on recent boards.

Intel Desktop Board NIC

Kexts for Intel ethernet cards.

 

Supported IDs:

0x105E, 0x105F, 0x1060, 0x10D9, 0x10DA, 0x10A4, 0x10D5, 0x10A5, 0x10BC, 0x107D,
0x107E, 0x107F, 0x10B9, 0x108B, 0x108C, 0x109A, 0x10D3, 0x10F6, 0x150C, 0x1096,
0x1098, 0x10BA, 0x10BB, 0x1501, 0x1049, 0x104A, 0x104B, 0x104C, 0x10C4, 0x10C5,
0x104D, 0x10BF, 0x10F5, 0x10CB, 0x10BD, 0x10E5, 0x294C, 0x10C0, 0x10C3, 0x10C2,
0x10CC, 0x10CD, 0x10CE, 0x10DE, 0x10DF, 0x10EA, 0x10EB, 0x10EF, 0x10F0, 0x1502,

0x1503, 0x153a, 0x153b, 0x1559, 0x155a, 0x15a0, 0x15a1, 0x15a2, 0x15a3.

 
Intel Server NIC

Supported cards: 

 

82575, 82576, 82580, dh89xxcc, i350 and i210, 82580 and maybe more.

 
 
Realtek NIC
Realtek NIC kext supports following IDs:


RTL8100E, RTL8101E, RTL8102E, RTL8103E, RTL8168B/8111B, RTL8168C/8111C, RTL8168CP/8111CP, RTL8168D/8111D, RTL8168DP/8111DP, RTL8168E/8111E, 

RTL8168E-VL/8111E-VL, RTL8168F/8111F, RTL8169, RTL8169S/8110S,RTL8169SB/8110SB, 

RTL8169SC/8110SC, RTL8401, RTL8411, 8112L, 8111C/8111D/8111E/8111F, 8105 Series.

 

post-1089822-0-09480200-1394043307.gif

Sound

 

Find that codec of audio have your hardware
 
Simply, with Ubuntu Live CD, Open app Terminal and type :  

cat /proc/asound/card0/codec#1 > ~/Desktop/codec_dump.txt

In Windows, go to "Device Manager" and look for "Sound, Video and game"
Under, choice "codec" (not the controller) and see for hardware vendor ID in the tab.something like this as shown in below pic.
idtdevmgr.jpg

Now you know your codec audio!

 
Installing Clover To Hdd Succeeded But Only Booting Win8 - Project OS X Forums

AppleHDA Patch Requests
 
AppleHDA Patch Requests. - Sound - InsanelyMac Forum
 

Voodoo Sound Kexts/Drivers

 

VoodooHDA - common problems

Voodoohda Driver - Project OS X Forums

VooDooHDA Volume Control/Mute Quickfix - OSx86 Snow Leopard (10.6) - InsanelyMac Forum
VoodooHDA 2.8.4 pkg installer - OSx86.net Hackintosh

VoodooHDA 2.8.5 for Mavericks http://www.insanelymac.com/forum/topic/297207-voodoohda-285-for-mavericks-slice-anv-signed/

 
Touchpad/Trackpad
Synaptics Touchpad [View Reference Link] [File Download Link]
Elan  Touchpad [View Reference Link]
 

 

post-333439-0-66783300-1394106279.jpeg  Graphics

 

Discrete Graphics Cards

How to check if your Graphic card are  fully working with CE/CI 
 
QE/CI is graphics acceleration. Easy way to check is look at your menu bar -- if the desktop background picture is 'showing through' (eg. the menu bar is partially transparent), then it is probably working. You can also enable magnification on the OS X dock, and see if you get smooth animation.
 
post-333439-0-98482600-1394106206.jpeg
 
 In this Example for the ATI HD 5000 Series: For that you card ATI HD works, the system need read this 04 kexts or never this will work.
 
1. Check if all kexts AMD are loading for your card with the command kexstat, open Terminal app and type
 

Note: Install the kext lspci.kext to the system return all the results
 

sudo kextstat | grep AMD

63 2 0xffffff7f80ba9000 0x1d8000 0x1d8000 com.apple.kext.AMDSupport (8.0.0) <62 10 9 7 5 4 3 1>
64 0 0xffffff7f80d81000 0x41000 0x41000 com.apple.kext.AMD5000Controller (8.0.0) <63 62 10 9 5 4 3 1>
75 0 0xffffff7f80e62000 0x3cd000 0x3cd000 com.apple.AMDRadeonAccelerator (1.0.0) <74 73 62 10 7 5 4 3 1>
77 0 0xffffff7f812ca000 0x13000 0x13000 com.apple.kext.AMDFramebuffer (8.0.0) <63 62 10 9 7 5 4 3 1>
 
2. Check that Framebuffer the system is loading for your card, or only read the default com.apple.kext.AMDFramebuffer 
 ioreg | grep ATY
    | |   |   | +-o ATY,Vervet@0  <class AtiFbStub, id 0x10000035e, registered, matched, active, busy 0 (90 ms), retain 8>
    | |   |   | | +-o ATY_Vervet  <class AMDFramebuffer, id 0x10000036b, registered, matched, active, busy 0 (16 ms), retain 18>
    | |   |   | +-o ATY,Vervet@1  <class AtiFbStub, id 0x10000035f, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_Vervet  <class AMDFramebuffer, id 0x100000379, registered, matched, active, busy 0 (0 ms), retain 14>
    | |   |   | +-o ATY,Vervet@2  <class AtiFbStub, id 0x100000360, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_Vervet  <class AMDFramebuffer, id 0x10000037f, registered, matched, active, busy 0 (0 ms), retain 14>
    | |   |   | +-o ATY,Vervet@3  <class AtiFbStub, id 0x100000361, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_Vervet  <class AMDFramebuffer, id 0x100000385, registered, matched, active, busy 0 (0 ms), retain 14>
 
3. Correct Value PCIRootUID
 
find the correct  value:  ioreg -l | grep -15 "AppleACPIPCI" | grep "_UID"
    | | |   "_UID" = "0"
 
4. Fake id with Clover boot loader, here a Example with the card : This is a technique to activate ATI HD cards with the boot loader Clover 
 
AMD r9 270 -7000 Series - Credits to Pokenguyen
 
If you're using Clover, you can use Clover Injection to force those 2 kexts loaded. Here are the supported ids for ATI HD7000 Series in the info.plist of the kexts
AMD7000Controller.kext: 0x26001002 0x22001002 0x67901002 0x67981002 0x679A1002 0x679E1002 0x67801002 0x68201002 0x68211002 0x68231002 0x68251002 0x68271002 0x682D1002 0x682F1002 0x68391002 0x683B1002 0x683D1002 0x683F1002 0x68001002 0x68011002 0x68061002 0x68081002 0x68101002 0x68181002
AMDRadeonX4000.kext - Pitcairn0x68001002 0x68011002 0x68061002 0x68081002 0x68101002 0x68181002

As you see, those ids are supported by both kexts, so we set these in Clover:

FakeID > ATI: 0x68001002

 
OS X will think our card id is 0x68001002 and load them, voila!
 
You also have to set FB Name for this card (I assume Futomaki).
Graphics > FB Name: Futomaki
Graphics > Inject ATI: check
Graphics > Dual Link: 0 for low resolution, 1 for high
Graphics > Load VBIOS: check (or not)
Graphics > Patch VBIOS: check (or not)

the final config.plist should be as shown below, and don't forget to use vanilla kexts too.

   

    <key>Devices</key>
    <dict>
        <key>FakeID</key>
        <dict>
            <key>ATI</key>
            <string>0x68001002</string>
        </dict>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>DualLink</key>
        <integer>1</integer>
        <key>FBName</key>
        <string>Futomaki</string>
        <key>Inject</key>
        <dict>
            <key>ATI</key>
            <true/>
            <key>Intel</key>
            <false/>
            <key>NVidia</key>
            <false/>
        </dict>
        <key>LoadVBios</key>
        <true/>
        <key>PatchVBios</key>
        <true/>
    </dict>

 

 

Onboard Graphics Chip

Integrate HD Graphics
 

post-333439-0-11219900-1394184542_thumb.jpgpost-1089822-0-01769600-1394188113_thumb.jpg
 
 
[GUIDE] 1st Generation Intel HD Graphics QE/CI - %5BGUIDE%5D 1st Generation Intel HD Graphics QE/CI - Intel - InsanelyMac Forum
 
Intel HD 2000/3000
 
post-1089822-0-67811800-1394188680_thumb.jpgpost-1089822-0-08899000-1394188679_thumb.jpg
 
Device IDs and Processors Info
 
post-1089822-0-96270800-1394189375.png
 
Note: HD2000/HD3000 are not the best adapted onboard graphics for OSX and there might be few or more graphical issues like glitches/artifacts after all having it configured to its best.Some work arounds has to be done to minimise these problems and may not be stable. Different troubleshooting methods work for different systems and might need to google and find one.
 
From the above IDs, 0116 and 0126 are the IDs of Intel HD 3000 device commonly used in Apple MacBook Pro8.1 and Mac Mini5.1. The native OSX drivers load only if any of these two IDs are present onboard, other than these two IDs then its must changing the device ID to one of these IDs using DSDT patch.
 
And also make sure of using the correct SMBIOS with respect to IDs. It  means the 0116 ID is for MacBooK Pro8.1 and 0126ID is for mac mini 5.1.
 
Follow the below steps to enable HD3000
 
1. Make sure vanilla AppleIntelGraphicsHD3000.kext and AppleIntelSNBGraphicsFB.kext are loaded.
 
2. Open DSDT.aml file using Macaisl or DSDTEditor application and look up for Device GFX0 or IGPU. Then find the address 0x00020000. Its should be something like this 

Device (GFX0)
        {
            Name (_ADR, 0x00020000)

Now paste the below code exactly after the above code as shown below shown below.

 

For Mac Mini5.1 (0126 Device ID)

 

 

 

Method (_DSM, 4, NotSerialized)
            {
                Store (Package (0x06)
                    {
                        "AAPL,snb-platform-id", 
                        Buffer (0x04)
                        {
                            0x00, 0x00, 0x01, 0x00
                        }, 

                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }, 

                        "device-id", 
                        Buffer (0x04)
                        {
                            0x26, 0x01, 0x00, 0x00
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }

 

 

 

For MacBookPro 8.1 (0116 Device ID)

 

 

 

Method (_DSM, 4, Serialized)
             {
                 Store (Package (0x0E)
                        { 
                            "AAPL00,backlight-control", 
                            Buffer (0x04)
                            {
                                 0x01, 0x00, 0x00, 0x00
                            }, 
                            "AAPL00,DualLink", 
                            Buffer (0x04)
                            {
                                 0x00, 0x00, 0x00, 0x00
                            }, 
                            "graphic-options", 
                            Buffer (0x04)
                            {
                                 0x04, 0x00, 0x00, 0x00
                            }, 
                            "device-id", 
                            Buffer (0x04)
                            {
                                 0x16, 0x01, 0x00, 0x00
                            }, 
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }, 
                            "AAPL,snb-platform-id", 
                            Buffer (0x04)
                            {
                                 0x00, 0x00, 0x01, 0x00
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                } 

 

 

 
Intel HD 4000/5000
 
post-1089822-0-95310700-1394188771_thumb.pngpost-333439-0-24185500-1394183780_thumb.jpg

 

HD4XXX series will be supported natively by OSX vanilla kexts. So only boot-loaders should be configured in order to enable them.

 

Here is a package of clover config files which contains preconfigured plist files for intel HD3000/4000/4400/4600.Use them wisely as required.

 

HD3000:4000:4400:4600 Clover config files.zip

 
 

Power Management, Speedstep and Sleep
 
Read from below links...
 
About power management (SpeedStep, sleep)
 
Power management for Sandy/Ivy Bridge/Haswell CPUs
 
 

Sleep
 
post-1089822-0-10091600-1394113899.gif
 
Proper combination for sleep is: 
1) patched HPET, TIMR, RTC, PIC sections in the DSDT.aml
2) patched EHCI/UHCI sections add the clock-id in the USB ports
3) patched AppleLPC kext with chipset id, add Method_DSM fix in the DSDT
4) removed NullCPUPowerManagement from EFI/Kext 10.9
5) patched AppleRTC kext to solve CMOS reset after sleep
 
Two Applications to monitor  Temperature/Voltage/ Speedstep - P_State
 
HWSensors : 
HWSensors | Free System Administration software downloads at SourceForge.net
FakeSMC kernel extension for OS X with hardware monitoring features  Brought to you by: blusseaukozlekslice2009
 

 

post-1089822-0-12816900-1393962685_thumb.pngpost-1089822-0-42466100-1393962688_thumb.png

 
DPCIManager : 
DPCIManager | Free System Administration software downloads at SourceForge.net
Simple OS X app for viewing PCI hardware info Brought to you by: phpdev32
 

post-1089822-0-98244300-1393962691_thumb.pngpost-1089822-0-62584300-1393962689_thumb.png

 
DSDT - How to
 

http://youtu.be/n5uN1NuThps

 
Kexts - How to install/edit/delete/permissions etc...
 

 

Install a Kext by hand

 

 

Tools Hackintosh

Clover Configurator.zip

EFI Mounter-v2-1.zip

System Info windows.zip

System Info Mac os x.zip

DarwinDumper.zip

MacKext.zip

Hackintosh Search.zip

Chameleon Wizard .zip

Kext Wizard.zip

ShowAllFiles.zip

Share this post


Link to post
Share on other sites

 hi, my sleep broken in 10.9.2, only can awake from sleep with the button power, my keyboard and mouse AppleBluetooth no have this function anymore :(

 

ah!!, I'm using Clover EFI now, because in Chameleon with 10.92 my sleep not work  :(

 

Help a noob here pleaseeee!!!!!  :P

 

Thanks!!!! :D

 

 

EDIT: Solved!!!! :)   I have removed all flags USBFix in config.plist Clover, then my wake from my keyboard is ok  :yes:  :D

Share this post


Link to post
Share on other sites

Where do i get the "kexts to Solve problems" folder as seen in the video for part III? 

I am trying to follow this tutorial to the tee.

 

Cheers,

Stew

Share this post


Link to post
Share on other sites

well, this depend what problem you have, if this is a problem with a kext or not, if you look in the first part of the guide have a lot of  kexts to for solve problems like still waiting for root device, pci config begin, IDE Controllers..etc..., 

 

3. Problems with the first boot ? Kernel Panic, crash system, the machine reboot,  Please, Screenshots of the error are always helpful  

Share this post


Link to post
Share on other sites

Excellent guide.  Thanks @ios9 & @IFIRE :D.

 

I've noticed that installers made with DiskMakerX or Apple's createinstallmedia tool lack a  /System/Library/Extensions folder (they actually rely on a hidden kernelcache file) -

 

post-846696-0-68517600-1398637866_thumb.png

 

If there are any problems during the install, it is much harder to modify/delete/add kexts since they are actually contained in the kernelcache rather than /S/L/E.  In these cases, it may be preferable to create the installer USB the traditional "hackintosh way" by expanding BaseSystem.dmg eg

 

like in the Vanilla OSX Install Guide or my Guide to creating a Vanilla Mavericks Installer using Windows which have an easily accessible S/L/E folder.

Share this post


Link to post
Share on other sites

hi   fusion71au, 

 

you is right, this method with DiskMaker  and the script from Apple have this problem if you need delete the graphics kexts, but you always can boot with -f -x -v to ignore caches and  bypass graphics problems, if  you need add any kext, you can add in the folder EFI/Kext/10.9 in the Clover boot loader. 

I have other method much more easy to make the USBInstaller with other app and a script that I have made, go post here and change this one.

 

thanks for your report, and very good guide for windows that you have made !!!

 

Thanks!!!!

Share this post


Link to post
Share on other sites

I installed (EFI mode) Clover on a stick but it just doesn't work. From the clover menu, I choose to boot from the installer stick (Mavericks) I made with DiskMakerX, but it does nothing. The menu just sits there after I press Enter, and it refreshes when I hit a key (any key). I tried with different clover settings, boot flags, onboard (intel 4000) / regular (nvidia gtx 650) graphics card... Nada. Windows 8 (EFI) boots fine from inside Clover.

Share this post


Link to post
Share on other sites

Check if you made the USB GUID and JHFS+, and make sure you're booting from Legacy Mode not UEFI mode (it wont work on UEFI mode, trust me, I tried it, and ppl who worked on that topic knows it) ;)

Share this post


Link to post
Share on other sites

Good to hear that :D

 

Yeah, I was so happy it worked, and then realized the boot process stops after a while whith some bluetooth error (I don't have a bluetooth on my desktop). This is my 3rd attempt to build a hackintosh (I've wasted 3 afternoons and a couple of nights so far) and it seems to me that it's nothing but problems upon problems. I appreciate your help though :-)

Share this post


Link to post
Share on other sites

Oh, I've tried both cards. Nothing changes. Judging from how right sized, nice and crisp the apple logo looks, the resolution seems to be my screen's native one (1680x1050). I also tried the various flags this guide suggests, and I've also disabled Intel's Vt-d technology (since some people suggest this is often the culprit). Here's the error by the way:

[IOBluetoothHCIController][SearchForTransportEventTimeoOutHandler]--Missing Bluetooth Controller Transport!

Share this post


Link to post
Share on other sites

hmmmmm, ok try to use intel's only and try this :

Add under Graphics this

<key>ig-platform-id</key>
<string>0x01620005</string>

OR

<key>ig-platform-id</key>
<string>0x01620006</string>

OR

<key>ig-platform-id</key>
<string>0x01620007</string>

Share this post


Link to post
Share on other sites

@midi: do you mean trying these values in the "FakeID" field in Graphics Injector (or whatever it's named) in the Clover options menu? If yes I tried these values but nothing changed.

 

@iFire: if I do that, the boot process ends much earler. It displays a  thing about "uptime in nanoseconds" for a second and reboots:

 

post-1351266-0-79318300-1401020331_thumb.jpg

 

 

 

PS1. The video of installing clover on a stick for legacy bios, says that you have to copy a bunch of kernel extensions to the stick's EFI partition (fakesmc, lspcidrv, nullcpublablabla). It doesn't say where to get these though, nor does this guide.

 

PS2. Not that it helped me with my problem but, I found out how to make Clover work with pure UEFI (source):

 

 

Note: If when you select the Installer to Boot to and the System instantly reboots back to the Clover Screen. Mount the EFI partition on your USB and go to  drivers64UEFI  and remove VBoxHfs-64.efi and replace it with HFSPlus.efi found here

Share this post


Link to post
Share on other sites

7. How to Install the kexts to the USBInstaller/EFI/CloverEFI/Kext 10.9 - https://www.dropbox.... Kexts 10 9.png

 

this are  in the guide, if you not read, not find  :yes:

 

EDIT: in the video how  to install Clover to USB Flash drive or HD, if you pay attention in the video have how to install the kexts to EFI Partition

 

or better download EFIMounter app from the guide, mount the EFI and put the kexts that you need

Share this post


Link to post
Share on other sites

@midi: do you mean trying these values in the "FakeID" field in Graphics Injector (or whatever it's named) in the Clover options menu? If yes I tried these values but nothing changed.

 

@iFire: if I do that, the boot process ends much earler. It displays a  thing about "uptime in nanoseconds" for a second and reboots:

 

attachicon.gifDSCN1449.JPG

 

 

 

PS1. The video of installing clover on a stick for legacy bios, says that you have to copy a bunch of kernel extensions to the stick's EFI partition (fakesmc, lspcidrv, nullcpublablabla). It doesn't say where to get these though, nor does this guide.

 

PS2. Not that it helped me with my problem but, I found out how to make Clover work with pure UEFI (source):

 

Well not that, you must edit the config.plist in Clover folder (in EFI folder :P ) and then go to

 <key>Graphics</key> #OR SOMETHING LIKE THAT

and copy ONE and ONLY ONE of the ig-platform-id I gave you, if one didn't work, try the other, and so one and so fourth, and for that you can use an OS X installed on any device and download Clover Configurator (download the release or the beta is the same ;) ) for a simpler way to edit that file, then go to Graphics section, and type one of these

0x01620005

OR

0x01620006

OR

0x01620007

IF you don't have it and have Windows OR linux instead, use a normal text editor (like Notepad++ on Windows OR gedit/nano on Linux :D )

And these values can't be changed on Clover (when booting) directly (you aren't faking anything), and btw, in this guide they show how to boot Clover when you're on Legacy BIOS/Mode and this to make sure that all the computers can run it (since Clover isn't meant for UEFI boards, and I do boot it from UEFI ;) ).

Tell us if this works ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×