Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
christina

VooDooHDA Volume Control/Mute Quickfix

22 posts in this topic

Recommended Posts

Okay , some of you might be using my modified VoodooHDA to be able to control volume. This works fine but it has it's own disadvantages.

Recently I found a new workaround for that.

 

  1. Install VoodooHDA (if it is already installed skip this step)
  2. If your volume control works turn it up to maximum , if it doesn't - leave it

  3. Install Soundflower (http://cycling74.com/products/soundflower/)
  4. Go into System Preferences > Sound > Output and change your output to Soundflower (2ch)
  5. Launch soundflower , click on the menu bar icon and change the 2ch device to "Headphones / Speaker"

It fixes Mute/Unmute and Volume control completely

 

PS: Don't forget to add Soundflowerbed.app to your login items

Share this post


Link to post
Share on other sites

Does not work for me. I followed your steps and when I choose Soundflower (2ch) as the output device in Sys Prefs I get the following message: The selected device has no output controls, and I lose sound completely...

Share this post


Link to post
Share on other sites
Does not work for me. I followed your steps and when I choose Soundflower (2ch) as the output device in Sys Prefs I get the following message: The selected device has no output controls, and I lose sound completely...

 

It should say that , but you should be able to hear sound if you configured everything correctly.

 

Did you forget to chose "Speaker / Headphones" in the Soundflower menu?

Is Soundflowerbed running?

Share this post


Link to post
Share on other sites
It should say that , but you should be able to hear sound if you configured everything correctly.

 

Did you forget to chose "Speaker / Headphones" in the Soundflower menu?

Is Soundflowerbed running?

 

I have no Speaker/Headphone option. These are the output options that I'm getting with the latest VoodooHDA kext:

 

Speaker (FIXED) - The one I select in Soundflower

SPDIF-Out

Digital-Out

 

And still I get no sound when I choose Soundflower 2h as my output device.

Share this post


Link to post
Share on other sites
I have no Speaker/Headphone option. These are the output options that I'm getting with the latest VoodooHDA kext:

 

Speaker (FIXED) - The one I select in Soundflower

SPDIF-Out

Digital-Out

 

And still I get no sound when I choose Soundflower 2h as my output device.

 

Are you sure you're using the latest version of VoodooHDA?

What is your default output device?

Share this post


Link to post
Share on other sites

My default output device (and the only one that actually outputs sound) is Speaker (FIXED). I am using the latest VoodooHDA from the ProjectOSX forum... Is there a newer one?

Share this post


Link to post
Share on other sites
Try using mine VoodooHDA

 

Which version are you using? The version you provided in your other volume fix thread is on 32 bit. I tried the 64 bit version provided in one of the comments in that thread but I lost sound completely when I used it...

Share this post


Link to post
Share on other sites

something wrong...

when play music a few minutes ,the soundflower will hang, must click speak(analog).

post-66264-1266656042_thumb.png

Share this post


Link to post
Share on other sites

Nice. It's not the greatest solution, but it's a solution none the less. Got it working on SL 10.6.3.

 

Now, is there a way to start the Soundflowerbed app as hidden? (so the icon does not appear in the taskbar?)

I've tried using automater to have it load and hide it, but I get errors.

 

Any help is appreciated! :P

Share this post


Link to post
Share on other sites

Not working for me either. I have the same issues as described above: only Speaker as output and when I select SoundFlower 2ch for the second option, I have no sound.

I'm on 10.5.7...

Perhaps with an update to 10.5.8 it might work ?

------

Update:

Sorry, it is working. I had to select also the option 'Speaker' in the drop down menu as in Max5's picture

Great job !!

Share this post


Link to post
Share on other sites

Okay , some of you might be using my modified VoodooHDA to be able to control volume. This works fine but it has it's own disadvantages.

 

Recently I found a new workaround for that.

 

  • Install VoodooHDA (if it is already installed skip this step)
  • If your volume control works turn it up to maximum , if it doesn't - leave it
  • Install Soundflower (http://cycling74.com/products/soundflower/)
  • Go into System Preferences > Sound > Output and change your output to Soundflower (2ch)
  • Launch soundflower , click on the menu bar icon and change the 2ch device to "Headphones / Speaker"
It fixes Mute/Unmute and Volume control completely

 

PS: Don't forget to add Soundflowerbed.app to your login items

 

 

 

Thanks you very much sir!!! It works like a charm on Mavericks DP1 10.9 using latest VoodooHDA 2.8.4 :D!

Share this post


Link to post
Share on other sites

not quick..its #best#fix for volume real control. hp 6700t alc268 0x284b8086 VoodooHDA 2.8.4 (big thanks for them) and 10.8.2 ML

 

thank you.

Share this post


Link to post
Share on other sites

Christina, I know it would sound a bit awkward, but I love you, girl!!! My HP DV4 2154ca had voodoohda 2.84 working out of the box but had no chance to enable the volume slider even editing the info.plist and enabling the volume option. Now, with that little flower, I installed the latest version and it just asked me to reboot the machine, after what I ran it once, set the channels audio and boom.. My volume control buttons as well as the slider are back in the game. I would add that flower thingy to my tutorial, so that the others know who pointed me to the idea and how to make the sound working just fine.

 

Thanks again and no offence but being in love is one thing, but love smb for a good thing he did - another. just to make it clear for every reader following this thread :)))))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×