Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Installing Mac OS X Lion on Hp Laptop

4 posts in this topic

Recommended Posts

I have a core2duo laptop. I was suggested to install Lion in laptop. I am currently using Ubuntu as my operating system. Here are my specifications.




I don't have any Mac so I was able to download .dmg file from torrent website. Here are the files in that .dmg file.




How can install Lion on my laptop? Can someone guide me?? I can use both Ubuntu and Windows for this guide..


Share this post

Link to post
Share on other sites



run this to see in details u hardware config




then u can see what image to search and download supporting u graphics (google)


good hack


It got this..




What to do now?? I was trying to find any thread which can guide me to install Lion from usb. Can't find any thread. Can you help?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MetalBreaker
      I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.
      SMBIOS: iMac13,1
      Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
      CPU: Intel Core i3-3210, iGPU disabled in UEFI

      All kexts updated to their latest versions, along with Clover.

      For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3
      Any help would be appreciated.
      Thank you for your time!
    • By ITzTravelInTime
      This is a dedicated thread about the intel 8255X based ethernet cards which, although being old (but also very cheap and easy to find used online), they still works in the latest macOS releases today i tested mine with the 64 bit compiled AppleIntel8255X kext and works like a charm! stable and withou any issues with mine 100 mbit managed ethernet switch and also without suffering of problems like connection dieing under heavy load or sleep/wake issues, so just to report that i have create this dedicated thread about and also i leave the kext as an attachment, in this post, this may be usefoul to have cheap working ethernet for hackintosh machines running the latest macOS or just to reuse old hardware some one can have laying around.
    • By End3rPwr50
      Hi, I wanted to install macOs 10.13 on my notebook.
      Here are the technical specifications:
      -Intel i7 6500U 2.50GHz Skylake (CPU)
      -12GB ram dd4 (RAM)
      -hp 81EC (MOTHERBOARD) with BIOS insyde F09
      -Intel HD Graphics 520 - AMD Radeon R7 M440 (Graphics cards)
      -Realtek PCIe FE Family Controller (Ethernet)
      -Broadcom BCM43142 802.11 bgn Wi-Fi M.2 Adapter (Wifi and Bluetooth)
      -Realtek High Definition Audio - Audio Intel® per schermi(HDMI)
      Thanks in advance

    • By bob.farm3366
      Hi all,
      I'm new on this forum but I have some experience installing hackintosh infact I have a hackintosh running El Capitan. I started installing high sierra on my laptop but i encountered some issues. The installer wan't start.
      I attach the EFI partition with logs so that someone could help me.
    • By giacomo.dessi2303
      Salve a tutti, ho un problema all'avvio di mac os che ho già provato a risolvere con foskvs ma senza risultati..
      Attualmente come smbios uso MacBookPro 12,1 (portatile in firma) mentre se uso imac 14,1 questo problema non si presenta.
      Dite che posso tenere iMac 14,1 magari rigenerando l'ssdt per il pm?