Jump to content

Atualizando sua AppleHDA


52 posts in this topic

Recommended Posts

funcionou perfeitamente conforme print, mirone! vlw!

 

fiz o mesmo, mudei o necessário menos patchear o binário. layout 28 e etc...

 

a kext para não perder som depois do sleep tb funciona, só a de dar aquela piscada na tela pro brilho ficar correto que não. preciso fazer o ctrl shift power pro brilho ficar certo.

post-564601-0-91786900-1406215021_thumb.png

testei já. foi a primeira coisa que fiz. mudar pro 3 e instalar.

 

não sei o pq mas no layout 28 fica perfeito. reconhece tudo, mic cristalino, mudança de fone pra caixa automática, mic e controle de volume de fone apple funcionando tb. completinho.

  • 1 month later...
  • 3 months later...

desculpa allan.

nao sabia que o mirone tava de ferias.

 

no meu caso, instalei do modo toleda.

deu certo o audio.

 

tu pode me explicar uma coisa.

na minha dsdt tive q modificar alguns parametros.

e rodei o script do toleda

so que a entrada da frente nao funcionou.

com esta kext deve funcionar?

  • 3 weeks later...

Estou pedindo esta ajuda para ter áudio no meu hack pois não sei o que está errado com ele.

Em “Informações do sistema”, é mostrado “ID do Audio:1”.

Na HDEF, o layout_id aparece como  “ 0x01, 0x00, 0x00, 0x00 “, que pelo que entendi do que pesquisei, corresponde a ID de audio mostrada pelas “Informações do Sistema”

Pelo que entendi, era para o áudio estar funcionando, pois o layout_id  que está na HDEF corresponde a ID de áudio mostrada pelas “Informações do sistema”.

Não tenho instalada a VoodooHDA e nem nenhuma HDAEnabler.

Meu boot.plist não tem nem a flag npci=0x2000 e nem a flag npci=0x3000.

O codec de áudio da placa-mãe é o Realtek ALC898.

Alguém pode me dizer o que está errado ou o que está faltando para o áudio do meu hack funcionar ?  Não sei o que fazer para corrigir o problema, pois pelo que pesquisei era para o áudio estar funcionando.

Agradeço pela ajuda.

A configuração do meu hack é: placa-mãe Gigabyte GA-Z77X-UP5-TH, processador I7-3770K, placa de vídeo MSI GTX 660TI, 8 GB RAM, 2 HDs 1 TB, bootloader Chameleon, Windows 7 em um HD e Mountain Lion 10.8.5 no outro

 

Abaixo está a HDEF:

Device (HDEF)
        {
            Name (_ADR, 0x001B0000)
            Method (_DSM, 4, NotSerialized)
            {
                Store (Package (0x04)
                    {
                        "layout-id", 
                        Buffer (0x04)
                        {
                             0x01, 0x00, 0x00, 0x00
                        }, 
                        "PinConfigurations", 
                        Buffer (Zero) {}
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
            OperationRegion (HDAR, PCI_Config, 0x4C, 0x10)
            Field (HDAR, WordAcc, NoLock, Preserve)
            {
                DCKA,   1, 
                Offset (0x01), 
                DCKM,   1, 
                    ,   6, 
                DCKS,   1, 
                Offset (0x08), 
                    ,   15, 
                PMES,   1
            }

Obrigado pela atenção

Edited by Allan
Texto em Code adicionado.

Instala estas duas kexts:attachicon.gifAppleHDA-2.4.7fc4-ALC898.zip

Mirone, minha dúvida é: instalando as duas kexts que você postou resolvo meu problema, ou  além de instalar as kexts devo também seguir as instruções do link ( http://www.insanelymac.com/forum/topic/290797-mountain-lion-realtek-alc-applehda-audio/ e http://www.insanelymac.com/forum/topic/290796-realtek-alc-applehda-audio-injection/ ) que o Allan forneceu no post anterior ao seu ?

Se for preciso apenas instalar as kexts, o que é melhor: renomear a AppleHDA original como .bak e deixar esta kext na pasta ou fazer uma cópia dela ?

Obrigado.

so instalar as duas ja resolve, e o melhor é fazer uma copia dela.

Mirone, obrigado pela resposta.

Antes de instalar as kexts que você disponibilizou, depois de alguma pesquisa fiz um passo-a-passo de como devo fazer para instalar as kexts e peço para você o favor de dar uma olhada para ver se não farei nada errado. Se for preciso alguma correção, alteração ou fazer mais alguma coisa que não pensei, por favor indique.

 

1 – Entrar em Sistema/Biblioteca/Extensions, localizar a AppleHDA.kext e fazer uma cópia dela em outro lugar (em uma pasta só para ela, por exemplo)

 

2 – Depois de feita a cópia, voltar para Sistema/Biblioteca /Extensions e deletar a AppleHDA.kext

 

3 – Depois de deletar a AppleHDA.kext, abrir o “Utilitário de disco”, selecionar o HD onde está instalado o Mountain Lion e clicar em “Reparar permissão de disco”

 

4 – Reiniciar

 

5 – Descompactar o arquivo com as kexts

 

6 – Depois de descompactar o arquivo, usar o “Kext Wizard” para instalar as kexts.

DÚVIDAS:

- as duas kexts devem ser instaladas na pasta onde estava a AppleHDA.kext original (Sistema/Biblioteca/Extensions ) ?

 

- qual das duas kexts deve ser instalada primeiro ?

 

- para cada uma das duas kexts instaladas, devo clicar em “Reparar permissão de disco” e reiniciar, ou seja, seguindo a sequencia de instalação, instalo a primeira kext, clico em “Reparar permissão de disco” e reinicio o micro, e depois instalo a segunda kext, clico em “Reparar permissão de disco” e reinicio o micro novamente ?

 

Obrigado pela atenção.

×
×
  • Create New...