Jump to content

Boot Issues Mavericks AMD


21 posts in this topic

Recommended Posts

Ive managed to get to the desktop, but only with Chameleon boot parameter  -F

Using com.boot.chameleon.plist gets instant reboot...

-F completely ignores com.boot.chameleon.plist ??  Correct?

I've got minimal stuff in there


-v -x npci=02X000 maxmem =3546

GE = Y/N


and I've removed all the Graphics Kext  (Nvidia)


Amd Althlon 64 X2 3500+

Nividia 9400Gt

4 M Ram  set to 3500 to remove bios issues



Link to comment
Share on other sites

More details please :)


1. How you did the Installer

2. What you've got in Extra folder?

3. Which kernel you use? If you use latest Andy or Bronya kernel, you need to block PowerManagement kext - use -blacklist flag.

4. Nvidia Graphics Kexts - don't delete them. First try to boot with -x flag. If you don't succes try delete NVDAResman.kext but also make a backup of this kext.

5. 4 M Ram set to 3500 to remove bios issues? What issues? I think there is no flag named maxmem=3546 :D Try normal maxmem=4096.


EDIT: -F (ignore boot configuration file)

Link to comment
Share on other sites

post-749905-0-46677600-1384292238_thumb.pngMore fiddling  and found I can inject the video card settings on Mav as with earlier versions 

so the Nvidia 9400 GT is showing with 1G of memory now.

Took the chameleon boot plist down to a minimum 


<key>Kernel Flags</key>
<string> -x npci=02X000</string>
<key>device-properties</key> <string>6c0200000100000001000000600200000d00000002010c00d041030a010000000101060000090101060000007fff04001e00000072006f006d002d007200650076006900730069006f006e0000002e0000006e5669646961204765466f7263652039343030204754204f70656e474c20456e67696e65205b4546495d22000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000004e00560043004100500000001800000004000000000001000600000000000000000000000e0000006e0061006d00650000000b000000646973706c617914000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f00640065006c0000001a0000006e5669646961204765466f72636520393430302047540e0000004e00560050004d000000200000000100000000000000000000000000000000000000000000000000000014000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a0065000000080000000000004020000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616322000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c61791c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656e74</string>
So screen looks nice but laggy and jittery....so not perfect yet...
This is an OLD box  GT5418E Gateway with AMD Athlon X2 64 3800+, Nvidia 9400 GT vid, 4 G ram and Nvidia chipset, bluetooth mouse and Apple Keyboard...
....What I did was download MYHACK , stick Bronya's latest Mav kernel in ... add a few Kext into extra to make it boot on this old box...
and then the install worked!
Jittery video
No audio (yet)  -  it's an ALC 888 but  Nvidia Chipset - on Snow I used Voodoo HDA, but so far nothing plays on Mav yet...
but PROGRESS people!!  
Link to comment
Share on other sites

Hi -- ok, going to try some enablers again... 

& try placing the NV...kext's back in.  


Thanks will report back if I have success.... while things are glitchy they are much better that 10.8.4....

so some hope for AMD users...


Back in 2009 I was surprised to get Lion running, then Snow....but 10.7 and 10.8 were never stable...10.9 not too bad so far...

hope Bronya and Sin & company can brew up a nice kernel!



Link to comment
Share on other sites

10.7 and 10.8 were never stable...

I've got the same :( But now there is opportunity to work out everything with the people like Andy, Bronya, Connactic, Shane and others :)


Also try to paste your DeviceID to the AppleGraphicsPowerManagement.kext to see if that helps.

Maybe PCIRootUID=1 and GraphicsEnabler=Yes? Try many combinations :)

Link to comment
Share on other sites

-x   No sound, as non essential kext.... shud know that by now... thanks


Now just gotta figure out how to get to the desktop without  safe mode!



also I deleted AppleIntelpowermanagement**. kexts

do u still need NVEnbler with Chameleon 2266??

Link to comment
Share on other sites

I think you never needed it: as far as I know, the 9400GT should work out of the box with GraphicsEnabler=Yes.


Did you do a clean installation, or did you install Mavericks on top of an older system?


All the best!

P.S.: no maxmem needed, no BIOS set needed other than AHCI mode if you have it, etc. What a mess. 

Link to comment
Share on other sites

Clean Install


9400GT not OOB on prior versions... 9400M yes, but never GT... lion, snow, etc


Tried nvenabler.... boot hangs at PCI config begins.....


Graphics Enabler = Yes doesn't seem to do anything on my Mav either...


Chameleon R 2266  so is up to date....


Only bios setting AHCI  , maxmem was from earlier problem with random reboots in Snow... Bios uses memory for caches and set maxmem to 3546 to prevent writing to memory area bios was using..(!)... really...


I'm kind of out of ideas tonight.... at least it's booting up  with - x ....



  • Like 1
Link to comment
Share on other sites

can somebody help me what to do now? i have done bootable flashdrive with myhack, i have boot to the installation with flags -v npci=0x3000 PCIRootUID=1 after succesfully instalation cp mach_kernel to my hdd where is new Mavericks and when im trying to boot with the same flags i have this: post-1173135-0-81632500-1384373407_thumb.jpgpost-1173135-0-81632500-1384373407_thumb.jpg and my machine restarts...


I have Asrock 970 Extream3 mb , amd Phenom IIx6 and Geforce 440 gt . please help...

Link to comment
Share on other sites

Shannee I've used npci 02X000  with lion and mLion...


Not sure why PCI error , all my PCI devices look ok  with boot -x , only difference I think is the video card. 9400GT Sparkle 1 M card...still unable to get it up and running except in safe mode so far.

Link to comment
Share on other sites

Another port?!  hmmmm.....no...


Tried booting with GraphicsEnabler= Y/N

without EFI string using NV*.kext's from DP8


but just get black screen.... or maybe other port?  Card has DVI and VGA port.... maybe?

will try tomorrow & check back...



Link to comment
Share on other sites

Wait: you mean you've been trying all this time with HDMI? I have a 9800GT and HDMI never gave a slightest sign it would someday work, so it's like I have a two-port card instead of a three-port one. Perhaps it's the same issue you're going through. Just change the ports, at first without any injection (no kexts, no EFI string, no whatever), using only GraphicsEnabler=Yes (or No) and maybe also PCIRootUID=0 (or 1). If it's not enough, try some injector kexts/EFI strings. If anything works, move to the last port and start over.

Link to comment
Share on other sites


Tried all things.... GraphicsEnabler Y/N

..boot flags


Mav boots up to a black screen....so if I inject the graphics into plist is works and boots to desktop but using -x

so think some other problem kext exist?


Still would like to get the Sparkle 9400 GT going else might scrap it!



Oh and also HDMI or VGA both work....with injected plist....otherwise black screen BOTH....

Link to comment
Share on other sites

GOT IT....

Here's how... grab NVDAN50HAL.kext and open and edit it with your video card ID (see attached)...used kext info from Snow but patched Mavericks kext...(see the attached for NVidia 9400GT and similar)

Removed -x , set GE=N

Rebooted and voila ! Desktop and acceleration...

This is Bronya's most recent BETA kernel.

It's still got a few little glitches ... pink icons at times, a bit of instability in Safari (so using Firefox...works FINE)

Now just to get sound going on this old Gateway BOX...






Link to comment
Share on other sites

  • 3 weeks later...

SOS!! I created a USB installer and used the latest kernel and essential kexts and AMD 10.9 boot CD and my installation would reboot after it seems like everything loaded in verbose mode like the other installations above.


It is it because my system is too old?



AMD Athlon 7850 AM2+ Black Edition

2GB Corsair DDR2

NVIDIA GeForce 210

Atheros DW1525 WLAN PCIe Card



Any suggestions would be appreciated. Thanks

Link to comment
Share on other sites


  • Create New...