Jump to content

AMD - Gigabyte 990FXAUD3 + FX6300/7950 build, installer hangs on boot.

17 posts in this topic

Recommended Posts

I am attempting to install 10.9 on my AMD computer. It's going much better than when I tried to install OS 10.8, but not a hell of a lot.

I downloaded the AMD kernel for the FX processors from here:


And I replaced the standard Mach Kernel with it. 


Here is the hardware



Gigabyte 990FXAUD3

XFX Double D 7950

8GB of RAM


I used MyHack to create the installer with the retail copy from the app store.


boot flags: arch=x86_64 PCIRootID=0 npci=0x2000 CPUs=1 GraphicsEnabler=No -v -f -x maxmem4096


It gets much farther than it did with 10.8, but it still hangs.

This is where it hangs:



So any ideas on where to go from here?

Share this post

Link to post
Share on other sites

How would one go about changing to clover from chameleon. Delete the chameleon files onnusb and just over right with clover?


How about inside a system that already boots same thing?

Share this post

Link to post
Share on other sites

I am also wondering how to change the bootloader. I tried installing it with the destination of my installer USB, but now it doesn't boot.

Share this post

Link to post
Share on other sites
boot flags: arch=x86_64 PCIRootID=0 npci=0x2000 CPUs=1 GraphicsEnabler=No -v -f -x maxmem4096

Maybe check the spelling typed flags because you have errors - PCIRootUID=0 maxmem=4096 cpus=1

I know that the capital letters are important too, so check this again.

Maybe try use USBBusFix=Yes with Chameleon.

Unfortunately I don't know Clover very much :)

Share this post

Link to post
Share on other sites

Here are the flags I used to get the installer to work. Waiting to see if I can actually run OS X without issues.


"arch=x86_64 -v -f -cpufamily PCIRootUID=1 USBBusFix=Yes npci=0x2000 maxmem=4096 GraphicsEnabler=No"


Hope this helps someone else!!!

Share this post

Link to post
Share on other sites



"arch=x86_64 -v -f -cpufamily PCIRootUID=1 USBBusFix=Yes npci=0x2000 maxmem=4096 GraphicsEnabler=No" + AtiConfig=Hamachi for Maveriks , dual screen etc…..bla………..bla…………bla  etc……. is good ;) 



Asus M5A97pro /Asus 7950 /CUII V2 




ootb on Maveriks (603) usb3 disable 

Edited by gils83

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By ThomasMattOnline
      Hello Everyone,

      Trying to get Hardware Acceleration working on my Hackintosh (HEVC Support) however I am such a noob, OpenCore is very new to me and would love some support.
      I have included screenshots and the EFI that is currently working on my System, I have USB 2 & 3.0 all working, however, the only thing I can fault is my GPU not being hardware acceleration enabled.

      Final Cut Pro X - Recognises GPU
      VideoProc - Doesn't recognise anything.
      (I am running the latest version of OpenCore 0.5.9)

      Things I've tried: I tried following the post https://www.tonymacx86.com/threads/catalina-10-15-2-update-lost-hevc-h265-acceleration.288563/ - No Luck
      I have also tried: https://forums.macrumors.com/threads/activate-amd-hardware-acceleration.2180095/page-53?post=28255048#post-28255048 - No luck either!

      My friend online tells me I shouldn't need such Kext as he has the same build as me but when I load his EFI on my system it boots with no USB 2 or 3.0 (I'm keeping his EFI off here as I've uploaded mine.)

      Please note: I appreciate all (any) pieces of advice and please do bear in mind that I am a noob and may need whatever you say simplifying as I can get easily confused.


    • By miliuco
      Radeon RX 580 8 GB graphics card on macOS High Sierra (as of 10.13.6), Mojave and Catalina on the P55-USB3 board: excellent performance with acceleration (Metal) OOB, no need for drivers (kexts), with 3 drawbacks, one has to do with the boot of the operating system (a solution is proposed), another with the number of rear connectors enabled (a solution is proposed) and another that only affects to one phase of the Mojave or Catalina installation (without clear solution for now).

      I have placed the XFX AMD Radeon RX-580 P8DFD6 8GB Triple X Edition GDDR5, 256BIT, DVI + HDMI + 3DP graphics card on a 10 year old motherboard (Gigabyte P55-USB3) in order to update the hackintosh to 10.14 Mojave and 10.15 Catalina because the card that I have used in past years, Nvidia Geforce GTX 750 1GB, has stopped working after 10.13.6 High Sierra since this was the last version for which Nvidia published the alternate web drivers that were necessary for the card to work well with graphic acceleration.

      The new RX 580 card needs considerably more space than the old one although it fits perfectly in an ATX case, and requires an additional power connector. It has 2 big fans that most of the time are stopped, at least in my case. In macOS it works perfectly, even with Metal acceleration, without additional drivers and without extra settings in Clover. But it has drawbacks that I comment below.

      Alterations during startup

      During the boot of the operating system, when the screen goes from the basic driver to the AMD driver, 2 artifacts appear randomly, they are very short in duration (from one to a few seconds):
      Very short flashing white screen that may or may not be accompanied by purple lines The fans runs for a few seconds (the noise is clearly audible). This behavior is solved with the installation of 2 kexts, Lilu and WhateverGreen. Lilu is an extension created by acidantheraand vit9696 among others whose function is to help to patch kexts, processes and libraries during macOS boot. It is accompanied by specific plugins for the task required, for example WhateverGreen that injects necessary patches for certain AMD, Intel and Nvidia graphics cards. It is mandatory to have both extensions together, one of them separately does not correct the problem.
      I have installed Lilu 1.4.4 and WhateverGreen 1.3.9 in the EFI/CLOVER/kexts/Other folder of the EFI partition and artifacts have disappeared. Remember that these 2 extensions are not necessary for the card to work properly, if you tolerate those very brief distortions of the screen or the noise of the fans running for a few seconds, you can live without Lilu and WhateverGreen.

      Note: authors recommend that when using Lilu and WhateverGreen with Radeon cards, NO graphic settings have to be added to Clover (Inject ATI, etc.).

      Note: these alterations, especially the brief white screen and less frequently purple lines and fan noise, are also seen in Windows and some real Macs with the same card.

      Alteration during macOS installation

      Boot from USB > Clover menu > Install macOS from Install macOS Catalina > screen works fine
      Boot from USB > Clover menu > Install macOS from MacintoshHD > black screen
      Booting from USB > Clover menu > Boot macOS from MacintoshHD > screen works fine.

      In the first and third stages, screen works fine. In the second stage the screen goes black although the installation continues. The user has nothing to do at this moment so you can leave the PC working until the Clover menu is shown again, the screen is recovered, the initial account options can be configured and you can enter into the newly installed system with correct resolution and acceleration.
      This behavior is not corrected even by placing Lilu and WhateverGreen into the USB device. At least in my case I have not found a solution for it. Yo can install macOS perfectly with that drawback of not seeing how it progresses during the second phase of the installation.

      Only 2 connectors of the 5 available work

      This card has 3 Display Port (DP) ports, 1 HDMI port and 1 DVI port. In my case, only 2 DP work, those that are further from the HDMI connector. It is enough if you use a single monitor or 2 monitors that can be connected by DP. But if you want to have 3 or more connected devices or some of them only have HDMI, it is necessary to enable the 5 connectors or at least 4 of them since the DVI is obsolete and does not allow resolutions as high as DP and HDMI.
      User foxbox has proposed a solution in a thread titled [Solved] Sapphire RX 580 Nitro + SE | black screen on HDMI and DVI. Must inject from Clover a modification to the Orinoco framebuffer (which is used in the RX 580 card) so that the 5 connectors lack a fixedly assigned address and, instead, receive it dynamically. This change is made from the KextsToPatch section of Clover. Read the post from foxbox.
      This has to be accompanied by 3 changes in the Graphics section of Clover: Orinoco in FB Name / Inject ATI / 5 in Video Ports. I have tested this solution in macOS Catalina and it effectively enables the 5 ports of the card but, since I only use 1 monitor, I have removed it and I am with Lilu and WhateverGreen.

    • By heiza
      Ryzen 7 2700X
      ASUS Prime X470 Pro
      32GB G.Skill Ripjaws V DDR4-3200
      ASRock Phantom Gaming Vega 56
      My motherboard doesn’t have an option for 4G encoding. And boot modes are listed as ”Windows UEFI Mode” and “Other OS”.
    • By Gunzar
      Hello there!
      TL:DR; I built a Hackintosh system using the OpenCore Vanilla Desktop Guide (running Catalina 10.15.4) and I use an AMD Ryzen 1600 CPU and Radeon RX 5700 XT GPU. All works well except my displays are very blurry and it feels like I’ll get a headache if I try to look at the screen for very long. The picture quality is noticeably worse than Windows or Linux. What can I do to fix it?
      Let me start off by saying that this is my first hackintosh build. I based my build on the Opencore Vanilla Desktop Guide at https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/. I’m running macOS Catalina 10.15.4.
      So I finished installing macOS after slowly and carefully taking about 8-10 hours to go through the guide yesterday and make sure I did everything properly. It paid off - it has been solid as a rock. However, there is one problem that is currently bugging me to no end - my displays are very blurry. This seems to be independent of any application or display resolution. My dock icons are blurry, the system text is blurry, app text is blurry (like in Slack, Safari, Notes, etc). This does not occur in Linux or Windows when using the same screens. 
      Also, as a test, I hooked up my girlfriend’s MacBook Pro to the same two screens, and the monitors are crystal clear again, just like they usually are in Windows. This leads me to think that my EFI may be configured improperly or my system may be missing some software or a kext that enables the displays to show a sharp image. I attached my EFI folder and my config.plist file for reference. 
      EFI setup:
      ACPI: SSDT-EC-USBX-AMD.aml Drivers: ApfsDriverLoader.efi OpenRuntime.efi VBoxHfs.efi Kexts: AppleALC.kext AppleMCEReporterDisabler.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext (version 1.3.8) My boot args are: "npci=0x2000 agdpmod=pikera keepsyms=1 debug=0x100 alcid=1"  
      System specs:
      Ryzen 5 1600, no overclock or anything special Corsair Vengeance Pro RGB RAM, 32GB total (2x16GB DDR4 dimms running at 2400MHz) XFX Radeon RX 5700 XT RAW II 8GB GPU (this is listed as a PCIe 4.0 GPU, could that cause issues since my motherboard is PCIe 3.0 only? Works great in Windows/Linux) ASUS Prime B350M-A motherboard Samsung PM961 256GB NVMe SSD  
      My monitors:
      Samsung U32J59x (32” @ 3840x2160) ASUS MX279 (27” @ 1920x1080) The blurry issue also occurs when I plug directly into my 58" Samsung 4K TV.  
      I’ve already tried these steps:
      Adjusting monitor “sharpness” settings, totally unbearable at “0” but still looks pretty bad even at “100” Trying a bunch of different resolutions in the “Display” preferences. On the 4k monitor, the only one that looks any better is the 1920x1080p option, but then I have far too little screen space left. Using SwitchResX, no different than using different resolutions in the regular Display preferences Using subpixel antialiasing in the terminal with no noticeable difference, even through reboots Turning on/off AMD FreeSync on my 4K monitor — if I turn on FreeSync, the display lags and stutters, and quality is not any better. Also tried turning on/off “game mode” but that had no difference. Tried switching DisplayPort version between 1.1 and 1.2 in monitor settings (on 4K monitor) Checking my BIOS settings, such as making sure CSM is off, against the OpenCore guide that I used to make sure everything was correct  
      Does anyone else have some other ideas that could help to correct this issue? Any ideas would be greatly appreciated. Thanks in advance!!
    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz