Jump to content

10.6.3 on an acer one 751h netbook (still waiting for boot device) (IDE HDD)


15 posts in this topic

Recommended Posts


I am installing Snow Leopard 10.6.3 onto my Acer One 751h netbook. I have been following this guide. What I have had to do differently though is use the NBI 0.84 RC1 to get into the installer as otherwise by simply using the bootloader that got installed on there already by the netbookinstaller app, it gave me a kernal panic as soon as I tried booting it. The next thing I had to do was get the JMicron36xATA.kext and inject it into the extensions.mkext on the Install DVD (on usb stick), by following this guide. This was so that it could see my IDE internal HDD.


It installed no problem, it even came up with that the installation was successful rather than what a lot have often had "installation failed" (although it has installed), but when I start it up (obviously going through the NBI on the USB, when I click enter normally it will come up with the apple logo and the loading wheel, and then a symbol will appear on the logo (image below)


So I boot into Verbose mode so I can see where it stops (image below in link)


So I searched "still waiting for boot device" and came across this tutorial but I try following it by entering what is quoted below,

cp -pr /Volumes/Mac OS X Install DVD/System/Library/Extensions/*ATA* /Volumes/Macintosh HD/System/Library/Extensions/.

but I have this (quoted below) appear which obviously is showing that it didn't do anything.

usage: cp [-R [-H |-L | -P]] [-apvX] source_file target_file

           cp [-R [-H |-L | -P]] [-apvX] source_file ... target_directory

I am enjoying myself doing this, and thats mainly what I use my netbook for, to mess around with it lol and I am pleased that I have managed to get really far without asking for help, but I do need a bit of help now lol :P


Thanks for the help and if you need to specs of my netbook, they are here.... The only thing that is different is that I have 2GB ram in instead of the 1gb that came with it previously.

Link to comment
Share on other sites

Do I need to reinstall the already installed installation then? As I watched a video on youtube about adding stuff via the single user mode rather than installing as he said that it is reasonably simple and it saves a lot of time rather than reinstalling.

Link to comment
Share on other sites

Do I need to reinstall the already installed installation then? As I watched a video on youtube about adding stuff via the single user mode rather than installing as he said that it is reasonably simple and it saves a lot of time rather than reinstalling.


youtube maybe help  you more.... :hysterical:

Link to comment
Share on other sites

I've put it onto the installer :)

Firstly I am gonna test adding the files via going into a live image of lubuntu and then if that works then waa-laa, if not, then i'll reinstall :)


thanks for linking to the kernel :)

Link to comment
Share on other sites

Ok I have managed to put the kernel in and it certainly works as I tried booting without the USB and it doesn't give a kernel panic, but then I still have the no symbol show up on the logo so I do the verbose mode again, and it still seems to be getting stuck in the same place:



I have tried to boot with #####, but when I use #####, normal boot with the logo, the loading wheel doesn't even appear and is just stuck.


BTW I do have an external dvd drive but silly me, I cannot find it lol. :L


If it is possible to inject the kexts from within Lubuntu then that would be helpful, unless someone can simply tell me how I can do what this tutorial is telling me to do (what I quoted)


thanks for the kernel though again, as that's out the way :)






I meant to say

Edited by jaseww
Link to comment
Share on other sites

Right I figured out why it was not doing it.


What I was doing by wrongly was writing "/Mac OS X Install DVD/" and "/Mactintosh HD/" not like this "/Mac\ OS\ X\ Install\ DVD/" and "/Macintosh\ HD/". Putting the "\" before the space makes tells the terminal there is a space there, so if you o not do that, then it will be wrong.


So all together I done

cp -pr /Volumes/Mac\ OS\ X\ Install\ DVD/System/Library/Extensions/ /Volumes/Macintosh\ HD/System/Library/Extensions/.

I removed the *ATA* because I wanted to copy the whole extensions folder.


So this tutorial is correct, just make sure you don't make the same error that I made with the spaces.


But I have realised now it is the wi-fi card that is the problem



So is there any way to disable it?

Link to comment
Share on other sites

I've put the latest version of chameleon on another one of my usb sticks and I do -v -f flags and it now gets stuck here instead...


I done pciroot=0 as well but it still gets stuck there


when I do pciroot=0, it gets stuck in the same place as before at the

start [/sourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-422.19/src/common/lmac/ath_dev/darwin/AtherosController .cpp:111591 load failed

Link to comment
Share on other sites

How do I get to the system /library/extensions folder then? As I've noticed that with lion +, you can access it, but then with snow leopard, going into Linux, which would show the whole HDD, there does not show a extensions folder in the system/library folder of the installation. I can see the folder on the install DVD, but I can't on the installation, but I do see a extensions.mkext. I tried unpacking that and putting kexts in how I done it with the install DVD extensions.mkext, but it couldn't pack it back up, came up with an error. Can't remember what, but do I need to remove them from the kexts for the graphics from the extensions.mkext?

Link to comment
Share on other sites

Well I'm gonna let it reinstall yet again, as I certainly am not finding anywhere mentioning about there being no extensions folder in the system/library, and hopefully then ill be able to do just that what you told me to do.


I got the kernel now so I doubt ill need to do anything as regards to that, but anyway, will see what happens lol

Link to comment
Share on other sites

Well I've reinstalled, and I realised now that what I done before in the terminal on the install DVD, that mucked it up, so I've got the extensions folder now like should do.


I've got the kernel on so that that works, (took a long time to get the permissions corrected in Linux so could put in the kernel), and I deleted the intelgma950.kext, and I got this come up when I tried booting again

Sorry, here's the picpost-1206170-0-16212600-1378569088_thumb.jpg

Link to comment
Share on other sites

Ok ignore the above image, as that was my error, as I accidentally added ".old" to legacy_kernel instead of mach_kernel, and I forgot to do...



<string> —> legacy_kernel <— </string>

<key>Kernel Flags</key>

<string> —> arch=i386 <— </string>



But now I get this again.


Ok I tried again, and this time it's back at the atheroscontrollwe.cpp11591 load failed


So I think it's certainly the wi-go that's causing this

and I did what the last post on this thread said to do...




but no difference

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...