Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

AtherosController.cpp:962 load failed after combo upgrade (no wi-fi hardware found)

8 posts in this topic

Recommended Posts

I just updated to 10.7.3 (Build 11D46) and get the following message upon boot:



Jan 23 05:31:14 localhost kernel[0]: start [/sourceCache/AirPortDriverAtheros9380/AirPortDriverAtheros9380-430.14.9/src/common/lmac/ath_dev/darwin/AtherosController.cpp:962] load failed


I can't access Wi-fi now (no hardware found).


Anyone got this message and fixed it? (I've seen it's not a specifc message to this version). I also got a kext error message after installation, I think it was related to not being able to load Apple16X50 IIRC (but I think this shouldn't be related to this error message).

Share this post

Link to post
Share on other sites

i think it has to do with PCMCIA driver for 0x24 . PCMCIA cardbus isnt pci.


best bet is to change card for a newer AR5B91 .. i had same error in 10.6.x with 0x24 ar5008x

Share this post

Link to post
Share on other sites

Thanks LatinMcG


I'll try getting another wireless card for my laptop. It seems strange, as the card was taken out of an Apple device and it was working perfectly with Lion out of the box.

Share this post

Link to post
Share on other sites

i had same issue with the real apple card. in my dell. ended up getting AR5B91 and never had a problem after.


but i read somewhere the airport driver for PCMCIA did this problem. (tries to take over for atheros older cards)


the Apple16X50 is the COM port in bios is enabled.. disable it . same with LPT

Share this post

Link to post
Share on other sites

I've had the same problem. I had to use IO80211Family.kext of 10.7.2. Strange thing is that when I get that message, it breaks bluetooth, firewire and obviously wifi. On console, it also says something about PCI Open Failed. The above-mentioned workaround fixes all of them. I'll try again when I re-download Lion from the App Store.

Share this post

Link to post
Share on other sites

ahh 9380 not 9280 ..newer atheros card. nevermind on pcmcia i confused issue with older card.

I have a 9280 and 9380 is what appears on Console when I get that error.

Share this post

Link to post
Share on other sites

I had a same problem..

To solve this problem, Open an info.plist file which is located in the AirportAtheros40.kext > Contents

and delete 2 line





p.s AirportAtheros40.kext is located in the IO80211Family.kext > Contents > Plugins.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Twml
      I have a HP Elitebook 8460P i5 2520M 2.49ghz 8GB ram laptop running High Sierra 10.13.1.
      I cant get it to update to 10.13.3 no matter what i try.
      App store or downloading the updates from apple website either single or combo updates. All fail.
      Downloading from the app store asks for a reboot to install, starts to install, says ETA then part way through just goes to a black screen no reboot no nothing just powered on doing nothing for hours. After rebooting manually i have a new option in clover MacOS install from hdd. booting it causes the system to endlessly reboot update wont install.
      however if i boot from the os not the update, system will start in 10.13.1 again.
      I recorded the verbose output during the install but it happens very fast, (less then 1 second a lot of text) so i recorded in 240fps slo-mo in some bad lighting unfortunately time of day it is, so hope its readable. 
      Any idea why i cant install the 10.13.3 updates?
      I have tried app store, manual 10.13.1 > 10.13.2, manual 10.13.1 > 10.13.3 combo
      File is to big to attach here (145mb) so here is a youtube link to my verbose boot
      i am getting with the update install. 
    • By kolejacik
      hello, if you buyed native OSX ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS Combo Card, here are the drivers for windows 7/8/10. enjoy!
    • By DonAmalio24K
      Buenas tardes, Tengo un problema grande y complicado, solicito la ayuda de una persona que pueda darme una mano. Resulta que tengo una VIT M2400 plateada y por estar leyendo que habia una actualizacion para la bios le di instalar y ahora se desactivo la opcion "ahci" y no puedo ni volver a instalarle Win7 ni 10. He tratado de conseguir activar la opcion por ms-dos con symcmos y consegui ver la lista de codigos pero entre casi 300 o mas codigos no se cual activar y no quiero probar activar uno por uno por miedo a empeorar la situacion, he buscado en internet alguna backup y no he dado hasta ahora con ninguno, he conseguido multiples programas pero con la actualizacion en formato "WHP" ninguno logra abrirlo. logre conseguir dos imagenes bios pero no tengo la seguridad si me podrian ayudar o dañar la laptop. 
      La pregunta es para saber si alguien que posea una laptop de igual modelo me podria ayudar haciendo una copia de su imagen bios y asi yo poder seguir con la creacion de una hackintosh. yo logre hacer el usb boot y se instalo pero por el error de la ahci no pude disfrutar del sistema por unos panic kernels los cuales no les consegui solucion en ningun lado. Agradezco de antemano la ayuda de la persona que pueda ayudarme.
      Me disculpo si este no es el lugar para hacer topicos por el lenguaje pero de verdad que ya no se que hacer tengo bastante tiempo tratando de solucionar el problema pero no lo consigo.
    • By Mkizle
      Hi all,
      My set up:
      Intel Core i7-6700 Skylake
      Asus H110M-A/M.2 Motherboard
      NVIDIA GeForce GTX 1060 6GB
      16GB DDR4 2133MHz
      250GB SK hynix SL301 SSD (Windows)
      Seagate 1TB BarraCuda (Extra Storage)
      Samsung 850 EVO 1TB (OSX)
      So i updated to High Sierra 10.13 (17A405) from Sierra, installed the latest NVIDIA Web Drivers 378. and everything seemed to be working apart from sound which i fixed also, i updated for the sole purpose that the new web drivers allow me to use FCPX with no Metal engine issues and now 3D text is visible and i can edit with no problems however, while downloading content i would say the computer had been running for about 1 hour or a little more and it did this, see picture below (attached)

      Because i was downloading several files and i assumed they where still running in the background i left it like that as i estimated another 30 mins would be enough for my content to download until i hard restarted the computer to see if that brought it back, i didnt touch it but it restarted it self and rebooted back into OSX and it looks back to normal now, has anyone had this problem? is there a fix? this would be a pain if i was in the middle of editing a project and i suppose i wont be editing on the hackintosh until i can assure that this wont happen.
      Thanks in advanced.

    • By Dubesor
      I know this is kind of broad, but if I build a workstation that's well supported on High Sierra now, how likely is it to still work well with the next major OSx release next fall?
      If you had to guess, what % chance do I have of encountering major issues when trying to update next fall? The kinds of issues that would seriously interfere with my day to day work of photo and video editing? For example, kext/kernel panics (is that even a thing still?) or major pieces of hardware suddenly not being supported, and so on...
      Has migrating your Hackintosh to the latest release has gotten easier in recent years? So for those of you who have been making builds for a while, is going from Sierra to High Sierra causing you fewer problems than Mavericks --> Yosemite for example or Yosemite --> El Capitan etc? 
      Sorry if this is a bit broad and ignorant, but I've been away from the forums for quite a while and just trying to get a sense of how "stable" and "future-proof" Hackintoshes are these days - compared to Apple's own desktops ...
      I'm OK not updating incrementally ie v13.1 to v13.2 if I need to, but I'm worried about having to start completely from scratch with each new main version.