Jump to content

Sony Vaio Duo 11: Fixing Brigntness, Sleep, USB3, Touchscreen?

Ingwie Phoenix

11 posts in this topic

Recommended Posts

Hello everyone!


I am sharing the DSDT that DSDT Editor was able to extract for me.

I have a near-complete installation, I am just missing small things like the brightness, USB 3, Sleep and to somehow disable the touchscreen since it is acting up the OS.


I know that, for brightness, I need to add a PNLF (or similar...) device. But I am not able to spot my screen - I only find GFX0, but I am unable to idendify my screen like LCD0.


The same comes in for sleep - when I select the Stand-By option from the shutdown-dialog it does indeed go down, but when I press the On/Off button again, it seems to crash as it tries to wake up, then completely reboots and prints me an error message in the dialog "The system wasnt shut down properly". But due to my Impairment, I am unable to actually read the error report :/


For USB 3, I installed "GenericXHCI" - or something like that - but it didn't work as well. Furthermore, if I make the OS boot with caches (In clover, "NoCaches"=>false) then I actualy loose my 2nd USB hub which correspondents to the actual ports on the device where I could plug in a device.


I also have to use NullCPU because the OS doesnt seem tor eally like my processor - but idendifies it completely correctly as an intel i5. O.o


I hope somebody is able to help me. :)


My setup:

Mashine: Vaio Duo 11 (SVD1121X--)

Processor: Intel i5 (1,7GHz, dual-core)


Graphics: Intel HD 4000

Screen (/ Touchscreen): some 1920-like resolution, its a retina-display, because when I reduce the actual screen resolution, the image litterally appears multiple times. It's 11" widescreen

Boot: UEFI. Using CloverEFI

Boot-args: slide=0


Regards, Ingwie!


PS: Since uploading doesnt work at all since I am "not permitted": http://ingwiephoenix.tk/DSDT.aml

Link to comment
Share on other sites



PNLF goes under the Scope_SB, not under the device.

For the USB 3.0, try the XHCI patch. 


I have attached the Ivy patches to use with DSDT editor, and a shell script that will patch your IntelCPUPowerManagement. 

Open terminal, type sudo -s, insert password, drop and drag the aicpm.sh in the window, press enter. 


I have no idea about the sleep issue. 





Link to comment
Share on other sites

Greeeeeat! Applied both and got them working.


In fact, the USB3 was my own fault - I got foobar'd by my BIOS. While installation, I set XHCI=false so my ports were forced into USB2, since I knew this would work better with Mac. Now, I found the XHCI patch - but forgot to turn USB3 back on xD. But it works now.


I also got rid of NullCPUM and have a native booting experience :)


But I am still not sure on the PNLF.

Can you tell me the approx. line number to add the piece of code to?

BTW, I am a PHP coder, so I understand a fair bit of file/code editing - in fact, im going ot studdy your little SH script when i am not busy :P


Regards, Ingwie

Link to comment
Share on other sites

Ah, right - reminds me on PHP's namespaces x)


So, in a tutorial I read, they said I need to figure out which "idendifyer" my display has. In yours i see APP0002. When I roam around my DSDT, I can't find anything like LCD or alike. I do find my GFX0 though.


Where approx. is the screen's idendifyer usualy?


Regards, and thanks for the help so far! :3

Link to comment
Share on other sites

  • 1 year later...

Hey, Sorry to inform you that your touchscreen may never work (or maybe it can later) cuz its digitizer is from "N-Trig" and they didn't release any OS X driver (YET?) like Wacom :( hope they do, I really want to buy a tablet like that. btw, do you recommend it to me?

Link to comment
Share on other sites

  • 9 months later...
  • 3 weeks later...

I found this as I was watching this for DSDT assistance, but I have since screwed everything up...


I don't know where I blew it.. I had a super smooth install of El Capitan on my Duo 11, but was applying DSDT fixes from the Vaio S instructions in order to get a battery indicator, and boom, no more startup.


I have reinstalled at much difficulty, and many hangs.  I see that changes to my Clover configuration definately changes the place at which it hangs... but I cannot get a full bootup.


In safe mode, my boot hangs at [iOBluetoothfamily]

Link to comment
Share on other sites

  • 1 month later...

  • Create New...