Jump to content
InsanelyMac Forum
kelobb

New iMac 2013 nvidia drivers

Recommended Posts

Hello

 

I just ask you if somebody has an access to newest iMacs with nvidia 6XXm graphics.

 

Could you drop somewhere graphics kexts?

Any info on version of these?

 

Regards and many thanks

Share this post


Link to post
Share on other sites
Advertisement

I dont think the nvidia drivers are the asked. They are from last 10.8.2 update / Oct 2012 =

304.00.05f02

 

The newest drivers are in the 10.8.3 dev build updates. (

304.10.65f01)

Share this post


Link to post
Share on other sites

I dont think the nvidia drivers are the asked. They are from last 10.8.2 update / Oct 2012 =

304.00.05f02

 

 

The newest drivers are in the 10.8.3 dev build updates. (

304.10.65f01)

 

Yes build 12D61...

Share this post


Link to post
Share on other sites

But I'm not apple developer and cannot access these builds...

So I;m asking for it.

 

No prob.

But what exact do you expect from those newer drivers?

I think within next 2 weeks you will get them within the offic. 10.8.3 update.

Share this post


Link to post
Share on other sites

Or maybe not, they are not the same, size is bigger from imac and Date Modified is later. I have another one GeForceGLDriver.bundle but its too big and can't upload to this forum.

Share this post


Link to post
Share on other sites

Or maybe not, they are not the same, size is bigger from imac and Date Modified is later. I have another one GeForceGLDriver.bundle but its too big and can't upload to this forum.

Can you upload it on www.osx86.net and put the link ?

Also i guess we will need your frameworks to make it work :

/System/library/Frameworks/OpenGL.framework

/System/library/Frameworks/OpenCL.framework

/System/library/PrivateFrameworks/GPUSupport.framework

 

Please correct me anyone if im wrong.

Thanks dude

Share this post


Link to post
Share on other sites

Or maybe not, they are not the same, size is bigger from imac and Date Modified is later. I have another one GeForceGLDriver.bundle but its too big and can't upload to this forum.

 

Could you upload it to MediaFire along with the Frameworks that slayer2333 mentioned.

 

Thanks

Share this post


Link to post
Share on other sites

Ok, I'm looking for any strings supporting Geforce 660M (10de:0fd4) - In AppleGraphicsPowerManagement no signs of it...

I'm stuck at kext loaded (both GK and NVDAstartup) and no graphics UI...

Hmm maybe Imac with this card has customized kexts?

Share this post


Link to post
Share on other sites

Hmm, interesting, Slayer2333 so where do You think is hack, osx i loading just like for example card with incorrect PCIRoot(uid) - just no starting to graphic mode, card is recognized, maybe playing with DSDT will help us.

We simply need ioreg dumps from real iMac with GTX660M and compare it.

Thx for sharing files.

Maybe smbios is key - just like intel hd3000...

Anyway we must wait for also official nvidia...

Regards

Share this post


Link to post
Share on other sites

What i see in bootlog : Controller: NVidia (Unknown) (vendor ID: 10de, device ID: 0e1b)

At the beginning i was thinking that my graphic card was not recognized but then when i looked closely to that line : device ID: 0e1b is my HDMI out for the 660m GTX and not the graphic card itself (device ID: 0fd4). I would be stupid but does it mean that ML is recognizing the HDMI audio out device as my graphic card and thats why it is not working ?

This dude here : http://www.insanelymac.com/forum/topic/286220-no-usb-no-bluetooth-no-wifi-any-help/ got his 660m GTX working natively with ML, and it has exactly the same device ID as ours, so i conclude that the drivers are there but not rooted the right way in our machines...

Any ideas on how to make it look at the graphic card as display device instead of the HDMI audio device ?

Share this post


Link to post
Share on other sites

From my experience recogintion of hdmi audio is not connected to recognition of graphic card, correct me if I'm wrong.

So we have a proof that with 12c54 build (normal 10.8.2?) the gtx660m is correctly recognized (even with 2GB RAM), and newer iMacs and 10.8.3 could help nothing in this manner.

The key maybe is in DSDT as always, maybe famous user "bcc9" could help us debugging the problem - see amd or dell xps guide from him.

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×