Jump to content
InsanelyMac Forum
Sinetek

Snow Leopard kernel testing on AMD

Recommended Posts

Advertisement

Every Single cpus tried. Still same

 

Ok, how did you install your SL?

 

(EG, I used A Retail Disc with Nawcom ModCD version 0.3.2, or I used iAtkos S3 with ACHI selected, and so on)

Try the ModCD 0.3.2 and see if you can get to the desktop, then we will work backwards from there.

Share this post


Link to post
Share on other sites

 

Ok, how did you install your SL?

 

(EG, I used A Retail Disc with Nawcom ModCD version 0.3.2, or I used iAtkos S3 with ACHI selected, and so on)

Try the ModCD 0.3.2 and see if you can get to the desktop, then we will work backwards from there.

 

I can open it with nawcom modcd but resolution is very low and it works with only 32 bit

Share this post


Link to post
Share on other sites

32bit kernel with 64bit Userland (-force64) is about the most stability you are gonna get from Snow Leopard. As for your resolution that is just a GraphicsEnabler=Yes fix I think. If not then a EFI String will do too. I would recommend Lion 10.7.5 with the latest bronzovka kernel it's pretty rock solid.

Share this post


Link to post
Share on other sites

@Duran,

 

Could you please write to bootflags? Because the command arch=i386 doesn't accept from this kernel.(as I know it accept only x86_64)

 

GraphicsEnabler= yes or no doesn' affect to anything. I tried hunderd times before.

 

I have Lion 10.7, but I couldn't find any bootcd for it. Newcom does only kernel panic before the installation.

Share this post


Link to post
Share on other sites

@Duran,

 

Could you please write to bootflags? Because the command arch=i386 doesn't accept from this kernel.(as I know it accept only x86_64)

 

GraphicsEnabler= yes or no doesn' affect to anything. I tried hunderd times before.

 

I have Lion 10.7, but I couldn't find any bootcd for it. Newcom does only kernel panic before the installation.

 

@YaPaY

 

Lion, the easiest way is to get iATKOS_L2. Restore it to a USB drive and copy the kernels on to it when installing Lion i find Bronzovka 10.7.4 kernel boots well into the installer and for first time boot you can find it here, but that is my computer set up and every system is different. Once installed, boot back into SL and then replace the lion kernel.

 

On Sinetek's Kernel you are right you can only boot to x86_64. But the legacy kernel is pretty stable booting into i386 and can run 64bit application.

 

Have you patched your files? As per the tutorial found here.

 

Created an EFI String for your card.

Add this to org.chameleon.boot

 

I created it as DVI First then VGA, that should fix your Graphics Problem when booting to OSX (Chameleon/Chimera as the bootloader)

 

device-properties

6a02000001000000010000005e0200000d00000002010c00d041030a000000000101060000020101060000007fff04001e00000072006f006d002d007200650076006900730069006f006e0000002d0000006e5669646961204765466f72636520393830304754204f70656e474c20456e67696e65205b4546495d22000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000004e00560043004100500000001800000004000000000003000400000000000007000000000e0000006e0061006d00650000000b000000646973706c617914000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f00640065006c000000190000006e5669646961204765466f726365203938303047540e0000004e00560050004d000000200000000100000000000000000000000000000000000000000000000000000014000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a0065000000080000000000002020000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616322000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c61791c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656e74

 

When you at your desktop message me and I will help you step by step.

Edited by Duran Keeley

Share this post


Link to post
Share on other sites

@duran,

 

Thanks your help. I patched necessary files according to your instructions and now pc doesn't restart own but this time I have got another problem: black screen.

 

I tried with graphics enabler yes or no. It's same.

Share this post


Link to post
Share on other sites

Can you boot into safe mode, I normally get the black screen when I boot using GraphicsEnabler=Yes and it detects that my graphics card model number and stuff but does not detect that a monitor is plugged in. When testing that I normally have VLC running to get in and restart and stuff. Try modcd again and add the efi string in.

Share this post


Link to post
Share on other sites
Can you boot into safe mode, I normally get the black screen when I boot using GraphicsEnabler=Yes and it detects that my graphics card model number and stuff but does not detect that a monitor is plugged in. When testing that I normally have VLC running to get in and restart and stuff. Try modcd again and add the efi string in.

 

I forgot the write, I opened with modcd added efistring to boot.plist still same.

 

Also -f black screen, too

 

Edit: I deleted the kext which starting with NV* and the first I could open desktop without modcd. Hurraaaa

 

And last problem: there is only one resolution 1024 x 768 and I can't change it. I opened with graphics enabler yes command

 

 

@ Duran you are great

 

Thanks a lot

 

I deleted Efi string and it opend with native resolution with my monitor. Transparent menus looks like wonderful. And I can see it work 64 bit and using all ram and CPU s

 

Sound card doesn't work but this is huge improvement for me.

 

Thanks again

Share this post


Link to post
Share on other sites

UPDATE: actually -seems- stable !!!

 

cpu: amd athlon x2 7850be

build: xnu-1504.15.3-sinetek

shasum: 3aa5e5b2d0fcc359776d56a5c9353ad6ae3b8431

bootflags: arch=x86_64 maxmem=4096 npci=0x2000 -nossse3bit

Edited by bcobco

Share this post


Link to post
Share on other sites

I used almost 1-2 hours and I should fix those problems:

 

1.) Hardware acceleration and second display doesn't work. Additionally I can't change the resolution. There is only native res 1280*900.

2.) I think because of HW acceleration the screen effects a bit choppy

3.) Flash videos doesn't work (of course I ınstalled from adobe.com latest versions

4.) Sound card doesn't work

5.) I can't see my other disk which on Windows 8 installed

6.) I need really power management because cpu fan works really higher than windows 8

7.) Font rendering is a bit strange.

Share this post


Link to post
Share on other sites

I used almost 1-2 hours and I should fix those problems:

 

1.) Hardware acceleration and second display doesn't work. Additionally I can't change the resolution. There is only native res 1280*900.

2.) I think because of HW acceleration the screen effects a bit choppy

3.) Flash videos doesn't work (of course I ınstalled from adobe.com latest versions

4.) Sound card doesn't work

5.) I can't see my other disk which on Windows 8 installed

6.) I need really power management because cpu fan works really higher than windows 8

7.) Font rendering is a bit strange.

 

1 & 2) Try install the latest chameleon bootloader, then try GraphicsEnabler=Yes. There are also nVidia Drivers on nVidia's site that you could try.

3) Are you using Safari for flash video or Chrome? Describe the problem, like blank black screen on video on YouTube

4) You can either fix this the easiest way you need VoodooHDA.kext but note, this Kext is known to give Kernel Panics at startups, like it will Kernel Panic and you restart and then it boots to the desktop, OR you can create a DSDT and then inject your sound that way.

5) Do they show up in the App Disk Utility? Then try mount it from there.

Share this post


Link to post
Share on other sites

6) Power management is not yet available for AMD CPUs. Remember, AMD support is a work in progress. The kext responsible for PM in OSX isn't called AppleIntelCPUPowerManagement.kext for no reason. :D

Share this post


Link to post
Share on other sites

6) Power management is not yet available for AMD CPUs. Remember, AMD support is a work in progress. The kext responsible for PM in OSX isn't called AppleIntelCPUPowerManagement.kext for no reason. :D

i also suggest to disable every kernel exstension related to control power: AppleIntelCPUPowerManagement and AppleGraphicsPowerManagement (if i remember)

also for nvidia fermi, i notice that a sleep display is needed in order to raise gpu throttle to usable level.

Share this post


Link to post
Share on other sites
1 & 2) Try install the latest chameleon bootloader, then try GraphicsEnabler=Yes. There are also nVidia Drivers on nVidia's site that you could try. 3) Are you using Safari for flash video or Chrome? Describe the problem, like blank black screen on video on YouTube 4) You can either fix this the easiest way you need VoodooHDA.kext but note, this Kext is known to give Kernel Panics at startups, like it will Kernel Panic and you restart and then it boots to the desktop, OR you can create a DSDT and then inject your sound that way. 5) Do they show up in the App Disk Utility? Then try mount it from there.

 

1 & 2) Already did it.Still same. There is no native driver for 9800 gt on NVidia web site?

3) Safari and Chrome, videos only blank screen

5) I will check it, thanks

Share this post


Link to post
Share on other sites

 

 

1 & 2) Already did it.Still same. There is no native driver for 9800 gt on NVidia web site?

3) Safari and Chrome, videos only blank screen

5) I will check it, thanks

 

3) Safari sounds like the same as Firefox, right click on it and click get info. Then tick open in 32-bit mode. As for chrome, try my launcher you can find it at this post: http://www.insanelymac.com/forum/topic/286674-working-applications-amd/

 

No there are beta CUDA drivers on nVidia's website.

Share this post


Link to post
Share on other sites

 

1 & 2) Already did it.Still same. There is no native driver for 9800 gt on NVidia web site?

3) Safari and Chrome, videos only blank screen

5) I will check it, thanks

 

The official nVidia drivers didn't mention my card either so I added the dev and device IDs to the kexts and it worked.

Share this post


Link to post
Share on other sites

Im going to buy tonymacx86 customac config.

 

Thanks everybody for helps

Share this post


Link to post
Share on other sites

Im going to buy tonymacx86 customac config.

 

Thanks everybody for helps

 

Hey bud, you sure? your setup is pretty cool it just takes sometime and customizing. Give Lion a try, it is rock solid with AMD right now.

Share this post


Link to post
Share on other sites

Hey bud, you sure? your setup is pretty cool it just takes sometime and customizing. Give Lion a try, it is rock solid with AMD right now.

 

Actually, I'm wasting too much time about installation and bugfixes. I should study :)

 

Therefore, I'm not sure. Additionally somethings like Power Management issues on AMD CPU's drops me to sad. Fully working fans makes me unhappy, too.

Share this post


Link to post
Share on other sites

Hi, YaPay!

 

It's understandable you go Intel: my first hack was an AMD, and it's currently my HTPC (running 10.7.5), but recently i took my i5 3570K gaming machine and made it a hackintosh, and now it's my main working machine. Intel is far easier to setup and maintain - hey, it's the hardware used by Apple! - and if you need a hack as a Mac replacement for get serious work done, not only for the fun of hacking, Intel will be always the recommended choice.

 

That said, don't go Voldemort: you'll waste your time twice with his spells: believe me. Even more than you already lost, and you'll spend money on it, so it's a double loss. Tell me your budget, and i'll post some options of Intel hardware for you to buy, and point you to the best intel helpers in the scene.

 

Best regards.

Edited by theconnactic

Share this post


Link to post
Share on other sites

Hi theconnactic,

 

I don't know what is Voldemort, I will buy the all HW's from switzerland:

 

Here is the list (according to tonymac86):

 

5IWEGGp.png

 

 

If you have any suggestion please inform me.

 

I will use my 300gb HDD for Hackintosh,

Edited by YaPaY

Share this post


Link to post
Share on other sites

Voldemort is the one who cannot be named in Hoggwarts, you-know-who: just think for a while about it and you'll figure it out ;)

 

His spells are named the Uni (but not that lovely unicorn from the D&D cartoon) and the Multi (well named, because of the multi-days of trouble it can bring about): don't fall to them. Again, believe me: i know what i'm talking about.

 

I think SS01 has a setup that you could well copy, since it works without any issues, out of the box and run quite stable. And, best of all, it's an Intel solution that's not pricey! :D I'll ask him to post it here.

 

To install Mountain Lion, use this guide (it never failed me): [Guide] The all-in-one guide to Vanilla OS X Mountain Lion + Chameleon + DSDT for beginners.

 

I personally would recommend Clover over Chameleon, but Chameleon is way easier to install. Don't use Chimera: it's not a stable solution since the 2.0 release.

 

Best regards!

Edited by theconnactic

Share this post


Link to post
Share on other sites

I couldn't find above parts on digitec in Switzerland :(

 

Continue to use AMD :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×