Jump to content
InsanelyMac Forum
sea_man

AMD 7970 Working With Full QE !

Recommended Posts

After some testing with Mario Bross we were indeed able to get a AMD 7970 working with QE under Mac OS X 10.8.3 using DSDT injection method.

 

http://rampagedev.wo...g-with-full-qe/

 

Important Note :

 

You need a working SLEEP system because a bug ...and also you will need your 7970 injected in the DSDT to have 100% support in any app....( your 7970 will also work partially without DSDT injection.. but without any FB loaded ), if you have a White o black screen after boot.. just put your system to sleep and later wake up.. it will make work your 7970.

 

Note: If you have problems whit the boot loader screen ( like a funny characters ) Just update your boot loader ! ( i test whit the last champlist and it work fine whit my 7970 )

 

Also this only work whit the 10.8.3 , the new 7***.kext can't work alone in 10.8.2.

 

Important: this also can apply to any AMD 7*** series GPU , just test and report ;)

 

 

screen-shot-2012-12-04-at-5-50-34-pm.png?w=640

 

 

screen-shot-2012-12-04-at-5-47-54-pm1.png?w=640

 

 

screen-shot-2012-12-04-at-5-50-51-pm.png?w=640

Share this post


Link to post
Share on other sites
Advertisement

Will this be easy to implement when 10.8.3 is out?

 

Yes , for now is working whit the two 10.8.3 released betas.

Share this post


Link to post
Share on other sites

would this work with a 6970 ?

 

No, this has nothing to do with the AMD 6970. The AMD 6970 will Never Be Supported. Its time for you to sell that card and move on to a new card.

Share this post


Link to post
Share on other sites

any news about 7650m? they say its a rebrand of 6630m... so will this card have a solution?

 

 

btw, the dev id of 7650m is in the beta 10.8.3 kexts.

 

Don't ask about it... just do the tests and report back the results. That is why I provided a guide.

Share this post


Link to post
Share on other sites

well booting normally, these kexts load: AMDSupport, AMD6000Controller, AMDRadeonAccelerator and

ATY_Init*. the aty i put it later with no results. but the gpu isnt recognized, just this info:

 

 

Monitor:

 

Tipo: GPU

Barramento: PCIe

Largura Lane PCIe: x8

Fornecedor: ATI (0x1002)

ID do Dispositivo: 0x6841

ID da Revisão: 0x0000

 

ill keep trying, and hopping for the best. not double cards, but use the ati one.

Share this post


Link to post
Share on other sites

I will join with my XFX 7870 DD, too.

 

Have to go into Sleep on every boot. I guess this is called cold boot issue?

 

Attached are a decompiled DSDT and an IOReg file.

 

EDIT:

 

Replaced the Chutoro framebuffer with a custom one. I chose it because of the matching port amount.

Still no luck.

7870.zip

Edited by k3nny

Share this post


Link to post
Share on other sites

I tried today, but after installing 10.8.3 Chameleon stopped working.

Note that I'm on UEFI, so no DSDT.

 

HAHAHA

 

UEFI does not mean you should not be using a modded DSDT. Not using a modded DSDT is the worst way to go when using OS X.

Share this post


Link to post
Share on other sites

Why are you laughing at me, I just did what this guy told me: ####################

 

Consider the source:

 

http://www.insanelym...ort-tonymacx86/

 

They only care about advertising and revenue on there site. Have you not noticed that they seem to only really support one manufacturer...

 

What they do not tell you is all the drivers that will not load and features that will not work without a DSDT. Having UEFI does not equal a Mac.

 

I was not laughing at you but the idea of thinking that UEFI BIOS means no need for a modded DSDT. I assume you are new to Hackintosh and once you are around for a bit you will understand.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×