Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

8 posts in this topic

Recommended Posts

Hello Everyone


I'm REALLY new to the whole idea of a 'hackintosh', i only found out about the concept about 6 months ago.


I have wanted to try and make a hackintosh ever since and about two weeks ago i got hold of my unlocked school netbook (A Lenovo S10e) and immediatly researched what to do. Yes, i know it's an old machine but this is all a big experiment for me.


So far i have been able to get Snow Leopard 10.6.4 working well Via S10 Snow Leopard Enabler, however i have one problem; the wireless card won't be recognised no matter what i try. The instructions that come with the enabler say that wireless should work "out of the box" but it doesnt, Bluetooth DOES work however.


The Enabler also says that audio, full screen resolution (1024 x 576), sleep, two finger scrolling and wired Ethernet SHOULD work and i can confirm that they do, it's just the wireless thats the problem!


My Machine's Specifications:

- Intel Atom N270 @ 1.6GHz


- 160Gb Fujitsu HDD

- Intel GMA 950

- Broadcom Bluetooth


I think the wireless PCI card is this: Broadcom BCM4312M


I previously have Windows 7 installed on this machine and the wireless worked fine


Thanks in advance for the help anyone can render! :help:



EDIT MODERATOR : Topic's title was updated !!!
Edited by fantomas1
If you have a question please do your best to use the search feature and search the forum before creating a new topic.

Share this post

Link to post
Share on other sites

Is the netbook still school property? If so, just please think twice about what you do with it. That said, don't know what this enabler you speak of is, but would need vendor and device ID for the wifi to see if it's workable. You can get info using this System Info, an app to get hardware and kexts info

Share this post

Link to post
Share on other sites



you have here an exemple to how install OS X Lion DP1 (first beta version of OS X Lion, 32-bits compiled system, can work on your proc Atom N270 ) on this netbook : http://www.insanelym...__+lenovo +s10e


the kexts (drivers) that he use can be used on Snow Leopard too, i believe ! See if there's kext for your wireless !


I heard that the wifi works but not ethernet !


Good luck !



P.S: there's a netbook sub forum moderated by marugby123, maybe he can help you more ! ;)


P.S.2: Netbooks Snow Leopard's compatibility : Go here ! as you can see, your netbook is very good for OS X ! ;)


P.S.3: The Guide ! :)

Share this post

Link to post
Share on other sites
Is the netbook still school property?


No, the school has handed ownership to me :)


would need vendor and device ID for the wifi to see if it's workable.


I used the System Info app you linked and it spat this out at me:


Pro/Wireless 5100 agn (shiloh) network connection

Vendor: Intel Corporation

Dev ID: 4237


Is this what you need? :)

Share this post

Link to post
Share on other sites
can you post the full output from system info?







well, apparently my post didn't you give too much interest !

Hello! I Apologies profusely! I ment no offense!


Unfortunatly the Lion install guide was not much help...i think, im not sure.


The Snow Leopard guide you linked was the first page i opened when i was researching what to do, lol

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jojo2203
      habe versucht nach der Anleitung von http://x220.mcdonnelltech.com/  auf einen X220 i7 zu installieren, bisher leider erfolglos. kann mir jemand die angehangenen Log Meldungen interpretieren und einen Tip geben an welcher Stelle ich weiter probieren muss. Habe es schon mit den folgenden Bootparametern probiert
      -v -x -s -f cpus=1 maxmem=4096 GraphicsEnabler=No -no-zp
      Es war ein 8 GB Speicherriegel gesteckt und die "neue" WLAN Karte, außerdem ist zusätzlich zur MSATA eine weitere HDD installiert.

    • By bepferr
      Ciao a tutti! Ho un Lenovo y50-70 con schermo UHD e Intel hd4600.. vorrei installare High Sierra, ho letto che questo laptop è una delle configurazioni più compatibili in assoluto.. Solo che non ne ho le capacità Qualcuno sarebbe in grado di darmi una mano?
      grazie mille!
    • By bepferr
      Hello everyone! I installed OS Sierra 10.12.6  on a Lenovo y50-70 with 4k monitor following the tonymacx86 guide (this: https://www.tonymacx86.com/threads/guide-lenovo-y50-uhd-or-1080p-using-clover-uefi.232960/ ). All is OK (except the bluetooth but I consider that a secondary problem) except that I can not absolutely activate the monitor! For example, I can connect an external monitor via HDMI and so doing everything OK. I would like to understand how to do it, does anyone have any idea? I have already set up the DVMT prealloc to 128mb with modified bios and installed coredisplayfixup in L / E but nothing. If I boot up setting clover id-ig 0x12345678 the monitor works but the graphics card is recognized only as 31mb and everything is slow, the web pages for example are unusable. I have an integrated intel hd4600 card. I hope you can help me, thank you so much in advance!
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Release v2018.01.28 on GitHub Updated to Clover r4394 Updated apfs.efi to patched 10.13.3 version Updated Lilu and AppleALC kexts to v1.2.3 (supports both Sierra and High Sierra) Revised misc kexts (FakeSMC)  ​Various Tweaks over Last months
      The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: My system is a T460 with i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files

      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup

      Notes on Custom Kexts