Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
nosammai

M14x Sata controller issue

5 posts in this topic

Recommended Posts

I installed a second hard drive into my Alienware M14x by replacing the optical drive with a caddy. I installed lion on the second hard drive, and it boots fine, but it's really slow after it boots. Sometimes when I click on anything, it just hangs for about 10 seconds then loads, but it's pretty inconsistent - sometimes its fine, sometimes it hangs. It's odd because I had lion working perfectly fine in the primary HDD bay, but when I move it to the optical drive caddy, it's slows down.

 

I was having this same problem in Windows, but I fixed it by installing Intel's Rapid Storage Technology drivers. Is there some sort of equivalent Kext, or something else that I should be doing to make it work properly? System Information says it's got an Intel 6 Series chipset. I know the optical drive port is only SATA 1.5 Gbps, but I don't think that should really affect it as much as it is.

Share this post


Link to post
Share on other sites

I got everything else working(QE/CI, Ethernet, sound, USB, PS/2), but I can't seem to figure this one out.

 

It's not that the disk is getting slow transfer speeds - they're up where they should be for a SATA 1.5 Gbps HDD. I opened up Activity monitor to look at the graph for disk activity, and it looks like there are spikes of I/O (Of normal speed) separated by valleys of 0 I/O. The spaces are all similar in length. I also did a benchmark in OSX on the HDD and it came out normal.

 

Again, I was having almost the same issue in windows that was solved by installing the Intel RST driver, but I'm not sure what the equivalent would be in OSX. I've been going at this for about three days now, and it's getting really frustrating. banghead.gif

 

Any and all help/suggestions would be greatly appreciated!

Share this post


Link to post
Share on other sites

I know this is old, but the ODD uses SATA I/1.5 compared to the SATA II/3.0 of the HDD. Hope this helps, just use the secondary drive for storage space and you'll be fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×