Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
gygabyte666

[UPDATED] Dell Optiplex 760 SFF Setup for ML, Lion & SL

122 posts in this topic

Recommended Posts

***Use EXTREME CAUTION when using either my Mountain Lion (10.8.x) or Lion (10.7.x) org.chameleon.Boot.plist without checking it first. It is setup to use kernel/boot caches which was disabled by default from Lion onward and will cause BOOT FAILURE if your E/E kexts aren't moved into S/L/E before the mkext rebuild. If your install isn't setup to use kernel/boot caches or you have no intention of using them, simply remove these lines from the plist and you'll be fine. The drawback from not using the caches is that your booting time will take longer:

 

<key>UseKernelCache</key>
<string>Yes</string>

You've been warned.***

 

By using the advise or files from this thread, you assume full responsibility for your actions and their results. I cannot be held responsible for any potential damage to your system or loss of data. Just sayin' ;-p

 

The issues with this system using either Mountain Lion (10.8.x), Lion (10.7.x), or Snow Leopard (10.6.x) have been resolved with the help from people in this thread and through many, many hours/days of trial and error on my part. To anyone with this system setup, I have provided zip archive(s) with all the files that I have either previously used or currently use on my Mac partition(s). They have been tested working on either 10.8-10.8.2, 10.7.3-4 or 10.6.8 and are all ready to use, just unzip them, apply them where they should be, repair permissions and rebuild mkext as needed and reboot.

 

The only issue I that couldn't be fixed is the random restart BIOS hang where the Dell splash boot-up screen will "hang" or "freeze" once the loading bar reaches full. CTRL+ALT_DEL doesn't fix this, the only way to resolve it is to press the power button to shut the tower off and then on again. This only seems to happen when rebooting from a Mac install. I can confirm that the BIOS hang doesn't happen after a reboot from a Tiger install. I might look further into this later.

 

Lastly, My system is running BIOS rev A05 during all tests. So I can't confirm the dsdt provided working on anything but that BIOS rev. It may also not function properly if used on a different size chassis of the 760, such as the full size model or ultra slim form factor model.

 

Thanks for everyone's help! :)

 

Download the zip archive(s) here:

Full (contains everything for all OSs) = Opti760_3Kitties.zip

Mountain Lion (10.8-10.8.2) = Opti760-MountainLion.zip

Lion (10.7.3-4) = Opti760-Lion.zip

Snow Leopard (10.6.8) = Opti760-SnowLeopard.zip

Last updated: 11/26/12

 

ORIGINAL POST:

Soooooo basically, I suck at this. I'm horribly unconfident in every aspect of DSDT creation/modification. I'm ashamed to admit but in all the years i've been tweaking and playing around with OSX86 I have NEVER been able to really figure out how to deal with using/editing DSDT files. My experience lies only with "dirty" hacks, through modification of current system files, or adding in new ones.

 

I have looked up and tried out more tuts than I care to count, each had their own specific way of going about it and NONE of them were very helpful. They all seemed to only cater to one specific motherboard type while leaving everyone else with a different board in the complete dark. Being lost to begin with, the last thing I planned to do was make guesses and risk completely f***ing up my hardware in the process.

 

So yeah, I need help. I would probably benefit most from learning from the work of others on MY own DSDT, not someone else's. So, I will provide two one DSDT file below, extracted from my system, completely unaltered. dsdt-Optiplex760-Untouched.zip

 

The second will be one that I tried to edit (and probably failed miserably), this should be used as examination from someone more skilled at DSDT patching to assess if I did it right or was completely wrong about it.

 

I only want a few patches applied because most everything on my system is working great! At least, according to my testing anyway. I was planning on applying the following patches but need help:

 

-RTC reset fix for CMOS.

-GeForce device/NVCAP injection (see below for code, originally referenced here)

-SpeedStep enabling (never attempted, I think it might be dangerous)

-Audio fix for ADI 198x (if exists, although i'm content with using current VoodooHDA solution)

-Sleep/Hibernate fix (should one exist, this one is VERY low priority)

-Network/Ethernet fix (also low priority, i'm currently using AppleIntelE1000e as a fix)

 

EVGA GeForce 6200 512MB PCI NVCAP:

0400000000000300040000000000000700000000

**This code was extracted using Everest Win7x64, then using NVCAP Maker v1.4.

 

That's really it. Most everything else important seems to function as expected. If someone with long time experience in creating/editting DSDT files reads this, I hope you'll considering helping me. I'm eager to learn this but not so eager to destroy hardware through constant trial & error, which is all I have going for me right now. So if anyone can and is willing to help, please try and do so. I will really appreciate it! If more info is needed i'll do my best to get it to you ASAP. Thanks for the read. :D

 

UPDATE: So, I decided to try to test out my edited DSDT linked above to see if it made any difference. Low and behold it appears I actually might have fixed a couple things. After testing it out and rebooting the first thing i noticed was that my RTC fix worked! My BIOS no longer resets after a reboot! I previously needed ElliottForceLegacyRTC to fix that. Then, I tried out my tiny graphic fix (to try to make sure my PCI was correctly read as 0. That seems to have worked too. Before the edits, I needed to use NVEnabler to get my 6200 to give me the black screen before the login screen, now it does it by simply adding the GraphicsEnabler flag. Lastly, I did a rough fix to my PIC & TMR and planned to edit my HPET which never was done because I didn't know what I was doing and didn't wanna risk frying my CPU. Still, I edited both PIC & TMR and tried to see if I could get my system booted without the need for the NullCPUPowerManagement kext and it actually worked too! Although, to be fair, I am pretty sure I didn't need to edit anything to get my CPU to work without NullCPUPM before. I just had it in my E/E folder to be safe.

 

Either way, i'm completely baffled by the fact that my half-assed attempt at a DSDT edit ended in slight success, especially since it gave me a s***-ton of errors while building. I still have a few fixes I REALLY need help with though. I don't have an audio fix, a sleep fix, a speedstep fix, an ethernet fix, or a GeForce injection. So please, if anyone has anything that might be able to help me, i'm all ears!

 

UPDATE#2: Tried adding in the Nvidia NVCAP injection linked above without success. Back to square one since QE/CI + Full resolution is STILL the only important thing missing from my system. I also keep getting a crapload of errors while rebuilding my DSDT for testing, which I can only imagine might lead to unforeseen problems later on potentially.

 

UPDATE#3: Installed SnowLeo on a USB HDD to test with to see if the 6200 would even work on that. Long story short, no it doesn't. That means I would have to go back as far as Leo just to get this stupid card to have full QE/CI. So I decided an upgrade was in order, after much discussion with Gringo, another forum member who was very helpful in the decision process, I have purchased a 9500 GT that should arrive within a few days. Hopefully my luck with QE/CI will change once I give the new card a try. Nothing could be worse than the slow ass, outdated, PCI-based 6200 I have been testing with. Will keep the thread posted on progress.

Share this post


Link to post
Share on other sites

Aw c'mon people. I know for a fact that some of you are DSDT gurus. Stop being greedy and help those who are a little confused about how to properly do this. Please?

Share this post


Link to post
Share on other sites

Yeah, as I said I don't know. I'm completely lost on almost everything concerning DSDT. I only edit them with guides/tuts I find online. Some of it I understand like the GFX stuff but most of it I don't know how to fix, afraid i'll break something. I'm trying to regenerate a fresh DSDT right now, should be ready soon.

Share this post


Link to post
Share on other sites

Sorry that took so long but I ran into unexpected problems. I was unaware that Chameleon automatically uses a dsdt file if its found in the Extra folder for the OSs. I always figured it had to be enabled through the plist before it was used so both SL & Lion have been relying on my crappy-modded dsdt without my knowledge this whole time, so once I removed them to try to provide a clean dsdt to dump, they both decided they weren't going to let GraphicsEnabler OR the EFI string allow full res or QE/CI for the 9500. So I had to scurry around hunting for compatible NVEnablers for them. On top of all that, my CMOS/BIOS reset every time I reboot and causes BIOS splash screen hangs, so that was added fun. >_>

 

But that's not important. What is important is that I got them. All new dumps, ioreg blah blah...I included anything and everything I thought might help. I also included a little quick and dirty readme in each to help explain what some things were for, etc.

 

Here is the info I gathered from my SL install, OptiPlex760_SnowLeo.zip

And this is the stuff for Lion, OptiPlex760_Lion.zip.

 

You'll likely notice there is more for SnowLeo than for Lion, thats mostly because a lot of the tools I use are older and work better on SL. Besides, I needed to rely on SL more for testing since it's on a USB and is portable. It also seemed to give me less hassles. Anyway, I really appreciate your help, I hope you find out something good. Let me know if you need more and i'll do what I can to get it. Hope you have better luck than I do! ;p

Share this post


Link to post
Share on other sites

one tip i give u on dsdt nvidia mod is.. NVDA,Parent is missing on older patches. stops working after 10.6.7

it shows NVDA,Gforce which is wrong.

 

i have to step out and il start looking at stuff later today/night

 

by the way .. linux live in usb would have been easier, i use linux mint.. with unetbootin or yumi usb tool

 

while im gone look into dsdt of 755 or 745 . forgot which.. compare 755.dsl or 745 with text wrangler or some tool.

Share this post


Link to post
Share on other sites

That's interesting because I noticed that mine showed Parent instead of GeForce and since I didn't know how it would affect things I didn't bother to change it. Hmm, good to know.

 

Ok, thanks for you time and everything. I only hope fixing the dsdt errors can help resolve a lot of the weird issues my system seems to have. Such as CMOS/BIOS reseting and hangs, obviously the finicky GFX setup, possible USB issues that i'm unaware of, SpeedStepping, and Sleep/Hibernate just to name a few.

 

I wonder, is it possible to patch a dsdt to fix audio issues? Voodoo is great since it allows my audio to function, for both front and back ports but I have a horrible static hissing noise that I can't get rid of, i've tired modding the Info.plist to change/add values and i've tried using newer/older revisions of the kext without success. This is merely an after thought, clearly i'm more concerned with the important things first, like better system stability and such. Thanks again, look forward to seeing what comes of this. :)

 

UPDATE: I use Linux a lot for this kind of thing too ususally. I don't typically have an install handy though. I usually just use live discs because they are quick enough for me to get hardware dumps, etc.

 

About the 755/745 dsdts. I don't really get how looking at those are going to help. I mean, what if they are incorrect or improperly modified, then i'll just get equally poor results right? I don't want to sound so negative but i've already proven to myself that I have no idea what i'm doing when it comes to dsdt patching/edits. i'll try to take a look though if i can find a dsdt for them.

Share this post


Link to post
Share on other sites

i saw a guide for dsdt for 755 that has the key issue.. EHCI missing 1d7 EHC2 1a7

and smbus addition. ill patch now if i get enough time. im in and out onsite repairing stuff all the times.

 

strangely i have a 755 here with blinking amber light. mobo or cpu or power supply issue.. but i coudl test dsdt in it for the key issues.

some addresses might be different but structure is same (text compare the dsl is how i find this)

 

http://www.insanelymac.com/forum/index.php?showtopic=274409&st=20

Share this post


Link to post
Share on other sites

First off, this:

EHCI missing 1d7 EHC2 1a7 and smbus addition.
Sadly, means nothing to me. Sorry :(

 

Secondly, I thought I had my RTC fix setup correctly in my first dsdt edit. It likely wasn't correct though because it would randomly still happen, although very rare. The real problem for me is the BIOS splash hangup. I assumed maybe it was USB related when something was plugged in/ejected while using Mac but it seems to happen even if nothing was connected through USB.

 

No worries about helping me out. I kind of gave up on the tower for the moment myself too. I've been screwing with kexts, dsdt, mods, edits, etc. for so long that I needed a little break before I tear my hair out. I mean, as much as I want it fixed and all done, I understand that life takes priority. I figure at the least, most of my problems can be solved through kexts as a last resort. Maybe not everything and it certainly won't be pretty but it'll suffice.

Share this post


Link to post
Share on other sites

the hang is cause of rtc and legacypatches

here try this dsdtfixed.aml rename to dsdt.aml in /Extra

EHCI (USB) is not added yet (as a test before we tackle that, but this should work as it did for pooky)

difference between u and pooky is he has intel ICH9 u have ICH10 .. 10 is more compatible than 9.. but both work fine.

usb issue with ich9 .. device ids change or missing not 10 that work fine. but both optiplex are missing ehci device in dsdt.

 

i restructured all the scopes pci0 and lpcb to its parent tree (scope makes it join another section of dsdt of the device .. i joined it toghether so no skippin arround.)

 

IRQs might still be out of whack .. we will see.

 

rtc is set to 0x02 not 0x10 as original with issues. i hear 0x08 might work. but i havent tried

dsdtfixed.aml.zip

Share this post


Link to post
Share on other sites

HOLY {censored} IT WORKED!!! Just tested it. I made sure to remove my LegacyRTC.kext first. I did two restarts. For the first I plugged in a USB device and ejected it to try to weed out what I thought was causing it. The second was just a regular login, then reboot. You sir, are my hero!!! I also did a shutdown and that seems to have failed. It went through the normal verbose messages and at the end the screen went blank, like it disconnected the video device and just hung there. The system never turned off. I dunno if that's useful to know or even relevant but I tested it as before I recall getting KPs if I did a shutdown from Lion. It might also be worth mentioning that if I have to do a hard shutdown, the system will do like a test restart about 2-3 seconds after it turns off. It will briefly come on (to test power settings or something i assume) then it'll shutdown and stay off. Might be just how the motherboard is wired though too I suppose, I don't know. No BIOS resets or splash hangs though using your dsdt!!!! Awesome!

 

Do you need more info from somewhere? I'm not really sure what else to check for in terms of changes aside from the RTC/BIOS reset/hangs. Thanks so much for your help!

Share this post


Link to post
Share on other sites

i know whats wrong. i didnt tweak shutdown thinkin it would work.. easy fix. also found how to add EHCI.

new dsdt coming soon. 10 minutes

 

by the way are u using usb keyboard and Mouse ??

also enable usb s3 wakeup in bios if an option.

 

if this didnt work on shutdown. then we have 1 more thing to fix in _GPE... add EHC1 and EHC2 next to usb5

Share this post


Link to post
Share on other sites

Oh ok, no prob. Yes, i've been using a USB keyboard and mouse. They are all I have right now anyway. Yes, my bios has an option for both S3 & S1 suspend mode, nothing specifically for USB though. I always have it set to use S3 anyway so it should be on. Gonna go test the new dsdt now. Will report back in about 2-3 mins with results.

 

Ok tested it out. Shutdown did the same thing. No difference. Tried it twice to make sure I wasn't crazy.

 

EDIT: Ok, so i'm trying to add in what you provided above to the dsdt you most recently added. I'm a bit confused. Where does this go exactly? I see a ton of different _GPEs but none that match L20. I see no usb5 mentioned either in this. *sigh* Sorry, I really don't understand dsdts though. :(

Share this post


Link to post
Share on other sites

w00t! Ok, testing now, same time frame as usual. I assume this contains just a shutdown fix right? No other fixes need checking?

 

EDIT: Checked shutdown and it still goes to CPU Halted & then shuts off the screen and hangs. Never actually shuts off. Tested it twice to be sure. Just in case its useful, I see a message on the screen during verbose that warns about C-States not being active, something about an LPCDriver or something. I also see what I think you were talking about before with EHCI. It says the USB will be unloaded across sleep. Not sure what it all means but maybe you do?

Share this post


Link to post
Share on other sites

try 5 rename to dsdt.aml and place in extra.. check shutdown or sleep.. then try the 760 with is my 6th attempt

 

 

i need ioregistry dump with ioregistry explorer. save and zip

 

 

the LPC not initialized is comon dell issue. cst is stil running i believe.

Share this post


Link to post
Share on other sites

Alright, thanks! Testing out both now...

 

UPDATE: Ok, sorry for the wait but I needed to make some food. :)

Tested them both out. Sadly, they both seemed to provide the same issues. Here is a little list I put together while I was testing to keep everything in order:

-Sleep seems to work but power led remains green & system remains active, it never goes into low-power mode (yellow, blinking led)

-LPC C-States failure still appears in verbose (dunno if anything was changed to avoid that though)

-Shutdown failure. Still same, unchanged

-Splash hang occured using the 760dsdt, (sleep related? They system fell asleep while i was making food and upon reboot it hung)

 

Hope it helps. Thanks again for all your help. Could never figure any of this dsdt stuff out on my own.

Share this post


Link to post
Share on other sites

Yeah, if you're stumped then i'm screwed, lol. I never got beyond the RTC fix when i did it. Even that was probably wrong. I plan to investigate the dsdts you made and compare them to the original to try and learn after this is all settled. :)

 

DarkWake? Haven't tried that flag yet. Is that supposed to help waking up or going to sleep?

Share this post


Link to post
Share on other sites

Been screwing with trying to fix the dsdt all day and i've got nothing to show for it. What really bugs me is that I have like a billion compile errors with every dsdt I have. I can never get them to compile with DSDT Editor, or with DSDTSE. I always have to use Chameleon Wizard to create the aml file. I don't like having to do it but its the only way I can compile them for testing.

 

I tried every shutdown fix I could find, using your 2 dsdt you made to fix my BIOS reset as the base. I suppose I could just deal with having a faulty shutdown but i'd like to fix it if it's possible. I'd also like to patch in my onboard audio so I can stop using Voodoo. The system uses a AD1984A. Can this be patched in to work vanilla without needing additional kexts?

Share this post


Link to post
Share on other sites

no the patchin in dsdt goes along with a legacy hda and applehda patch. so voodoohda is best bet. u probably need to find one tweaked for ad1984.

 

the trick to dsdt is the { goes along with } so if youre missing oradded a } or { then it wil gove errors.

 

Device

{

here goes the stuff

} if u move cursor here in dsdt editor u see it turns orange. and u scroll and u see the begining orange that encloses it

 

if i add second }| then it wont "enclose the section"

 

by the way .. im wondering what your device ids are.. maybe needs some legitimate mac ids injected for ich10

 

compare lspci -n of ich10 mac models and yours

Share this post


Link to post
Share on other sites

Yeah, I know how to edit the DSDTs I'm saying that even my freshly ripped DSDTs have compile errors in them, which leads me to believe there are tons of errors in them before any modifications are even done. I don't know how to fix them all. There must also be some kind of super secret dsdt patch database that I'm unaware of because almost all the ones I find and test never work. That's all.

 

Thanks for clearing up the audio thing too. I figured I'd be stuck with Voodoo, which is fine but it's tough to find/edit it to make it work better with my hardware. I've searched for a specific match for it without success so I've relied on trying to edit different revisions of it.

 

I have no idea which Mac models are ICH10 supported. How would I find this out and/or apply fixes? Thanks for the insight as usual. :)

Share this post


Link to post
Share on other sites

Replaced my hdd today with a much larger one. I installed Lion, SL and Win7 on it. I did my usual setup too with all my usual apps, settings etc. very little issues this far and the system was running, installing {censored} and updating for almost the entire day.

 

Most of the issues are minor and can probably be easily fixed with quick patches here and there. Such as iDVD whining about not having a SuperDrive to burn with, the App Store saying it can't verify my computer, and Parallels not allowing me to install the software bc it claims my processor can't do virtualization (Even though my BIOS has a dedicated section for it). Other than those, everything's been as well as if it were a Mac Pro tower. Most annoying things are the shutdown not working and the EHCI errors about sleep. I think the EHCI are also what is causing the BIOS boot hang bc it's still happening randomly. Otherwise all is well. Figured I'd add this info up if for nothing else, for reference to someone else later on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  


×