Jump to content

[GUIDE] – HP8530p/8530w – Mavericks 10.9.1


78 posts in this topic

Recommended Posts



Trying to get my vga out working on my 8530w T9600 but with ###### this doesn't work. When using the dsdt from Gunman it works, however the cpu is running hot (as he stated already this isn't a good idea, but just wanted to check if it would solve the vga out issue).




Is your vga out working and so yes, can I have a copy of the dsdt you used so I get the right speedster settings?


cdrom does work here btw.





Link to comment
Share on other sites

  • 4 weeks later...

Thanks for your work. I have a 8530w and install the Mountain lion DP2 successfully by use your dsdt. Cpu is T9600, seems speedstep works. DVD also works. I download a DSDT from an Chinese forum, the author says that it fixed the Brightness control by add Device (PNLF), also get DSDT + AppleHDA.kext working (10.6.7) and sleep works fine. But this DSDT result black screen to me.

I fixed this dsdt and it doesn't result in black screen now. You guys can try it. Use scroll and pause to control the brightness, and use the attached applehda.kext. Sound works fine, auto-switch between speaker and headset. But the microphone still not work. Sleep also works fine. Use Fn+F3.


Here is the DSDT and modified AppleHDA.kext.


Link to comment
Share on other sites

Hi duian,


brightness control through settings should also work with my dsdt.


currently only changing brightness using the FN Keys won't work ;)


I'm having a look into that dsdt later ;) maybe it has some other improvements...



Link to comment
Share on other sites

New Things

I use an app call iDSDT,fix your dsdt with HDA part and generate the modified appleHDA.kext

it works, also can auto switch from headset jack to internal speaker...but microphone still not work.


Maybe it will help your work.


1.iDSDT also need the HDA code get from the Linux.

2.if you want use the applehdamod.kext, you must delete the applehda.kext.



Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

reading around I discover that T9600 is actually used by mac themselves.

so I commented all the 'begin speedstep fix' in your dsdt and recompile it without any issue.


it looks perfect


it does go to sleep, cpu frequency changes accordingly to smc monitor, brightness control works for me on 'scroll and pause' button on keyboard, cdrw is working too.


I still have to check hdmi cable and indeed audio is working with voodoo.

I'll explore the idsdt also because voodoo set the input gain to 90 ( 2.7.3 ) so until the boot is complete there is a very loud noise coming from the speaker.


update went super smooth from 7 to 7.4



Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Any of you have any clue on how i can downgrade the bios.. The 8530p i got already had the F.20 (RSA Encrypted bios) so i can't get the whitelist removed on it. And i haven't been able to get the recovery bios restore to work to downgrade... I have already changed the gfx to the 770m because i honest don't like ati... :P

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
  • 9 months later...

Hi at all,

the last post was long time ago...

On my hp lion 10.7.5 is installed and running nice. I tried to install 10.8.2(3) with different distros, but all reboot the system in early boot process. I used many boot parameters no effect. How did you install 10.8? Can anyone give me assist to?



Link to comment
Share on other sites

  • 7 months later...

time for a litte update:


did a fresh install with mavericks using myhack and one of my old dsdts. works great so far - but the unresolved problems still exist.


after some research for new drivers (audio etc) I found two very nice discussions in chinese boards:





seems like they've fixed many of our problems - but I have trouble downloading the files from pcbeta...


from 51nb I got a working AppleHDA.kext file for our AD1984A which is great success!

internal speaker, headphone output and the internal microphone are working. external microphone is not working


my dsdt and the applehda file is attached below...





Link to comment
Share on other sites

Hi gumman,


glad to hear that you're now running 10.9.1 on your HP 8530 and that sound is now working with the internal AD1984 :)


Additionally, i've stumbled across a post-installation package which contains a VoodooSDHC.kext for the internal Ricoh cardreader (Get it from http://www.dailyblogged.com/wp-content/uploads/2012/06/10.7.3_Post-Install.zip - It's meant for the Dell Inspiron 1525 which has the identical cardreader built-in)


It'd be really great if you could test this.





Edit: Added link and description to post-install package

Link to comment
Share on other sites

some more updates:

raeis was kind to send me the files from pcbeta - many thanks again!.

Those files are a huge improvement. Their DSDT has some nice patches inside but some stuff is missing (firewire for example) - needs some further investigation.... Unfortunately it had a compatibility issue for 10.8.5 and above which broke speedstepping but I fixed it.
(see http://www.tonymacx86.com/mountain-lion-desktop-support/109371-higher-temps-after-upgrade-10-8-5-a.html for more info)

Most of the kext files from the pcbeta thread are useless for 10.9 (except AppleHDA) - but kexts from other sources work properly with the patched dsdt :) !

I'm happy to say that this stuff is finally fixed:

  • Audio - AD1984A via AppleHDA / DSDT (except ext. microphone input)
  • Battery/AC – Notebook Battery Status
  • Brightness Control via FN-Key
  • TouchStick and TouchPad (gestures etc.)
  • LID ( Sleep when Closing LID)
  • Sleep

You'll need the following kexts:

  1. AppleIntelE1000.kext from http://sourceforge.net/projects/osx86drivers/files/Kext/ for the Ethernet Controller
  2. AppleHDA.kext from my last post: delete any existing AppleHDA.kext from /S/L/E/ and install via Kext Wizard
  3. ACPIBatteryManager.kext from https://github.com/RehabMan/OS-X-ACPI-Battery-Driver - Install via Kext Wizard. Delete AppleSmartBatteryManager.kext from /S/L/E - this will enable the Battery Status;)
  4. FakeSMC.kext from https://github.com/RehabMan/OS-X-FakeSMC-kozlek - Replace any other instances of FakeSMC.kext with this version. I'm not 100% sure if this step is needed - but you'll get a nice HWMonitor app which lets you check if speedstepping is properly working (see below) ;)
  5. VoodooPS2Controller.kext from https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller - Install the way it's described there. This will enable all the special HP-Keys, TouchPad, TouchStick and Brightness Control via FN-Keys.

Some other notes:

Speedstepping is not enabled in this DSDT. You'll have to enable it via Chameleon or any other Bootloader which is the appropriate way to enable Speedstepping. To do so - enable P and C-State generation in your org.chameleon.Boot.plist and add the right SMBios.plist for a MacBookPro5,1 to your extra folder. You can generate one using Chameleon Wizard. Make sure that after a reboot the following Kexts are loaded. AppleLPC, AppleIntelCPUPowerManagement, AppleHPET. Check using kextstat in a shell. Also make sure that NullCPUPowerManagment.kext is not loaded - if so remove that kext file. Finally check if your cpu changes frequency while idle using the HWMonitor.app (see above). Temp of my CPU (T9400) is around 40°C...


Many thanks to the guys involved in all those fancy dsdt patches and kext driver stuff... ;)





--- edit #1


added some more dsdt fixes (v2):

  • HPET fix from macintoshy's DSDT - fixes weird usb behaviour - thanks!
  • EHCI (ICH10)
  • SATA (ICH10)
  • SBUS (ICH10)

--- edit #2


Some people are messaging me if this dsdt is compatible with their specific CPU:

Yes it is. As it doesn't contain any specific speedstepping settings you can use this dsdt on any hp8530p/w.

Just make sure to enable speedstepping via chameleon (see note above)


Edited by gumman
Link to comment
Share on other sites

gunman now i can reply to your post can you please help me with apply your dsdt i download it but i don't know what to do with it. i install mavericks i got sound and battery to work from your kext thanks to you for that. but i cannot boot with out graphicsenabler=yes every time can you tell me how to boot normally and apply your dsdt. thanks for the help i appreciate it

Link to comment
Share on other sites

gunman i click save i got ioregistry file now i don't know how to export , i can only boot with mavericks bootable usb with graphics enabler=yes 

i install bootloader chamelon and it doesn't boot at all. i got sound and battery working but i cannot boot without the mavericks usb with graphicsenaber=yes boot flag even after i install chameleon i try booting without usb with graphic enabler and it hangs . i appreciate your help i give you iosregisrty file i attach file it says i am not permitted to attach this type of file. 

Link to comment
Share on other sites

@any1982: zip the ioreg file and it's possible to attach it. I'm not sure why you can't boot directly from the hdd.

Now I guess some kexts are missing, because in the pm you said that it was possible for you to boot without GraphicsEnabler=yes when using a mult*beast installation and the dsdt.

Maybe it's just time for another part of the guide which explains how to set up mavericks.... be patient.

Link to comment
Share on other sites

[update] - Installing Mavericks 10.9 - Non Dual Booting Guide

After two years since starting this thread it's time for an update on how to install the latest OS X to your hp8530p/w.

Note: In this guide I only explain how to install OS X without taking care of any parallel Windows installation.



1.) Creating a Mavericks Installer using myhack / preparing the USB Drive


a.) Mount your mavericks image $something$.dmg

b.) Format your usb device with the Disc Utility as "Mac OS Extendend (Journaled)" else myhack won't detect it.

c.) Start myhack installer, enter su password, choose "Create OS X Installer" and "Create OS X 10.9 Install Disk" afterwards
d.) Choose your usb drive as volume to run myhack on, let myhack scan the system for your mounted mavericks image
e.) Proceed with the installation process.

f. ) After myhack has finished, copy the downloaded dsdt.aml to the Extra folder of the "myHack OS X 10.9 Install Disk"




2.) Install Mavericks on the hp8530p/w


a.) Plug the created myHack Install USB Stick into your hp8530p/w

b.) Press ESC after the hp boot prompt and F9 afterwards to choose the USB Device as boot device.
c.) In Chameleon choose "myHack OS X 10.9 Install Disk" and enter the additional paramter -v (in case something goes wrong)
d.) Wait for the setup to start... takes some time
e.) Format your HDD using Utilities -> Disk Utility as Mac OS Extended (Journaled) - Proceed with the setup

f. ) Myhack will ask you some additional questions during installation - I answered them in this combination

- Use Generic Extra that comes with myHack - YES

- Remove ApplePolicyControl.kext - YES

- Remove AppleTyMCEDriver.kext - YES

- Remove AppleUpstreamUserClient.kext - I'm not sure - I tried both.. didn't make any difference. Your choice.

g.) The setup will restart - boot the HDD in Chameleon - you can remove the usb drive at this point.

h.) Proceed with the Installation.... Done.




3.) Driver Installation


a.) Navigate to /Extra/ and remove the whole folder "Extensions" and "RemovedExtensions"

b.) Copy the following files from the downloaded Extra.zip to /Extra

- SMBios.plist

- org.chameleon.Boot.plist

c.) Copy the latest dsdt.aml to /Extra

d.) Go to /System/Library/Extensions and remove the following files

- AppleHDA.kext

- AppleSmartBatteryManager.kext

- myhack.kext

e.) Extract the SLE.zip and install the following files using kext wizard to /S/L/E/

- ACPIBatteryManager.kext

- AppleHDA.kext

- AppleIntelE1000.kext

- FakeSMC.kext

- VoodooPS2Controller.kext

f.) Reboot
g.) Finish the installation of the VoodooPs2Controller Dameon (see https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller/wiki/How-to-Install). If you don't to this, your keyboard/touchpads won't work after sleep!

h.) Optional: Check if speedstep is working using the HWMonitor.app (inside SLE.zip)






Update to 10.9.1 via AppStore is possible without any issues - just replace the updated AppleHDA.kext with the one from SLE.zip again...


I hope I didn't miss something...


Enjoy your hackbook,


Link to comment
Share on other sites

gunman i want to thank you for the guide for mavericks. i follow everything to the letter. and now my mackintosh finally works perfect. i appreciate it . i would not been able to get anything working without your support. I'm a newbie.

Link to comment
Share on other sites

  • 4 months later...

Well anyways my motherboard ended up going so i replaced it and the gpu with the fx770m so far it all works but the wifi card so im replacing that to i ended up flashing with a non whitelisted f.13 bios so all is swell thanks for all your help with the files and such :)

Link to comment
Share on other sites


  • Create New...