Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Aegisa

[Solved] Problems sleep and wake

6 posts in this topic

Recommended Posts

Hello everyone, after 2 days of trying to build hackintosh from my old pc, i finally got almost perfect hackintosh.

 

I'm running Lion 10.7.2 on

C2Quad Q6600 (socket 775)

P5K-SE (P35, ICH9)

4x 1GB DDR2 800

ASUS ENGTS 450 1GB

ALC883 onboard sound

640GB HDD (SATA2 without AHCI or SATA2 IDE)

 

And struggling to fix these problems, and still failed to.

 

1. USB storage drive (External Harddrive, and flashdrive) is not ejected properly every times i sleep my PC Solved by SleepWatcher 2.2

2. Onboard Ethernet is not working after wake from sleep. It failed to retrieve IP address from DHCP. But Apple USB Ethernet working just fine.

3. my onboard Ethernet is turned on while sleep but cant do Wake On Lan.

4. after bootup my pc shutdown and restart is working fine. After wake from sleep i cant do the restart but still can do the shutdown. Problem solved by using OSXRestart.kext (Neither EvOreboot nor OpenHaltRestart is working)

5. This is off the topic but I cant patch my DSDT to get SpeedStep working. So if any one knows how to fix this, please help.

6. Auto Sleep not working, monitor goes black but system still running. Also cannot wake it unless reboot. Worked after I replaced my onboard data controller with AsMedia ASM1061

 

And here is my Post-Installation, i case you guys needed to know for diagnostics

1. ###### with ##### + GF100 Fermi patch

2. Custom DSDT here

3. org.chameleon.Boot.plist here

4. AttansicL1Ethernet.kext here

5. SATA IDE kexts here

6. xnu-sleep-enabler here

7. AppleHDA.kext for ALC883 (working with patched DSDT) here

 

 

Thank you guys in advance :D

Share this post


Link to post
Share on other sites

the bug is :

 

Lnx2Mac driver : in the ga-z68x-ud3h-b3 (rev1,3) guide of Gordo74.

 

... Awesome : this driver kill the sleep/wake function, and usb ejected not so clean.

 

FIX : install realtek official driver.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×