Jump to content

App Store - Your device or computer could not be verified


67 posts in this topic

Recommended Posts

Why are you using WLAN? Is that connecting to another computer using internet sharing? Anyway, only see 1 device and not a list because only one connection is enabled, and although that says ethernet, it isn't.

No, I don't. I only use a wifi pendrive to surf the web. I only install the ethernet driver so as I can download apps from the MAS, but it don't work.

What do I have to do?

 

Here is a screenshot of the network info. Is regular that the ethernet circle is red? I am not connected via ethernet but I have installed the ethernet controller driver.

 

http://imageshack.us...56162alle0.png/

 

Help me please! :)

Check the screenshot (Schede ethernet means ethernet cards). http://imageshack.us...56162alle2.png/

 

PS: My ethernet controller is a Broadcom BCM57780. My PC is a preassembled XPS DELL 8000 with a Dell custom mobo, i7 860, Nvidia GTS 240, 6GB 1333Mhz RAM.

I trown this driver http://www.osx86.net/view/3089-broadcom_netlink_bcm57781.html but as you can see it doesn't seem to work.

 

I have OS X ML 10.8.0.

OK, I think we can fix this, go to /Library/Preferences/SystemConfiguration/ and send me file there called NetworkInterfaces.plist

 

I will edit it and post it back with instructions

OK, download attached file, unzip and place it on your desktop. Open up terminal and enable root access by typing: sudo -s

enter password and set it aside for a second.

open System preferences and under Network tab, delete all the connections then hit apply. You will loose internet access at this point. Network.png

now back in your open terminal window copy and paste the following, hit return after each line:

cp -R ~/Desktop/NetworkInterfaces.plist /Library/Preferences/SystemConfiguration/

chown root:wheel /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

chmod 644 /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

reboot

 

after reboot, go back to system preferences and into the network pref pane and add ethernet FIRST. check that it shows as en0 as noted earlier, if it does, then add your wifi. This may be a bit of over kill, but do it once and do it right so you don't have to do it again!

 

Edit: Just a note to anyone else, the NetworkInterfacess.plist file attached is specific to iPho's hardware only, it will not work for anyone else and would only cause you problems!

NetworkInterfaces.plist.zip

  • Like 1
  • 1 year later...

@eep357 & @Gringo Vermelho,

 

My airport card is Rosewill N900PCE. I used @eep357 Terminal commands to install the following Network Interface.Plist from my Mountian Lion to Mavericks 10.9.1. The Airport card worked perfectly in Mountain Lion but I am having problem with Mavericks.

 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Interfaces</key>
<array>
<dict>
<key>Active</key>
<true/>
<key>BSD Name</key>
<string>en0</string>
<key>IOBuiltin</key>
<true/>
<key>IOInterfaceType</key>
<integer>6</integer>
<key>IOInterfaceUnit</key>
<integer>0</integer>
<key>IOMACAddress</key>
<data>
ACYYiH0m
</data>
<key>IOPathMatch</key>
<string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/NET0@1C,2/IOPCI2PCIBridge/ETH0@0/yukon2osx/yukon/en0</string>
<key>SCNetworkInterfaceInfo</key>
<dict>
<key>UserDefinedName</key>
<string>Ethernet</string>
</dict>
<key>SCNetworkInterfaceType</key>
<string>Ethernet</string>
</dict>
<dict>
<key>Active</key>
<true/>
<key>BSD Name</key>
<string>en1</string>
<key>IOBuiltin</key>
<true/>
<key>IOInterfaceType</key>
<integer>6</integer>
<key>IOInterfaceUnit</key>
<integer>1</integer>
<key>IOMACAddress</key>
<data>
ACYYiH0l
</data>
<key>IOPathMatch</key>
<string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/NET1@1C,5/IOPCI2PCIBridge/ETH1@0/yukon2osx/yukon/en1</string>
<key>SCNetworkInterfaceInfo</key>
<dict>
<key>UserDefinedName</key>
<string>Ethernet</string>
</dict>
<key>SCNetworkInterfaceType</key>
<string>Ethernet</string>
</dict>
<dict>
<key>Active</key>
<true/>
<key>BSD Name</key>
<string>en2</string>
<key>IOBuiltin</key>
<true/>
<key>IOInterfaceType</key>
<integer>6</integer>
<key>IOInterfaceUnit</key>
<integer>2</integer>
<key>IOMACAddress</key>
<data>
aByiAMrX
</data>
<key>IOPathMatch</key>
<string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/pci-bridge@1/IOPCI2PCIBridge/pci168c,30@0/AirPort_AtherosNewma40/en2</string>
<key>SCNetworkInterfaceInfo</key>
<dict>
<key>UserDefinedName</key>
<string>Wi-Fi</string>
</dict>
<key>SCNetworkInterfaceType</key>
<string>IEEE80211</string>
</dict>
<dict>
<key>Active</key>
<true/>
<key>BSD Name</key>
<string>fw0</string>
<key>IOBuiltin</key>
<true/>
<key>IOInterfaceType</key>
<integer>144</integer>
<key>IOInterfaceUnit</key>
<integer>0</integer>
<key>IOMACAddress</key>
<data>
AB6MAAr7CW0=
</data>
<key>IOPathMatch</key>
<string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IEEE@1E/IOPCI2PCIBridge/FRWR@2/AppleFWOHCI/IOFireWireController/IOFireWireLocalNode/IOFireWireIP/fw0</string>
<key>SCNetworkInterfaceInfo</key>
<dict>
<key>UserDefinedName</key>
<string>FireWire</string>
</dict>
<key>SCNetworkInterfaceType</key>
<string>FireWire</string>
</dict>
</array>
<key>Model</key>
<string>MacPro5,1</string>
</dict>
</plist>
 
In Mavericks, after I installed Yukon Marvell LAN kext, it turned the Wi-Fi off. Therefore, in Mavericks I can only use either Wi-FI or Yukon Ethernet only but not both. Following is the Network interface.plist of Mavericks without Yukon Marvell LAN kext because that is the only way Wi-Fi can  be turn on and usable. If I have both Lan & Wi-fi in Mavericks, only Yukon Marvell LAN works. 
 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Interfaces</key>
<array>
<dict>
<key>Active</key>
<true/>
<key>BSD Name</key>
<string>en0</string>
<key>IOBuiltin</key>
<true/>
<key>IOInterfaceNamePrefix</key>
<string>en</string>
<key>IOInterfaceType</key>
<integer>6</integer>
<key>IOInterfaceUnit</key>
<integer>0</integer>
<key>IOMACAddress</key>
<data>
aByiAMrX
</data>
<key>IOPathMatch</key>
<string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/pci-bridge@1/IOPCI2PCIBridge/pci168c,30@0/AirPort_AtherosNewma40/en0</string>
<key>SCNetworkInterfaceInfo</key>
<dict>
<key>UserDefinedName</key>
<string>Wi-Fi</string>
</dict>
<key>SCNetworkInterfaceType</key>
<string>IEEE80211</string>
</dict>
<dict>
<key>Active</key>
<true/>
<key>BSD Name</key>
<string>fw0</string>
<key>IOBuiltin</key>
<true/>
<key>IOInterfaceNamePrefix</key>
<string>fw</string>
<key>IOInterfaceType</key>
<integer>144</integer>
<key>IOInterfaceUnit</key>
<integer>0</integer>
<key>IOMACAddress</key>
<data>
AB6MAAr7CW0=
</data>
<key>IOPathMatch</key>
<string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IEEE@1E/IOPCI2PCIBridge/FRWR@2/AppleFWOHCI/IOFireWireController/IOFireWireLocalNode/IOFireWireIP/fw0</string>
<key>SCNetworkInterfaceInfo</key>
<dict>
<key>UserDefinedName</key>
<string>FireWire</string>
</dict>
<key>SCNetworkInterfaceType</key>
<string>FireWire</string>
</dict>
</array>
<key>Model</key>
<string>MacPro5,1</string>
</dict>
</plist>
 
I hope either one of you can help me out. Right now when I am using Wi-Fi, App Store does not owrk return with error you device or computer cannot be recognized. Contact support for help. Under IOregistry, the device ID /vendor is 168c, 30@0, AtherosNewma40P2Interface.
 
Thank you very much for your kind attention. 
 
Please note that I triple boot Windows 8.1, ML 10.8.5 and Mavericks 1.9.1 in 3 separate hard drives. MB Asus P6T Deluxe V2, Graphics Nvidia Ti-Boost GTX 650, i7 920, 16GB GSkill mem.

If you're fine with using only the Wi-Fi, revert your changes for the Marvell ethernet controller so the driver doesn't load for it.

Then go here: http://www.insanelymac.com/forum/topic/295534-mac-app-store-access-with-nullethernetkext/

 

If you need both working at the same time..then..yeah that's a weird issue. I don't know why that happens, sorry.

×
×
  • Create New...