Jump to content

macOS Monterey & Big Sur on Dell XPS 17 L702x Optimus


mackyreddy
 Share

945 posts in this topic

Recommended Posts

@styrian - Which kext are you using. It should work without you losing sound. Refer to this post: http://www.insanelymac.com/forum/topic/273500-os-x-mountain-lion-install-guide-for-dell-xps-17-l702x-optimus/?p=2009722

for Clover 10.9.2.

 

@romturk - Maybe you can switch to Clover. I'm exclusively clover now. But if you can't I can try to get you an updated kext for Chameleon.

Hello!

 

Thank you very much for your great guide and for sharing your experience and developments with the community.

 

I am using on 10 8.5 the by you provided patched AppleHDA.kext here from Downloads and I dont want to use with clover a second config.plist to be able to boot ML with caches and working sound.

 

Because of the for 10 9.2  by Clover on the fly done bin patch of AppleHDA, to have working sound, the cached AppleHDA.kext of ML is infected because of the not before by you done rename patch in the binaries xml.zlib to aml.zlib and therefore looking for not existing aml.files in it´s Resources, if loaded from the cache. The rest of the on the fly by Clover done patch is either because of allready done or not found in the biniaries without any effect ignored.

 

In any case sound with the by me offered solution is working (booting by ignoring the caches resulting in loading the xml.files and with caches loading the aml.files)

 

I hope, my offered solution for solving this problem is in your sence and could be easy done by everyone without bigger changes.

 

Have fun.

Link to comment
Share on other sites

Hello!

 

I know, it is a bit off topic here, but a short remark for updating the L702x 3D to 10 9.3 or 10 9.4 assuming you have followed the Clover guide of Webcivilian and use a SMBios based on MBP 8,3:

 

Please do it only as ever on a Hack with a from Apple downloaded Comboupdate. Run the update, but before reboot do the following with the subsequent named and to your desktop S/L/E copied kext:

 

 

All credits go to PikeRalpha for the info.

 

You have to add your system board ID from SMBios MBP 8,3 in the info.plist of  AppleGraphicsControl.Kext/Contents/Plugings/AppleGraphicsDeviicePolicy.kext/Contents/Info.plist as last line of the Configmap with the other models in this way:

 

                 <key>Mac-942459F5819B171B</key>             
                <string>none</string>

 

 

After editing the info.plist and installing it back with your preffered kextutility to S/L/E and repairing permissions and afterwards rebooting by ignoring caches, everything should be fine again. If you have missed something, you can correct errors by setting in Clover the following key in arguments under options: nv_disable=1 and booting by ignoring caches.

 

Apple has something changed in the Nvidia gfx management.

Because of the used personality with AMD gfx the above edit is needed for the 3D variant to avoid the blackscreen issue at boot.

 

For all variants of the L702x: Sound is broken after update to 10 9.3 or 10 9.4. The working solution should be to copy over the updated AppleHDA.kext from S/L/E to desktop and add in it´s Resources folder the layout88.aml.zlib and platform.aml.zlib files from the for 10 9.2 by Webcivilian patched kext. After installing the AppleHDA.kext back with reparing permissions and a first reboot by ignoring caches and a second one with caches, sound should start after about 30 seconds.

 

If this is not working for you, just install back the patched AppleHDA.kext from 10 9.2.

 

I have found no other issues. It seems, that the update is safe.

 

Have fun.

Link to comment
Share on other sites

Hello!

 

@ Webcivilian!

 

Sorry for the ApplHDA issue. I have started with switching over to clover with a fresh 10 9.3 install and had therefore to add manually the aml files to the Resources folder. Is for sure working in the way you have done it thanks.

 

I have a work in progress to make the L702x 3D variant fully working with native recognized AppleBacklightDisplay. If I can get it stable working and there is a common interest of active participating members here, I will upload them. (By the way, begging me by PM does not make me sharing my partial advancements by PM with a single member - If I do that, I sare them with all members of the community)

 

In any case the Appstoresoftwareupdate is not safe for the 3D variant, ending after update with a black screen, caused by changes in the Nvidia gfx management. I personally prefer updating systemversions by downloading the comboupdates, run them and before rebooting digging around in S/L/E looking for updated versions of important kexts. In this way I have never got a not revertable messup on all my devices starting with 10 6.0.

 

@Luznik

If you can not get  your 3d variant installed with the guide of Webcivilian, because of not dedected sources for the device in db (Look after a minute or so in the installprotocol for errors), you have to follow this guide  starting at choice 2: http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/?p=2019599

 

This is the last post in this thread, that I have done for things only concerning the 3D variant of the L702x, because  I want to keep the thread on topic.

 

Have fun.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Hello!

 

@ Webcivilian!

 

Sorry for the ApplHDA issue. I have started with switching over to clover with a fresh 10 9.3 install and had therefore to add manually the aml files to the Resources folder. Is for sure working in the way you have done it thanks.

 

I have a work in progress to make the L702x 3D variant fully working with native recognized AppleBacklightDisplay. If I can get it stable working and there is a common interest of active participating members here, I will upload them. (By the way, begging me by PM does not make me sharing my partial advancements by PM with a single member - If I do that, I sare them with all members of the community)

 

In any case the Appstoresoftwareupdate is not safe for the 3D variant, ending after update with a black screen, caused by changes in the Nvidia gfx management. I personally prefer updating systemversions by downloading the comboupdates, run them and before rebooting digging around in S/L/E looking for updated versions of important kexts. In this way I have never got a not revertable messup on all my devices starting with 10 6.0.

 

@Luznik

If you can not get  your 3d variant installed with the guide of Webcivilian, because of not dedected sources for the device in db (Look after a minute or so in the installprotocol for errors), you have to follow this guide  starting at choice 2: http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/?p=2019599

 

This is the last post in this thread, that I have done for things only concerning the 3D variant of the L702x, because  I want to keep the thread on topic.

 

Have fun.

 

 

im interested as i have the 3D model 

 

 

what i really want to know is there any sorta of pre-made iso for the L702X 3D systems or the L702X standard that can be a few mods to get working with 3D display

other wise looks like im going to have to go though some bunch of guides lost trying to figure {censored} out 

 

i want to dual boot this and windows 8.1 update 1 on a 120 SSD i also have a data hhd that i can use to store others infos  the ssd is just for booting to mostly.

 

guess i will try to figure it out and maybe ill post results 

Link to comment
Share on other sites

is there a updated guide with all info learned over the course of this thread all rolled up  for the two models.

 

none of this {censored} makes sense.

i got as far as making the vmware mavericks install and would like to get usb formatted 

Link to comment
Share on other sites

Hello, I have an USB stick with Mavericks 10.9.4 and with clover, but I can't make it launch the installer on my laptop. Everytime I try to install it, the installation process stops and a forbidden sign appears on screen. What am I missing??

Link to comment
Share on other sites

Working perfect on a Dell L502X system. (i7 2670QM, 540m Nvidia)

 

The only thing missing is the card reader and some good geek bench results. Only getting 7400 points. (should it be around 9k?)

 

What do you think I should change? And how can I generate a DSDT and SSDT for my laptop automatically, to check if that would increase the scores :)

Link to comment
Share on other sites

Hey.

 

I've been trying to install Mavericks on my 3D L702x, but I can't reach the installer. It keeps hanging on "Could not communicate with Bluetooth Transport successfuly" . I'm also getting a few  "Found  transaction which hasn't moved in 5000 miliseconds". 

 

I've setup a config.plist in VMware sandy + nvidia + generate. I put in boot params IGPEnabler= No, GraphicsEnabler=Yes, PCBootUDID=0.

 

If i try to load the installer from the USB3 ports it stalls at IOProviderClass

 

Can you give me any pointers?

Link to comment
Share on other sites

  • 1 month later...

Hello,

 

Timewalker's guide is excellent. works like a charm. Thanks him for that. Jus t have a question: is HDMI (Video audio) connection working in dell xps 17 L702x Optimus? or is it just audio out working? 

Link to comment
Share on other sites

  • 3 weeks later...

Hello Everyone, 

 

After longtime time just checked out OS X on my XPS 17, looks like OS X turned into resource hogger.I really don't know the reason behind this and i don't know why apple not working on reducing the memory footprint where as Microsoft reducing memory consumption with every new update to its existing OS base.

 

Checkout the pics in order to have a better understanding how memory management working in OS X and Windows. Please leave your comments and feedback on this issue.

 

11vjybp.jpg

 

2u6gsn8.png

 

143i5o9.jpg

 

106buo4.png

 

 

1z2n3oo.png

 

 

 

Windows 7 SP1 RTM

 

20rpj88.jpg

 

 

Windows 8.1 RTM

 

o05hdw.png

 

 

Windows 8.1 RTM Update

 

20trvo7.png

Link to comment
Share on other sites

@mackyreddy i agree that macos uses too much resources and also asks you to upgrade to a new version to use certain software. Like i can use most of the software i use with XP on win8.1 but cant use xcode on older versions. Thats the main reason that i try to upgrade all the time. Still i wonder if it behaves same on a real mac too. anyone ? 

Link to comment
Share on other sites

Hello Community,

 

Wanted to discuss one issue. Installed Yosemite public beta, been using it for about 2 weeks. Everything seems to be working normal, managed to fix imessage and facetime, so all is ok, except one part - i can't enable location services.

I can switch it on, lock the preference, but after some time, location service gets disconnected ( i go to preferences and the check mark is unpicked for location services on).  

 

Solved. deleted locationd folder in /var/db somwehre, it was somekind of write-read error. 

Link to comment
Share on other sites

  • mackyreddy changed the title to macOS Monterey & Big Sur on Dell XPS 17 L702x Optimus
 Share

×
×
  • Create New...