Jump to content

macOS Ventura on Dell XPS 17 L702x Optimus


955 posts in this topic

Recommended Posts

  • 2 weeks later...

Hi There..

First thank you all for your time and efforts.


I just want to add a small information, the tutorial worked perfectly except for the audio (ACL665).

If you reboot the machine from a Linux session the audio will not work, you need to make a complete shutdown to have the audio working.

Link to comment
Share on other sites

  • 4 weeks later...

13. Now Copy OSInstall.mpkg from XPS 17 10.8.x Kexts Pack and replace the existing OSInstall.mpkg in your USB ( /System/Installation/Packages/)
14. Now Copy OSInstall from XPS 17 10.8.x Kexts Pack and replace the existing OSInstall in your USB(/System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/)


Where can I find OSInstall.mpkg and  OSInstall folder? There are no such files in "XPS 17 10.8.x Kexts Pack V3.zip".

Link to comment
Share on other sites

Question for DoiX or anyone that can help me. I used DoiX's installer package to get things working on my XPS 15Z. My question is how could I patch my own DSDT that i extracted with the patches that have been made to the default dsdt from the installer? if so, how can I go about doing so? I am not a cpu whiz so please bear with me. I just dont know where to begin and which patches to include in my DSDT...please Help! Another thing is I although I get audio working after patching the default dsdt from the installer with the ALC269 patch and AppleHDA, i still do not have Microphone working. Any ideas? 

Link to comment
Share on other sites

  • 2 weeks later...

Well sure mate I can, Thanks!


Its the DELL xps 17 vel l702x (16 ram, 2670 sandybridge, gtm 555 3gb 3D graphics with intel hd 3000 integrated into the processor)

I am running a win7 homeprem os right now and its located at the ssd drive but I have a 700 gb hdd as a second drive(hard).

I want to install a few OPS's that is preferably both win 7 and osx (and maybe if possible the win8 on it as well?? u think its worth it?) and the 700gb hdd would be off for linux distros = fedora 20 alpha, ubuntu ...? ) 

anyone to tell how to sort out the config scheme?

I am stuck now at the creating of a bootable Mountain Lion (i was trying with 10.8.5 now and it was failured = the pen did not boot any bootloader or OSx installation menager. And now i will try to complete the guide from this topicbut with 10.8.3 probably and maybe that will work. In the 10.8.5 kext extension folder there was not those kexts that the guy ask for to delete in his guidefor example there was no AMD namedkext only ATI kexts so I did not delete any . And some other weak stepes like that. then after creating a bootable pen I dowunladed a chemeleon installer and installed it from the installator there and that was probly the mistake wasnt it? it ruined it?




and then amI gonna be able to update easly form a 10.8.3 to 10.8.5 ???



Link to comment
Share on other sites

@ Lucznik - The guide is for L702X non 3D version that is the Optimus version where we have to disable the nvidia card as it does not work. For your setup it should work out of the box and you don't have to delete any kext.


You would need to first get a clean version of the OS X image preferably from the Mac App Store. You would also need to get an unlocked BIOS which would enable Speedstep for your CPU or you will kernel panic and you won't be able to load the setup. http://www.insanelymac.com/forum/topic/273500-os-x-mountain-lion-install-guide-for-dell-xps-17-l702x-optimus/?p=1865872

Link to comment
Share on other sites

I got the .dmg file that has all the L702X stuff all set up on it.

I did a restore to Both USB stick and Hard drive.  

I get error "Operation System Can not be Found"  I then made a Rescue USB stick.  I can boot from it to get the drive to load, but can not get Chameleon to load on boot from the hard drive.

I have tried:

Different Hard Drive.


Checking to make sure the partition was marked as active.


Any help would be greatly appreciated.

Thanks in advance.

Link to comment
Share on other sites

  • 2 weeks later...

Here what worked for me:


Used the MyHack installer to make a USB thumb-drive.  

From the mounted downloaded install image to you thumb drive, I copied:

  • dsdt
  • ssdt's
  • Extra folder and replaced what was there.
  • S/L/E I replaced that folder with the entire folder from the downloaded image. 

Then booted with flags: USBBusFix=Yes PciRoot=0 -v

Once in the installer I partitioned my Mac Hard Drive, which is in the primary bay:

Mac OS Extended Journaled 

With the Option of Master Boot Record (MBR).

Then ran the installer.

After the install was done, I copied those same files to my fresh install that I had copied to my USB.

There will still be some tweeks you'll need to do but that is what got me up and running with the initial install.


Side notes.

Switched out the wireless to a DW1501.  Works very well, is dual band and a/b/g/N

The display and everything look fantastic.  1080 ect.  It's very zippy.

I installed GuildWars on it for kicks and it runs great.

Mine has 8G of Ram as well and it detects it as it should.

Feel free to PM me if you have any questions.  It's been a few weeks since I did the initial but will try to help if I can.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

no way. 32 gigs ram , unlocked bios and sandybrindge proc will do !! anyone to check it ?


Check out Memory Management or Ram Usage at Idle on 10.6.8, 10.7.5, 10.8.5 & 10.9.


Mavericks is one of the worst release ever from apple, can be compared with Windows Vista ( Slow, Laggy, worst memory management, resource hogger and what not)


I would recommend to stick with OS X Lion 10.7.5 as its the best iteration available with proper optimization, anyway we would be playing with OS X 10.10 Developer Previews around April 2014, So just wait for few more months.



Link to comment
Share on other sites

Hello guys again.. Thanks to your posts and some own common sense, i managed to make the OSX almost 100% great :) one issue, as i understand, making osx startup disk, in order to have nvram and all other stuff, is not possible? because mine says that unable to make boot cache in boot helper partition. I am using dual HDD ( one for Win 7 and another for OSX).. Maybe you have the suggestions, or guide me in the right direction. 


I am using clover 2236 if i correctly remember. 


Thank you in advance

Link to comment
Share on other sites

@ mackyreddy - It's not resource hogger. If you go through the technical details, Mavericks compresses memory so it assigns the kernel more memory at one state so that it can write to the area and compress it even nothing is being compressed. Making sure that it's not available to any other process/app. It's being managed by the kernel now for allocation. Processes can still request memory the same way but the management has changed quite a bit.

@ Pashulia - For Clover to boot your OS X partition you need to have the modded BIOS to begin with. After that you need to go into the BIOS and enable the UEFI boot option. Also you hard drive needs to be GPT partitioned. 


Once you have these thing you can install OS X to that drive or if you already have those installed you need to install clover for EFI motherboard option. Its one of the option in Clover installer. You would also need config file and other items such as DSDT or SSDTs placed and correctly referenced in the clover's config.plist file.

Link to comment
Share on other sites

@ webcivilian - I have ML runing for about half a year. Everything you said is done and working flawlessly. Just one issue, as i understand, in order to create nvram and rc.shutdown.local ( if i know correctly) the ML system needs to be made as Startup disk ( in system preferences > startup disk ) but i can not do it, because it gives the error mentioned before. I can run system and everything, just can't make ML as startup disk and have brightness and sound values stored, to have them the same on next boot.

Link to comment
Share on other sites

@ Pashulia - Did you install on your OS X partition? Did you choose the EFI installation option? I don't think you can choose the start up disk from System Pref. You need to install the RC scripts to /etc. Using the Clover installer install the RC scripts if not done already. Or follow the below method of manually installing RC scripts. 

http://www.insanelymac.com/forum/topic/293246-mavericks-on-dell-vostro-3450-inspiron-14r-uefi-clover/ (The instructions should be at the end of the first post by TW)

Link to comment
Share on other sites

Thanks for the guide! It worked well for me a few months ago but now I have a problem after needing to reinstall.

I get to the part where install fails and you go through and clean out SLE etc.

I cannot proceed beyond this point, where you choose language / initial setup.

The screen is stretched horizontally and I can only see half of it.

I remember this happening last time but no idea what to do to fix it.

I've tried so many things, I am losing my mind for the past 48 hours.



2410m with 1600x900 display. geforce550m.

I have used a 2410 ssdt someone made, as well as creating my own (ssdt-0.aml through ssdt-6.aml)

Created my own dsdt, pretty sure that is what I did before.

Edited the chameleon boot plist to use 1600x900


All of the amd, ati, geforce, intel 4k, and all of those NVxxxx.kext, have been removed.

I've put dsdt and ssdt in /extra and/or root to seemingly no consequence.

I've used every combination of both mine and other peoples ssdt for the 2410m.

Please help, I am breaking down over here. It wouldn't be so bad if I didn't know it is capable of working, and that I was capable of getting it working, just 2 months ago.

Thank you!

Link to comment
Share on other sites


  • Create New...