Jump to content

macOS Monterey & Big Sur on Dell XPS 17 L702x Optimus


mackyreddy
 Share

945 posts in this topic

Recommended Posts

Well i always maintain the original version of DSDT which has layout id 665 beacuse as you know there are differences in memory consumption problem and i am working on it, i guess i uploaded that one, i will update again.

 

One request Webcivilian i have made quite few changes & alterations with regards to GFX & IGPU code and what not in the Nvidia Off DSDT, can you just take screenshots of Activity Monitor Memory consumption with different DSDT's ( From the new Kext Pack). I want to have a look at it.

 

cheers 

 

Edit:

 

Hello Everyone,

 

New Kext Pack has been uploaded with patches & tweaks to Stock A.19 DSDT, Nvidia Off DSDT with Dual Link patch, GFX0 & IGPU code changes, AppleHDA layout id changes, patches from Webcivilian, New Extra folder, updated kexts from Rehabman etc.

 

From now no more black or blank screen regardless of any DSDT :P

 

Have fun.

Link to comment
Share on other sites

I figure you should know this, boot.plist EFI doesn't inject only the DualLink Patch, but also correct values for the IGPU that closely matches the MBP one. I made it that way to reduce random artifacts. So if anyone is having them after switching to DSDT only patch, try adding the EFI string back to the boot.plist.  As far as i know, the DSDT will have priority over the EFI string so no conflicts will occur.

 

Also... depending on the string you have, it may also inject values for the NVIDIA card (when/if it's active)

  • Like 1
Link to comment
Share on other sites

i just done what u said, but when i boot from usb it say

 

boot 0: done

boot 1: error

 

i tried UEFI enabled/disabled... same thing... what can i do?

 

 

Well make sure you format the usb with MBR partition not GPT (guid).

how i can do it? When i restore it will format as source...

i need help

Link to comment
Share on other sites

@ DoiX - Yes, I have been using the EFI string and I don't have any artifacts. Also, it is needed to turn off NVIDIA card. I have tried the DSDT without the EFI string and card will get detected which means its not off. Maybe I'm not using the correct DSDT but I think injection works great. Thank you for that.

 

 

@ MBDip - Open Disk Utility and select your drive. Then go to the partition tab and in there you will see Options. click on that and there you can select the partition type such as GUID or MBR.

Link to comment
Share on other sites

@ webcivilian

 

Even the memory consumption problem has been resolved with the new DSDT. So can you confirm it  by taking screenshots of Activity Monitor Memory consumption with different DSDT's ( From the new Kext Pack). I want to have a look at it. 

 

@ Everyone

 

I would recommend everyone to update to the latest DSDT, as its one of the best available & better optimized DSDT for our laptop.

Link to comment
Share on other sites

Guest ananth

hey guys i installed mountain lion 10.8.4 using apple store image using the tutorial, i was able to go to the installation page with no errors.But the installation failed for some reason. i tried to boot into the os but it gave me an error(ACPI_SMC_PlatformPlugin:registerLPCDriver-failed to locate SMC driver) should i change the FakeSMC kext. Can u give me a proper fakeSMC kext for 10.8.4?

Link to comment
Share on other sites

Hello,

 

first my specs:

XPS17

i7 2830QM

Gefore GT555m 3D!

4GB Ram

Stock A19 Bios.

 

I just destroyed my old Mountain Lion Installation ( don't ask why please ;-) ).

Got it working with an USB-Install of 10.8.0 Appstore-Version in the past, but i cannot remember on how i got all this working so well -.-

 

So now i got an 10.8.2 Appstore-Version and followed your guide to make an USB-Install.

But i have the 3D-Version and the USB-Installer runs black after loading all kexts.

Is here someone with the 3D Version installed 10.8.2 with an USB-Install and got it working like a charm.

DSDT/SSDT and Kexts for the 3D-Version would be great. Read nearly the whole thread, but it is quite confusing because of the missing tonymac-links and so on.

The Guide for building the USB-Install is great. Thanks for that so far ;-)

 

Thanks in advance. And sorry for my bad? english, but i'm from Germany and it was a long day ;-)

Link to comment
Share on other sites

Just see my notes. Make sure to use DSDT of the same BIOS setup and version (yes, memory regions do vary even if you change some bios settings and thus the memap changes as well) it comes from originally, otherwise you may run into brightness keys not functioning issue.

attachicon.gifIOWMI_hotkoffy.zip

Tried it, but did not work.

Use A12 Bios, because this gives me best sleep/wake.

Here is my DSDT.

Hope to find a solution, because this is the only thing not working left (ok there is the intel wifi ;-) but thats just impoosible and found an alternative)

 

Thanks in advance

DSDT.zip

Link to comment
Share on other sites

@ mackyreddy - Which DSDT are you talking about? Is it the NVIDIA Off DSDT?

 

Also, did you test the device is turned off (NVIDIA) without the device properties? You might to have the graphics kexts installed to check it?

 

I can't get you ?

 

I asked you to compare the memory consumption in activity monitor using both DSDT's from the new kext's pack, as you said even you have a difference in memory consumption.

 

Well with the new Nvidia Off DSDT, the memory consumption problem has been sorted out and is working fine on my system, i don't have any problems and I am no longer using device properties.

 

what Graphics kexts are you talking about ? i have deleted all nvidia related kexts, all i have is intel hd 3000 kexts active on my system.

post-197843-0-61152500-1373305745_thumb.png

post-197843-0-22369200-1373305753_thumb.png

Link to comment
Share on other sites

Tried it, but did not work.

Use A12 Bios, because this gives me best sleep/wake.

Here is my DSDT.

Hope to find a solution, because this is the only thing not working left (ok there is the intel wifi ;-) but thats just impoosible and found an alternative)

 

Thanks in advance

Do you see a device like this in your Registry ? http://cl.ly/image/3g0e1G1n1B06

You should see the kext being attached properly if you've done the edits, but your memory OperationRegions are worng. If you don't see it, then you've failed to install the kext properly.

Link to comment
Share on other sites

  • mackyreddy changed the title to macOS Monterey & Big Sur on Dell XPS 17 L702x Optimus
 Share

×
×
  • Create New...