Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Dartamis

What network cards work?

613 posts in this topic

Recommended Posts

Can some of you list network cards that you have working (native), I can't seem to get mine to show up so I'll go pick one up at the store.

Share this post


Link to post
Share on other sites

Broadcom 57xx Onboard NIC - DIDN'T WORK

3Com 3C19250 USB NIC - DIDN'T WORK

3Com 3C980-TXM - DIDN'T WORK

3Com 3C905C-TX - WORK

 

did you post this question on 360hacker?

Share this post


Link to post
Share on other sites

i think my 905c croaked.... it's not getting power from the bus... doesn't matter which slot... it does seem to get power at weird angles while inserting it but once fully seated... no juice

Share this post


Link to post
Share on other sites
Broadcom 57xx Onboard NIC - DIDN'T WORK

3Com 3C19250 USB NIC - DIDN'T WORK

3Com 3C980-TXM - DIDN'T WORK

3Com 3C905C-TX - WORK

 

did you post this question on 360hacker?

 

hey tidal I posted that question on 360hacker, and your list looks familiar :D

Share this post


Link to post
Share on other sites

I owuld assume intel chipsets have more of a chance of working (natively). So any hardware built in onboard would be more likely. Im about to install on my dell 700m, *crosses fingers*.

 

although since a 57xx broadcom series card didnt work. i worry about my "broadcom 440x integrated controller.... brb..

 

 

-S

Share this post


Link to post
Share on other sites

Since the VMWare built-in ethernet drivers do not work, I am wondering if anyone had success using external USB ethernet cards with VMWare? I am not going to do a native install and would like to continue to use VMWare, but lack of network makes it difficult.

 

My other thought was to use the serial ports+ppp to do some kind of loopback remote access to my host OS. Haven't tried that yet, but I really do want to get this up and going.

 

-Robert

Share this post


Link to post
Share on other sites
Broadcom 57xx Onboard NIC - DIDN'T WORK

3Com 3C19250 USB NIC - DIDN'T WORK

3Com 3C980-TXM - DIDN'T WORK

3Com 3C905C-TX - WORK

 

did you post this question on 360hacker?

 

 

Broadcom 5701 *should* work. It's listed in the supported network cards from xplOdenet.com Have you actually tried and confirmed it does not? According to that site, ONLY the following should work:

 

3COM 3C90x

Broadcom 440x

Broadcom 5701

Intel 8254x

Intel 8255x

Realtek 8139

Realtek 8169

 

And also those supported by the below:

BMacEthernet

DP83816Ethernet

GMACEthernet

DEC21x4Ethernet

 

-----

 

I have OS X running in VMWare, but with no net, it's kind of useless. I have a P4 3.2 w/ SSE3 Hyperthreading and whatnot, on an Intel 915 chipset w/ 900 Graphics card. The network card is Broadcom 57xx GigaFast ethernet. If it doesn't work, though, I won't bother with a native install. If it *does*, it sounds like I'm in great shape.

Share this post


Link to post
Share on other sites
My Intel Pro/100 works perfectly.  OSX thinks it's "Built-in Ethernet."  Hah!

 

Intel PRO/1000CT (ASSUS P4C800E-Deluxe) also works. *Yes*, I am running native. I haven't enabled the onboard sound yet (that's next).

 

 

 

*Smirking*

Share this post


Link to post
Share on other sites

VMWare works with a serial port / PPP connection. I used a demo of Virtual Serial Port Driver XP v5 to create a pair of serial ports. I bound one of them to Incoming Connections, no flow control, 115200. Allow directly connected users to connect without a password, give it a pair of IP addresses under TCP/IP config.

 

The other serial port I bound to the Virtual Machine. Within OSX select the Null Modem at 115200 as your modem, unselect compression and wait for dial tone. Under PPP Options, select use terminal window. Click Connect. When the terminal window appears, type in CLIENTCLIENT and hit enter (you won't see anything in the window as you type). The XP side should respond with CLIENTSERVER. Click connect. If all goes well you'll be connected via PPP.

 

Those of you using Native mode can probably do the same thing with a null modem cable.

 

There's some hacks you can do to your mdmhayes.inf to prevent needing to type in CLIENTCLIENT manually:

 

http://www.tivohelp.com/archive/tivohelp.swiki.net/45.html

 

We do the same trick for directly connected TiVos, should work fine here too.

Share this post


Link to post
Share on other sites

I just bought a new Realtek 8169 card (Compusa)

 

I install boot up and have a connection. All of a sudden I get the Restart screen. I reboot and when I go back I have 9 PCI3 Slot Realtek cards and I cannot get connected once again. Is there a fix for this?

 

Thank you

Share this post


Link to post
Share on other sites

All linksys cards do not work <_< . but that is expected, as linksys is a PC only card manufacturer. Looks like I need to shell out on a Realtek card. Does anyone know if there are any Realtek's that support Ubuntu 5.04, windows, and OSX86? Cause networking is essential in Linux :rolleyes: .

Share this post


Link to post
Share on other sites

my Broadcom 57xx Onboard NIC does NOT WORK

I have Dell Optiplex GX280

 

please, if someone can remove that card from supported list, because IT DOES NOT WORK, and I have tried virtualy anything possible to make it work...

Share this post


Link to post
Share on other sites

My broadcom 57XX onboard does not work, interestingly it works fine under Darwin 8.0.1. When I boot in single user verbose mode it complains about not being able to get an interrupt

 

got it working by disabling plug'n'play OS in my bios - also fixed onboard ac97 sound.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×