Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Cheezmen

Dell Inspiron 530

17 posts in this topic

Recommended Posts

General Info

Snow Leopard 10.6.4 (has been running since 10.5.3)

latest AnVAl bootloader

All Vanilla (Except appleHDA)

 

 

 

Working

Shutdown/Restart

Native Speedstep (Via DSDT)

Graphics (with NVIDIA 8600GT, unsure of onboard graphics)

Processor (Q6600 with tape mod for 3GHZ)

RAID MODE (unsure of actual raid, but system boots when the bios is set to raid)

Atleast 3/4 SATA ports (if 3 work, 4 most likely do)

Audio Out with 5.1 (Use Aggregate device to achieve this, using ALC 888 Binary modded appleHDA

Bluetooth and Card Reader (connected through usb channel)

DVD DL/SL + - burning

Native Ethernet with additional kext

Firewire (TI Firewire card, included by Dell)

All Memory SLots (2GB per slot max)

PCI Cards

Front and Back USB

** These two with community FakeSMC kexts

Temperatures (CPU,GPU,HD,Northbride)

Fan Speeds

 

 

Not Working - If you can help with these, Please do

Wake up from sleep - (succesfully goes to sleep mode {eg. power light blinks} however, upon wakeup fans increase and decrease speed, while nothing appears on the monitor, and it has no ping{Possibly due to use of WLAN card})

Hibernate (Previously working, unsure of problem)

PowerButton bringing up power menu

 

ATTACHED - Dellinspiron530.zip

Single Legacy Patches Kext (AHCI, Bluetooth, SMC, AGPM)

DSDT.dsl

Dellinspiron530.zip

Share this post


Link to post
Share on other sites
General Info

Snow Leopard 10.6.4 (has been running since 10.5.3)

latest AnVAl bootloader

All Vanilla (Except appleHDA)

 

 

 

Working

Shutdown/Restart

Native Speedstep (Via DSDT)

Graphics (with NVIDIA 8600GT, unsure of onboard graphics)

Processor (Q6600 with tape mod for 3GHZ)

RAID MODE (unsure of actual raid, but system boots when the bios is set to raid)

Atleast 3/4 SATA ports (if 3 work, 4 most likely do)

Audio Out with 5.1 (Use Aggregate device to achieve this, using ALC 888 Binary modded appleHDA

Bluetooth and Card Reader (connected through usb channel)

DVD DL/SL + - burning

Native Ethernet with additional kext

Firewire (TI Firewire card, included by Dell)

All Memory SLots (2GB per slot max)

PCI Cards

Front and Back USB

** These two with community FakeSMC kexts

Temperatures (CPU,GPU,HD,Northbride)

Fan Speeds

 

 

Not Working - If you can help with these, Please do

Wake up from sleep - (succesfully goes to sleep mode {eg. power light blinks} however, upon wakeup fans increase and decrease speed, while nothing appears on the monitor, and it has no ping{Possibly due to use of WLAN card})

Hibernate (Previously working, unsure of problem)

PowerButton bringing up power menu

 

ATTACHED - Dellinspiron530.zip

Single Legacy Patches Kext (AHCI, Bluetooth, SMC, AGPM)

DSDT.dsl

 

@Cheezmen

i too am trying to fix my hack to get wake-up-from-sleep.

I have an Inspiron 530. My CPU is Core 2 Quad Q9300 running at 2.5Ghz.

It is based on P35/G33 chipset.

 

I have tried ATI X1900 card and nvidia gt 240

I am using sleepenabler and NullCpu....kexts

arch=i386 in boot plist as I get a KP if it boots 64 bit (something about No HPET...CPU configured incorrectly...bla bla )

 

I had a look at your DSDT and it is very different from mine.

 

I can get restart to work but Shutdown just does the same as restart

Sleep hangs the 530 - i.e. does not wake up.

 

You seem to have made more progress than I have.

 

At the moment I do not really want to mess with over-clocking but just to get the basics working.

Questions: Do you know what I would have to change in my DSDT for the CPU ? secondly, will your DSDT work on my rig ?

Share this post


Link to post
Share on other sites

For Shutdown to work properly on 530s, try turning OFF Remote Wake Up in the Power Management Setup of the BIOS.

 

@Cheezmen

i too am trying to fix my hack to get wake-up-from-sleep.

I have an Inspiron 530. My CPU is Core 2 Quad Q9300 running at 2.5Ghz.

It is based on P35/G33 chipset.

 

I have tried ATI X1900 card and nvidia gt 240

I am using sleepenabler and NullCpu....kexts

arch=i386 in boot plist as I get a KP if it boots 64 bit (something about No HPET...CPU configured incorrectly...bla bla )

 

I had a look at your DSDT and it is very different from mine.

 

I can get restart to work but Shutdown just does the same as restart

Sleep hangs the 530 - i.e. does not wake up.

 

You seem to have made more progress than I have.

 

At the moment I do not really want to mess with over-clocking but just to get the basics working.

Questions: Do you know what I would have to change in my DSDT for the CPU ? secondly, will your DSDT work on my rig ?

Share this post


Link to post
Share on other sites

I just got 10.6.3 working on my Dell Inspiron 530 like 30mins ago. So far, I have working onboard sound, ethernet and video. Obviously video is only 1024x768 until i get a cheap nvidia card. Front and rear usb work. The front card reader kinda works (tried a SD and Memory Stick, MS not worky). I can also shutdown and restart without issue. Haven't tried sleep yet though.

 

My 530 is an E4500 Core2Duo 2.20GHz.

Share this post


Link to post
Share on other sites
General Info

Snow Leopard 10.6.4 (has been running since 10.5.3)

latest AnVAl bootloader

All Vanilla (Except appleHDA)

 

 

 

Working

Shutdown/Restart

Native Speedstep (Via DSDT)

Graphics (with NVIDIA 8600GT, unsure of onboard graphics)

Processor (Q6600 with tape mod for 3GHZ)

RAID MODE (unsure of actual raid, but system boots when the bios is set to raid)

Atleast 3/4 SATA ports (if 3 work, 4 most likely do)

Audio Out with 5.1 (Use Aggregate device to achieve this, using ALC 888 Binary modded appleHDA

Bluetooth and Card Reader (connected through usb channel)

DVD DL/SL + - burning

Native Ethernet with additional kext

Firewire (TI Firewire card, included by Dell)

All Memory SLots (2GB per slot max)

PCI Cards

Front and Back USB

** These two with community FakeSMC kexts

Temperatures (CPU,GPU,HD,Northbride)

Fan Speeds

 

 

Not Working - If you can help with these, Please do

Wake up from sleep - (succesfully goes to sleep mode {eg. power light blinks} however, upon wakeup fans increase and decrease speed, while nothing appears on the monitor, and it has no ping{Possibly due to use of WLAN card})

Hibernate (Previously working, unsure of problem)

PowerButton bringing up power menu

 

ATTACHED - Dellinspiron530.zip

Single Legacy Patches Kext (AHCI, Bluetooth, SMC, AGPM)

DSDT.dsl

 

 

My firewire is not working . The disk shows in system profiler but not mounted. It also does not show up in disk utility. Any advice is greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

Since I didn't have luck with my beasty amd machine, I'm going to try and turn my old dell inspiron into a hackintosh to get me by until I can build a better one.  I am wondering what distro these guys used to get it working.  iatkos? 

Share this post


Link to post
Share on other sites

no distro (only to restore in disk utility.. then erase and go full retail).. just retail 10.6 and USB 8GB restored to USB from .DMG with restore tab in disk utility to a GUID partitioned and formated HFS+ then copy /Extra to it and install chameleon 2.x to it

 

these files are needed

/Extra/DSDT.aml

/Extra/SMBIOS.plist

/Extra/org.Chameleon.Boot.plist (with proper settings.. use chameleon wizard)

/Extra/Extensions/FakeSMC.kext

 

i have a DSDT for inspiron 530 that works sleep, wake, power buton menu and shutdown if u have a nvidia video card

 

also similar to "chance of snow at 530" pack.

Share this post


Link to post
Share on other sites

My inspiron is the dual core one, if I get it working, would I be able to upgrade my processor the the q6600 quad core model?  It says it will work on the board, and if i replaced it, does osx auto install drivers for upgraded hardware or would i have to reinstall?

 

Still trying to figure out how to use the extra files like DSDT and the others to install. 

Share this post


Link to post
Share on other sites

get the dell part number and we can find out if it is.. theres 2 models of the board.. one does NOT work with core2 quad or duo.

should be something like  CN-0#####

 

how to use the files ? chameleon 2.x loads those files automaticaly on boot from /Extra/

 

pretty much .. u need to make a USB OSX disk. then install chameleon 2.2 to it and put the Extra folder in usb... now boot setup.

when done. bot usb and this tiem boot the hdd from USB. when done, copy the Extra frm USB to hdd root then install chameleon 2 to the HDD.

dont forget to install FakeSmc.kext to /System/Library/Extensions with kext wizard or some tool.

 

http://www.insanelymac.com/forum/topic/253697-dell-inspiron-530/page-4

 

no need to redetect new  cpu.. chameleon 2 does this.

Share this post


Link to post
Share on other sites

cn-0g679r-73604-926-0402 is my board's serial number.

 

It's possible to use 2 usb sticks to install something like aitkos? one for distro and one for chameleon?

 

I don't have dvds big enough for full aitkos install QQ

Share this post


Link to post
Share on other sites

wait what about kernels, since someone is actually responding somewhere.  On my AMD, I am running an fx series processor, and a few months ago a kernel was released for it.  How do I use the downloaded kernel?  I am using Niresh.

Share this post


Link to post
Share on other sites

 http://en.community.dell.com/support-forums/desktop/f/3514/p/19392474/19915558.aspx

Dell Inspiron 530 530 SMT SFF Motherboard G679R RY007

You need to Find if the board says G33M02 or G33M03 on it in white letters.

The G33M02 does not work with quads.  The G33M03 does.

Bios version 1.15 or higher is required for newer CPU's

My recollection is that G679R RY007 says G33M02 under the

square aluminum heatsink in the Center of the board.

you have cn-0G679R so it looks like no upgrade to quad.. maybe core2 duo some models

 

 

kernel is a file on root of hdd its invisible unless u unhide hidden files. use a tool called unhide and hide for osx

 

http://www.insanelymac.com/forum/topic/282707-chameleon-install-on-usb-without-existing-osx/

use a 8gb USB but u need to install chameleon to it from windows . there is a tool but ive never used it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×