Jump to content

10.4.1/4/5 Live and Install DVD


81 posts in this topic

Recommended Posts

So Modbin, what all can the DVD you made do? Does everything work once it boots up to OS X? Is it just like having it installed? Can you just put it into most newer PCs and boot from it?

 

(Once I can get some of this info, I'll write an article about it and I'm sure it'll bring a lot of really interested people to help work on/improve things. :D )

@Mash

download the rar from my last post and watch the video inside.

it is just like having it installed,but some apps don`t work.

I think it is ram disk issue for most of them like iTunes.

most of the apps are working.

 

@all

is there anyone who followed my instructions and made a DVD?

 

 

update: delete or patch /usr/bin/login otherwise you get pam error when opening Terminal

(lazy me haven`t tested terminal).

 

 

make a new folder

/Network

and

/Network/Library

and

/Network/Users

and

/Network/Applications

 

and see what happens.

 

 

work to do for you:

make a global ram disk!

or we have to add a lot of them in rc.cdrom

and my desktop is already full of them,watch the video they are called untitled.

 

 

 

 

the following is only testing!

and only testing!

 

I think it is save to paste in all of your preferences com.apple.whatever.plist into/private/var/root/Library/Preferences/

 

paste

/System/Library/Speech/Voices

to have all the voices if you need.

 

added

/system/library/dictionaries

/system/library/find

searching still doesn`t work.

 

/System/Library/StartupItems

/System/Library/Caches

/System/Library/CFMSupport

/System/Library/ColorPickers

/System/Library/Colors

/System/Library/ColorSync/Scripting

/System/Library/ColorSync/Calibrators

/System/Library/Filters

/System/Library/Image Capture

/System/Library/Keychains

/System/Library/LocalePlugins

/System/Library/LoginPlugins

/System/Library/Modem Scripts

/System/Library/Monitor Panels

/System/Library/Printers

/System/Library/ScriptingAdditions

/System/Library/Security

/System/Library/StartupItems

/automount

/cores

/private/tftpboot

 

pasted

/System/Library/ColorSync/Profiles

/System/Library/Components

/System/Library/Services

/System/Library/Spotlight

/private/etc

 

now my /System/Library folder on DVD is completely synced to my hd one.

I only left out the extensions directory and bootcache.

do not replace anything!

 

made ram disk for automount and Network in rc.cdrom.

like:

#

# Create a RAM disk for /Network

#

echo "Creating RAM Disk for /Network"

dev=`hdik -drivekey system-image=yes -nomount ram://1024` # 512k

if [ $? -eq 0 ] ; then

newfs $dev

mount -o union -o nobrowse $dev /Network

fi

 

doesn`t work like I thought.

modbin, you have done more in a month than what all of us devs have been able to do for over half a year! :( BAH! You should go and start updating the main status page regularly now that you have basically fullfilled our original LiveDVD goals. Awesome work man...I think I should probably cede this forum to you :laser:

 

Also, I think I'll try to adapt Charles's ramdisk system to the system you've built. Hopefully, this will be a little more convenient and add some more functionality.

ok some hints for you revenge:

 

 

ok we will add the Charles bootcd ramdisk now

 

1. download bootcd and make a iso

ok it doesn`t work

you have to copy newfs_hfs from /sbin to /usr/sbin first

and if you like add the bless command from 10.4.1

 

2. copy some stuff from the created bootcd to your DVD; always same location

/usr/bin/RamDisk (it is also in bootcd.app)

/ramdisk

/private/etc/RamDisk

3. replace everything inside the contents folder

with your stuff

 

example:

/private/var/root (the complete folder)

you should now have:

/private/etc/RamDisk/contents/private/var/root

now delete /private/var/root

and replace it with a new created hex file called root

inside the hex file you should only have

/ramdisk/contents/private/var/root

in hex:

2F72616D6469736B2F636F6E74656E74732F707269766174652F7661722F726F6F74

it is like a hard link or alias,maybe you find a better way to create it.

 

I am no shure what the difference is between

private hex= 70726976617465

/private hex= 2F70726976617465

../private hex=2E2E2F70726976617465

 

some hardlinks have private some /private and other have ../private

 

!PLEASE FIGURE THIS OUT AS I`M NOT WORKING ON RAMDISK!

 

4. finally add the following line to your rc.cdrom

 

/usr/bin/RamDisk etc/RamDisk 5.000000 /ramdisk

 

maybe add -inkernel (not shure)

 

/usr/bin/RamDisk etc/RamDisk 5.000000 /ramdisk -inkernel

 

5.000000 = 5Mb

 

don`t forget to delete the original ramdisk in rc.cdrom

 

WORK TO DO:

load Loginwindow,if someone is famillar with IDA Pro please disassemble it.

that`s the main goal now,so we can remove finder,dock,systemuiserver from rc.cdrom as loginwindow does the job for us.

 

 

update of my instructions and rc.cdrom:

http://rapidshare.de/files/29733666/update.rar.html

some notes for loginwindow :construction:

 

use "Reset Password.app" to set new root password for your DVD or hack the original

(I really like to know what password apple set for root)

 

paste /private/var/db/.AppleSetupDone

 

add:

BUDDYCOOKIE="/var/db/.AppleSetupDone"

in rc.cdrom

 

loginwindow now loads :construction: instead of Setup Assistant

but doesn`t accept my password :-( Netinfo Manager does )

 

 

I have 2 questions:

where are the passwords stored in OSX?

 

is there anyone working on this?

My 250 Gb Maxtor crashed yesterday,every osx live related stuff is gone. :compress:

So no updates for the next time.

 

:):) :censored2: :censored2: :censored2: :censored2: :censored2: :censored2: :censored2: :censored2: :censored2: :censored2: :censored2:

 

Any chance of recovery? Was it a physical head crash?

luckily I posted all important steps in here. :sorcerer:

so I have a new Hard Disk and just made a new Live/Install DVD

:D

the instructions are all ok, but if someone is willing to work on BOOTCD ramdisk please -

I have to say the hex hardlinks I posted above are not working :-(

The Ramdisk is working fine but I wasn`t able to link my desktop to the ramdisk.

An alias is working but if I try to make a new folder on Desktop, Finder crashes.

  • 2 weeks later...

mobdin... i'm having some trouble.

 

i used to hdiutil attach lalala.iso -readwrite

i moved all the folders you said, clicking don't replace for all of the ones that already exist, and edit all the files you said to and the dvd size remains the same as before?

 

also when i try use the image in vmware it loads the desktop (without dock or finder) and the rainbow pinwheel just keeps spinning.

 

what am i doing wrong?!?!? :S

mobdin... i'm having some trouble.

 

i used to hdiutil attach lalala.iso -readwrite

i moved all the folders you said, clicking don't replace for all of the ones that already exist, and edit all the files you said to and the dvd size remains the same as before?

 

also when i try use the image in vmware it loads the desktop (without dock or finder) and the rainbow pinwheel just keeps spinning.

 

what am i doing wrong?!?!? :S

 

the dvd size is ok it is only a container, but the free space inside will be reduced.

did you put finder,dock and systemuiserver in rc.cdrom?

I guess not,but you can use my version of rc.cdrom it is in one of the downloads.

but I can post the latest version of it if you need.

does it mount your hd and dvd?

is the pinwheel spinning for ever and can you move it ?

some more details please.

good to hear that someone is working on the stuff.

btw which version 10.4.4?

hey mobdin, i'm using 10.4.4-5 myzar image. i edited rc.cdrom and put finder and dock in but not systemuiserver i think. i'll try using your version of rc.cdrom.

I can move the pinwheel it just never loads os x.

I don't know if it mounts my hd and dvd yet seeing as i haven't been able to get to the desktop. I'm going to try later and see if using your rc.cdrom will fix things :P

 

 

i'm hoping for a rainy weekend so i can stuff around with it some more.

ta Dragon

hey mobdin, i'm using 10.4.4-5 myzar image.

 

I`m using the same 10.4.4-5 myzar.

so it should work.

maybe try to install without the 10.4.5 update and paste the stuff in, cause the install dvd is version 10.4.4.

but if i remember correctly it should also work with 10.4.5.

always boot with -v to see the error messages.

anyway here is the latest version of my rc.cdrom and a screenshot of the new licence agreement

i used the one fravia made. :blink:

http://rapidshare.de/files/32363291/insanelymac.rar.html

mobdin, it seems like people are interested in this live dvd.... but I think the main reason no one is doing anything is because your instructions are all over the place.

 

i think that you would get a whole heap of people into it by creating a ppf that people can just apply on the dvd. I don't know if that would be legal or not. still you could do that or you could get ALL of your instructions and files and make a tutorial/guide type of thing. put everything in order so that people can follow the instructions more carefully.

 

BTW, i'm reinstalling 10.4.5.

I plan to give it a try using the JaS 10.4.7 install DVD. My system is an IBM ThinkCentre (8183) which runs SuSE Linux 10.1 on one primary partition and OSX86 JaS 10.4.6 on the other. The System Profiler says:

 

CPU Type: Intel® Pentium® 4 CPU

Number Of CPUs: 1

CPU Speed: 3.4 GHz

L2 Cache (per CPU): 512 KB

CPU Features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT

PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM EST

 

Memorex DVD16+/-DL4RWnD2:

Firmware Revision: 1.A1

Interconnect: ATAPI

Burn Support: Yes (Unsupported)

Profile Path: None

Cache: 2048 KB

Reads DVD: Yes

CD-Write: -R, -RW

DVD-Write: -R, -RW, +R, +RW, +R DL

Burn Underrun Protection CD: Yes

Burn Underrun Protection DVD: Yes

Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO

Media: No

 

Display:

Type: VGA-Compatible Controller

Bus: Built-In

VRAM (Total): 128 MB

Vendor: Intel (0x8086)

Device ID: 0x2572

Revision ID: 0x0002

Kernel Extension Info: No Kext Loaded

Displays:

Display:

Resolution: 1600 x 1200

Depth: 32-bit Color

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

 

I have ordered an external firewire disk enclosure to hold a spare 160GB HDD and a fresh install of JaS 10.4.7. Will see what happens and let you know.

 

Now, to expose my ignorant noob status with OS X. I could use some pointers to information on creating CD/DVD images that are bootable on non-apple intel systems.

 

I have been able to open the JaS ISO image I downlaoded, modify it and have it bootable after burning it to a DVD-RW. However, when I tried making copies of the image or making an image from scratch they would not boot. I know it is possable to create hybred disk images for MAC/PC. I just have no idea how to do it.

 

I would appreciate it if someone could point me to the correct book/how-to to get me started.

Guest
This topic is now closed to further replies.
×
×
  • Create New...