Jump to content

DELL Vostro 3700 / 3xxx ( i5, Nvidia 330M ) OSX86 Snow 10.6.3

288 posts in this topic

Recommended Posts

EDIT 2010-06-12: Thread renamed. Lets collect knowledge here. Everybody welcome! :-)


current state of the vostro 3700 project 2010-06-23:


- 10.6.3 working

- LAN (native)

- Graphic (native / +QE, full Acc + Res, with GraphicsEnabler=yes )

-- HDMI works, hotplug is o.k., dualscreen / extended monitor o.k. No sound transfer yet.

- Firewire (native 400)

- USB (native)

- Trackpad (Synaptics 7.2) with basic tapping:

-- basic tapping: via 10.5.6 Synaptics Trackpad Enabler (see this thread)

- Sound ( VoodooHDA_with_volume_control_fix_vostro_3700.kext.zip - thanks @piyokos :) )

- Bluetooth:DellBluetoothHCI.1.2.pkg ( Skype + Logitech Headset = o.k.! )

- Battery Time approx. 100 min

- hibernate / deep sleep see Post #281

- WIFI via original air port (compatible) card Post #137


missing: internal W-LAN, real sleep, Trackpad gestures


10.6.4 update: breaks my LAN (Internet and VNC works) so better keep 10.6.3 for now.






------------------------- old start post:




maybe someone knows what to do:


I try to install Snow 10.6.2 to my new DELL Vostro 3700 ( i5-430M 2.26 GHz, Nvidia Geforce 330M, 17 '', ) .

The target-HD is connected via USB.

The first step works with the SnowLeoDVD (10.6.2). My settings:

System: Base & Tools

Bootloader: Cham. RC4 10.5

Chipset: LegacyAHCI

Patches: Fake, NullCPU, PlatformUUID, HaltRestart


When I start with the DVD I need boot options:


busratio=20 -v

(or busratio=17 -v)


without busratio I get a immediate reboot.

With this bootflag the first step from DVD works up to the the first reboot promt ("Install Succeeded, reboot").

Then reboot: The Chameleon Loader starts and shows my new partition on HD, I start (busratio=20 -v) but right after loading of the kexts something crashes and then immediate reboot!

It´s so fast I even can not read the last command lines to get any hints.

I tried some other busratios ( 17, 22, .. ) and also some combinations with cpuratios but no success.


when I boot without -v I see the white start screen with the apple logo flashing for the part of a second, then reboot.


Any help for me out there ?


I thought the vostro 3700 should work well on OSX due its MBP near hardware ( 330M Graphics, i5, .. ) and the price is amazing. Performs great on cinebench!


Many thanks in advance!

Link to comment
Share on other sites

I have the same Vostro 3700, I did the bootcd and retail SnowLeo dvd approach.


At first I could not get it to work, got mostly "CPU Halted" and rebbot, trying with several "Busratio=x" values, it turned out to be that I had 6GB ram, removed 4GB and now the boot cd could boot an start the installation.


I tried so many times I have forgot the steps but I vill do it again, but I do remember that the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd from tonymacx86 didn't work. I used Empire EFI 1.085r2 cd to get it to work.


Booted on Empire EFI cd and swaped the cd to the retail dvd, have the 10.6.3 retail dvd, booted with "busratio=16 cpus=1 -v -f -x" got "Install failed" please restart at the end of the installation.


Restarted with the Empire EFI cd in and the same boot flags, finish the installation and installed myHack with as little extra as possible. Didn't reboot as I installed the MacBookpro 5.1 smbios.plist from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] package, changed all the 5.1 to 6.1 in smbios.plist and installed the MacBookpro 10.6.3 update, re installed myHack and rebooted.


As I didn't load any "drivers" for, not true had to use the one for ps/2 support from myHack package to get the touchpad to work, removed the vendor id from touchpad pref.pane to get it loading.


I do have some problems to get the USB ports to work, the error I get at boot is well known, might work with a DSDT file.


I did get the USB to work once (sounds promising) and when they did the webcam was working. They did work when I booted with a not documented "busratio=x cpus=x" combination.


Well I didn't remember the values....



Link to comment
Share on other sites

Hi to both of you, i bought the vostro as i thought it would be idle to install snow leopard


i installed using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], nvidia version from tonymac, use busratio=17 (i5-430m) -v -x -f


swap dvd at startup for 10.6 retail, when fails at end restart with ibeast busratio=17 -v -x -f


finish install, updated to 10.6.2 couldnt update to 10.6.3 as keeped crashing.


then installed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. then can boot with just busratio=17


USB didnt work so removed applehep.kext then usb works, web cam etc, full graphics.


Benchmarks very good.


Wireless still not working, and cant update to 10.6.3 to install macpro update.


I get 1 cpu showing with two cores, with the macbook pro update does it correctly show the i5 processor in the about box.


So really would like to get wireless working if anyone can help.


So its nearly there but not quite, but make sure it does hiberate, as that will lock it and you will have to go into disk utility and repair permissions.


You can let the screen sleep but stop hard drives turning off.


Not sure if speedstep is working or not.


Any further help from you guys is always appreciated.


If anyone has a good dsdt file for this vostro then let me know


Mine i5-430m, 4gb ram gt330m, wirelss 1520 dell half card.

Link to comment
Share on other sites

Thanks for feedback! :-)




get it working with iPortable Snow, prepared on a desktop on a USB drive.

iPortable Snow / 10.6.2


first boot on the 3700:

busratio=20 cpuratio=20 cpu=2

some tweeks, then

update to 10.6.3 on my Desktop (Q6600 / P35-DS4 Board)

then boot without flags possible.

set kernel to "legacy_kernel"

when 10.6.3 update on 3700 -> KP


Graphics: 330 works like a charm with GraphicsEnabler=yes, native

Cinebench 11.5 results:

OpenGL: 15,62 fps :-)) ( CPU / Render: 1.73 )


boot with -force64 works



Network / LAN: works:

Realtek RTL8111DL Ethernet Controller

Installed: RealtekR1000SL.pkg


Sound: works:

VooDooHDA 2.5.3 Snow Leopard


Bluetooth: works:




missing / not working:


Internal WIFI / W-LAN

dont know if I need

Dell Wireless WLAN 1397 Half MiniCard


Dell Wireless WLAN 1520 Half MiniCard


any Idea what to use there to get it working ?


Sleep: Not working ( SleepEnabler 10.6.3 active )

Monitor gets dark, CPU fan continues running, Power Button is on

Tried to get deep sleep, but no success yet.


I also search something to dim the display

Something for better CPU Power management ( fan is always running - is this normal ? )

Something for battery control.


I am not shure, Dell says the Trackpad is able for gestures (??), didn´t found this working unter Win 7


anyway, stay tuned .. :-)

Link to comment
Share on other sites

Nice some good headway.


Im going to have another go at 10.6.3 so i can install the macpro update


wireless card is 1520 bcn43xx chipset but tried a few things but none seem to work.


Im interested to look at the dsdt update as this maybe get sleep working,


do your usb always work or did you remove the applehep file.


im interested in trying the installation the way you did it, are you running it all from usb drive or are you ending up with it on your hard drive, i have another box can you give me a nice detailed how you got where you are.


Also your using busratio=20 what i5 you got in your vostro. As ive got i5-430m which needs busratio=17 i thought

Link to comment
Share on other sites

It turned out that I got i5-540m in my Vostro (Thanks Dell), but I only paid for the ordered i5-430m, so I need to use busratio=18 to get it to work.

With the right busratio I got [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to work for installation and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to get it to boot, just started to sort out the why I still have difficulties to get the USB to work, sometimes they do and sometimes they don't...


I have the A02 bios, the latest, have tried with A01 bios at first.


Later this evening I will remove some ram to see if that has something to do with it, I have 6 GB.



Link to comment
Share on other sites

short update:


on a second try network (Cabled LAN) runs also native :-)

No need for RealtekR1000SL.pkg


just wait a bit or remove and add new.


Snow Book now goes into production as mobile desktop replacement, but many things is still missing:


- Something that turns off NVIDIA and goes Intel Accelerator to save battery

- also a down(!)clocking tool to save energy and allows fanless / quiet operation.

fan is always running! battery lasts for 100 min. Guess no speed step yet.

- sleep ( deep sleep / hibernate )

- internal W-LAN / WIFI

- Trackpad: Only basic operation, no tap detection or gestures.

- Card Reader




- LAN (native)

- Graphic (native / +QE, full Acc + Res, with GraphicsEnabler=yes )

- Firewire (native 400)

- USB (native)

- Trackpad (native, basic functions)

- Sound ( VooDooHDA 2.5.3 Snow Leopard)

- Bluetooth:DellBluetoothHCI.1.2.pkg ( Skype + Logitech Headset = o.k.! )


sometimes I get KP on boot. But when booted its stable.



when I start manually with -force64 (legacy_kernel) It works fine.

If I add -force64 or arch=x86_64 to the Extras/**boot.plist it ALWAYS crashes (???)


If we get success with some more things we could collect a Vostro 3xxx package. :-)

Link to comment
Share on other sites

I think we are getting closer...


Just a short update, need to get my kidz to help me clean up the house before grand mam is coming...


I've tried the tool to switch graphics card on the MacBook Pro, but it don't work, but card is listed as a Nvidia 9x00m GT, guess that has something to do with the bootloaders.


I got the MacBook Pro update to work, but only when installing with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and the native 10.6.3 Snow DVD, if I start with the 10.6.0 it panic when installing the 10.6.3 update.


When I booted from a recovery Snow USB image I got from a friend it looks like the Wireless is visible, have to dig in to this later tonight.


It look's like a lot of new lap's are using Core i5/7 GT3x0m and qm/hm 57 chipset, so things are looking god to sort out errors.



Link to comment
Share on other sites

Give me an idea how it works out for both of you. I'm thinking of pulling the trigger on one of these in a week or two for OS X, mostly concerned about general stability and how well the 330M works.

Link to comment
Share on other sites

Just a short update..


For the GT 330m, I just use "Graphics Enable=y" i com.apple.boot.plist and installed 10.6.3 dvd. In verbose boot I can see that NVDANV50Hal.kext is loaded with/to the graphics card.


It's kind of strange as it shows both an PS/2 and USB conection, I use the VoodoPS2 from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] pakage. Mine is a Synaptics.

As for the trackpad I have some to two finger touch working, scrolling and zooming is working and it was something more don't remember right now.


For the Dell 1520 I guess it will not work, as I reed on a web site that the card sitting the new MacBook Pro has the same chip from Broadcom but are a built together with BT on the same card/PCIe slot, and as we can use BT this might be hiding the WiFi part on the same PCIe bus, or something like that.


I have got a "rescue" usb stick from a friend, think it's built on a dmg file called something like 911Leo or Leo911.

When I boot on this the WiFi card are shown in system profile but can not bee used, I will try to update the usb with the drivers from the MacBook Pro update as this has the right kext for the chip.


Oh, I haven't found any way to "switch" graphics on the Dell, don't think it is possible, haven't got it working in Windows ether. Maybe the Dell can only use the Nvidia card to save money in production/support who knows...


Or I haven't understand how it works... That wouldn't be the first time that happend....




Link to comment
Share on other sites

Just a short update..


For the trackpad I have some to two finger touch working, scrolling and zooming is working and it was something more don't remember right now.



How did you get the Trackpad working?

Mine is still out of the the box, 1-Finger Tracking + both Mouse Keys, no tapping.


System says Synaptics 7.1 or something like this.


My Sys - state is unchanged, but the basics works stable. Sometimes it does a KP on start, but when started again no problems. Expect for virtual Machines, I tried parallels 5 and VMWare Fusion and both make a full crash (reboot) when try to start a VM. strange.

Audio is also strange, It works but you cannot mute or change volume.

Link to comment
Share on other sites



Let's see, my Vostro is a European version, with 1600x900 display, I did get a i5-540m not i5-430m as was ordered, my Dell also had a sticker beside the trackpad showing some two finger functions and this is working in Windows with the factory installed drivers.


On delivery it had the A01 Bios I upgraded it to A02 since I at first had problems to get my USB ports to work, but that made no difference for that I think.


As for the trackpad I use the VoodooPS2 that is in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] pakage, to get the trackpad pref pane to work I followed this guide " http://www.insanelymac.com/forum/index.php?showtopic=142466 " and it worked.


Have to leave home for some domestic work, so no messing around with my SnowyDell for a month, bhuuu bhuuu.....


But when I get back I will try solve some of the remaining problems.



Link to comment
Share on other sites

How did you get the Trackpad working?

Mine is still out of the the box, 1-Finger Tracking + both Mouse Keys, no tapping.


System says Synaptics 7.1 or something like this.


My Sys - state is unchanged, but the basics works stable. Sometimes it does a KP on start, but when started again no problems. Expect for virtual Machines, I tried parallels 5 and VMWare Fusion and both make a full crash (reboot) when try to start a VM. strange.

Audio is also strange, It works but you cannot mute or change volume.


Hey, just ordered a 3700 with a 330M video card so hopefully I can join the little group here. But preliminary diagnosis: occasional KP/crash on boot, volume with no mute/level access, probably means a DSDT issue. Try upgrading the laptop bios and also compiling a custom DSDT with "DSDT patcher". I'm attaching the proper application (for OSX) to this post. You can also use this guide:




Tell me how it goes!


Link to comment
Share on other sites

Hello all,


I have a Sony VAIO VPCF115FM laptop (with very similar configuration to the Dell Vostro 3700). I have created a very detailed set of guides AND a customized Boot CD (you need to use a SL R 10.6.3 DVD for the install). If any of you would like to give it a tray and see if it works for you on your machine, that would be great.


Here is the link:



OH! You will need to use a different DSDT then ours though.


The more people we have trying to get devices working, the better!





Link to comment
Share on other sites

USB didnt work so removed applehep.kext then usb works, web cam etc, full graphics.




I have Vostro 3400 Corei5-520M 2.4Ghz with Geforge 310M 512MB and 4GB RAM.


I installed with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]-Supported 2.0 and Retail 10.6.3 as it's the ONLY combination that works. The problem is that one the USB hub/controllers doesn't get detected so i have no USB ports, webcam or wifi that is detected either.


You mentioned removing this file. Where is it ? Can you provide more details on how you did it cause if i can get my USB ports working, i can finally concentrate on getting the rest of it working..


Thanks for your help,



Link to comment
Share on other sites

Hi, you should have a look at the Blog now from Tonymacx86 as the new version of [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is supposed to overcome the USB problem.


I tried it buy it made things worse by completely wiping out USB.. Not even the built in keyboard and track pad work any more..


Oh well, looks like I'll have to wait for someone to make DSDT for the Vostro 3400 as my attempt failed miserably.



Link to comment
Share on other sites

I had success with iPortable Snow. Just download, its a very cool package with all tools you need.

You can generate your DSDT easily self after the first start.

I did the update to 10.6.3 on another machine ( bootet it on a gigabyte P35-DS4 desktop, did the update, then back to vostro 3700). I did the first step of installation on a external USB drive.


I did no changes on the installation since my last post.

Was out of office on a job with the 3700 for some days and it worked very well and fast as desktop replacement! :-)

Just need to get hibernate/sleep and maybe tapping on the trackpad. Battery Time is approx. 100 min.


Strange is the total crash / reboot when triying to get Parallels or VMware startet.

Link to comment
Share on other sites

Well, the 3500 arrived today and I'm busy trying to get OSX properly sorted (booting from the combined esata/usb port).


I am trying to do things as vanilla as possible for the moment and resisting throwing kexts into the extensions folder. This means it is slow going as every now and again you get to a system that you just have to wipe and start again from (and I am working from retail 10.6.0 and then applying combo updates!).


Things came to a bit of a grinding halt and left me head scratching fpr a while when i encountered the USB problem - i.e. ports not working. Unfortunately the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] solutions don't work for this board, so I had to go back to good old DSDT editing. However, I am on the brink of a breakthrough as my last edits brought the USB ports to life, Unfortunately, my graphics were screwy at that stage, so now I am going back and re-installing again. At least though I am working from a DSDT that I know has some of the right stuff in it!


Going to bury my head now and work, but when I get things workable I'll post a guide.....


Good luck !


Here's some piece of advice that sort of worked for me :


Use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 - Supported and install from 10.6.3 Retail DVD. This will get you full Nvidia support right from the start.


After that well good luck getting the USB ports to work. I tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 but didn't get very far. I know i need a proper DSDT but my attempt to make one failed miserably.. Hope you can do better.



Link to comment
Share on other sites

bit frustrating now ..


I get VoodooPS2Controller-0.98-installer.pkg




removed all Apple PS2 things and also AppleACPIPS2Nub.kext


while trying sometimes trackpad basic work, sometimes KP on start, sometimes no Trackpad


Current state:


ALL Apple PS2 things/.kexts + AppleACPIPS2Nub removed (also in "Extra/Extensions/"), on System/Extensions just:

- VoodooPS2Controller.kext


Pref Pane: shows VoodooPS2, I can enter and set parameters, but no effect and after restart all settings is lost and resetted. Trackpad still works basically, no tapping or gestures. Keyboard also works

Link to comment
Share on other sites

For an i5-430m vostro 3700, do I need to pick up a copy of 10.6.3 retail from an Apple store in order to use it with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]?


I have 10.6.0 retail CDs but all I get is unstability, weird video issues, a KP when I try to install the 10.6.3 combo over it, plus I need busratio=20 just to boot.

Link to comment
Share on other sites


  • Create New...