Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
nawcom

10.6.3 legacy kernel for INTEL/AMD ready to download by qoopz/nawcom - a few new features

Recommended Posts

Alright, xnu src was released so that means patching up that source code so everyone else can use the latest and greatest kernel.

 

Standard fixes are included, plus a few extra stuff:

 

* Built-in kernel blacklister automatically blacklists bad kexts from loading. Therefore you don't need to use a disabler to disable it manually

* bigger dmesg Which translates to a larger log file so that you can troubleshoot easily

* uuid patching/fix Eliminates the need of UUID kext or specifying manually

* fsb detection

* cpu cache detection

* reboot fix- Eliminates the need of OpenHaltRestart and fixes shutdown/reboot issue

* sse3emu -SSE3 emulator for SSE2 processors . Bear in mind that most of the applications in Snow Leopard run fine with this emulator.

 

Some things added:

 

* For people wanting to use XCode apps, I decided to add all the CHUD kexts to the kext blacklist. This means no more kp hell when installing and dealing with the development tools. If anyone thinks this is something that shouldn't be added, let me know.

 

Features in this specific package:

 

* If you have SleepEnabler installed, your SleepEnabler kext will get updated. If you don't use it, don't worry about it - it won't get installed.

* All of the CPUIDs in the new versions of programs from the 10.6.3 update will get patched. this means you don't need to deal with the hell regarding iTunes, etc.

 

(The actual patcher program also gets installed (/usr/local/bin/patcher, you can run from anyware via Terminal) as well as the CPUID text file (/Library/CPUIDs/*) Though this is only important to people who love control and want to be able to run it themselves :-P - this is all automated in the installer regardless. Unfortunately we still havent gotten on the fly patching working, so this is a reasonable fix for it for now.)

 

I do make cpuid files for updates and keep them online http://nawcom.com/osx86/cpuids/ for AMD people to use regarding updates as well as a nice frontend to Maxxuss' patcher app, drag and drop a cpuid.txt file onto the app to launch it - just like Taruga's HDA Patcher.

 

Anyways, good luck to all. Source diffs are always available. -> http://nawcom.com/osx86/files/10.6/Kernels...-1504.3.12.diff

 

If anyone wants to contribute I'm always on irc - irc.osx86.hu #snowleopard #hackint0sh; irc.voodooprojects.org #chameleon #xnu-chat; irc.moofspeak.net #osx86.

 

Updated code - If you had issues before please try the new version

 

For the people that have been getting instant reboots, so far them booting with arch=i386 works. I am looking into why this is needed in this version of the kernel by looking into diffs between xnu versions. Since this kernel is only one architecture i386 is the only real option. I've updated the pkg so it checks to see if you have arch=i386 in kernel flags, and if you don't it will add it to your kernel flags.

 

External link: http://nawcom.com/osx86/files/10.6/Kernels...-10.3.0.pkg.zip

Another External link: http://www.mediafire.com/?mqyzohqmnyg

 

If you are looking for the 10.6.2 xnu kernel, look here: http://www.insanelymac.com/forum/index.php?showtopic=191606

Edited by nawcom

Share this post


Link to post
Share on other sites
Advertisement

Working great as the old one. Only problem so far (same as every kernel) when running in 64bit it won't load 32bit apps at all, instant crash.

Share this post


Link to post
Share on other sites

Works on my AMD phenom II system, however the FSB detection is off, i suppose this shouldn't be too difficult to fix since the bk kernel had this fixed in 10.6.2.

Furthermore it reports my 800mhz ddr2 ram as 1600mhz.

Also, -force64 works, i got to run galaxies but most apps crashes etc and no 64bit extensions etc.

 

Apps i tried in forced 64bit mode that crashed:

Chess

iTunes

Quicktime player 7

DVDplayer

EnergyXT

Coda

Garageband

Macirssi

Logic express 32 and 64 bit mode

...

 

Also it seems like iTunes wont work in 32bit mode either, anyhow thanks for the quick kernel:)

Share this post


Link to post
Share on other sites

works fine on amd (phenom 9600) and finally it boot -force64 , and like all we know, no 32bt app is working :(

Share this post


Link to post
Share on other sites

Yeah I've heard of some issues regarding some intel processors. There are some little changes in some of the code regarding cpuid.h and .c as as well as lapic.c which might relate to how the added code gets incorrectly handled in regards to intels. I should have this fixed by the end of today.

Share this post


Link to post
Share on other sites

On my wks in signature i tried the kernel...

All works great and really fast...

Only issue i had (and this is why i revert to old 10.2) is with mouse.

It is an usb keyboard and mouse from microsoft, drivers are from microsoft.

With your kernel, my mouse run strange, very slow and not fluid, like moving in little steps...

Thanks

Share this post


Link to post
Share on other sites

Thanks for the new kernel. It looks the kernel is somewhat unstable on my system. I got KP while booting the system.

And CPU frequency shows incorrectly in dmesg:

 

TSC: Frequency = 0.0000MHz, FSB frequency = 201.30763MHz, bus ratio = 10

 

Also reboot fix does not work. I had to restore OpenHaltRestart.kext in order to reboot the system properly.

Share this post


Link to post
Share on other sites

Hello,

 

thanks for the kernel 10.3.0 - it helped to my SnowLeo to come up

on my Acer 5220. Unfortunately my Leo on disk0s2 does not come up.

I am going to search for solution.

Kind regards,

 

bozon42

 

PS: rewritten /Volumes/SnowLeo/legacy_kernel -->mach_kernel

in :

/Extra/com.apple.Boot.plist

/Library/Preferences/SystemConfiguration//com.apple.Boot.plist

rewritten:

legacy_kernel -->mach_kernel

 

and OK!!!

p2: Leo -v -f arch=i386 cpus=1

p3: SnowLeo -v -f

 

Regards,

 

bozon42

Share this post


Link to post
Share on other sites

hi nawcom and qoopz,

 

Just to let you know guys, this one and the old 10.2.0 kernel from you broke the legacyhda solution, running on 10.6.3 system with 10.6.2 AppleHDA. It was ok with stock 10.3.0 kernel.

Share this post


Link to post
Share on other sites

Works great on my Pentium-D. Finally got it upgraded from 10.5 to 10.6. One trick though; If you have >= 4GB RAM, you need to add the kernel flag -force64 to make it boot. Nawcom, was this what your patch for "instant restarts" fixed?

 

 

One more issue: whenever I shutdown or reboot, it appears to zap my CMOS. I didn't have this in 10.5. Any ideas? Can I disable the built-in shutdown/reboot and go back to OpenHaltRestart?

 

Thanks again!

Share this post


Link to post
Share on other sites

Hey rayflower, I modified this kernel to include the Phenom FSB detection, but I'm still waiting to see if Andy has some more fixes to add before I put it online. Also, I don't know what changed, but I have the same problem that fxwizrd has where the CPU speed is not detected, even though the FSB is correct. As for OpenHaltRestart.kext, I still use the one that was posted a while back on my EFI partition and it works great.

Share this post


Link to post
Share on other sites

Thanks for the fabulous works.

 

So far snow 10.6.3 ran great for more than a week on my AMD 8450+ ASUS M3A78.

 

A pity is that the voodooHDA still not work with this kernel (or vise verse) for my VT1708B, which worked great when in leopard age with your leopard kernel.

Share this post


Link to post
Share on other sites

I just wanted to share that I upgraded to the 10.3.0 latest revision (Apr 4 19:13). And all the previously mentioned problems are still present:

- CPU clock does not show correctly

- reboot fix does not work. I still have to use OpenHaltRestart.kext

- KPs occasionally

 

I attached screenshots of KPs with previous and current revision of kernel.

post-98067-1270923739_thumb.jpg

post-98067-1270923759_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×