Jump to content
MadTux

New ALC861VD ALC268 ALC660/660VD

239 posts in this topic

Recommended Posts

Post here only feedbacks when using these kexts, dont't ask for help, for that go to another topic:

How to Patch AppleHDA.kext

THX Eddie94 for making installers. U are the man!

This deletes AppleAzaliaAudio.kext and install AppleHDA.kext and AppleHDAEnabler.kext!

In all the installer you must select your driver!ONly into the alc268 installer is selected default the first MT driver!In others you must select your driver!

P.S. U must remove EFI string for audio if U have

Packages:

ALC861VD: ALC861VD.mpkg.zip

ALC268: ALC268.mpkg.zip

ALC660/660VD: ALC660_660VD.mpkg.zip

 

ALC861VD Leo

Kext should give U IntSpeaker, HeadPhones, IntMic, ExtMic and Volume control with balance but no mute. It will show devices in System Profiler. It is for Leopard.

MadTux_ALC861VD_beta_Leo.zip

This is for Toshiba, poste the feedback and a model of laptop.

KEXT: MTux_ALC861VD_Toshiba_SysProf.zip

ALC268 Tiger/Leo

Thx collit99 for fixing headphones node pins in a kext.

MadTux_ALC268_A.zip

MadTux_collit99_ALC268_B.zip

ALC660/660VD Tiger/Leo

Thanks wiwi for modding to ALC660!

http://forum.insanelymac.com/index.php?sho...440#entry921587

 

How To Install

Remove AzaliaAudio.kext

Install HDAEneabler from Kabyl and the ALC kext downloaded from here.

Repair permissions and kextcache with OSx86Tools

reboot.

 

It will not kernel panic on HDAController. It just works, on Tiger and Leo.

 

HDAEneabler from Kabyl

HDAEnabler.kext.zip

Please post results. Don't just download :-)

 

Sound should come from speakers, and when you plug the headphones it should switch automaticly

Share this post


Link to post
Share on other sites
Advertisement
MadTux,

 

Thanks for all your hard work on these audio kext's. Unfortunately, I can't find HDEnabler anywhere. Can you help?

 

~Fix

I uploaded on first page.

Share this post


Link to post
Share on other sites
ALC861VD

This kext will give U IntSpeaker, HeadPhones, externalMic and Volume control but no mute.

 

 

ALC268

MadTux_ALC268_A.zip

 

 

It will not kernel panic on HDAController. It just works, on Tiger and Leo.

Use with HDAEneabler:

HDAEnabler.kext.zip

Please post results. Don't just download :-)

 

Sound should come from speakers, and when you plug the headphones it should switch automaticly

 

P.S If some one has newer codec dump for ALC862 card, please post it.

P.P.S if some one have vanilla HDA from 10.5.0 Leopard please post it.

 

Thanks for this new kext(ALC268), this headphone, speakers switch automatically is cool.

 

I will test this later.

 

by the way this kext fix shutdown But no sound coming from the headphone jack, and I also notice I can't use the mic in jack there's no option only the internal mic.

 

Thanks!

Share this post


Link to post
Share on other sites
Thanks for this new kext(ALC268), this headphone, speakers switch automatically is cool.

 

I will test this later.

 

by the way this kext fix shutdown But no sound coming from the headphone jack, and I also notice I can't use the mic in jack there's no option only the internal mic.

 

Thanks!

Yes, headphones problem is reported, and I puted only Internal mic, for first testings, if it works I will add new devices to codec.

P.S Do U have "Noise reduction" under Mic pref?

Share this post


Link to post
Share on other sites
Yes, headphones problem is reported, and I puted only Internal mic, for first testings, if it works I will add new devices to codec.

P.S Do U have "Noise reduction" under Mic pref?

 

Hmmm.. still can't get any sound from the headphone jack, the automatic switching is working.

 

Yup there's Noice reduction.

 

I will do further testing, I will also check the permission. But the switching is awesome I hope I can get the Headphone jack working.

 

Be right back.

Share this post


Link to post
Share on other sites
Hmmm.. still can't get any sound from the headphone jack, the automatic switching is working.

 

Yup there's Noice reduction.

 

I will do further testing, I will also check the permission. But the switching is awesome I hope I can get the Headphone jack working.

 

Be right back.

 

Try this, give me feedback.

MadTux_ALC268_Leo_Test.zip

Share this post


Link to post
Share on other sites

Ok I tried it on my Vostro 1510 and the audio seems to work a little bit louder but when I plug in my headphones I do not get any sound on them, how ever in the system prefs it does show it going from speakers to headphones. Any ideas.

 

I am hopeing that this new fix will also fix the shutdown issues that this has with the ALC268 on the Vostro 1510.

 

I have almost everything working ecept for the sleep mode. when it wakes up the audio does not work.

 

But this idea of have the sound change from speakers to headphones when you stick the headphones in is a really kewl ideal.

 

 

Thanks

Scott

Share this post


Link to post
Share on other sites

Nice, but what about this? http://forum.insanelymac.com/index.php?showtopic=127227

I've been trying to complete the procedure... I just have many things on my mind... such as the way to *probably* getting to work the Netlink Gigabit PCI-x Broadcom card on this Acer 5315; besides me being so lazy... I just enjoy the freedom of using its airport anyways.

 

Anyhow, here I am... wondering which way should I go... the one where I would end up with a patched AppleHDA from 10.5.5 with the advantage of its newly-added codecs... or should I remain as lazy as one could be around these forums and just download both A & B alc268 files listed above along with HDAEnabler dot kext... for testing to see what happens?

 

Well... since I'm almost half way trough your guide... I guess I'll just keep going and see what happens, but I would like to see which would be the smartest choice depending on your advice. yes?

 

EDIT: what's the difference between A & B? btw... having a external mic, an internal one right by the crystal cam, a headphone, and internal spkrs... what would you keep and erase from PlatformDriver.plist's PathMap? perhaps I should have asked this somewhere else (in "How to patch...") but I'm just lazy... LOL (not enough to write as you can see...)

Share this post


Link to post
Share on other sites
Nice, but what about this? http://forum.insanelymac.com/index.php?showtopic=127227

I've been trying to complete the procedure... I just have many things on my mind... such as the way to *probably* getting to work the Netlink Gigabit PCI-x Broadcom card on this Acer 5315; besides me being so lazy... I just enjoy the freedom of using its airport anyways.

 

Anyhow, here I am... wondering which way should I go... the one where I would end up with a patched AppleHDA from 10.5.5 with the advantage of its newly-added codecs... or should I remain as lazy as one could be around these forums and just download both A & B alc268 files listed above along with HDAEnabler dot kext... for testing to see what happens?

 

Well... since I'm almost half way trough your guide... I guess I'll just keep going and see what happens, but I would like to see which would be the smartest choice depending on your advice. yes?

 

EDIT: what's the difference between A & B? btw... having a external mic, an internal one right by the crystal cam, a headphone, and internal spkrs... what would you keep and erase from PlatformDriver.plist's PathMap? perhaps I should have asked this somewhere else (in "How to patch...") but I'm just lazy... LOL (not enough to write as you can see...)

 

I suggest U to make 10.5.5 kext. Mine kexts, are for testings and work in progress, I created 268_A and 268_B (equal to ALC268_Install1 and Install2) to see does shutdown and mine pinconfigs works on these cards. I already moved to Leopard(I am running 10.5.5 for ALC862VD) with mine card.

And Yes, please ask questions on that Topic not here. I will be putting all kext that a made on this page. For easier feedback tests, not questions "How to patch 10.5.2 and above"

 

Ok I tried it on my Vostro 1510 and the audio seems to work a little bit louder but when I plug in my headphones I do not get any sound on them, how ever in the system prefs it does show it going from speakers to headphones. Any ideas.

 

I am hopeing that this new fix will also fix the shutdown issues that this has with the ALC268 on the Vostro 1510.

 

I have almost everything working ecept for the sleep mode. when it wakes up the audio does not work.

 

But this idea of have the sound change from speakers to headphones when you stick the headphones in is a really kewl ideal.

Thanks

Scott

 

No it is mine idea I was first who created kext for over year ago with this switch inside, go here for history lesson:

http://forum.insanelymac.com/index.php?showtopic=63957

Share this post


Link to post
Share on other sites

helo

actually i use alc 260 et AppleHDAPatcherv1.20 and i have to use sigmatel dump:

 

Codec: SigmaTel CXD9872AKD

Address: 0

Vendor Id: 0x83847664

Subsystem Id: 0x104d1300

Revision Id: 0x100201

Default PCM:

rates [0x7e0]: 44100 48000 88200 96000 176400 192000

bits [0xe]: 16 20 24

formats [0x1]: PCM

Default Amp-In caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1

Default Amp-Out caps: ofs=0x7f, nsteps=0x7f, stepsize=0x02, mute=1

Node 0x02 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out

Amp-Out caps: N/A

Amp-Out vals: [0x66 0x66]

Power: 0x0

Node 0x03 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out

Amp-Out caps: N/A

Amp-Out vals: [0xff 0xff]

Power: 0x0

Node 0x04 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out

Amp-Out caps: N/A

Amp-Out vals: [0xff 0xff]

Power: 0x0

Node 0x05 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out

Amp-Out caps: N/A

Amp-Out vals: [0x66 0x66]

Power: 0x0

Node 0x06 [Audio Input] wcaps 0x1d0541: Stereo

Power: 0x0

Connection: 1

0x07

Node 0x07 [Audio Selector] wcaps 0x300903: Stereo Amp-In

Amp-In caps: N/A

Amp-In vals: [0x00 0x00]

Connection: 1

0x0e

Node 0x08 [Audio Input] wcaps 0x1d0541: Stereo

Power: 0x0

Connection: 1

0x09

Node 0x09 [Audio Selector] wcaps 0x300903: Stereo Amp-In

Amp-In caps: N/A

Amp-In vals: [0x80 0x80]

Connection: 1

0x15

Node 0x0a [Pin Complex] wcaps 0x400181: Stereo

Pincap 0x08173c: IN OUT HP Detect

Pin Default 0x03211030: [Jack] HP Out at Ext Left

Conn = 1/8, Color = Black

Pin-ctls: 0xc0: OUT HP

Connection: 1

0x02

Node 0x0b [Pin Complex] wcaps 0x400181: Stereo

Pincap 0x0814: OUT Detect

Pin Default 0x400000fb: [N/A] Line Out at Ext N/A

Conn = Unknown, Color = Unknown

Pin-ctls: 0x00:

Connection: 1

0x04

Node 0x0c [Pin Complex] wcaps 0x400181: Stereo

Pincap 0x0814: OUT Detect

Pin Default 0x21211040: [Jack] HP Out at Sep Rear

Conn = 1/8, Color = Black

Pin-ctls: 0x00:

Connection: 1

0x03

Node 0x0d [Pin Complex] wcaps 0x400181: Stereo

Pincap 0x08173c: IN OUT HP Detect

Pin Default 0x03a1502e: [Jack] Mic at Ext Left

Conn = 1/8, Color = Red

Pin-ctls: 0x24: IN

Connection: 1

0x02

Node 0x0e [Pin Complex] wcaps 0x400081: Stereo

Pincap 0x0824: IN Detect

Pin Default 0x90371160: [Fixed] CD at Int N/A

Conn = Analog, Color = Black

Pin-ctls: 0x20: IN

Node 0x0f [Pin Complex] wcaps 0x400181: Stereo

Pincap 0x0814: OUT Detect

Pin Default 0x92171110: [Fixed] Speaker at Int Front

Conn = Analog, Color = Black

Pin-ctls: 0x40: OUT

Connection: 1

0x05

Node 0x10 [Audio Output] wcaps 0x40211: Stereo Digital

PCM:

rates [0x3e0]: 44100 48000 88200 96000 176400

bits [0xe]: 16 20 24

formats [0x5]: PCM AC3

Node 0x11 [Pin Complex] wcaps 0x400301: Stereo Digital

Pincap 0x0810: OUT

Pin Default 0x034513a0: [Jack] SPDIF Out at Ext Left

Conn = Optical, Color = Black

Pin-ctls: 0x00:

Connection: 2

0x10* 0x09

Node 0x12 [Audio Input] wcaps 0x140311: Stereo Digital

PCM:

rates [0x160]: 44100 48000 96000

bits [0xe]: 16 20 24

formats [0x5]: PCM AC3

Connection: 1

0x13

Node 0x13 [Pin Complex] wcaps 0x440381: Stereo Digital

Pincap 0x0834: IN OUT Detect

Pin Default 0x40c000fd: [N/A] SPDIF In at Ext N/A

Conn = Unknown, Color = Unknown

Pin-ctls: 0x00:

Connection: 1

0x18

Node 0x14 [Pin Complex] wcaps 0x400001: Stereo

Pincap 0x0820: IN

Pin Default 0x90a70020: [Fixed] Mic at Int N/A

Conn = Analog, Color = Unknown

Pin-ctls: 0x20: IN

Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out

Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=1

Amp-Out vals: [0x00 0x00]

Connection: 4

0x0a 0x0d 0x14* 0x02

Node 0x16 [beep Generator Widget] wcaps 0x70000c: Mono Amp-Out

Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=0

Amp-Out vals: [0x00]

Node 0x17 [Volume Knob Widget] wcaps 0x600000: Mono

Node 0x18 [Audio Output] wcaps 0x40201: Stereo Digital

 

 

but i can use the twice on the same time because one disable the other

do you have a solution?thanx for replie

Share this post


Link to post
Share on other sites

ok I have tried both versions and I get sound but none after sleep/wake The more that I look into it I think it has something to do when the laptop wakes up. I read somewhere that it rejects some .kext when it wakes back up. Dont know still learning on all this.

 

Scott

Share this post


Link to post
Share on other sites
Just noticed I lost the "Noise Reduction" when I got the External Speakers/Headphone working...

Can you write a short install guide for ALC268, please?

 

I have Internal Speakers working and I see the automatic switch between Internal Speakers and Headphone but I have no sound on Headphone. Why can I not completely mute the sound?

Share this post


Link to post
Share on other sites

Hey MadTux and collit99 I tried to modify AppleHDA.kext myself but had no luck.

Could one of you two geniuses try to adress the Alc268 problem that either mutes the sound after sleep or makes the volume really low both on headphone out? That would be awesome!

Share this post


Link to post
Share on other sites

ALC 268 driver works like a charm... i can finally shutdown my laptop without using the power button in the end

 

Thanks a lot....

 

Just a question, to all, since i installed the 10.5.5 from ideneb i have this strange issue with sound. It turn's off if it's not needed. literally this is what happens, the mute button becomes orange, and if i play a song (or whatever other action that requires audio) it unmutes itself. Does anyone have this issue???

Share this post


Link to post
Share on other sites
Post here only feedbacks when using these kexts, dont't ask for help, for that go to another topic:

How to Patch AppleHDA.kext

 

ALC861VD

This kext will give U IntSpeaker, HeadPhones, Mic and Volume control with balance but no mute.

 

ALC268

Thx collit99 for fixing headphones problem in kext.

MadTux_ALC268_A.zip

 

ALC660/660VD

Thanks wiwi for modding to ALC660!

http://forum.insanelymac.com/index.php?sho...440#entry921587

 

It will not kernel panic on HDAController. It just works, on Tiger and Leo.

Use with HDAEneabler:

HDAEnabler.kext.zip

Please post results. Don't just download :-)

 

Sound should come from speakers, and when you plug the headphones it should switch automaticly

 

P.S If some one has newer codec dump for ALC862 card, please post it.

P.P.S Please don't post dump here, if U want help about making kexts go here:

 

I used your kext for ALC268. Autosensing and shutdown now works! Only thing that does not work is mute. Sound is also very low when after waking from sleep.

Share this post


Link to post
Share on other sites
Can you write a short install guide for ALC268, please?

 

I have Internal Speakers working and I see the automatic switch between Internal Speakers and Headphone but I have no sound on Headphone. Why can I not completely mute the sound?

 

what kext are you using?

 

 

I used your kext for ALC268. Autosensing and shutdown now works! Only thing that does not work is mute. Sound is also very low when after waking from sleep.

 

Hmmm... Sound is okay after sleep not low on my acer 4310.

 

Can someone provide a quick how-to install this please?

 

Just use KextHelper.

Share this post


Link to post
Share on other sites

I have installed the second Kext for the ALC268 and It works fine. Now the OS recognizes when I connect the Headphone and falls back when I disconnect it.

 

Very good Job. Thanks for the patient and effort.

 

I have a new codec dump for ALC268. I did it with a Ubuntu Live CD. I list its contents below, but if you prefer I can post it in another place. It would be fine to get the external mic, Line in and SPDIF OUT working. If I can help in any way let me know.

 

 

Codec: Realtek ALC268

Address: 0

Vendor Id: 0x10ec0268

Subsystem Id: 0x1025011d

Revision Id: 0x100003

No Modem Function Group found

Default PCM:

rates [0x560]: 44100 48000 96000 192000

bits [0xe]: 16 20 24

formats [0x1]: PCM

Default Amp-In caps: N/A

Default Amp-Out caps: N/A

GPIO: io=4, o=0, i=0, unsolicited=1, wake=0

IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0

IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0

IO[2]: enable=0, dir=0, wake=0, sticky=0, data=0

IO[3]: enable=0, dir=0, wake=0, sticky=0, data=0

Node 0x02 [Audio Output] wcaps 0x1d: Stereo Amp-Out

Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0

Amp-Out vals: [0x21 0x21]

Converter: stream=0, channel=0

PCM:

rates [0x560]: 44100 48000 96000 192000

bits [0xe]: 16 20 24

formats [0x1]: PCM

Node 0x03 [Audio Output] wcaps 0x1d: Stereo Amp-Out

Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0

Amp-Out vals: [0x28 0x28]

Converter: stream=0, channel=0

PCM:

rates [0x560]: 44100 48000 96000 192000

bits [0xe]: 16 20 24

formats [0x1]: PCM

Node 0x04 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x05 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital

Converter: stream=0, channel=0

Digital:

Digital category: 0x0

PCM:

rates [0x5e0]: 44100 48000 88200 96000 192000

bits [0x1e]: 16 20 24 32

formats [0x1]: PCM

Node 0x07 [Audio Input] wcaps 0x100111: Stereo

Converter: stream=0, channel=0

SDI-Select: 0

PCM:

rates [0x160]: 44100 48000 96000

bits [0x6]: 16 20

formats [0x1]: PCM

Connection: 1

0x24

Node 0x08 [Audio Input] wcaps 0x100111: Stereo

Converter: stream=0, channel=0

SDI-Select: 0

PCM:

rates [0x160]: 44100 48000 96000

bits [0x6]: 16 20

formats [0x1]: PCM

Connection: 1

0x23

Node 0x09 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x0a [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x0b [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x0c [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x0d [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x0e [Audio Mixer] wcaps 0x20010a: Mono Amp-In

Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-In vals: [0x00]

Connection: 1

0x02

Node 0x0f [Audio Mixer] wcaps 0x20010b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-In vals: [0x00 0x00] [0x00 0x00]

Connection: 2

0x02 0x1d

Node 0x10 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-In vals: [0x00 0x00] [0x00 0x00] [0x80 0x80]

Connection: 3

0x03 0x1d 0x02

Node 0x11 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x12 [Pin Complex] wcaps 0x400001: Stereo

Pincap 0x0820: IN

Pin Default 0x411111f0: [N/A] Speaker at Ext Rear

Conn = 1/8, Color = Black

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Node 0x13 [Pin Complex] wcaps 0x400001: Stereo

Pincap 0x0820: IN

Pin Default 0x411111f0: [N/A] Speaker at Ext Rear

Conn = 1/8, Color = Black

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Node 0x14 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x00 0x00]

Pincap 0x081003c: IN OUT HP EAPD Detect

EAPD 0x2: EAPD

Pin Default 0x0221101f: [Jack] HP Out at Ext Front

Conn = 1/8, Color = Black

DefAssociation = 0x1, Sequence = 0xf

Pin-ctls: 0xc0: OUT HP

Unsolicited: tag=04, enabled=1

Connection: 1

0x0f

Node 0x15 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x00 0x00]

Pincap 0x081003c: IN OUT HP EAPD Detect

EAPD 0x2: EAPD

Pin Default 0x99130110: [Fixed] Speaker at Int ATAPI

Conn = ATAPI, Color = Unknown

DefAssociation = 0x1, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x40: OUT

Unsolicited: tag=00, enabled=0

Connection: 1

0x10

Node 0x16 [Pin Complex] wcaps 0x40010c: Mono Amp-Out

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x80]

Pincap 0x0810: OUT

Pin Default 0x411111f0: [N/A] Speaker at Ext Rear

Conn = 1/8, Color = Black

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x00:

Connection: 1

0x0e

Node 0x17 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x18 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out

Amp-In caps: ofs=0x00, nsteps=0x02, stepsize=0x4f, mute=0

Amp-In vals: [0x00 0x00]

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x80 0x80]

Pincap 0x083734: IN OUT Detect

Vref caps: HIZ 50 GRD 80 100

Pin Default 0x02a19840: [Jack] Mic at Ext Front

Conn = 1/8, Color = Pink

DefAssociation = 0x4, Sequence = 0x0

Pin-ctls: 0x24: IN VREF_80

Unsolicited: tag=00, enabled=0

Connection: 1

0x02

Node 0x19 [Pin Complex] wcaps 0x40008b: Stereo Amp-In

Amp-In caps: ofs=0x00, nsteps=0x02, stepsize=0x4f, mute=0

Amp-In vals:

Pincap 0x083724: IN Detect

Vref caps: HIZ 50 GRD 80 100

Pin Default 0x99a30941: [Fixed] Mic at Int ATAPI

Conn = ATAPI, Color = Unknown

DefAssociation = 0x4, Sequence = 0x1

Misc = NO_PRESENCE

Pin-ctls: 0x24: IN VREF_80

Unsolicited: tag=00, enabled=0

Node 0x1a [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out

Amp-In caps: ofs=0x00, nsteps=0x02, stepsize=0x4f, mute=0

Amp-In vals: [0x00 0x00]

Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1

Amp-Out vals: [0x80 0x80]

Pincap 0x083734: IN OUT Detect

Vref caps: HIZ 50 GRD 80 100

Pin Default 0x0281304e: [Jack] Line In at Ext Front

Conn = 1/8, Color = Blue

DefAssociation = 0x4, Sequence = 0xe

Pin-ctls: 0x20: IN VREF_HIZ

Unsolicited: tag=00, enabled=0

Connection: 1

0x02

Node 0x1b [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x1c [Pin Complex] wcaps 0x400001: Stereo

Pincap 0x0820: IN

Pin Default 0x411111f0: [N/A] Speaker at Ext Rear

Conn = 1/8, Color = Black

DefAssociation = 0xf, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x20: IN

Node 0x1d [Pin Complex] wcaps 0x400000: Mono

Pincap 0x0820: IN

Pin Default 0x4017952d: [N/A] Speaker at Ext N/A

Conn = Analog, Color = Pink

DefAssociation = 0x2, Sequence = 0xd

Misc = NO_PRESENCE

Pin-ctls: 0x20: IN

Node 0x1e [Pin Complex] wcaps 0x400380: Mono Digital

Pincap 0x0810: OUT

Pin Default 0x02451130: [Jack] SPDIF Out at Ext Front

Conn = Optical, Color = Black

DefAssociation = 0x3, Sequence = 0x0

Misc = NO_PRESENCE

Pin-ctls: 0x40: OUT

Unsolicited: tag=00, enabled=0

Connection: 1

0x06

Node 0x1f [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono

Processing caps: benign=0, ncoeff=10

Node 0x21 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x22 [Vendor Defined Widget] wcaps 0xf00000: Mono

Node 0x23 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out

Amp-Out caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1

Amp-Out vals: [0x01 0x01]

Connection: 7

0x18 0x19 0x1a 0x1c 0x14 0x15* 0x12

Node 0x24 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out

Amp-Out caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1

Amp-Out vals: [0x01 0x01]

Connection: 7

0x18 0x19 0x1a 0x1c 0x14* 0x15 0x13

Share this post


Link to post
Share on other sites

Hi,

 

New AppleHDA kext with Internal/External MIC, still no mute but I'm working on it.

 

Based on ALC268Installer2.

 

Credit goes to Taruga and Madtux!

 

Auto switching and Shutdown(Without using HDAFIX v3) should work.

 

Works on my Acer Aspire 4310.

 

Still needs HDAEnabler.

 

ALC268_with_External_Mic.zip

Share this post


Link to post
Share on other sites

I have tried it in my Acer Aspire 4720z and only the internal mic is showing in the preferences. The headphone/internal speakers switching works fine.

 

Thanks for the effort.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×