Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
munky

[Guide] Boot from EFI partition, zero modification installs on Intel SSE2 or better...

1,407 posts in this topic

Recommended Posts

*** Special thanks to Turbo, Dense, dfe, zef and the rest of the chameleon team for making this possible... :D ***

 

** DEPRECATION NOTICE: This functionality is coming to a Chameleon release very soon. Once Chameleon supports this approach, this project will be retired. Thanks to everyone who uses this bootloader, thanks for the support and the kind words :D **

 

 

LATEST UPDATES:

 

- *** CHAMELEON 2 RC1 is out and looks pretty damned *amazing* - go check it out! It does everything this bootloader does and far more ***

 

- D'oh! v6 looks for DSDT.aml in the root partition, not EFI partition. v6.1 corrects this error.

 

- DSDT override patch now integrated (v6) (credit and huge thanks to mackerintel!), for 10.5.6 support.

 

- Source code attached. Didn't get round to commenting and cleaning up. Suffice to say, 99% of the work was done by dfe, turbo, zef and the team.

 

CHANGELOG:

 

- v6.1 corrects the bug whereby v6 looked for the DSDT.aml file in the root partition, not the EFI partition.

- v6 is a stopgap solution in case 10.5.6 hits before the new Chameleon is released. It supports DSDT.aml file in root of EFI partition.

- v5.1 fixes an error in the packaging - in v5, 'boot' was the v5 version, but 'boot-turbo-munky.bin' was still v4.

- v5 has updated FSB detection code from Chameleon

- Basic dual booting is possible. Just hit esc at darwin bootprompt and enter 81 for 2nd drive, 82 for 3rd...

- v4 now supports JMicron ATA

- v3 now supports Boot.plist on the EFI partition

- v2 now supports device-properties (aka EFI Strings) in com.apple.Boot.plist !

 

A *BIG* thank u to Chameleon team for sharing their great sources - porting was a cinch!

 

The release of dfe's amazing boot-132 loader was an eye-opener for many of us in the community. The fact we can boot the shrink-wrapped, unmodified retail Leopard DVD on modern Intel machines (and, it turned out, on any SSE2 or better Intel machine) means we have the ability to boot a totally unmodified OS X. (The install DVD of course boots into Mac OS X).

 

However, it seemed most people didnt realise the gravity of this, or simply thought 'oh thats nice, use retail to install. ok, back to hacking in /System/Library/Extensions....'.

 

This is, imho, the wrong approach.

 

The *right* approach is to leave /System/Library/Extensions alone, and apply patches and modifications to the system from a different vector, just like boot-132.

 

This is, in my humble opinion, the ultimate hackintosh install method.

 

What benefit does that give you?

 

* Well, how about trouble-free Software Update direct from Apple? Even on SSE2 Intels? (and AMDs when Voodoo 9.5.0 final comes out...)

 

* How about being able to completely erase and reinstall the OS without breaking ur carefully-assembled patches?

 

* How about being able to boot *the same disk* on a real mac and your hack?

 

* How about having a com.apple.Boot.plist completely outwith the installed OS?

 

all without losing the usual EFI strings goodness you've come to expect from a bootloader... (Thx to Chameleon team!)

 

 

So munky, where's the beef?

 

Well first, a little history...

 

When you format a GPT (GUID Partition Table) disk in Disk Utility, there is always a hidden, 200Mb partition created as the first partition on the disk. This is supposed to be a 200Mb FAT-32 partition used for storing EFI drivers, and is mandated by the EFI / GPT specs.

 

Apple honours the specs and so puts the 200Mb partition there. However, (and this is the important part...) *Apple dont use it!*

 

So we can hijack it and use it for our own ends. :D

 

 

You're still not getting to the point...

 

Ok ok. So here goes. We repurpose the EFI system partition to hold our kexts (and, if necessary, kernels) so we dont have to change the main installation. AT ALL.

 

The nice thing is that Mac OS X and Disk Utility (at least the graphical version) will continue to hide the EFI partition, as you're not supposed to see it. But you also have the option to mount it if you need to make changes. And, of course, on ALL systems (currently Intel SSE2 and better), Software Update can be used without much chance (if any) of breakage.

 

Hmmm... ok i'm sold. So how do I do it?

 

Well, first grab the attached zip file. This contains a modified version of boot0 from chameleon, the unmodified boot1h from chameleon, and a fork of dfe's boot2. boot0 has been changed to look for the EFI system partition, and boot2 has been modified to load extra kexts from the EFI partition.

 

Warnings, Pre-Requisites

 

*** YOU'RE DOING THIS AT YOUR OWN RISK BTW. Dont {censored} at me if your computer explodes and kills your cat. ***

 

You are probably best to try getting your system to boot a retail disc with boot-132 before you attempt this method. Getting it to work with boot-132 is good practice for maintaining a 'patches-free' system, and will give you a good idea of the kexts you'll need for your particular system.

 

NB: YOU CANNOT USE ANYTHING OTHER THAN A RETAIL DVD. Dont try a restore or drop-in disc, they WILL NOT WORK.

 

Another BIG NOTE: existing chameleon, pc-efi etc bootloaders can seriously mess this up. If you have problems please try with only one hd attached and make sure u *completely destroy* the existing partitions before install.

 

In the following guide, i've used the convention of diskXsY. Please understand, you should NEVER type diskX or diskXsY - X and Y are placeholders and need to be replaced with proper values. On most systems installed to the first hard disk, this will be disk0. Partition 1 on any GPT disk formatted by Disk Utility will be the 200Mb EFI partition. So in most cases, we'll be talking about disk0, rdisk0 and disk0s1.

 

Finally, please make sure you read and re-read this guide before starting. If you are unsure about any of the steps, then my advice is DONT DO IT. Wait for someone to turn these set of instructions into an easy-to-use installer or something.

 

Finally, the beef!

 

So, best practice is to use a boot-132 disc and install a fresh Leopard installation onto a GPT disk from retail. Lets call this 'Phase 0'. You find or create a boot-132 disc capable of booting to the installer from a retail Leo disc on your particular setup. Go into Disk Utility from the menu and partition one of your drives as GUID Partition Table type and create at least one partition big enough for Leopard. Look elsewhere for questions about boot-132 (like the links above). This guide assumes you can, and have, booted the retail Leo disc and installed to a GPT disk.

 

Once you've done that, boot into your new install via boot-132, and do the following:

 

Phase 1: Reformatting the EFI System Partition.

 

1) Open Terminal

 

2) sudo -s (and type in your password)

 

3) diskutil info / | grep Identifier - this tells you the values for diskXsY for '/', which is the currently-booted system. (If you're doing this on a disk other than the one you've booted from, you need to modify accordingly.)

 

4) diskutil list - diskXs1 should be called EFI. this is the hidden EFI partition on your target drive.

 

5) diskutil eraseVolume "HFS+" "EFI" /dev/diskXs1 - now, be *VERY* sure this is the correct drive. this will format the EFI partition as HFS+. (NB After erasing it will try to mount it, but will fail with "Could not mount disk0s1 with name after erase". Ignore this).

 

Phase 2: Installing the modified bootloader.

 

1) Extract the attached zip file to a directory (Safari might do this for you).

 

2) in terminal, cd to that directory (the one containing boot0, boot1h, boot-turbo-munky.bin and fdisk)

 

3) ./fdisk -f boot0 -u -y /dev/rdiskX - this puts the stage 0 bootloader onto the target disk

 

4) dd if=boot1h of=/dev/rdiskXs1 - this puts the stage 1 bootloader onto the target partition (EFI partition)

 

5) mkdir /Volumes/EFI

 

6) mount_hfs /dev/diskXs1 /Volumes/EFI

 

7) cp boot-turbo-munky.bin /Volumes/EFI/boot

 

8) cp update.sh /Volumes/EFI/

 

Phase 3: Make the disk bootable

 

This stage may not be necessary on some boards, but on my Intel board and Bad Axe boards it is. If you skip this step and your system wont boot, try doing it. That said, doing this on boards which DONT need it will do no harm so my logic is do it anyway.

 

Type the fdisk command and then each line as shown:

 

1) ./fdisk -e /dev/rdiskX (NB: Ignore any fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory error)

 

2) f 1

 

3) w

 

4) q

 

Phase 4: Setup your new bootloader EFI partition

 

1) Setup directory tree:

 

mkdir -p /Volumes/EFI/System/Booter

mkdir /Volumes/EFI/Extensions

mkdir /Volumes/EFI/.fseventsd

 

2) touch /Volumes/EFI/.fseventsd/no_log - this prevents the File System Events Daemon (fseventsd) from logging on this volume, which can cause the EFI partition to become unmountable.

 

3) copy necessary extensions into /Volumes/EFI/Extensions (eg:

 

cd

cp -R *.kext /Volumes/EFI/Extensions)

 

4) if necessary, copy patched kernel into /Volumes/EFI/ (eg:

 

cd

cp mach_kernel.voodoo /Volumes/EFI/

 

5) cd /Volumes/EFI

chmod +x update.sh

sudo ./update.sh - this will build a kextcache in /System/Booter. Please check update.log for any errors. (Dependency warnings are ok and normal - the dependencies will be available at boot time from /System/Library/Extensions).

 

6) umount /Volumes/EFI (If this fails, do umount -f /Volumes/EFI).

 

7) rm -rf /Volumes/EFI

 

8) If your machine cannot use the vanilla kernel, at this point you must take a note of your install's UUID. Open Disk Utility.app and click on the partition containing your fresh install. Click the blue 'I' information icon and look for Universal Unique Identifier. This should be a fairly long hex string. Write this down somewhere on a piece of paper. (not in a text file on the computer!)

 

You should be ready to boot at this stage.

 

Phase 5: Test boot!

 

So this differs slightly depending on whether you have a Core cpu or not - that is, whether you can (or choose to) run the vanilla kernel or a patched kernel.

 

If you boot the vanilla kernel, you should just have to press Return, as the bootloader should find your installed OS.

 

If you boot a patched kernel, the magic you need is this:

 

bt(0,0)/mach_kernel.voodoo -v boot-uuid=.

 

With a bit of luck, you'll boot up into your nice shiny new Leopard install, and be able to use Software Update without worrying.

 

 

Phase 6: Post-Install - Kexts, EFI strings, Boot.plist, Troubleshooting

 

Kexts:

 

So you booted back up, but you maybe dont have gfx support, or are missing some nice LAN kext... To mount EFI:

 

sudo -s

mkdir /Volumes/EFI

mount_hfs /dev/diskXs1 /Volumes/EFI

 

to install new kexts:

 

sudo -s

cd path/to/kext

cp -R Blah.kext /Volumes/EFI/Extensions

cd /Volumes/EFI

./update.sh

 

 

EFI Strings and com.apple.Boot.plist:

 

v3 of the bootloader supports a com.apple.Boot.plist file located on the EFI partition. You can place this in either of these two locations:

 

/Volumes/EFI/com.apple.Boot.plist

-or-

/Volumes/EFI/Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

Its your choice, and it makes no difference. If you have both it will favour the one in /Library/Pref.....

 

This is, of course, the place to put EFI strings - aka device properties - strings. This bootloader supports EFI strings in the same format as Chameleon expects them.

 

Troubleshooting

 

If you ever get 'mount_hfs: Invalid argument' when trying to mount the EFI partition, do this to fix it:

 

fsck_hfs /dev/disxXs1.

 

*** Always unmount the EFI partition before rebooting, to stop this happening! umount /Volumes/EFI! ***

 

:)

 

Notes

 

On my system (a Pentium D920 currently, though after tomorrow it'll be a Core 2 Duo), there is actually one modification to the installed system, and that is the com.apple.Boot.plist file. I simply couldnt be bothered typing out the uuid every time I booted the machine, so I put my boot parameters into that plist file. v3 supports a com.apple.Boot.plist on the EFI partition :)

 

I also have a vanilla installation on a USB drive which I share between two real macs (my home MacBook Pro and my work MacBook Pro) as well as my hack. I have the necessary kexts and kernels on the EFI partition (remember, the real macs ignore this partition), and to boot it on my hackintosh, i just have to type in the correct parameters for booting, ie:

 

bt(0,0)/mach_kernel.voodoo boot-uuid=. v3 supports com.apple.Boot.plist on EFI. :)

 

One thing - you can actually use rd=diskXsY to specify the boot device. I prefer using boot-uuid because that wont break if I change the configuration of hard disks on my machine, whereas the diskXsY values could.

 

 

Another thing, for pre-Core users, please keep the relevant System.kext on the EFI partition for the kernel you wish to use. For example, my hackintosh has mach_kernel.voodoo (9.4.0 kernel for 10.5.4), and the 9.4.0 (10.5.4) System.kext in /System/Booter/Extensions.mkext. These are used in preference to the kernel and System.kext on the installation, which are both vanilla 9.5.0 (10.5.5) versions. This means USB mounting etc wont break.

 

 

Dual- Triple- Quadruple-.... Booting!

 

Since this bootloader is based on dfe, you can hit escape at the darwin boot prompt and enter a new bios device id to boot from. If you have a 2nd hard disk with Windows, you can hit esc, type 81 and enter, and it should show the darwin prompt with 'Foreign OS'. Hit enter to boot Windows ;)

 

 

Background Reading

 

If this stuff is new to you, or you're having trouble following, please read these threads first:

 

http://forum.insanelymac.com/index.php?showtopic=113288

 

http://forum.insanelymac.com/index.php?showtopic=123841

 

http://forum.insanelymac.com/index.php?showtopic=123313

 

 

Source Code

 

Now attached. Apologies for not having commented it all properly, or even doing basic cleaning up. All work by dfe, turbo, zef, chameleon team with a couple small bits and bobs from me.

 

Changelog and Downloads

 

v1 is the original bootloader, comprising Turbo's changes to the dfe bootloader. Deprecated by v2

v2 supports EFI strings in com.apple.Boot.plist. apply them in chameleon style - ie tag. Deprecated by v3

v3 supports a com.apple.Boot.plist on the EFI partition (in root or in /Library/Preferences/SystemConfiguration), boots faster, and integrates the update.sh script :)

v4 supports JMicron and other 'troublesome' ATA

v5 adds the improved FSB detection code from Chameleon

v5.1 is a repackaging of v5 to correct a misnamed file. No other changes.

v6 supports DSDT override, and has apple boot logo removed (needed to save space :) )

v6.1 makes the bootloader look for DSDT.aml in root of EFI partition, not boot partition. D'oh!

 

v5.1 source attached.

efi_boot_v5.1.zip

efiboot_v5.1_source.zip

efi_boot_v6.1.zip

v61_src.zip

Share this post


Link to post
Share on other sites

I'm lovin' the logic behind this... sounds great not having to muck around with extensions when doing updates etc.

 

I'm gonna give this a shot. I'm using the chameleon bootloader, so I'm guessing that has to be removed first right?

Share this post


Link to post
Share on other sites

Thanks for this. ^_^

On my system (a Pentium D920 currently, though after tomorrow it'll be a Core 2 Duo), there is actually one modification to the installed system, and that is the com.apple.Boot.plist file

What about Applehda.kext?

AFAIK, we still need to replace it onto S/L/E, but maybe i missed something.

Share this post


Link to post
Share on other sites

sorry, you're right. my hack is currently running sans audio. i've been waiting for someone to figure out how to patch it from boot-132 / Extra folder. i think there will be a way.

 

worst case scenario, if audio is all we patch manually, then its not too much hardship to repatch after a system update...

Share this post


Link to post
Share on other sites

awesome munky :)

Im afraid but i cannot test this now

 

but asap i'll, let the 9.5.0 sse3 kernel out by voodoo or someone and i have bunch of time to format my disk as gpt (mine's mbr... oh) and install the whole stuff again, but i'm excited to see these things working.

 

please keep the good work

and thanks for your effort.

Share this post


Link to post
Share on other sites

I tried to follow the guide, but got an error:

 

bash-3.2# ./fdisk -e /dev/rdisk1
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
Enter 'help' for information
fdisk: 1> quit

 

Is this something missing or do I just need some additional fdisk parms?

Share this post


Link to post
Share on other sites

can i put my whole extention from leopard 10.5.4 so i dont get still waiting for root device becouse i dont know what causing it

Share this post


Link to post
Share on other sites

Still sorting it atm, but you should add a note to ignore this error as it worried me until I read down the instructions a little to find the manual mounting bit:

 

Mounting disk
Could not mount disk0s1 with name  after erase
[ + 0%..10%..20%..30%..40%..50%..60%..70%..80%..90%..100% ] 
Finished erase on disk disk0s1

 

Thanks. :blink:

Share this post


Link to post
Share on other sites

it tries to boot but i didn't get to login screeen (i think it's because the mess in my extra/extensions folder)

goin' to sleep now, will try tomorrow

Share this post


Link to post
Share on other sites
dudecuda: boot with -v and see whats happening. try booting with -f as well.

 

I did both, with the exact same results both times. I'm wondering if the alternate kexts are even being loaded. I triple checked my directory structure and everything is fine.

 

 

Update:

I have a copy of leopard 10.5.0 on a small 8GB partition on my second HD. I can use this boot method to boot that partition just fine. Further more, the alternate kexts are being loaded since I have PS2 support. My primary partition has 10.5.5, so something is definately broken here.

Share this post


Link to post
Share on other sites

Mine freezes at the Apple Logo screen also.

 

Here is error with -v:

 

img2119dj8.jpg

 

With -v -f: it freezes at the mDNSresponder line this is a few up from bottom.

 

It works fine with my USB or CD Boot-132.

 

Could it be a problem with the Stage-2 as noted in the post here:

GPTEFIboot Thread

Its the very last line of first post.

 

I am using 10.5.5 also.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×