Jump to content

HowTo: Retail DVD booten


229 posts in this topic

Recommended Posts

Nein es wird dadurch nichts schwieriger! Du kannst nachwievor deine Kexts für Audio und Graka installieren!

 

Der "Schmäh" bei der ganzen Geschichte ist nur das wenn du von der CD bootest oder dir einen bootbaren USB Stick erstellt hast (mehr dazu im Englischen Insanely Teil) dann hast du einen originalen Leopard auf der PLatte der zu 100% Updatefähig ist!

 

Außerdem wird früher oder später ein grafisches Bootmenü alla EFI vorhanden sein dan ist das ganze noch bequemer!

Habe das ganze jetzt mal ausprobiert.Die original OS X DVD bootet zwar, aber nach dem auswählen der Sprache kommt die Meldung "MAC OS X lässt sich auf diesem Computer nicht installieren".Allerdings brahcte die Patch Boot-CD ein paar EBIOS Fehlermeldung am Anfang. Also scheint schon da was nicht in Ordnung zu sein.

2. Die iso öffnet ihr mit Ultraiso (in Windoof) und extrahiert die initrd.img3. die initrd.img öffnet ihr mit Transmac (in Windoof) und wechselt zum ordner extras, extensions
Man bruacht zwingend ein Windows oder? Unter Mac OS kann man die dsmos.kext nicht in das /extras/extensions/ der Patch-CD kopieren?

 

 

Ich geb´s auf.. Das ganze funktioniert nicht. :-((

Klappt bei mir leider nicht.

 

Booten von Cd klappt, neue DVD einlegen auch. Enter,-v

 

Dann startet Darwin (nochmal?) und es wird was von der DVD geladen und dann kommt plötzlich ein Reboot.

 

 

Hat einer eine Idee, was das sein kann?

wär nicht schlecht wenn wir ein paar hardware infos haben könnten!

Generell funzt es NUR mit Core2Duo und Core2Quad CPU's sowie Mainboards ab intel 945 chipsatz!

 

Sorry... Ein Asus Barebone mit Intelboard. Chipsatz g945, Core2, 8600gt.

 

Leo4all läuft ohne Probleme.

 

Mit der neuen Installationsmethode bleibe ich aber mittendrin hängen, d.h. es passiert nach einigen Sekunden ein Reboot, obwohl es laut den anderen Postings hier an sich funktionieren müsste.

Das mit der dsmos.kext ist einfach. Der einsatz dieser kext ist ILLEGAL weil sie nahezu das ganze Mac OS X decryptet. Deswegen ist sie nicht in der ISO enthalten. Sobald man sie einsetzt macht man sich strafbar, auch hier in Deutschland.

 

Btw. man kann das auch alles auf einen USB Stick packen und von dem dann booten wie von der CD.

Noch mal zur dsmos.kext:

 

Die Frage war ja, welche man nehmen muss. Wo liegt denn da genau der Unterschied? Ich lese immer, dass es modifizierte Versionen für verschiedene Verwendungszwecke gibt, aber blicke das nicht so ganz. Ich muss dazu sagen, dass ich mit meinem Kalyway Leopard recht zufrieden bin, aber wenn ich es irgendwie besser zum laufen kriegen kann, dann gerne.

 

Jetzt mal an meinem Beispiel, wenn ich jetzt diese neue Methode benutzen wollte, woher wüsste ich welche dsmos.kext die Richtige ist?

 

Ich habe ein Esprimo Mobile Laptop von Fujitsu mit einem Intel Core 2 Duo Prozessor T5850 (2.16 GHz, 667 MHz FSB, 2 MB L2 Cache) und einem Intel 965GM Mainboard. Als Grafikkarte kommt ein Intel GMA X3100 Chip zum Einsatz.

 

Tut mir Leid wenn ich dumme Fragen stelle, aber ich bin von Haus aus ein Webdeveloper und nicht so ganz fit was solche Spezialitäten angeht :2cents:

Jetzt mal an meinem Beispiel, wenn ich jetzt diese neue Methode benutzen wollte, woher wüsste ich welche dsmos.kext die Richtige ist?

 

Schau mal hier: http://forum.insanelymac.com/index.php?showtopic=113288

 

Ganz unten der zweite Downloadlink. Das ist das Rundum-Sorglos-Paket. Da sind schon alle .kexts drin. Einfach brennen - booten - fertig.

 

Btw. man kann das auch alles auf einen USB Stick packen und von dem dann booten wie von der CD.

 

Ja, aber man braucht leider Windows dazu, um einen bootfähigen Stick zu erstellen. Hier die Anleitung, falls noch jemand Windows drauf hat: http://forum.insanelymac.com/index.php?sho...mp;#entry805274

wär nicht schlecht wenn wir ein paar hardware infos haben könnten!Generell funzt es NUR mit Core2Duo und Core2Quad CPU's sowie Mainboards ab intel 945 chipsatz!
Nein funkt mit allen Core cpus: Core Duo, Core Solo, ...
Sorry... Ein Asus Barebone mit Intelboard. Chipsatz g945, Core2, 8600gt.Leo4all läuft ohne Probleme.Mit der neuen Installationsmethode bleibe ich aber mittendrin hängen, d.h. es passiert nach einigen Sekunden ein Reboot, obwohl es laut den anderen Postings hier an sich funktionieren müsste.
Is "Execute Disable Bit" im bios aktiviert und CPUID_Limit sowie HPET deaktiviert?
Schau mal hier: http://forum.insanelymac.com/index.php?showtopic=113288

 

Ganz unten der zweite Downloadlink. Das ist das Rundum-Sorglos-Paket. Da sind schon alle .kexts drin. Einfach brennen - booten - fertig.

 

Ich nehme an du meinst das "modified kexts"-Pack? Oder bin ich heute etwas blind? :2cents:

Es gibt nur 2 verschiedene dsmos.kext ; eine für tiger und eine für leopard.... da die für tiger nicht wirklich verbreitet is, denk ich mal, dass so ziemlich jeder der ne dsmos.kext hat, die auch für leopard is

Ich nehme an du meinst das "modified kexts"-Pack? Oder bin ich heute etwas blind? :angry:

Ja genau das meine ich. Hat ca. 40MB. Wenn du das Image mountest und dir den Inhalt der initrd anschaust, dann siehst du, dass dort schon einige Kernel Extensions drinn liegen.

 

NForce Chipsatz Treiber, Audi (AC97 und Azilla)... und eben auch die dsmos.kext. Ohne diese Datei, wird die grafische Oberfläche niemals starten.

post-228051-1215254513_thumb.png

Ok, danke :angry: Kann man mit der Methode vll. auch eine arbeitende WLAN Karte (Intel 3945) erwarten, oder hat das damit wenig zu tun? Bis jetzt habe ich irgendwie keine Lösung gefunden, um das Modell ans Laufen zu kriegen.

Ok, danke :angry: Kann man mit der Methode vll. auch eine arbeitende WLAN Karte (Intel 3945) erwarten, oder hat das damit wenig zu tun? Bis jetzt habe ich irgendwie keine Lösung gefunden, um das Modell ans Laufen zu kriegen.

 

Nö, i3945 funkt noch(?) nicht, und hat auch damit wenig zu tun :(

am besten mal eine unterstützte karte kaufen und tauschen

Naja mal sehen. Danke für die Antworten. Vielleicht kriege ich auf nen frisches MBP vom Chef, als neuer Arbeitsplatz, den ich mit nach Hause nehmen darf :angry:

Tja, ich kriege das leider nicht hin, obwohl es auf den 945boards ja gut funktionieren soll.

 

Ich habe jetzt im Bios an den ACPI Einstellungen Änderungen vorgenommen, und habe es damit wenigstens geschafft, dass es nicht mehr zu Reboots kommt, hängen bleibe ich aber trotzdem.

 

Je nach Boot-CD-Variante komme ich nach Wechsel zur retail DVD bis "Mac Framework sucessfully installed" oder (2 Zeilen weiter) bis "starting dsmos".

 

Danach passiert nix mehr. ;)

wenn nach dsmos nix mehr kommt kanns an der grafikkarte liegen, schon mal -x probiert?

 

Nein, ich glaube das ist es nicht. Ich kann es auf ACPI Probleme eingrenzen, finde aber keine Lösung.

 

 

 

Meine Leo4all bootet mit folgenden Bios Einstellungen:

 

Suspendmode: Auto

ACPI 2.0 Support: Enabled

ACPI APIC Support: enabled

 

 

Leopard retail lädt bei diesen Einstellungen von der DVD diverse kext (Boote mit -v -f) und startet dann den Rechner neu... :thumbsup_anim:

 

Schalte ich ACPI APIC Support auf disabled werden die kext ebenfalls geladen und kein neustart initiert ;-), ich komme aber nicht über "mac framework successful ... cluster... etc. hinaus. nicht einmal bis dsmos.

 

Was ich nun gar nicht verstehe ist folgendes: Belasse ich diese Einstellung (ACPI APIC Support auf disabled) und starte meine Leo4all Installation wie gehabt, dann bleibe ich beim Start an der exakt gleichen Stelle hängen wie beim Retail install.

 

Erst wenn ich ACPI APIC Support: enabled einschalte, startet mein System wieder.

 

Was mache ich falsch?

Man soll "Chameleon" installieren?

 

Was ist denn Chameleon? Google bringt die unterscheidlichsten Ergebnisse, die aber alle nichts mit dem booten einer Retail DVD zu tun haben. :(

 

edit: Die Suche "Chamaleon" + das Stichwort "EFI" brachte mich ans Ziel: http://forum.insanelymac.com/index.php?sho...aded&start=

 

Schau dir mal das hier an: http://forum.insanelymac.com/index.php?showtopic=104754

Damit sollte es dir möglich sein Chameleon zu instalieren! :)

Habe "modified kexts-Pack" gebrannt und dann mit einer orginalen Leo DVD installiert. Ging alles prima und ohne Probleme. Bootet ohne Probleme und bindet meine 8800GTX ein. Hab dann das 10.5.4er Pack installiert und nun bootet er nicht mehr.Es kommt "Still wating for root device"Was kann das sein?

P35C-DS3R

Q6600

4x500GB SATA

4GB RAM

 

Ergänzung:

Nach booten mit -v -s ging er erst zum Prompt (#) und nach exit hat er gebootet.Jetzt bootet er mit 10.5.4 ganz normal. Keine Ahnung was das war.

Hat schon jemand erfolgreich die Retail DVD gebootet, der KEIN Firewire auf seinem Board hat?

 

Im Englischen Forum wurde geschrieben, dass ich eine Update-DVD verwende. Aber ich habe die Retail Vollversion und bekomme immer diese Fehlermeldung: http://forum.insanelymac.com/index.php?sho...0&start=20#

 

Da im Handbuch steht, dass Firewire eine Systemvorraussetzung ist, glaube ich, dass es daran liegt, dass mein EP35-DS3 kein Firewireport hat.

×
×
  • Create New...