Jump to content

theStevo 4.5 Patch Released

90 posts in this topic

Recommended Posts



What is it? - This PPF will patch the Kalyway 10.5.2 ISO so that it will install all needed drivers to make your ASRock DualVSTA board run to the best of our community's knowledge.


Where is it? - TPB. If you don't know what that is, google it. If you know where to get installation discs, you really should know what that means...


What support is in it?

*VIA Rhine - network on all DualVSTA boards

*ALCinject and AppleHDA - sound on all DualVSTA boards

*8237A ATA UDMA - UDMA on 775-DualVSTA and 4Core-DualVSTA

*8237S ATA UDMA - UDMA on 4Core-DualVSTA SATA-2

*Maybe... Maybe... SATA on 4Core-DualVSTA SATA-2


That's it? Yes, but maybe not from your perspective. There should be other boards out there that use 8237A/S, and those should benefit from this change too. If you don't use VIA Rhine or ALC888 then delete those kexts. Its much easier not having to ghost an install and play with kexts after it is properly booting.


Why do I need this over 4.1? - Well, first of all, some of you don't really. If you use a 775-DualVSTA without an ATA drive, you won't find a difference. However, if you do use ATA you get UDMA. 4Cores get UDMA on ATA. And, maybe, (as in I DON'T own the board to test it) SATA for the 4Core-DualVSTA SATA-2. This release has a functioning kextcache! Yay for not having to wait five minutes for everything to cache before running, and yes that is slightly exagerated. Plus Kalyway has some fun extras. More apps, more patches, and better drivers. If you want newer ATI or nVidia, its easier to use this then use 4.1 and update to 10.5.2.


Why Kalyway? - In my opinion, iAtkos isn't up to par with this round of installation discs. Sorry. I like Leo4All, but I feel like it might have an excessive amount of options for a newbie. However, it was almost on equal footing in my decision. JaS beta is good, but not quite stable or complete. Special mention, props to EqUaTe for improving iAtkos. r3 by EqUaTe is definately the best revision of iAtkos. I still think Kalyway has the crown. More importantly, it has no drawbacks for this board with the patch.


No guide for how to make it? - No. Because people don't read before they think. I said in my last version that the guide was only for the interested. Still I had multiple people asking me if I could make it easier to patch than following the whole guide. So no, sorry. If your curious, the principles are mostly the same as what was used in the 4.1 patch.


My network connection drops. Can you fix it? - No. No. No. I often didn't have that problem. However, on the rare occassion that it showed itself I didn't have the time or determination to diagnose it. When I did, it didn't show itself. There are people in the 4.1 post that worked on it, two types of solutions. See if they work for you. If not, please don't post here. There are other boards that use this chipset, and any modification to the kext should be done in a thread dedicated to it so as to make sure that everybody who it concerns can find it. Not only does it diffuse the focus of this topic, but it helps assure no progress will occur for the chipset. However, if you find a sure-fire solution, tell me and I will incorporate the solution giving you full credit. Its not that I'm not interested, I'm just trying to make sure that everybody is as efficient as possible.


Other business:


Credits - Thank you lean for your help with AppleVIAATA in a kickstart and ideas for further development. Major kudos. And, thank you to m.muller for the original process!


MediaFire download: http://www.mediafire.com/?uzjm0txz1in



Also, to installation disc creators, if you're listening: I appreciate your efforts greatly. I truly do. Having made modifications now for a while, I can appreciate the concept of effort required for a full installation disc. I mean no disrespect when I say that I am disappointed in the fact that this chipset is still not supported by default in ANY disc. I don't know whether its presumption upon my service or apathy, but I find either unacceptable. I've offered to help support for this board. Give advice, test, make the modifications and give them back; hell you can even keep all the credit. I don't know why somebody hasn't taken me up on this. I've messaged a good majority of you, and still no replies. I am very appreciative of your services, I have no desire to have to make my own install discs. You, being the creator of the work, have the full right to include whatever you please, I recognize that. But with this patch being in the fourth functioning revision dating from JaS 10.4.8, I fail to see the continual exclusion. Please contact me.


The problem is that when adding support you don't want to break existing drivers. Everyone chimes on about how they want certain hardware support but most don't understand there is often a tradeoff that it breaks other drivers. Provide me with a source based solution that adds the support you need (such that nothing else breaks) and I will look at integrating it into future releases (I have direct contact with most of the guys make distributions).


My own work involves find a baseline for what all OS X distributions should support. Its a matter of determining which chipsets are used by the majority of people. VIA is not the chipset the majority of users have. Its really that simple.


Was the mass storage drivers based on VIAATA? Anything based on VIAATA is a major problem due to the issues with 4GB of ram.


AppleHDA is another issue. Changes to it break it for other users where the defaults work. You are injecting codecs into it which means replacing support. I'm hoping at some point someone does a new kernel extension for Azalia using IOKIT and can handle as many codecs as we can find out there.


Adding the Networking drivers is something that sounds quite easy. Often just small tweaks to the plist can make sure it doesn't clash with existing hardware.


I understand your frustration but you have to realise how hard it is to get everything working in one distribution. I spent months working with Kalyway (and a fair bit of time with eddie11c) trying to fix compatibility issues. We haven't been lazy, its just really hard to solve the problems. Some of the more important issues such as the boot loader have had a much higher priority and have only recently been solved which allows on us to focus on other areas.

Dense - Thank you so much for your concise and thorough response. Though audio and networking would be nice from the install disc, I primarily provide my patches for the VIAATA. Adding or changes kexts after the install is much easier than ghosting to SATA. The VIA Rhine driver is making it into many install discs and the audio is a mere download away once you have your network connection. The AppleVIAATA that I'm using in this patch is built from source where I added support for 8237A/S UDMA, as per my work with lean. The possible support of SATA-2 came from a simple plist tweak. I don't believe that these changes would break any current hardware support, at least from what I saw in examining AppleVIAATA kexts on install discs. I believe I heard something once of using AppleVIAATA for nForce support on some chipsets, but unless I'm wrong that has been renamed into its own kext for install discs these days. I was not aware of a 4GB of RAM issue, I'll look into that. I will PM you later today with a link for the sources to the AppleVIAATA used in this patch. Thanks much for your reply.


mitch_de - Yes, I'll do that later today. ALCinject, AppleHDA, and VIA Rhine are the same as they always have been. However, it might be good to issue all kexts separately again.

I tried to install Kalyway 10.5.2 with your patch on my PC, enabled No Execute and HPET table, zeroed the partition, which I formatted with HFS+ Journaled. But after installing (I enabled your patch, used a non-vanilla kernel) it says there's no system installed or something like that. Can you please tell me the packages I should activate in order to successfully install Leopard?

mwk_soul - My install settings were 9.2 sleep kernel (ToH) and the patch. Applications are your decision, they won't make a difference. Natit or any other video card drivers shouldn't make a difference, however if you're curious I installed NVinject after the install.


Ben_K - No, PPF-o-matic is a Bin based patcher. It has no knowledge of files inside an image.


Dense - Here is a link to download the source xCode project for the VIAATA. I will PM to confirm. http://rapidshare.com/files/109430433/Appl...d_lean.zip.html


mitch_de - Kexts used in patch: http://rapidshare.com/files/109430849/theS...5kexts.zip.html

Well, I'll need some details about your configuration if I'm going to help. Unfortunately, nobody else has posted any results...


that's why feedback helps...



Details on my PC are available in my sig, but I'll add them here anyway:

Asrock 4CoreDual-VSTA (non-SATA), Pentium D925 , Kingston 1 GB Memory DDR2, NVIDIA GeForce 7300 LE, Seagate 160 GB IDE Drive, TSSTcorp CD/DVDW SH-S182M


If it helps, I didn't overclock any of the components. My BIOS version is 2.30.

As I said before, I loaded "best settings" (don't remember how this is called on my motherboard), then enabled HPET table and No-execute.


For the install I re-formatted the drive (this time without 0-erase). I unchecked every additional program, unchecked all drivers, just checked your patch, no other intel patches, used sleep kernel, no JaS APIC/ACPI, no AMD patches.


Oh, one more thing: I tested the MD5 sum and it is the same and there are no detected errors in the DVD.


Sorry for taking so long to answer (I know what 2 days mean :D )

Hey Stevo,


Thanks so much for all your work. I really appreciate it. 4.0 worked great on my 4CoreDual-SATA2 (r1.0 BIOS 1.9).

I patched and burned Kaly 10.5.2 w/4.5 last night. I'll install this weekend and report back. Unfortunately, I don't have an SATA drive to test that, but I'm gonna sell some stuff on eBay so I can get one next week and post my results (or Dev IDs) here when I do.


Thanks again.

BTW, I have a USB2 & SATA (with internal ATA port) combo PCI card that also uses VIA chips. I'm using it for USB2 in a Digital Audio G4 (I could never get the ATA working (I only tried the kext from Darwin PPC with added DevID). Now I'm thinking I may try it with this kext in my Hackintosh, or maybe recompile the source for PPC and try it in the G4 again (though I'm no programmer, I dabble a bit).

Thanks for upping the source and individual kext files.


i post here too :


i have a mobo AsRockcoredual-vsta(with good BIOS setting, HPET table enabled), with one ide drive and two ide optical drive. (and E4400 o/c, 2gb ram pc5300, geforce fx 5700VE)

i used kalyway 10.5.2 patched with TheStevo 4.5 patch.

i had a lots of problems :

I had to move my windows partition to the right of the disk (using Gparted) and create my leopard partition on the left of the windows partition.(if I didn't do that it didn't work, probably because of primary partition and logical partition or something like that, i didn't understand)

so then i booted from DVD, it worked fine, i formated my partitions to HFS+ (non-journalized, about 10GB) and my selection of package during install was : kernel : default (all are installed by default)

graphic : i choosed nvinject 256mo as i have a 256mo graphic card

network : i didn't choose wifi carf because i haven't one, but i let selected the network card driver that were selected (maybe it's an error from me, tell me plz)

mobo chipset : i let selected all the packages here because there were selected by default (maybe it's an error too, tell me plz)

i didn't select jas 10.4.8 packages

i didn't select AMD packages

i selected TheStevo patch

for the audio i let selected the packages that were selected by default(i had no sound so i did a mistake here but i have an external sound-card so it doesn't matter)

and i think that's all, install worked fine

i rebooted, i removed the DVD from the drive, i typed -v at the boot, it booted fine, i saw the welcome video (very nice), i created my account, etc..., all worked fine, i discovered the desktop (fantastic), i tried to connect to internet, it worked. BUT i had to go away for a meeting, so i let my computer powered on. And then when i came back my computer was block on sleep -.-

so i rebooted, i typed -v, and i had the "still waiting for root device " error, because of something like VIAATA and VIAsomething were blocking something (i don't remember well).

so i booted from a linux live cd, i googled this error, i found no solutions (tell me if you have infos )

i tried to boot with several option like -s, -x, kernel=sleep, kernel=nforce, but it didn't work, finally i booted with "-v -s -x kernel=vanillakernel", i had to write something (-fy, -uw, mount , i don't remember well) and it booted fine, so i was back to my desktop.

i tried internet, it worked fine, but about 30min later internet disapeared ( i think it's the "ethernet drop" bug in kalyway 10.5.2)

i entered in sleep mode to see if it worked fine , it didn't, it were blocked in sleep, so i have reset.

next time i booted with only the -v flag, it booted fine (oh!) but a message box told me via rhine extension couldn't be used because it weren't installed fine, i tried to reinstall with kexthelper but i couldn't. i had no internet so i rebooted, and HERE is where i am now, i get only a blank cursor at the boot, no ways to select an OS-.-

here i'm writing from my linux live cd, asking help.

so plz tell me which packages you selected and how you installed it...

i think that i let selected too much packages and there were conflict between them, but i'm not sur about it...

thanks for help me


Install went fine for me, except ViaRhine.kext got error "was not properly installed". I fixed permissions on it and rebooted, then it loaded fine. I haven't tested it yet, because I have no hardwire network in my garage where my hackintosh currently lives. I'll test it later, wired to a wifi router in AP mode.

Sleep works fine for me (ASrock 4coreDualVsta-SATA2-r1.0) with Suspend to Ram on, ACPI HPET table enabled in bios. Strange thing is I have to have USB devices plugged in at boot-up or they are not recognized later. I doubt this is related to theStevo patches though. Maybe a flaw in the SleepKernel, I think it worked with modbin, but it is only 32bit and my CPU is 64bit (E2180).

Thanks again.

Hi TheStevo


i'm new and i've got a little problem with the patching of the image

i've downloaded your patch from TPB ,i've downloaded Kalyway10.5.2 .

When i open ppf-o-matic i choose your patch thestevo4.5.ppf ,i choose my kalyway 10.5.2 image (.iso) .i launch the patch it's take abour four minutes then it's says thats the patching was sucsessfully done .So i burn the patched image (iso) and it doesn't works i tried to boot on it but nothing is happenning .and i also tried to mount the image but he says that it's damaged

If someone can help me :) (Sorry my english is not so good i'm french)

Spart16 - Be sure to check the MD5 sum of the image to make sure that it was properly patched. If the MD5 sums don't match, then you'll have to check the MD5s of the PPF and original ISO file and re-acquire those as necessary. Most likely you are patching correctly, but one of the elements in the patching process is corrupt.


DaFrigN - You might want to look into Superhai's USBGenPC. I don't know if it would fix it, but it sounds like it is along the lines of what Superhai is working on. Since you have an SATA2 board, can you give me some more info? The kext that is in this patch contains modifications for your board, and I need some feedback on it. Do you have UDMA on your ATA? (This can be found in IORegistryExplorer). Are you working properly and stable on SATA? Any other info would be great!


thiathias - Unfortunately, trying to do the dual boot on one hard drive was the source of half your trouble and the patch isn't really designed to aid in that endeavor. As for the AppleVIAATA kext error, that might have been a fluke. Occasionally, I have had kexts not load one boot in three dozen, and then go back to working the next time. Since nobody else has reported that error, and I can not reproduce it in my testing, I believe you just had a fluke. However, the VIARhine problem does seem to be universal. I'll conclude my message to you after this...


For Everybody's Information: It appears that everybody has a problem loading VIARhine on the second boot. As DaFrigN said, the solution is to repair permissions on it. This is my bad, I had this issue and didn't think of it when writing the original post. The easiest way for newbs to do this is to go into Applications, Utilities, open the Disk Utility, select your boot disk, hit Repair Disk Permissions, and reboot. I don't know why it does this. There are two kexts (VIARhine and ALCinject) that are installed into the extensions folder during installation. The other two (AppleVIAATA and AppleHDA) are copied over after installation. All have the same permissions, and more importantly ALCinject is placed in the same way. So, I don't know why: A, it works on the first install and then has corrupted permissions. B, ALCinject isn't doing the exact same thing. So anyway, its a minor problem and that is how to fix it.


Thiathis, you were the unfortunate victim of trying to dual boot with an existing installation, a fluke error on AppleVIAATA (at least that's what it looks like to me), and not knowing how to fix the VIARhine issue. However, take courage in knowing you did everything write until dealing with VIARhine. Your install was, in fact, perfect. Sorry for that.


mwk_soul - If you aren't using SATA, then you should be able to install with almost any distribution. There are only a few that don't support ATA on these boards. I have not yet heard from anybody that BIOS revision makes a difference on installation to these boards. You might have a unique situation, but I would examine that more closely if I were you. The no operating system error is usually attributed to weird multiboot issues with Windows, in my experiences. It does not appear that you issue is directly related to the patch.

Thanks for information i have already check the MD5 of your patch and it's OK my iso is the same i've burned and installed on my pc ,i will check once again i didnt't check the MD5 of the patched iso image file i will check it

Thanks for info! :)

thanks for infos

after this issue (viarhine) i booted (as a simple try, i didn't know it would get it work) with -x or -s (the one which repair permission at boot i think), i typed the commands given, and then viarhine was working fine, without drop issues. so it's ok for viarhine.

but now my problem is : i can't boot without DVD.

i followed the tutorial (the one with the file "files.rar" on rapidshare that we have to copy at the root of "123" named usb-key), it fixed my boot, ok, but then with the -v flag i get the error "com.apple.acpiplatform has imediate dependencies on both com.apple.kernel and com.apple.kpi components, use only one style".

but the fact is i wanted a stable computer usable by my family so i installed ubuntu and now i have the ubuntu(grub?) bootloader.

right now i'm trying to get my printer, my usb devices (i have the same issue that dafrign i think), and my geforce FX 5700VE working, and then i will try to fix the boot.

anyway thanks for the patch and for help, if you have any infos on my issues, plz tell me

i forgot to add something about my graphic card : i think it's recognized as i can get 1280x1024x32 working, BUT my problem is : i haven't Quartz Extreme so applications like photobooth can't work -.-

Ok i'm happy to have 1280x1024, this is nice, but I would do some video effect, and compositing...

I think it's my graphic ram that isn't recognized (i have 256mo so i selected NVinject 256 in install)

Hi thestevo

the md5 of my iso Kalyway_10.5.2_DVD_Intel_Amd.iso is 54b2cee2c04ec3f8b9d14e19cd1d598e and of your patch the md5 is 842bf47ea7ece48c2ae778053b07dc96 and it's okay but what's the original md5 of the kalyway leopard 10.5.2 iso file .there are 3 md5 in your txt and the one of kalyway 10.5.2 don't match with the mine should i redownload kalyway?

thiathias - What I was trying to say in my first message is that I think you should reinstall, with the information that you know now, a clean reinstall. The AppleACPIPlatform issue stems from that fix that you tried, I don't know exactly what that entailed. However, if you reinstall and fix the permissions on VIARhine, then you'll be fine. You almost had it last time. As for the NVInject, the ones with the memory amount by them are for 8x00 nVidia cards. You don't have one of those so you just need the plain NVInject option.


Spart16 - Usually it is the case that you'll have to redownload. PPF patchers can be very picky because of the binary patching nature of the application. When I went to create the PPF after I had a working ISO file, I realized that I had accidentally modified the original. I couldn't create the patch off of that because it would through everybody off. So, I had to redownload the whole ISO before I could create the PPF to upload for everybody. It's a pain, but at least I think it will fix your problem.



  • Create New...