Jump to content

Dell Laptops Post-installer - XPS, Inspiron, Vostro, Lattitude


  • Please log in to reply
1016 replies to this topic

#61
kevinosx

kevinosx

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

E1705 Core 2 Duo 2ghz, Leo4All v3.

STAC9200 in package did not work. Controls appear but no sound. AppleHDA 1.20 plus the STAC9200.txt over at that site with the dumps fixed it (mute only turns on, have to adjust volume to un-mute)

The 2-finger scrolling thing didn't work out so well. I did figure out on my own that it's pressure-sensitive, but only seems to work for me with one finger pressed kinda hard. It did mess up double-tap sensitivity ; ;



I had the issue that no audio source was selected after installing the package, may be the same with you (probably is if you saw the controls), go into system preferences then audio and change the audio control to the master one and it will work. Infact with this kext you control the subwoofer and mid-highs seperately, but you can adjust the buttons for this in butler.

#62
jmvBMW

jmvBMW

    Insanely Bimmer

  • Members
  • PipPipPipPip
  • 194 posts
  • Gender:Male
  • Location:Chile

:)
Is there any possibility that you can develop a driver for Yukon Ethernet?
Connection rate by Airport is really slow....
Thanks in tons!


+1! :D waiting for a 88E8040 driver!!

We appreciated you great work!! :P

#63
008200

008200

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Installatie Leopard Kalyway 10.5.1 : KALYWAY_LEO_10.5.1intel_SSE2_SSE3.zip.
System: Dell 9400 Bios A09 - 1.83 MHz - 2 GB Ram - Ati 1400X graphics - Internal Empty SATA disk 160 GB.
Custom install: choose * 1+2 Vanilla, *SSE2 and *boot efi MBR (no video or audio!).
Just after fresh installation I installed KalywayIntelCombo10.5.2.zip.
I 've installed: ati 1400 (1440*900 pixels), Sigmatel 9200 for Dell 9400, Power: battery meter; Broadcom 440x ans 2 finger scrolling.
Rebooting resulted in a non - booting system :) .
I saw no way to uninstall this Kalyway-IntelCombo-update and had to reinstall the KAlyway 10.5.1 again.

#64
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
Your work is VERY appreciated..MANY THANKS

Any future for XPS m1710 machines - i.e. 2 finger scrolling (and a bluetooth fix (does not work after 10.5.2 update))

>iSOJO


P.S. THANK YOU :)

#65
iseany

iseany

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Freshz meadowz

Hullo, could you maybe add Dell 1525 to the list? I'm using the (dreaded) GMA X3100 :) Anyway, here's my config:

Install Kalyway 10.5.1, updated to 10.5.2 with Kaly Combo Update
GMA X3100, ONLY works on EXTERNAL monitor. 1680 * 1050 * 32. Full QE/CI (total blank on internal monitor. why won't it run on 1440 * 900 when capable of 1680 is beyond me). Already tried natit.kext but didn't work, don't want to use the sleep trick :(

Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller <VEN_11AB&DEV_4354> (couldn't find any kext on the forum yet)
After editing IONetworkingFamily.kext/Contents/PlugIns/AppleYukon.kext/Contents/Info.plist, the Ethernet was detected!!! Success was short lived - status shows "Ethernet cable not plugged in" regardless of it connected or not :( Profiler shows ethernet is present complete with IP address, but I couldn't access my router 192.168... so the NIC is still not properly initialized.


http://forum.insanel...o...=93773&st=0
a group of 1525 useres with lots of sucess


Single user mode saved my life many times now, after (really) countless of erase and installs of Leopard, I really loathe GMA X3100



#66
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts

E1705 9400 2.0 core duo gma950

Everything installed fine except the smbios from netkas caused my kalyway 10.5.2 with Vanilla Kernel to crash.

Dell 1390 wireless does not function with IONetworkingFamily from 10.5.2 may I suggest a fix in a future package for this?

Also the mouse started to act very weird after install (it will just decide to scrool when I move my finger just a tiny bit) tried to do what your guide says to fix it but it didn't do anything. Maybe I need to replace the touchpad kext with an older one?


Ok i've included IONetworkingFamily 10.5.1 for your wireless card.
About your touchpad, you should read Ranova's topic, everythings is explain about how to configure it. If you have any success, please, just post your configuration file here.
I can't do anything for you cause it seem's that we don't have same trackpad model.

The 2-finger scrolling thing didn't work out so well. I did figure out on my own that it's pressure-sensitive, but only seems to work for me with one finger pressed kinda hard. It did mess up double-tap sensitivity ; ;

Same answer. For most computers, just 1-finger scrolling is working.

#67
gNOMEintheRedHat

gNOMEintheRedHat

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Is anyone else having trouble with RapidShare?

It's displaying 8 letters in the capcha with the little kitty, and says "Enter the 4 letters with the kitty to download"

I tried the FIRST 4 and the LAST 4, there are NUMBERS so I tried with and without them too...

help!

#68
paranoya6

paranoya6

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
ok so i still cant get my computer to shut down and restart i have

XPS 1530
T7250 2.0ghz Processor
3gb Ram
8600gt
200 gb hard drive

the other problem is i cant find my trackpad plst to change the settings i need to make it higher like the tutorial says but i cant figure out where it is. everything else is AWESOME all the people that own macs at the studio are so jealous that i only paid 1150 bucks for my MacBook Pro;)

#69
hello123456789

hello123456789

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
i have a dell inspiron 1720.
lots of you are talking about only haveing 1 core active, when i boot in verbose mode it says 2 logical cpus so im guess both cores are working.
also using this package i got audio working.
when i installed 2 finger scrolling it completely messed up my mouse and am doing a reinstall.

#70
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
the previous Dell Laptop models (ie Inspirons 6400, 9400, or XPS 1X10) suffer from this issue, with both cores active they have stuttering, with just one active don't.

But in the new generation of Dells (XPS M1X30, Inspirons 1X20 and, Vostros) this is not happenning.

#71
hello123456789

hello123456789

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
oh ok that would explain it.
Does anyone know why when i install the 2 finger scroll my mouse will stay in the top left corner and not work?
it works if i use a usb mouse but the trackpad doesn't work.

#72
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts

when i installed 2 finger scrolling it completely messed up my mouse and am doing a reinstall.

Your computer model is not specified in the 2-fingers option! And you don't have to reinstall to whole system, just folow links in readme.

#73
hello123456789

hello123456789

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
woops have already done a reinstall!

#74
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Is incredible how people get used to reinstall everytime something didn't work, that's the MS way...

#75
diddy

diddy

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Hello I have serious problem after using this Software. I hope that somebady could help me.
I have a Vostro 1700 (T7700, 3GB, 8600 M GT,...) and Kalyway updated to 10.5.2. I just used this installer for: Battery Meter + the first Finger scrolling + media keys enabler.

After a restart...
->Kernel panic :(

"Darwin kernel Version 9.2.0.....
"Unable to find driver for this plateform "ACPI" @/SourceCode/xnu/xnu-1228.3.13/ipkit/kernel/IOPlatformExpert.cpp: 1407..

I'm very disapointed. Please help me!

Sorry for my bad english.

#76
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Are you using a patched kernel or vanilla kernel?
Anyway, if you have a dual boot or an access to your disk (you can use a Linux LiveCD or Singleuser boot), try to check if AppleACPIPlatform.kext is in your Extensions folders (System/Library/Extensions/)
If not, copy the backuped one's (/DellLaptops/Backup/) in extensions folder, and reboot.

#77
diddy

diddy

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Thanks a lot! It works, my AppleACPI...kext was disapeared.
But now my touchpad is unusable. I've deleted FFscroll but same problem after...

#78
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts

Thanks a lot! It works, my AppleACPI...kext was disapeared.
But now my touchpad is unusable. I've deleted FFscroll but same problem after...


Did you install it on external disk or do you have 2 leo's systems?
About 2 fingers, just read installer's instructions: Vostros are actually not supported!

#79
diddy

diddy

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Lol, firstly i tryed to backup using linux but I can't write on the MacOsX partition.
Then I used pcwiz VM Leopard, I added physical drive where I have Leopard in VmWare to do that and it works (why not?).
Secondly, I know that it was not for Vostro but I've test :unsure: , this is my fault but it might exist a solution to turn back no?
Thanks.

#80
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
I just wanted to know if you Leopard's system partition is on external HD, and/or if you have one installed on internal HD.
to unintall:

Uninstalling

To revert back to regular trackpad\keyboard:
go into terminal, and type:
sudo -s
rm -rf /System/Library/Extensions/ApplePS2Controller.kext

Now use kext Helper to install the backed up ApplePS2Controller.kext. Reboot and you should be back to normal. Note: if you dont reinstall this kext correctly, you will be without keyboard and trackpad and you will have to use an external mouse\keyboard to fix the problem. (In my case, all I had was a BT mouse, so I had to download an onscreen keyboard to enter my password in kext helper )







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy